Introduction

 Bosch Logo

Introduction, goals of Conferencing Protocol

This specification describes the Bosch Conference Protocol for the DICENTIS Conference System. This specification is intended to be used by developers who want to use this interface to develop a client application to control the functionality available.

The Bosch Conference Protocol is created to have an interface which is similar for the following Bosch conference product families:

  • DICENTIS Conference System

  • DICENTIS wireless (future development)

  • CCS 1000D (future development)

So that solutions can be used across the Bosch conference portfolio.

The Protocol provides the information about which functions are available and how they are used. A web based demonstrator is available to assist developing and debug fixing your own interface. https://<server>:31416/Demonstrator/ConferenceProtocolDemonstrator.html

Bosch Security Systems

(c) Bosch Security System B.V., 2024


License

Bosch License Statement of use:

This topic contains the following sections:

  • SOFTWARE LICENSE FOR:UNITED STATES OF AMERICA, CANADA, MEXICO, BRAZIL, ARGENTINA, PARAGUAY, URUGUAY, VENEZUELA, COLOMBIA AND ECUADOR
  • Software license for Russia
  • SOFTWARE LICENSE FOR ANY OTHER COUNTRY
  • Software maintenance Agreement
SOFTWARE LICENSE FOR:UNITED STATES OF AMERICA, CANADA, MEXICO, BRAZIL, ARGENTINA, PARAGUAY, URUGUAY, VENEZUELA, COLOMBIA AND ECUADOR

STOP!

PLEASE READ THE FOLLOWING TERMS AND CONDITIONS CAREFULLY

IF YOU DO NOT AGREE WITH THESE TERMS AND CONDITIONS, DO NOT REGISTER THE AUTHORIZATION CODES MENTIONED IN THIS DOCUMENT, INSTEAD, PROMPTLY REMOVE AND DELETE THIS DOCUMENT AND ASK FOR A FULL REFUND AT YOUR SUPPLIER

BOSCH SECURITY SYSTEMS B.V. LICENSE AGREEMENT FOR SOFTWARE

Bosch Security Systems B.V. (hereinafter referred to as “Bosch") licenses this computer program and all associated documentation (the “Software”) for your non-exclusive use subject to the following terms and conditions:

  1. LICENSE - Under the terms of this license:

    • You may use the Software only on a single computer at a time and only for the operation of Bosch products.

    • You may not modify, decompile, disassemble or reverse engineer the Software.

    • You may, not sublicense, lease or otherwise rent the Software without Bosch 's prior written consent.

    • You may make one copy of the Software solely for backup or archival purposes. No other copying of the Software or the accompanying documentation is permitted.

    • This license will terminate automatically if you fail at any time to comply with any of its terms or conditions. Upon termination, you shall immediately destroy the Software or return it to Bosch along with any copies you have made, and to delete any installed copy from your hardware.

  2. TRANSFER OF OWNERSHIP - You may transfer this license to another party only if you:

    • Also transfer this Agreement, the Software and all accompanying documentation and (by sale or lease) ownership of the associated Bosch hardware, if applicable

    • Require the other party to abide by the terms of this license agreement, and

    • Destroy all copies of the Software and any updates that you do not transfer to the other party.

  3. OWNERSHIP AND COPYRIGHT OF THE SOFTWARE - Although the media containing the Software is yours, the Software is owned and copyrighted by Bosch and/or its suppliers. You may not remove, change or delete the copyright notice from the Software. The Software contains confidential and trade secret information of Bosch. You will instruct your employees and others having access to the Software in and ensure their compliance with the terms of this agreement. You will use your best efforts to prevent any unauthorized copying of the Software.

  4. Updated: Bosch will be entitled to update and/or modify the Licensed Software.

  5. SECTION REGARDING FREE OPEN SOURCE SOFTWARE.

    • The software of the offered program possibly includes open source software and third party software under royalty free licenses (“FOSS”).

    • The FOSS in the program is subject to FOSS license agreements (“FOSS-Licenses”). Pursuant to these FOSS-Licenses, Bosch has to pass on to you their terms and conditions and you have to comply with these terms and conditions and fulfill respective obligations when using the FOSS in another way than merely installing and running it internally on your machines, e.g. through further disposal of the product, as by distribution, selling, or otherwise passing it on to a third party. The rights under the FOSS-Licenses are being granted to you, and in the event of you passing on a copy of the product to another party, the terms and conditions of the respective FOSS-Licenses apply to the distribution of any included FOSS (in some cases, the FOSS-License provides a direct license from the author/licensor of the FOSS to the third party). For many FOSS-Licenses, Bosch itself can neither grant nor obtain these rights for you. The applicable FOSS-Licenses are available on the internet address of the provider of the FOSS or will be made available by Bosch upon your request.

    • The FOSS itself does not contribute to the sales price of the program offered by Bosch and the FOSS is thus is provided without royalty or monetary compensation.

    • You have to, either expressly, or implied by amendment or adaptation of the FOSS, accept and take responsibility for your compliance with the applicable FOSS-Licenses. Further, you have to agree that updates or new versions of the software program may contain different or additional FOSS or changes in the FOSS-Licenses.

    • If any terms or restriction of this EULA conflict with the FOSS-Licenses or any other license conditions of Open Source Software included in this product, the terms and conditions of these Open Source Software licenses shall prevail.

  6. Responsibility for Webcasting

    You will be exclusively responsible for any liability arising from unauthorized access or alteration to the Webcast Data or Content. You will also be responsible for any liability arising from any material or data which has been Webcast that includes any threatening, defamatory, obscene, offensive or illegal material or any material which infringes any person's intellectual property rights. Except as expressly otherwise stated in the Agreement, we will not be responsible for any liability arising from the failure to Webcast any material or data.

  7. Purpose of Transmission

    • You will use the Services and Equipment only as may be lawful and for lawful purposes.

    • So far as permitted by law and save as expressly herein set out you will not have and you waive and assign to us all and any rights relating to our Website the Hardware and the Software and/or any code and/or the names or designations thereof.

  8. Consent

    You will obtain the consent of any person to be filmed or Webcast, or, in the case of minor children, obtain the consent of their parent or guardian.

  9. Reproduction of the Content

    You will not copy or reproduce the Content or the Webcast Data on to any other server or location for further reproduction without our prior written consent, which will not be unreasonably withheld. However, you may provide third parties with links to the Webcasts so that they can view them.

  10. TAXES - You must pay all taxes that may now or hereafter be imposed, levied, or assessed with respect to the possession or use of the Software or this license. You shall file all reports required in connection with such taxes.

  11. WARRANTY, LIMITATION OF LIABILITY, REMEDIES - THE SOFTWARE IS PROVIDED “AS IS” WITHOUT WARRANTY OR CONDITION OF ANY KIND INCLUDING WARRANTIES FOR MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. NEITHER BOSCH NOR ITS SUPPLIERS SHALL BE LIABLE FOR ANY LOSS OF PROFITS, LOSS OF USE, INTERRUPTION OF BUSINESS, LOSS OF DATA, NOR FOR INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES OF ANY KIND WHETHER UNDER THIS AGREEMENT OR OTHERWISE, OR FOR ANY CLAIM BY ANY OTHER PARTY.

    Bosch does not warrant the functions provided by the Software. However, Bosch warrants the media on which the Software is furnished to be free from defects in materials and workmanship under normal use for a period of 90 days from the date of original purchase. Bosch's entire liability to you, and your exclusive remedy, shall be the replacement of the media containing the Software not meeting Bosch's warranty, provided you return the same to Bosch. The replacement will be warranted for the remainder of the term of the original warranty or 30 days, whichever is longer. You assume responsibility for the selection of the Software to achieve your intended results, and for the installation, use and results obtained from the Software.

  12. U.S. GOVERNMENT RESTRICTED RIGHTS - The Software is provided with restricted rights. Use, duplication, or disclosure by the U.S. Government is subject to restrictions as set forth in subparagraph (c)(1)(ii) of the Rights in Technical Data and Computer Software clause at 52.227-7013 or its successor.

  13. EXPORT LAWS, APPLICABLE LAW - The deliveries and services (fulfillment of contract) are under the proviso that their fulfillment is not contrary to the compliance with national or international regulations, especially export control regulations, embargoes or other sanctions. The contract parties commit themselves to supply all necessary information and documents needed for the export / transfer to other EU member states / import. Delays due to export control assessments or export control licensing procedures invalidate terms and dates of delivery. When licenses are not granted respectively the delivery and service is not licensable, this contract becomes void regarding to the affected parts. Claims for damages resulting from the above mentioned reasons and from mentioned delivery delays are excluded.

    The customer commits himself to comply with all relevant export control regulations in case of resale or onward delivery, i.e. all national regulations or EC regulations as well as US regulations). The resale or onward delivery of listed commodities (products, software and technology), the resale to embargoed countries or to blocked persons, organizations or companies or to consignees which use the commodities for a military end-use, for nuclear, biological or chemical weapons or nuclear technology could require an export license. The reseller or the customer who makes the onward delivery has to apply for the necessary licenses.

    The customer should note that the US export control law is also applicable when the commodities are completely or only partly originated in the USA. This can also be the case if the components are of US origin although the contract has no other reference to the USA.

    Infringements of the rules of law are subject to contract annulation.

  14. If any terms or conditions of this Agreement are declared illegal, null or void or for any other reason considered non-applicable, such terms or conditions will be considered eliminated or non-existing in the Agreement and will not affect the validity and applicability of the other terms and conditions.

  15. This Agreement shall exclusively be governed by the laws of The Netherlands.

Software license for Russia

ВНИМАНИЕ!

ВНИМАТЕЛЬНО ПРОЧТИТЕ СЛЕДУЮЩИЕ УСЛОВИЯ

ЕСЛИ ВЫ НЕ СОГЛАСНЫ С ДАННЫМИ УСЛОВИЯМИ, НЕ РЕГИСТРИРУЙТЕ КОДЫ АВТОРИЗАЦИИ, УПОМИНАЕМЫЕ В ДАННОМ ДОКУМЕНТЕ, ВМЕСТО ЭТОГО СВОЕВРЕМЕННО УДАЛИТЕ И УНИЧТОЖЬТЕ ДАННЫЙ ДОКУМЕНТ И ОБРАТИТЕСЬ К ПОСТАВЩИКУ ЗА ПОЛНЫМ ВОЗМЕЩЕНИЕМ УПЛАЧЕННОЙ ЗА НЕГО СУММЫ. Использование данного Программного обеспечения означает, что вы принимаете указанные ниже условия.

BOSCH SECURITY SYSTEMS B.V. ЛИЦЕНЗИОННОЕ СОГЛАШЕНИЕ НА ПРОГРАММНОЕ ОБЕСПЕЧЕНИЕ

Программное обеспечение, устанавливаемое в настоящий момент (именуемое в дальнейшем «Лицензионное программное обеспечение»), разработано Bosch Security Systems B.V. (именуемой в дальнейшем «Bosch»). Bosch предлагает Конечному пользователю лицензию для его использования на указанных ниже условиях. Регистрация кодов авторизации Лицензионного программного обеспечения и (или) использование Лицензионного программного обеспечения означает, что Конечный пользователь принимает условия настоящего лицензионного соглашения с Конечным пользователем (именуемого в дальнейшем «настоящее Соглашение»), в частности, Конечный пользователь принимает следующие условия.

  1. Определения

    Соглашение:

    настоящее лицензионное соглашение на программное обеспечение.

    Bosch:

    Bosch Security Systems B.V.

    Содержимое:

    весь добавляемый и транслируемый материал.

    Конечный пользователь:

    физическое или юридическое лицо, для которого предназначено программное обеспечение или оборудование. Этот термин основан на том, что назначение программного продукта или оборудования может быть полезно для клиента. Конечного пользователя можно противопоставить разработчикам и программистам продукта. Конечные пользователи также находятся в группе, отдельной от установщиков или администраторов продукта. (http://www.techterms.com/definition/enduser).

    Оборудование:

    инструменты и другие элементы, необходимые для выполнения конкретной операции или задачи.

    Лицензионное программное обеспечение:

    программное обеспечение, для работы которого требуется легальный код авторизации.

    Услуги:

    нематериальные продукты, такие как хранение и распространение информации и содержимого.

    Данные веб-трансляции:

    содержимое веб-трансляции.

    Веб-трансляция:

    веб-трансляция представляет собой мультимедийную презентацию, которая распространяется через Интернет с использованием технологии потоковой передачи мультимедийных данных для одновременной трансляции одного исходного содержимого нескольким слушателям или зрителям. Веб-трансляция может распространяться в режиме реального времени или по требованию. Веб-трансляция главным образом передается через Интернет.

  2. Авторские права

    Лицензионное программное обеспечение является интеллектуальной собственностью Bosch, которой принадлежат все соответствующие авторские права. Bosch сохраняет за собой навсегда право собственности Лицензионного программного обеспечения.

  3. Право на использование

    Конечный пользователь получает персональное неисключительное право на использование Лицензионного программного обеспечения только при условии его использования на 1 (одном) компьютере одновременно без размещения каких-либо ссылок в сетях. Bosch также сохраняет за собой все права, не переданные явным образом Конечному пользователю по настоящему Соглашению.

    Конечный пользователь не вправе продавать, передавать в аренду или иное пользование Лицензионное программное обеспечение или иным образом передавать или уступать права на его использование. Конечный пользователь не вправе декомпилировать, разбирать, осуществлять обратную разработку или каким-либо образом изменять программный код без предварительного письменного согласия Bosch. Несанкционированное копирование Лицензионного программного обеспечения запрещено в прямой форме.

  4. Бесплатное программное обеспечение с открытым исходным кодом

    • Программное обеспечение в предложенной программе может включать в себя программное обеспечение с открытым кодом и стороннее программное обеспечение, предоставляемое по бесплатным лицензиям (“FOSS”).

    • FOSS в программе регулируется условиями лицензионного соглашения FOSS («лицензии FOSS»). Согласно лицензиям FOSS, компания Bosch должна передавать вам соответствующие условия использования, и вы должны соблюдать их и выполнять соответствующие обязательства при использовании FOSS, не просто устанавливая и запуская ПО на ваших компьютерах, но, например, осуществляя утилизацию продукта за счет распределения, продажи или иной передачи ПО третьей стороне. Права по лицензиям FOSS предоставляются вам, и в случае передачи копии продукта другой стороне условия использования соответствующих лицензий FOSS применяются к передаче любого входящего в комплект ПО FOSS (в некоторых случаях лицензия FOSS представляет прямую лицензию от автора/лицензиара FOSS третьей стороне). Для многих лицензий FOSS компания Bosch не может ни предоставить, ни получить эти права для вас. Соответствующие лицензии FOSS доступны по интернет-адресу поставщика FOSS или предоставляются компанией Bosch по запросу.

    • Само ПО FOSS не влияет на цену продажи программы, предложенной компанией Bosch, и предоставляется без комиссии или денежной компенсации.

    • Вы должны явно или косвенно посредством поправки или адаптации FOSS принять ответственность за соблюдение соответствующих условий лицензий FOSS. Кроме того, вы должны согласиться с тем, что обновления или новые версии ПО могут содержать другие или дополнительные продукты FOSS или изменения в лицензий FOSS.

    • Если какие-либо условия или ограничения данного лицензионного соглашения конфликтуют с лицензиями FOSS или любыми другими условиями лицензии программного обеспечения с открытым кодом, включенного в этот продукт, приоритет имеют условия и положения этих лицензий на программное обеспечение с открытым кодом.

  5. Гарантия

    Bosch гарантирует, что Лицензионное программное обеспечение будет функционировать в значительной мере в соответствии со всей доступной документацией, поставляемой с этой или с предыдущими версиями Лицензионного программного обеспечения. Bosch не делает никакие дополнительные заявления и не предоставляет никакие дополнительные гарантии (явные или подразумеваемые), в том числе, среди прочего, относительно пригодности Лицензионного программного обеспечения для продажи и соответствия другим конкретным целям, отсутствия ошибок в Лицензионном программном обеспечении, а также, что в результате использования Лицензионного программного обеспечения или любых его копий не нарушаются права на интеллектуальную или промышленную собственность (например, патенты, авторские права или товарные знаки) третьих лиц.

  6. Обновления

    Bosch имеет право обновлять и (или) модифицировать Лицензионное программное обеспечение.

  7. Цель передачи

    Принимая условия настоящего соглашения, вы в явной форме подтверждаете свое согласие и обязуетесь использовать Лицензионное программное обеспечение, Услуги и Оборудование только для целей, для которых они предназначены, в соответствии с применимыми (местными) законами и нормативными актами. Вы не вправе привлекать к ответственности Bosch за убытки или претензии в связи с незаконным и (или) запрещенным использованием Лицензионного программного обеспечения, Услуг и (или) Оборудования и должны оградить компанию Bosch от любых подобных претензий, возникших в результате таких действий (например, от третьих лиц). Если установка или использование Лицензионного программного обеспечения, Услуг или Оборудования ведет к получению вами каких-либо прав, считается, что вы отказались от этих прав и передали их Bosch, если иное не определено в явной форме в настоящем Соглашении.

  8. Ответственность за веб-трансляцию (применяется только в случае веб-трансляции)

    Вы несете полную ответственность по обязательствам, возникающим в результате несанкционированного доступа к данным или содержимому веб-трансляций, а также за их изменение. Вы также несете ответственность по обязательствам, возникающим в результате незаконной веб-трансляции материалов и данных, а также за распространение угрожающих, непристойных, клеветнических, оскорбительных или незаконных материалов или материалов, размещение которых нарушает права на интеллектуальную собственность третьих лиц. Мы не несем ответственность по обязательствам, возникающим в результате сбоев веб-трансляции материалов или данных, если иное не выражено явно в настоящем Соглашении.

  9. Согласие

    Вы должны получить согласие лица на его съемку, в случае съемки несовершеннолетних — получить согласие родителей или опекуна.

  10. Воспроизведение содержимого

    Вы не должны копировать или воспроизводить Содержимое или Данные веб-трансляции на какой-либо другой сервер или в другое место для дальнейшего воспроизведения без получения предварительного письменного согласия, в предоставлении которого может быть отказано только при наличии разумныъх причин. Тем не менее, вы вправе предоставлять третьим лицам ссылки на веб-трансляции для просмотра.

  11. Изменение настоящего Соглашения

    Изменения настоящего Соглашения действительны в случае их письменного одобрения Bosch и Конечным пользователем. Условия в отношении Конечного пользователя применяются вне зависимости от их упоминания в формах заказа или в другом виде, если иное не принято компанией Bosch в письменной форме путем дополнения настоящего Соглашения.

  12. Ограничение ответственности

    Bosch не несет перед Конечным пользователем ответственность за убытки, в том числе за упущенную выгоду, потерю сбережений или любые другие случайные или косвенные убытки Конечного пользователя, возникшие в результате использования или невозможности использования Лицензионного программного обеспечения, даже если Bosch или его представители были уведомлены заранее о возможности таких убытков или претензий от любой другой стороны. Обязательные (императивные) законные требования Конечного пользователя остаются не затронутыми.

  13. Срок действия и расторжение Соглашения

    Настоящее Соглашение вступает в силу с момента открытия Конечным пользователем пакета, содержащего Лицензионное программное обеспечение.

    Конечный пользователь имеет право расторгнуть данное Соглашение в любое время. Для этого он должен предоставить письменное заявление в Bosch в соответствии с положениями, указанными в настоящем Соглашении.

    Bosch имеет право расторгнуть данное Соглашение в любое время путем предоставления письменного уведомления Конечному пользователю, но только в том случае, если Конечный пользователь не соблюдает те или иные обязательства в рамках данного Соглашения. В случае расторжения Соглашения Конечным пользователем или компанией Bosch Конечный пользователь должен незамедлительно прекратить использование Лицензионного программного обеспечения и всех его копий, а также вернуть его Bosch или уничтожить Лицензионное программное обеспечение и все его копии. Кроме этого, Конечный пользователь должен своевременно (но не позднее, чем в течение пяти дней с момента расторжения) предоставить в компанию Bosch письменное подтверждение осуществления возврата или уничтожения Лицензионного программного обеспечения и всех его копий, а также прекращения его использования. В дополнение к этому при расторжении по причине несоблюдения обязательств Конечным пользователем Bosch сохраняет право применить любые средства защиты своих прав, которые доступны в рамках закона и по соглашению, включая право на возмещение убытков.

  14. Экспортный контроль

    В отношении поставки продуктов и предоставления услуг (выполнения соглашения) действует положение о том, что их осуществление не должно противоречить национальным и международным нормам, в частности, нормативным актам по экспортному контролю, эмбарго и другим санкциям. Стороны обязуются предоставлять всю информацию и документы, необходимые для экспорта / передачи другим государствам ЕС / импорта. При возникновении задержек в результате оценки в рамках экспортного контроля или процедуры лицензирования в рамках экспортного контроля сроки и даты поставки аннулируются. Если не предоставляются соответствующие лицензии, и в отношении поставки товаров или предоставления услуг не могут быть предоставлены лицензии , данное соглашение становится недействительным для вовлеченных сторон. Требования по возмещению убытков в результате указанных выше причин и задержек поставки исключаются.

    Клиент обязуется соблюдать все требования, связанные с экспортным контролем, в случае перепродажи или последующей поставки, то есть все национальные нормативные требования или нормативные требования ЕС, а также нормативные требования США. При перепродаже или последующей поставке перечисленных товаров (продуктов, Лицензионного программного обеспечения и технологии), перепродаже в страны, на которые наложено эмбарго, или лицам, организациям и компаниям, чьи активы заморожены, а также адресатам, которые используют товары в военных целях, для создания ядерного, биологического или химического оружия или разработки ядерных технологий, может потребоваться лицензия на экспорт. Реселлер или клиент, осуществляющий последующую поставку, должен обращаться за получением необходимых лицензий.

    Клиент также должен учитывать, что законодательство по экспортному контролю США применяется также тогда, когда товары полностью или частично произведены в США. Данное положение также может применяться, если компоненты произведены в США, но несмотря на это в соглашении отсутствуют прочие упоминания США.

    Нарушение правил, установленных законодательством, является основанием для расторжения данного Соглашения.

  15. Конфиденциальность

    Стороны обязуются обеспечивать конфиденциальность информации или данных, предоставляемых раскрывающей стороной, если получающая сторона знает или должна разумно знать, что эти данные являются секретными и (или) конфиденциальными и (или) что такое разглашение может нанести вред раскрывающей их стороне. Получающая сторона не должна раскрывать эти данные другим сторонам, не участвующим в настоящем Соглашении, кроме случаев наличия предварительного явного письменного разрешения на разглашение соответствующей информации или раскрытие осуществляется согласно требованиям закона или по требованию компетентных органов власти.

  16. Прочие условия

    Если любое положение настоящего Соглашения стало или должно стать недействительным, оно не влияет на действительность остальных положений. В таких случаях недействительное положение должно быть заменено любым другим допустимым положением, похожим по значению и цели на оригинальное положение.

    Если это явно не согласовано сторонами в письменной или иной форме в рамках данного Соглашения, срок для предъявления претензий к Bosch составляет 1 (один) год с момента получения Конечным пользователем персонального неисключительного права на использование Лицензионного программного обеспечения.

  17. Применимое законодательство

    Настоящее Соглашение регулируется правом Нидерландов исключая применение коллизионных норм.

SOFTWARE LICENSE FOR ANY OTHER COUNTRY

STOP!

PLEASE READ THE FOLLOWING TERMS AND CONDITIONS CAREFULLY

IF YOU DO NOT AGREE WITH THESE TERMS AND CONDITIONS, DO NOT REGISTER THE AUTHORIZATION CODES MENTIONED IN THIS DOCUMENT, INSTEAD, PROMPTLY REMOVE AND DISTROY THIS DOCUMENT AND ASK FOR A FULL REFUND AT YOUR SUPPLIER. By using this Software you accept the terms stated below:

BOSCH SECURITY SYSTEMS B.V. LICENSE AGREEMENT FOR SOFTWARE

The software program that is currently being installed (hereinafter referred to as “the Licensed Software") has been developed by Bosch Security Systems B.V. (hereinafter referred to as “Bosch"). Bosch hereby offers End-User a license to use it under the following terms and conditions. By registering the authorization codes of the Licensed Software and/or using the Licensed Software End-User agrees to be bound by the terms and conditions of this End-User license agreement (hereinafter referred to as "this Agreement") and more specifically End-User agrees to the following:

  1. Definitions

    Agreement:

    this license agreement for software;

    Bosch:

    Bosch Security Systems B.V.;

    Content:

    all added and broadcasted material;

    End-User:

    an end-user is the person or organization that a software program or equipment is designed for. The term is based on the idea that the "end goal" of a software or hardware product is to be useful to the consumer. The end-user can be contrasted with the developers or programmers of the product. End-users are also in a separate group from the installers or administrators of the product. (http://www.techterms.com/definition/enduser);

    Equipment

    the tools, or other items needed for a particular activity or purpose;

    Licensed Software:

    software that need a legal authorization code to work;

    Services:

    intangible products such as storage and distribution of information or content;

    Webcast Data:

    content of the webcast;

    Webcast/Webcasting:

    a webcast is a media presentation distributed over the Internet using streaming media technology to distribute a single content source to many simultaneous listeners/viewers. A webcast may either be distributed live or on demand. Essentially, webcasting is “broadcasting” over the internet.

  2. Copyright

    The Licensed Software is a proprietary product of Bosch and Bosch owns all copyrights therein. Bosch retains title and ownership of the Licensed Software at all times.

  3. Right to use

    End-User is hereby granted the personal non-exclusive right to use the Licensed Software only on and in conjunction with one (1) computer at one (1) time and without further linkups in networks and the like. Bosch also reserves all rights not expressly granted to End-User herein.

    End-User may not sell, rent or lease the Licensed Software or otherwise transfer or assign the right to use it. End-User may not decompile, disassemble, reverse engineer or in any way modify program code without the prior written consent of Bosch. Unauthorised copying of the Licensed Software is expressly forbidden.

  4. Free Open Source Software

    • The software of the offered program possibly includes open source software and third party software under royalty free licenses (“FOSS”).

    • The FOSS in the program is subject to FOSS license agreements (“FOSS-Licenses”). Pursuant to these FOSS-Licenses, Bosch has to pass on to you their terms and conditions and you have to comply with these terms and conditions and fulfill respective obligations when using the FOSS in another way than merely installing and running it internally on your machines, e.g. through further disposal of the product, as by distribution, selling, or otherwise passing it on to a third party. The rights under the FOSS-Licenses are being granted to you, and in the event of you passing on a copy of the product to another party, the terms and conditions of the respective FOSS-Licenses apply to the distribution of any included FOSS (in some cases, the FOSS-License provides a direct license from the author/licensor of the FOSS to the third party). For many FOSS-Licenses, Bosch itself can neither grant nor obtain these rights for you. The applicable FOSS-Licenses are available on the internet address of the provider of the FOSS or will be made available by Bosch upon your request.

    • The FOSS itself does not contribute to the sales price of the program offered by Bosch and the FOSS is thus is provided without royalty or monetary compensation.

    • You have to, either expressly, or implied by amendment or adaptation of the FOSS, accept and take responsibility for your compliance with the applicable FOSS-Licenses. Further, you have to agree that updates or new versions of the software program may contain different or additional FOSS or changes in the FOSS-Licenses.

    • If any terms or restriction of this EULA conflict with the FOSS-Licenses or any other license conditions of Open Source Software included in this product, the terms and conditions of these Open Source Software licenses shall prevail.

  5. Warranty

    Bosch warrants that the Licensed Software will perform in substantial compliance with all available documentation supplied either with this or with previous versions of the Licensed Software. Bosch makes no further representations or warranties, expressly or implied, such as, by way of example but not of limitation, regarding merchantability or fitness for any particular purpose, that Licensed Software is error-free, that the use of the Licensed Software or any copies thereof will not infringe any intellectual or industrial property rights like patent, copyright or trademark of any third parties.

  6. Updates

    Bosch is always entitled to update and/or modify the Licensed Software.

  7. Purpose of transmission

    By accepting this agreement you explicitly acknowledge and oblige yourself to only use the Licensed Software, the Services and the Equipment for their intended purposes and according to the applicable (local) laws and regulations. You can never hold Bosch liable for any damage or claims in connection with illegal and/or otherwise prohibited use of the Licensed Software, the Services and/or the Equipment and shall indemnify Bosch from any claims in this respect (e.g. of third parties). If installing and use of the Licensed Software, Services and Equipment would lead to any right for you, you are deemed to waive this rights and assign them to Bosch, unless expressly stated in this Agreement otherwise.

  8. Responsibility for Webcasting (only applicable in case of webcasting)

    You will be exclusively responsible for any liability arising from unauthorized access or alteration to the Webcast Data or Content. You will also be responsible for any liability arising from any material or data which has been webcast unlawfully or that includes e.g. any threatening, defamatory, obscene, offensive or illegal material or any material which infringes any person's intellectual property rights. Except as expressly stated otherwise in this Agreement, we will not be responsible for any liability arising from the failure to webcast any material or data.

  9. Consent>

    You will obtain the consent of any person to be filmed, or, in the case of minor children, obtain the consent of their parent or guardian.

  10. Reproduction of the Content

    You will not copy or reproduce the Content or the Webcast Data on to any other server or location for further reproduction without our prior written consent, which will not be unreasonably withheld. However, you may provide third parties with links to the Webcasts so that they can view them.

  11. Changes to this Agreement

    No changes to this Agreement are valid unless with Bosch's and End-User's written approval. The terms and conditions of End-User are applicable whether or not contained in order forms or otherwise, unless specifically accepted by Bosch in writing by means of an addition to this Agreement.

  12. Limitations of liability

    Bosch shall not be liable to End-User for any damages, including any loss of profit, loss of savings or other End-User's incidental or consequential damages arising out of End-User's use or inability to use the Licensed Software, even if Bosch or its representatives have been advised of the possibility of such damages or for any claim by any other party.

  13. Validity and termination

    This Agreement shall be valid with effect as of the date End-User has opened the package containing the Licensed Software.

    End-User is entitled to terminate this Agreement at any time by simple written notice to Bosch subject to the provisions set out hereinafter.

    Bosch is entitled to terminate this Agreement by simple written notice to End-User but only in the event End-User fails to comply with any of its obligations pursuant to this Agreement. In the event of termination, whether by End-User or by Bosch, End-user shall immediately stop any use of the Licensed Software and of all copies thereof and shall return to Bosch or destroy the Licensed Software and all copies thereof and End-User shall promptly (but at the latest within five days after termination) confirm in writing to Bosch that it has returned or destroyed Licensed Software and all copies thereof and has terminated use. In addition, in the event of termination because of End-User's failure to comply with its obligations, Bosch reserves the right to invoke any and all other remedies available to it in law or contract including the right to claim damages.

  14. Export control

    The deliveries and services (fulfillment of contract) are under the proviso that their fulfillment is not contrary to the compliance with national or international regulations, especially export control regulations, embargoes or other sanctions. The contract parties commit themselves to supply all necessary information and documents needed for the export / transfer to other EU member states / import. Delays due to export control assessments or export control licensing procedures invalidate terms and dates of delivery. When licenses are not granted respectively the delivery and service is not licensable, this contract becomes void regarding to the affected parts. Claims for damages resulting from the above mentioned reasons and from mentioned delivery delays are excluded.

    The customer commits himself to comply with all relevant export control regulations in case of resale or onward delivery, i.e. all national regulations or EC regulations as well as US regulations). The resale or onward delivery of listed commodities (products, Licensed software and technology), the resale to embargoed countries or to blocked persons, organizations or companies or to consignees which use the commodities for a military end-use, for nuclear, biological or chemical weapons or nuclear technology could require an export license. The reseller or the customer who makes the onward delivery has to apply for the necessary licenses.

    The customer should note that the US export control law is also applicable when the commodities are completely or only partly originated in the USA. This can also be the case if the components are of US origin although the contract has no other reference to the USA.

    Infringements of the rules of law are subject to this agreement termination.

  15. Confidentiality

    Parties shall keep confidential any information or data provided by or on behalf of the disclosing party, which the receiving party knows or should reasonably know is secret and / or confidential and / or that disclosure may be harmful to the disclosing party. The receiving party shall not disclose this to others, not involved in the performance of the Agreement, unless the disclosing party has given explicit prior written consent to disclose the relevant information or disclosure occurs because the law or a competent authority obliges the receiving party to do so

  16. Miscellaneous

    If any provision contained in this agreement should be or become invalid, this shall not affect the remaining provisions. In such cases the invalid provision shall be replaced by a valid provision approximating as closely as possible to the sense and purpose of the original provision.

    Unless explicitly agreed otherwise by the parties in writing, or otherwise provided for in this Agreement, any claim against Bosch shall in any case expire after one (1) year from the time that End-User was granted the personal non-exclusive right to use the Licensed Software.

  17. Applicable law

    This Agreement shall exclusively be governed by the laws of The Netherlands.

Software maintenance Agreement

MAINTENANCE SERVICE LEVEL AGREEMENT

Supplement to the Software Maintenance Agreement

Bosch Security Systems B.V. ("Bosch") develops, markets and licenses software for use in Conference, Public Address, Voice Evacuation and Networked Audio systems. The Bosch Software Maintenance Agreement (the “Agreement”) sets out the terms and conditions under which Bosch will provide "Maintenance Services" for the "Software" (as defined in the Agreement).

This Service Level Agreement Supplement (the "Supplement") is a supplement to and a part of the Agreement, and sets forth the extent, detail and dependencies of the Maintenance Services to be provided by Bosch to a system integrator (“Customer”) of the software (the “Software”). The provision of Maintenance Services under the Agreement is subject to and conditioned on the terms of this Supplement.

Bosch only provides Maintenance Services on the Software to a Customer who has obtained a valid user license to the Software pursuant to the Agreement.

Terms defined in the Agreement shall have the same meaning when used in this Supplement unless otherwise expressly stated.

  • Maintenance Services. Maintenance Services include:

  • bug-fixing ("Support Services"); and

  • issuing new Releases of the Software.

  • Support.

  • Support Services are comprised of the analysis and correction of an "Error" (define below) in the Software.

  • An "Error" is a "Reproducible" (defined below) malfunction or issue in the Software that causes the Software to operate in a way that is materially different from what is described in the applicable documentation.

  • "Reproducible" means that the issue that causes the Error must re-occur when the operation and configuration of the Customer implemented version of the Software is repeated in Bosch’s support center, indicating that the issue is caused by a bug or other issue inherent to the software, rather than caused by the specific Customer environment or use.

  • In case of doubt on the Reproducible character of an issue, Bosch will normally provide Services as if the issue was reproducible (i.e. without any additional fee); provided, however, if, at any time during analysis or resolution, an issue appears to be not Reproducible, Bosch's continued resolution efforts will be subject to Customer agreeing to pay Bosch's then current fees and charges for such efforts.

  • If, on initial analysis, an issue appears not be Reproducible, Bosch may still choose to assist the Customer in finding a solution, but Bosch does not have any contractual duty to do so, and Bosch is entitled to charge additional fees, and such continued Bosch assistance will be subject to Customer agreeing to pay Bosch's then current fees and charges for such efforts.

  • If, after final analysis, an issue is found to be Reproducible (even if it appeared as non-Reproducible at initial logging), Bosch will not charge any additional such fees.

  • Different levels of Errors. Errors shall be categorized in accordance to their severity as defined in the following four (4) Severity Levels:

  • Severity Level 1 (Critical). An Error is Severity Level 1, when, in the production environment, the Software is completely down, or a major function of the Software is not working at all or is inaccessible, and there is no workaround available.

  • Severity Level 2 (Serious). An Error is Severity Level 2, when, in the production environment, the Software is significantly impaired (e.g. loss or degradation of a substantial functionality), which causes the Software to perform materially less than as described in the applicable documentation, or, in a test or back-up environment, the Software is completely down, or a major function of the Software is not working at all or is inaccessible, and there is no workaround available.

  • Severity Level 3 (Moderate). An Error is Severity Level 3, when, in the production environment, the Software encounters a technical or functional problem, but a temporary workaround is available, or, in a test or back-up environment, the Software is significantly impaired (e.g. loss or degradation of a substantial functionality), which causes the Software to perform materially less than as described in the applicable documentation.

  • Severity Level 4 (Minor). An Error is Severity Level 4, when there is an issue that relates to improvement of performance or functionality, or there is an issue for which a permanent workaround has been provided.

  • Support Services.

  • Errors have to be logged by Customer through the designed telephone hot-line, or via a dedicated support helpdesk website or email address ("First Line Support"). Bosch will indicate to Customer the exact contact details for First Line Support.

  • Bosch will use its reasonable efforts to provide Customer with a solution to the Error.

  • Solution times. Since Bosch will not know in advance of receipt of Customer's notice of an Error what the cause of an Error is, or how it can be resolved, Bosch cannot commit to solution times. Bosch will use reasonable commercial efforts to resolve the Error as soon as possible, taking into account the Severity Level of the Error.

  • Availability of First Line Support.

  • First Line Support is available during normal business hours of your Bosch sales representative, excluding weekends and holidays.

  • Remote Access and On-Site Support.

  • It is an essential condition of Support Services that Customer provides on-line remote access to the production environment of the Software. If no such remote access is provided, the level of Service may be severely impacted, and the response times will be delayed as a result.

  • The standard Support Services do not include On-Site Support. Upon Customer written request, and subject to Customer's agreement to pay Bosch's then current fees and charges therefor, Bosch may (but is under no obligation to) agree to provide On-Site Support. In such case, all travel and accommodation costs shall be charged in addition to Bosch's then current fees and charges.

  • Conditions to be able to call upon Support Services.

  • In order to be able to call upon Support Services, the Customer must:

  • have a valid user license to the Software, and not be in breach of any of the terms of the Software license;

  • have effectively paid all due and owing license, maintenance, and other fees owed to Bosch;

  • use the Software strictly in accordance with the applicable documentation and the Bosch instructions (including but not limited to the hardware and technological environment and usage instructions as issued by Bosch from time to time);

  • comply with the instructions on installment of the latest Software release as set out in this document or as instructed by Bosch from time to time;

  • ensure that the Software is only used by Customer's personnel that is properly qualified and trained in the use of the Software;

  • Bosch is entitled to request Customer to impose certain minimum training and certification requirements to the staff using the Software, in order to comply with the latest condition above.

  • If at the time Customer contacts First Line Support, it appears that Customer does not comply with one or more of the above conditions, Bosch will be entitled (but is not obligated) to make the provision of Support Services subject to payment of additional fees and charges.

  • If at the time Customer contacts First Line Support, it appears that the issue to be logged has been resolved by a new Release (either a Major or Minor Release, including fixes and hot patches) that has already been made generally available by Bosch, then Customer will first have to implement such Release, prior to Bosch performing any Support Services.

  • The following are not included in Software Support Services (“Out-of-Scope Services”):

  • data retrieval;

  • support of issues that are not Reproducible, or that otherwise fail to be qualified as Errors;

  • support of interfaces;

  • support of Customer-specific development software;

  • support of the technological environment in which the Software is installed;

  • support of hardware (Bosch cameras, or other parts of the Bosch hardware configuration are covered by separate agreements, and are specifically excluded from Software Support Services); and

  • support of third party software.

  • Upon Customer’s request, Bosch may (but has no obligation to) accept to provide Out-of-Scope Services, subject to Customer agreeing to pay Bosch's then current fees and charges therefor for time and materials. Any such Out-of-Scope Services will be provided on a reasonable effort basis, without any commitment as to Response or Solution times.

  • New Releases.

  • Bosch will make available to Customer new Releases of the Software as and when they are made “generally available” by Bosch to similarly situated customers. New Releases are made available to Customers with valid Maintenance Agreements at no additional cost.

  • Implementation (e.g. installation, license activation, and configuration) of new Releases is not included in the Maintenance Services. If Customer wants to receive such implementation services, they need to be ordered separately.

  • ALTHOUGH BOSCH WILL USE COMMERCIALLY REASONABLE EFFORTS TO ENSURE BACKWARDS COMPATIBILITY BETWEEN RELEASES, BOSCH DOES NOT GUARANTEE FULL BACKWARDS COMPATIBILITY, AND THE IMPLEMENTATION OF A NEW RELEASE MAY CAUSE SOME DATA LOSS. CUSTOMER SHOULD MAKE A FULL BACK-UP OF ALL DATA THAT CUSTOMER WISHES TO RETAIN PRIOR TO THE IMPLEMENTATION OF A NEW RELEASE.


Scope

This user manual describes the use of the Bosch Conference Protocol for the Bosch DICENTIS Conference System. To understand this manual, knowledge is expected on the following areas:

  • Coding knowledge of languages such as :HTML, AngularJs and C#. In this documentation, definitions and examples are using code fragments of these languages. If user wants to develop any application in other languages, can also use this conference protocol but is responsible in converting these examples to the appropriate language.

  • The network based synoptic system and its installation.

This user manual is intended for users, who want to use the Conference Protocol into their application.

The current version of the Conference Protocol provides functionality to:

  • Login: Authentication to Login and logout

  • Image management: Manage background image for synoptic layout(create, list, delete and update and apply background image)

  • Synoptic layout store: Storing of synoptic layout with all configuration for future reference

  • Synoptic seat management: Load all seat details. Also grant speech at the seat and remove participant from discussion using cancel Speech at seat.

  • Synoptic discussion list: List participants speaking or waiting to speak and their related data such as microphone states (On, Off or Muted), speaking type of the speaker (IsSpeaker, IsPrioritySpeaker, IsResponder, IsImportant, IsRequest, IsResponseRequest), Seat Id and Seat name etc.

  • Voting and attendance information: List the presence of participants and the vote they casted.

This application works based on client server communication basis. The client is developed using HTML and AngularJs. The conference protocol is developed using C#.

In this manual, we will find the code fragments of all mentioned technology as examples to clarify the use of the conference protocol for synoptic layout.

See Also

Other Resources

Introduction


History

History of Conference Protocol

Version

Details

DICENTIS 6.1

  1. Added requests

    • GetMicrophoneSensitivityDescriptionRequest
    • GetMicrophoneSensitivityRequest
    • UpdateMicrophoneSensitivityRequest
    • ResetMicrophoneSensitivityRequest

  2. Added responses

    • GetMicrophoneSensitivityDescriptionResponse
    • GetMicrophoneSensitivityResponse
    • UpdateMicrophoneSensitivityResponse
    • ResetMicrophoneSensitivityResponse

  3. Added methods

    • GetMicrophoneSensitivityDescription
    • GetMicrophoneSensitivity
    • UpdateMicrophoneSensitivity
    • ResetMicrophoneSensitivity

  4. Added events

    • SeatMicrophoneSensitivityUpdated

  5. Added permission

    • CanControlMicrophoneSensitivity

  6. Added Field

    • MaxRequests

    • MaxResponses

  7. Conference protocol demonstrator

    • Added microphone sensitivity commands in synoptic seat management tab

DICENTIS 5.1

  1. Added requests

    • GetSupportedHeadphonesRequest

    • RequestSpeechRequest

    • GrantSpeechRequest

    • RemoveSpeechRequest

    • RequestResponseRequest

    • GrantResponseRequest

    • RemoveResponseRequest

    • GetDiscussionOptionsRequest

  2. Added responses

    • GetSupportedHeadphonesResponse

    • RequestSpeechResponse

    • GrantSpeechResponse

    • RemoveSpeechResponse

    • RequestResponseResponse

    • GrantResponseResponse

    • RemoveResponseResponset

    • GetDiscussionOptionsResponse

  3. Added methods

    • GetSupportedHeadphones

    • RequestSpeech

    • GrantSpeech

    • RemoveSpeech

    • RequestResponse

    • GrantResponse

    • RemoveResponse

    • GetDiscussionOptions

  4. Added events

    DiscussionOptionsChanged

  5. Added permission

  6. Updated enums/models

    1. Enum

    2. Model

      • Added Headphone and AutomaticMicrophoneSelection in InterpreterDeskInfo

      • Added two lists "ParticipantIds" and "SeatIds" to ActivateMicrophoneRequest

      • Added two lists "ParticipantIds" and "SeatIds" to DeactivateMicrophoneRequest

  7. Conference protocol demonstrator

    • Added getSupportedHeadphones button in ControlInterpretation tab

    • Added removeAllRequests button in SeatManagement tab

    • Added stopAllSpeakersAndRemoveAllRequests button in SeatManagement tab

    • Added shiftFirst button in SeatManagement tab

    • Added requestSpeech button in SeatManagement tab

    • Added grantSpeech button in SeatManagement tab

    • Added removeSpeech button in SeatManagement tab

    • Added requestResponse button in SeatManagement tab

    • Added grantResponse button in SeatManagement tab

    • Added removeResponse button in SeatManagement tab

    • Added mute button in SeatManagement tab

    • Added unmute button in SeatManagement tab

DICENTIS 4.3

  1. Added requests

  2. Added responses

  3. Added methods

  4. Added events

  5. Added permission

    • CanPrepareAdhocVoting

  6. Updated enums/models

    1. Enum

      • Added

    2. Model

      • Added

DICENTIS 4.2

  1. Added requests

    • OpenAgendaRequest

    • CloseAgendaRequest

    • ActivateMeetingRequest

    • DeactivateMeetingRequest

    • OpenMeetingRequest

    • CloseMeetingRequest

    • GetMeetingsRequest

    • GetParticipantAccessDeniedReasonsRequest

    • ActivateAdHocVotingRequest

    • ActivateVotingRequest

    • OpenVotingRequest

    • CloseVotingRequest

    • HoldVotingRequest

    • ResumeVotingRequest

    • AbortVotingRequest

    • RejectVotingRequest

    • AcceptVotingRequest

  2. Added responses

    • OpenAgendaResponse

    • CloseAgendaResponse

    • ActivateMeetingResponse

    • DeactivateMeetingResponse

    • OpenMeetingResponse

    • CloseMeetingResponse

    • GetMeetingsResponse

    • GetParticipantAccessDeniedReasonsResponse

    • ActivateAdHocVotingResponse

    • ActivateVotingResponse

    • OpenVotingResponse

    • CloseVotingResponse

    • HoldVotingResponse

    • ResumeVotingResponse

    • AbortVotingResponse

    • RejectVotingResponse

    • AcceptVotingResponse

  3. Added methods

    • OpenAgenda

    • CloseAgenda

    • GetMeetings

    • ActivateMeeting

    • DeactivateMeeting

    • OpenMeeting

    • CloseMeeting

    • GetParticipantAccessDeniedReasons

    • ActivateAdHocVoting

    • ActivateVoting

    • OpenVoting

    • CloseVoting

    • HoldVoting

    • ResumeVoting

    • AbortVoting

    • RejectVoting

    • AcceptVoting

  4. Added events

    • MeetingListChanged

    • ParticipantAccessDenied

  5. Added permission

    • hasParticipantBasedLicense

    • canViewRemoteParticipants

  6. Updated enums/models

    1. Enum

      • Added

        • AccessDeniedReason - Reason for partcipant denied access.

        • canControlVoting - Permission to control voting.

    2. Model

      • Added

        • ControlMeetingCommands

        • ControlAgendaCommands

        • ParticipantAccessDeniedReasons

  7. JsonRequest : GetMeetingInfoRequest

    • Added Field : MeetingId

  8. JsonRequest : GetAgendaTopicsRequest

    • Added Field : MeetingId

  9. JsonRequest : GetParticipantsRequest

    • Added Field : MeetingId

  10. JsonRequest : GetVotingsRequest

    • Added Field : MeetingId

  11. JsonResponse : GetDiscussionListResponse

    • Added Field : ReferenceTime

  12. Conference protocol demonstrator

    • Added Control Voting tab

    • Added Control Meeting tab

    • Added UI for participant access denied notification

    • Added getMeetings button in Meeting tab

    • Added Field : SpeechStartTime

    • Added Field : RemainingSpeechDuration

    • Added Field : SpeechTime

DICENTIS 4.1

  1. Added requests

    • GetRoomNameRequest

    • GetRoomContactEmailRequest

    • RegisterPluginRequest

    • UnregisterPluginRequest

    • GetPluginRequest

    • GetPluginsRequest

    • SendPluginEventRequest

    • SendPluginCommandRequest

    • SubscribePluginEventRequest

    • UnSubscribePluginEventRequest

  2. Added responses

    • GetRoomNameResponse

    • GetRoomContactEmailResponse

    • RegisterPluginResponse

    • UnregisterPluginResponse

    • GetPluginResponse

    • GetPluginsResponse

    • SendPluginEventResponse

    • SendPluginCommandResponse

    • SubscribePluginEventResponse

    • UnSubscribePluginEventResponse

  3. Added methods

    • GetRoomName

    • GetRoomContactEmail

    • RegisterPlugin

    • UnRegisterPlugin

    • GetPlugin

    • GetPlugins

    • SendPluginEvent

    • SendPluginCommand

    • SubscribePluginEvent

    • UnSubscribePluginEvent

  4. Added events

    • RoomNameChanged

    • RoomContactEmailChanged

    • PluginsChanged

    • PluginEventAvailable

    • PluginCommandAvailable

  5. Updated enums/models

    1. Enum

      • Added

        • ParticipantSeatType - For supporting remote and local participants.

      • Updated

        • DeviceType - Added FlushBaseDevice and IntTxoDevice.

        • EnumDeskType - Updated name for camel casing.

    2. Model

      • Added

        • PluginDescription

        • PluginCommandDescription

        • PluginEventDescription

      • Updated

        • Participant - Added Email and ParticipantType field.

        • SeatInfo - Added SeatType and Attributes field.

  6. Conference protocol demonstrator

    • Added Rooms tab

    • Added Plugin tab

DICENTIS 4.0

  1. Conference protocol demonstrator

    • Update UI for issue , cancel and get interpreter meta requests.

  2. Added methods

    • IssueInterpreterMetaFunction

    • CancelInterpreterMetaFunction

    • GetInterpretationMetaFunctionStatus

  3. Added conference events

    • InterpretationMetaRequestStatusChanged

  4. Added requests

    • IssueInterpreterMetaFunctionRequest

    • CancelInterpreterMetaFunctionRequest

    • GetInterpretationMetaFunctionStatusRequest

  5. Added responses

    • IssueInterpreterMetaFunctionResponse

    • CancelInterpreterMetaFunctionResponse

    • GetInterpretationMetaFunctionStatusResponse`

  6. JsonRequest : GetNotesFileListRequest

    • Updated field : StartDate (To accept date in string format of 'yyyy-MM-dd')

    • Updated field : EndDate (To accept date in string format of 'yyyy-MM-dd')

DICENTIS 3.7

  1. JsonResponse : GetVotingInfoResponse

    • Added Field : VotingTimerType

  2. JsonResponse : CheckNotesFileTamperedResponse

    • Added Field : IsDocumentSigned

DICENTIS 3.6

  1. Conference protocol demonstrator

    • Show conference protocol version in demonstrator

  2. JsonResponse : GetInterpreterSeatsResponse

    • Added Field : DeskType

    • Removed Field : DeskInUse

  3. JsonResponse : GetInterpreterBoothsResponse

    • Added Field : AutoRelay

    • Removed Field : BoothInUse

  4. JsonResponse : GetInterpretationRoutings

    • Added Field : DestinationLanguageQuality

  5. Added Methods

    • SelectInterpretationInputLanguage

    • SelectInterpretationFloor

    • SelectRelayInterpretation

    • RaiseBoothNotification

    • GetBoothNotifications

    • GetNotesFileList

    • DeleteNotesFiles

    • TransformNotesFile

    • CheckNotesFileTampered

  6. Added ConferenceEvents

    • BoothNotificationsChanged

    • NotesFileListChanged

  7. Requests added

    • CheckNotesFileTamperedRequest

    • TransformNotesFileRequest

    • DeleteNotesFilesRequest

    • GetNotesFileListRequest

  8. Responses added

    • CheckNotesFileTamperedResponse

    • TransformNotesFileResponse

    • DeleteNotesFilesResponse

    • GetNotesFileListResponse

DICENTIS 3.5

  1. JsonResponse : GetSeatsResponse

    • Added Field : VisType

    • Added Field : CanPrio

  2. JsonResponse : GetParticipantsResponse

    • Added Field : VisType

    • Added Field : CanPrio

  3. JsonResponse : GetInterpretationRoutingsResponse

    • Added Field : AutoRelayContribution

  4. Added Methods

    • GetMajorityResult

    • GetQuorumResult

    • GetVotingInfo

  5. Added ConferenceEvents

    • MajorityResultChanged

    • QuorumResultChanged

    • VotingInfoChanged

  6. JsonResponse : getDiscussionList

    • Added Field : activeImage

    • Added Field : activeVideo

  7. JsonResponse : GetVotingsResponse

    • Removed Field : votingInstanceId

    • Removed Field : MeetingId

    • Added Field : referenceNumber

    • Added Field : documentationLink

  8. Renamed ConferenceEvent :

    Old name : MeetingStateChanged

    New name : MeetingInfoChanged

  9. JsonResponse : GetMeetingInfoResponse

    • Removed Field : meetingId

  10. JsonResponse : GetAgendaTopicsResponse

    • Removed Field : meetingId

DICENTIS 3.4

  1. Presentation control added

  2. JsonResponse : GetSeatsResponse

    • Removed Field : Name

    • Added Field : SeatName

  3. JsonResponse : GetDiscussionListResponse

    • Removed Field : Name

    • Added Field : ScreenLine

  4. JsonResponse : GetParticipantsResponse

    • Old structure

      { "participants": [
      {"id": <string> , "participantInfo": {
      "canVote": <bool>
      , "id": <string>
      , "isAuthenticated": <bool>
      , "personInfo": {
      "country": <string> , "firstName": <string> , "group": <string> , "id": <string> , "lastName": <string> , "middleName": <string> , "region": <string> , "title": <string> },
      "voteWeight": <int>
      } } ] }

    • New structure

      { "participants": [ {
      "canVote": <bool>, "country": <string>, "firstName": <string>, "group": <string>, "isAuthenticated": <bool>, "lastName": <string>, "middleName": <string>, "participantId": <string>, "region": <string>, "title": <string>, "voteWeight": <int>
      } ] }

  5. canControlMasterVolume, canSwitchSystemPowerOn and canSwitchSystemPowerOff

    permissions available for users with activate meeting or configure system rights or participant with managemeeting rights.

  6. Method name updated

    Old Name : GetsIndividualVotingResult

    New Name : GetsIndividualVotingResults

  7. JsonResponse : GetsIndividualVotingResultsResponse

    Old name : GetsIndividualVotingResultResponse

    New name : GetsIndividualVotingResultsResponse

    Removed Field : VotingResult

    Added Field : IndividualVotingResult

  8. JsonResponse : GetsIndividualVotingResultsRequest

    Old name : GetsIndividualVotingResultRequest

    New name : GetsIndividualVotingResultsRequest

  9. Added Methods

    GetParticipantSeats

  10. Removed Methods

    getMeetingStateInfo

  11. Renamed a property of AgendaTopic class

    Old name : Active

    New name : State

  12. Added a new enumeration

    • AgendState

DICENTIS 3.3

Volume control added

DICENTIS 3.2

Initial version


HowTo Overview

This section includes How To documentation for performing common conferencing system tasks.

In This Section

  • How To Use Conference Protocol

  • Conference Protocol Basic

  • Error Handling

  • Events

  • Authentication

  • Examples

  • How to use Linux based demonstrator

  • How to use conference protocol demonstrator

  • How to calculate speech timer

  • Permissions


How To Use Conference Protocol

This page provides a step wise description regarding use of various functionalities available with conference protocol such as login, image management, synoptic layout store, synoptic seat management, and synoptic discussion list etc.

Opening a protocol channel

The conference protocol runs over a web socket. To open a channel to the protocol, create a websocket to the address :

Copy
wss://<host>:31416/Dicentis/API

using the (sub)protocol

Copy
DICENTIS_1_0

The protocol only supports wss, i.e. secure web sockets. Insecure web sockets are not supported. No http headers, credentials or cookies need to be set. Any specified will be ignored. In JavaScript, one would create the socket using:

By default, the websocket server uses self signed certificates. To create and use valid certificate refer to the release notes in the section "Creating certificates on the Server".

JavaScript
Copy
var s = new WebSocket(“wss://DicentisServer/Dicentis/API”, “DICENTIS_1_0”);


Conference Protocol Basic

Once the web socket is opened, the client can send request messages. The server responds with response messages. All messages are formatted using JSON.

All messages, both request and response have a similar format, as defined by this JSON schema:

Copy
{
"type": "object",
"properties": {
    "messageId": {
        "required": true,
        "type": "integer"
    },
    "operation": {
        "required": true,
        "type": [
            "string",
            "null"
        ]
    },
    "parameters": {
    "required": true,
    "type": [
        "object",
        "null"
    ],
    "properties": {}
    }
  }
}

The messageId is not used by the server. It serves only for the client to match requests it sends to responses received from the server. When the server generates a response, it copies the messageId received in the request message to the response. The client should not use messageId value 0 because that number is used by the server for notifying events.

The operation is a string that identifies the operation on the server to be executed. It is not case sensitive. Operations are defined later in this document. The server copies the operation name from the request to the response, except when an error occurs.

Finally, every request and response message has a parameters field. This field is an object. In requests to the server, it that holds all the parameters for the operation to be executed. In responses it holds the results of processing.

Since the parameters field is an object, it itself contains fields.

  1. If a request message contains any fields in the parameters object that the server does not understand, the operation will fail, and the server will return an error message.
  2. If the client does not specify all the fields that the server can handle, the server will fill in suitable defaults and the operation will complete normally.


Error Handling

If the server detects a protocol error (e.g. bad formatted JSON) in a request, it closes the web socket.

In all other cases, the server responds with an error message. An error message conforms to the message format defined in the previous paragraph.

messageId is copied from the request message.
operation is set to the string “error”.
parameters is set the object with the JSON schema:

Copy
 {
  "type": "object",
  "properties": {
    "message": {
      "required": true,
      "type": [
        "string",
        "null"
      ]
    }
  }
}

Note that the message holds information useful to the client application developer, not to the end user. And it is not intended to be parsed. Different implementations of the server may have different error messages.


Events

An event message may be sent by the server at any time. A client needs to be aware that after sending a request, the server may send an event message before the response.

Just like error messages, event messages conform to the basic message format.

messageId is set to 0.
operation is set to the string “event”.
parameters is set the object with the JSON schema:

Copy
{
  "type": "object",
  "properties": {
    "events": {
      "required": true,
      "type": [
        "array",
        "null"
      ],
      "items": {
        "type": [
          "string",
          "null"
        ]
      }
    }
  }
}

Each event is identified by a string value. Events never carry any data. Instead, once the event occurs, the client must use one of the operations to get the data. For example, when the event “PermissionsChanged” fires, the client can use the “GetPermissions” operations to get the set of current permissions.

An event will only fire once. It needs to be reset by the client for it to fire again. There are two ways to reset the event:

  1. The reset is implicit when the corresponding data is retrieved. For example, After PermissionsChanged event has fired, no more PermissionChanged events are fired, even if the permissions change. Only after the client has requested the current permissions using GetPermissions, the PermissionsCanged event will fire again.
  2. An explicit reset by calling “RegisterEvents” for the event again.

The documentation for each event explains which operation resets the event.

Although this might seem complex, normally it works intuitively on the client application side. The advantage of this way of working is that the Dicentis server will never overload a slow network connection with a huge amount of events, nor with data that is already out of date by the time it arrives at the client.

The “RegisterEvents” and “UnregisterEvents” operations allow a client to filter the events it wants to receive. After a new web socket connection is established, no events are generated until “RegisterEvents” is called.


How to Authenticate

In order to be able to use the conference protocol, the clients need to log in using the “LogIn” operation. It is illegal to call “LogIn” again after a successful login.

To log off, client can close the web socket connection, or use the “LogOut” operation.

Without a valid LogIn, all other operations will return an error message.


Examples

Message exchange for the RegisterEvents operation

Request:

Copy
{
  "messageId": 1,
  "operation": "RegisterEvents",
  "parameters": {
    "events": [
      "DiscussionListChanged",
      "ParticipantsChanged"
    ]
  }
}

Response:

Copy
{
  "messageId": 1,
  "operation": "RegisterEvents",
  "parameters": {}
}

Message exchange for the GetPermissions operation

Request:

Copy
{
  "messageId": 1,
  "operation": "GetPermissions",
  "parameters": {}
}

Response:

Copy
{
  "messageId": 1,
  "operation": "GetPermissions",
  "parameters": {
    "permissions": [
      "canAddDevicesToSeats",
      "canSelect"
    ]
  }
}

A request for an unknown operation:

Request:

Copy
{
  "messageId": 3,
  "operation": "DummyOperation",
  "parameters": {}
}

Response:

Copy
{
  "messageId": 3,
  "operation": "error",
  "parameters": {
    "message": "DummyOperation is an unknown operation"
  }
}

A malformed request. Here the operation is missing:

Request:

Copy
{
  "messageId": 3,
  "parameters": {}
}

Response:

Copy
{
  "messageId": 3,
  "operation": "error",
  "parameters": {
    "message": "Bad message format"
  }
}

Another request. Here the parameters object contains some unknown fields (GetPermissions does not take any parameters, but here an events parameter is passed):

Request:

Copy
{
  "messageId": 4,
  "operation":"GetPermissions",
  "parameters":{"events":["DiscussionListChanged","ParticipantsChanged"]}
}

Response:

Copy
{
  "messageId": 4,
  "operation": "error",
  "parameters": {
    "message": "Could not find member 'events' on object of type 'GetPermissionsRequest'. Path 'parameters.events', line 1, position 67."
  }
}


How to use Linux based demonstrator

This document provides information regarding the use of Linux based demonstrator

Setup for executing conference protocol demonstrator on Linux system

Below steps describe, setting up conference protocol demonstrator

  1. Copy "ConferenceProtocolDemonstrator" folder from Technician\Tools folder to Linux system
  2. Open the terminal, navigate to "ConferenceProtocolDemonstrator" folder
  3. Check the system compatability for building the "ConferenceProtocolDemonstrator" output file by executing "make" command as below
    In case if the system compatability does not meet the requirements as above please follow below procedure
    Installation Required 2
  4. Clean the output file by executing "make clean" command.
  5. Build the "ConferenceProtocolDemonstrator" output file by executing "make all" command
  6. Execute the generated output file “./ConferenceProtocolDemonstrator” or "make exec", so that the "ConferenceProtocolDemonstrator" will start
How to connect to DICENTIS server
  1. To connect to DICENTIS server execute "connect" command, once the "connect" command starts execution, prompt asks to enter the DICENTIS server IP address, provide the valid IP address of DICENTIS server
  2. "Successfully connected" message is displayed with server status and information
Commands

  • Send command: Sends request to the server

    1. Type "send" command, all the available send operations are displayed
    2. Prompt asks to enter operation, enter any of the operations in the list.
      For example: enter "login"
      Prompt asks to enter Username and password, when valid credentials are provided, login request is sent and response is received
    3. When login is requested without valid credentials, error response is received

    Close command: Closes the connection with DICENTIS Server

    Display command: Displays all the request and response history

    Help Command: Displays all the commands available and gives information about what they do

    Exit command: Exits the program


How to use conference protocol demonstrator

ConferenceProtocolDemonstrator is a webpage which is built using ConferenceProtocol, it helps the users in understanding how to write their own application using ConferenceProtocol

How to use conference protocol demonstrator
  1. In browser(supports only in Firefox, Edge, Safari, Chrome) enter URL “https://<Server>:31416/Demonstrator/ConferenceProtocolDemonstrator.html”
  2. It opens conference protocol demonstrator webpage. All the tabs except login tab will be disabled
  3. Enter valid username and password, on successful login, user can see permissions they have and all the tabs gets enabled
    Valid User Name Password
Example

1) How to turn on a microphone for seat.

Prerequisites
  • The WebClient requires Manage Meeting rights.
  • Logged in user requires Activate meeting rights. The participant (user part of the group participantsgroup) and part of the active meeting has manage meeting rights.

Login to the Conference protocol demonstrator. And check if you have canManageMeeting permission to activate the microphone.

Using Conference protocol demonstrator navigate to "Synoptic seat management" tab.

Copy one of the seat guid from seatId column paste to text box.

Click on AddSeatToSpeakers button.

2) How to use power on /off the system.

Prerequisites
  • The WebClient requires Power off rights.
  • Logged in user requires Activate meeting rights. The participant (user part of the group participantsgroup) and part of the active meeting has manage meeting rights.

Login to the Conference protocol demonstrator. And check if you have canSwitchSystemPowerOn canSwitchSystemPowerOff permission to power on and off the system.

Using Conference protocol demonstrator navigate to "Power mode" tab.

Use getSystemPowerMode button to retrieve current power mode status.

If system power mode status is "poweredOn" then user will see "setSystemPowerMode(PowerModeOff)" as button text to power off the system.

If system power mode status is "poweredOff" then user will see "setSystemPowerMode(PowerModeOn)" as button text to power on the system.

How to debug
  1. Goto browser’s DEBUG mode by pressing F12 in the browser, in console window all requests, responses, errors are logged.

    For example: Click on "getMasterVolumeRange" button in "Control Volume" tab, you can see the request and response as in the below image


Permissions

This page explains the various permissions for the logged in user can have.

Name | Description
canManageMeeting | In order to have canManageMeeting permission, web client seat needs to have Manage Meeting rights and logged in user needs to have activate meeting rights or logged in Participant needs to have manage meeting.
canControlInterpretation | In order to have canControlInterpretation permission, web client seat needs to have Manage Meeting rights, system should have special licenses, premium licenses or ultimate licenses and logged in user needs to have ActivateMeeting or logged in participant needs to have manage meeting.
canEditSynoptic | In order to have canEditSynoptic permission, logged in user needs to have ConfigureSystem rights.
canSelect | In order to have canSelect permission, logged in user needs to have ConfigureSystem rights.
canAddDevicesToSeats | In order to have canAddDevicesToSeats permission, logged in user needs to have ConfigureSystem rights.
canViewVoting | In order to have canViewVoting permission, system should have special licenses, premium licenses or ultimate licenses, the synoptic seat needs to have Can Vote, and Voting Scripts should be configured to have rights for External System.
canEnableSeatIllumination | In order to have canEnableSeatIllumination permission, logged in user needs to have ConfigureSystem rights.
canSwitchSystemPowerOn | In order to have canSwitchSystemPowerOn, web client seat needs to have Power On rights. Logged in participant needs to have manage meeting rights.
canSwitchSystemPowerOff | In order to have canSwitchSystemPowerOff, web client seat needs to have Power Off rights. Logged in participant needs to have manage meeting rights.
canViewRequestItems | In order to have canViewRequestItems, logged-in user either needs to have Manage Meeting rights or logged-in user needs to have Special permission.
canViewFirstRequestOnSeat | In order to have canViewRequestItems, logged in user either needs to have Manage Meeting rights or logged-in user needs to have Special permission.
canDeactivateMicrophone | This permission only gets enabled in Response mode, logged in user needs to have Manage rights.
hasSpecialPermission | In order to have hasSpecialPermission. Web client seat needs to have special permission.
canViewInterpretation | In order to have canViewInterpretation, Logged in user either needs to have Activate meeting rights. Logged in participant needs to have Manage Meeting rights.
canControlMasterVolume | In order to have canControlMasterVolume, web client seat needs to have Volume Control rights. Logged in user either needs to have Activate meeting rights. Logged in participant needs to have Manage Meeting rights.
canControlVoting | In order to have canControlVoting, system should have LVPM license, web client seat needs to have Voting Control rights. Logged in user needs to have Activate meeting rights. Logged in participant needs to have Manage Meeting rights and Vote rights.
System user's details.
Users | Users not part of the ParticipantsGroup. The group to which they are assigned can have a combination of user rights (Configure System, Activate meeting, Prepare meeting, Assign access rights, nothing).
Persons | Users which are part of the ParticipantGroup (and do not have Configure System, Activate Meeting, Prepare Meeting, Assign Access rights, rights).
Participants | Persons who are assigned to a meeting which is activated.


How to calculate speech timer for each entry in discussion list

GetDiscussionListResponse is having referenceTime which is Synoptic server's Environtment.Tick ( which is used to sync time with devices time)

In Conference protocol demonstrator

  • localreferencetime : This is date.now() at client side when synotic client receives DiscussionListChanged event.

  • will start timer if speech timer is enabled, each discussionlistentry.speechTime is calculated every 1 sec as below

  • var speechTime = entry.remainingSpeechDuration;
if (entry.microphoneState == "on") {
speechTime = c entry.remainingSpeechDuration - (referenceTime + (Date.now() - localreferencetime) - entry.speechStartTime);
}

var seconds = parseInt((speechTime / 1000) % 60)
var  minutes = parseInt((speechTime / (1000 * 60)) % 60)
var hours = parseInt((speechTime / (1000 * 60 * 60)) % 24);

var minus = speechTime {<} 0 ? '- ' : '';

hours = Math.abs(hours);
minutes = Math.abs(minutes);
seconds = Math.abs(seconds);

hours = (hours {<} 10) ? "0" + hours : hours;
minutes = (minutes {<} 10) ? "0" + minutes : minutes;
seconds = (seconds {<} 10) ? "0" + seconds : seconds;
entry.remainingSpeechTime = minus + minutes + ':' + seconds;

    Bind entry.remainingSpeechTime in html and displayed as HH:SS format


Conference Protocol Reference

This help file describes the Conference protocol.


ConferenceApiHandler.AbortVoting Method

AbortVoting Method

Abort the open voting
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
}
Remarks
Requires:
  • canControlVoting permission.
See Also

Reference

Permission
OpenVoting
CloseVoting
HoldVoting
ResumeVoting
RejectVoting
AcceptVoting


ConferenceApiHandler.AcceptVoting Method

AcceptVoting Method

Accept the closed voting
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
}
Remarks
Requires:
  • canControlVoting permission.
See Also

Reference

Permission
OpenVoting
CloseVoting
HoldVoting
ResumeVoting
AbortVoting
RejectVoting


ConferenceApiHandler.ActivateAdHocVoting Method

ActivateAdHocVoting Method

Activate an ad-hoc voting
Syntax
Json
Request:

Copy
{
    "description": <string>,
    "number": <string>,
    "subject": <string>
}

Response:

Copy
{
}
Remarks
Requires:
  • canControlVoting permission.
The maximum characters, the request parameters takes is fixed and if the length limit exceeds, the values are truncated.
  • number: Voting number for the ad-hoc voting, the maximum characters supported is 50.
  • subject: Voting subject for the ad-hoc voting, the maximum characters supported is 50.
  • description: Voting description for the ad-hoc voting, the maximum characters supported is 255.
See Also

Reference

Permission
OpenVoting
CloseVoting
HoldVoting
ResumeVoting
AbortVoting
RejectVoting
AcceptVoting


ConferenceApiHandler.ActivateMeeting Method

ActivateMeeting Method

To activate a meeting.
Syntax
Json
Request:

Copy
{
    "meetingId": <string>
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ActivateMicrophone Method

ActivateMicrophone Method

Un-mutes the microphone for the specified seat.
Syntax
Json
Request:

Copy
{
    "participantIds": [<string>],
    "seatId": <string>,
    "seatIds": [<string>]
}

Response:

Copy
{
}
Remarks
Requires:
  • canManageMeeting permission.
  • canDeactivateMicrophone permission.
To execute this method microphone mode should be in "Response" mode and seat should be an active responder or an active speaker, which is muted. Note that it only unmutes the muted speaker/responder, doesn't add a new seat or shift a requester in responders queue or request to speak queue to active speaker/responder.
  • To add a new seat or to shift a requester in responders queue or request to speak queue to active speaker/responder use AddSeatToSpeakers.
See Also

Reference

Permission
DeactivateMicrophone


ConferenceApiHandler.ActivatePresentation Method

ActivatePresentation Method

Activate the presentation screen of the device.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
}
See Also

Reference

DeactivatePresentation


ConferenceApiHandler.ActivateVoting Method

ActivateVoting Method

Activate a voting
Syntax
Json
Request:

Copy
{
    "votingId": <string>
}

Response:

Copy
{
}
Remarks
Requires:
  • canControlVoting permission.
See Also

Reference

Permission
OpenVoting
CloseVoting
HoldVoting
ResumeVoting
AbortVoting
RejectVoting
AcceptVoting


ConferenceApiHandler.AddSeatToSpeakers Method

AddSeatToSpeakers Method

Adds the seat to active speakers list.
Syntax
Json
Request:

Copy
{
    "seatId": <string>
}

Response:

Copy
{
}
Remarks
Requires:
  • canManageMeeting permission.
Seat will be shifted to active speakers if seat is in responders queue or request to speak queue. If seat is not in present responders or request to speaker list then seat will be added to active speaker list.
See Also

Reference

Permission
RemoveSeatFromDiscussionList


ConferenceApiHandler.CancelInterpreterMetaFunction Method

CancelInterpreterMetaFunction Method

Cancel interpreter meta request from a seat.
Syntax
Json
Request:

Copy
{
    "request": <string>,
    "seatId": <string>
}

Response:

Copy
{
}
Remarks
Requires:
  • canControlInterpretation permission.
Cancels speak slow from given seat.
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.CanExecutePresentationPlugin Method

CanExecutePresentationPlugin Method

Syntax
Json
Request
Response
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.CheckforLicense Method

CheckforLicense Method

Syntax
Json
Request
"canManageMeeting"|"canEditSynoptic"|"canSelect"|"canAddDevicesToSeats"|"canViewSynoptic"|"canViewVoting"|"canEnableSeatIllumination"|
"canSwitchSystemPowerOn"|"canSwitchSystemPowerOff"|"canViewRequestItems"|"canViewFirstRequestOnSeat"|"canDeactivateMicrophone"|
"hasSpecialPermission"|"canControlInterpretation"|"canViewInterpretation"|"canControlMasterVolume"|"canPrepareMeetingAndAgenda"|
"canViewMeetingNotes"|"canViewVotingNotes"|"canViewRemoteParticipants"|"canControlVoting"|"hasParticipantBasedLicense"|"canControlMicrophoneSensitivity"Response
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.CheckIfNoNullOrEmptyGuids Method

CheckIfNoNullOrEmptyGuids Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.CheckNotesFileTampered Method

CheckNotesFileTampered Method

Check whether the notes file is tampered with and its certifcate is valid
Syntax
Json
Request:

Copy
{
    "fileName": <string>
}

Response:

Copy
{
    "fileVerificationResponse":
    {
        "hasHashTag": <bool>,
        "isAuthenticatedUsingCertificate": <bool>,
        "isDocumentSigned": <bool>,
        "isTampered": <bool>
    }
}
Remarks
Requires either of:
  • canViewMeetingNotes permission or
  • canViewVotingNotes permission
Files with size exceeding 50 MB are not signed, hence property 'IsDocumentSigned' returns 'false' for such files.
See Also

Reference

Get list of meeting and voting notes xml file details.
Deletes the given notes files
XSL transforms the specified notes file


ConferenceApiHandler.CloseAgenda Method

CloseAgenda Method

Close Agenda for current meeting.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.CloseMeeting Method

CloseMeeting Method

To close active meeting.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.CloseVoting Method

CloseVoting Method

Close the open voting
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
}
Remarks
Requires:
  • canControlVoting permission.
See Also

Reference

Permission
OpenVoting
HoldVoting
ResumeVoting
AbortVoting
RejectVoting
AcceptVoting


ConferenceApiHandler.ConvertStringsToGuids Method

ConvertStringsToGuids Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.CreateFile Method

CreateFile Method

Creates the specified file.
Syntax
Json
Request:

Copy
{
    "attributes": [<string>],
    "payload": <string>,
    "title": <string>
}

Response:

Copy
{
    "fileId": <string>
}
Remarks
Requires:
  • canEditSynoptic permission.
Attributes indicate what contents of file represent and can contain list of values like 'Bosch.Synoptic.Layout', 'Bosch.Synoptic.Index'
See Also

Reference

Permission
UpdateFile
ListFiles
LoadFile


ConferenceApiHandler.CreatePluginDescription Method

CreatePluginDescription Method

Syntax
Json
Request
{
    "pluginCommands":
    [
        {
            "name": <string>
        }
    ],
    "pluginEvents":
    [
        {
            "name": <string>
        }
    ],
    "pluginInterface": <string>,
    "pluginName": <string>
}Response
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.DeactivateMeeting Method

DeactivateMeeting Method

To deactivate active meeting.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.DeactivateMicrophone Method

DeactivateMicrophone Method

Mutes the microphone for the specified seat.
Syntax
Json
Request:

Copy
{
    "participantIds": [<string>],
    "seatId": <string>,
    "seatIds": [<string>]
}

Response:

Copy
{
}
Remarks
Requires:
  • canManageMeeting permission.
  • canDeactivateMicrophone permission.
To execute this method microphone mode should be in "Response" mode and seat should be an active responder or an active speaker. Note that it only mutes the active speaker/responder, doesn't remove the seat from discussion list.
  • To remove from discussion list use RemoveSeatFromDiscussionList.
See Also

Reference

Permission
ActivateMicrophone


ConferenceApiHandler.DeactivatePresentation Method

DeactivatePresentation Method

De-Activate the presentation screen of the device.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
}
See Also

Reference

ActivatePresentation


ConferenceApiHandler.DeleteFile Method

DeleteFile Method

Deletes saved files.
Syntax
Json
Request:

Copy
{
    "fileId": <string>
}

Response:

Copy
{
}
Remarks
Requires:
  • canEditSynoptic permission.
See Also

Reference

Permission
CreateFile
UpdateFile
ListFiles
LoadFile


ConferenceApiHandler.DeleteImage Method

DeleteImage Method

Deletes the specified image.
Syntax
Json
Request:

Copy
{
    "imageName": <string>
}

Response:

Copy
{
}
Remarks
Requires:
  • canEditSynoptic permission.
Only background image of synoptic can be deleted.
See Also

Reference

Permission
ListImages
SaveImage


ConferenceApiHandler.DeleteNotesFiles Method

DeleteNotesFiles Method

Deletes the notes files.
Syntax
Json
Request:

Copy
{
    "fileNames": [<string>]
}

Response:

Copy
{
    "success": <bool>
}
Remarks
Requires :
  • canPrepareMeetingAndAgenda permission
See Also

Reference

Permission
Defines delete notes file request.
Get list of meeting and voting notes xml file details.
XSL transforms the specified notes file
To check the file is tampered or not


ConferenceApiHandler.EnableSeatIllumination Method

EnableSeatIllumination Method

Enables or disables seat illumination mode.
Syntax
Json
Request:

Copy
{
    "enable": <bool>
}

Response:

Copy
{
}
Remarks
Requires:
  • canEditSynoptic permission.
When the system is in Installation mode and seat illumination mode is enabled, the microphone LED and microphone button LED will be illuminated RED when the seat is selected. This helps placing the icons on the correct location on the synoptic layout.
See Also

Reference

Permission
SetIlluminateSeat


ConferenceApiHandler.ExecutePluginCommand Method

ExecutePluginCommand Method

Syntax
Json
Request
Response
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GenerateJwtToken Method

GenerateJwtToken Method

Syntax
Json
Request
Response
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetAgendaTopics Method

GetAgendaTopics Method

Gets the list of agenda topics information for the active meeting.
Syntax
Json
Request:

Copy
{
    "meetingId": <string>
}

Response:

Copy
{
    "agendaTopics":
    [
        {
            "agendaTopicId": <string>,
            "description": <string>,
            "discussionId": <string>,
            "meetingId": <string>,
            "state": "opened"|"closed",
            "subject": <string>
        }
    ]
}
Remarks
Requires:
  • DCNM-LMPM
Gets list of agenda topics for active meeting.
See Also

Reference

AgendaTopic
GetMeetingInfo
GetParticipants
GetMeetings
GetVotings


ConferenceApiHandler.GetBoothNotifications Method

GetBoothNotifications Method

Gets the booth notifications from the system.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "notifications":
    [
        {
            "boothId": <string>,
            "notifications": [<string>]
        }
    ]
}
Remarks
In order to execute this function the system should have DCNM-LIPM license
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetDiscussionList Method

GetDiscussionList Method

Gets the list of speakers, requests, request responders, important and priority speakers of the active discussion.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "discussionList":
    [
        {
            "activeImage": <bool>,
            "activeVideo": <bool>,
            "isFirst": <bool>,
            "isLastMinuteActivated": <bool>,
            "microphoneState": "off"|"on"|"mute",
            "participantId": <string>,
            "personInfoId": <string>,
            "remainingSpeechDuration": <int>,
            "screenLine": <string>,
            "seatId": <string>,
            "showSpeechTimer": <bool>,
            "speakerType": "isSpeaker"|"isPrioritySpeaker"|"isResponder"|"isImportant"|"isRequest"|"isResponseRequest",
            "speechStartTime": <int>
        }
    ],
    "referenceTime": <int>
}
Remarks
Requires:
  • canViewSynoptic permission
See Also

Reference

Permission
AddSeatToSpeakers
ActivateMicrophone
DeactivateMicrophone
RemoveSeatFromDiscussionList


ConferenceApiHandler.GetDiscussionOptions Method

GetDiscussionOptions Method

Gets the discussion options of the active discussion.
Syntax
Json
  Remarks

            Requires:

  • canViewSynoptic permission

  See Also
Reference
Permission
GetDiscussionList


ConferenceApiHandler.GetEnableSeatIllumination Method

GetEnableSeatIllumination Method

Gets state whether system is in installation mode or not.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "enable": <bool>
}
Remarks
Requires:
  • canEnableSeatIllumination permission.
This function identifies that the system is in Installation mode. Microphones cannot be activated in that mode.
See Also

Reference

Permission
EnableSeatIllumination


ConferenceApiHandler.GetIlluminatedSeat Method

GetIlluminatedSeat Method

Gets identifier of the illuminated seat.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "seatId": <string>
}
See Also

Reference

GetEnableSeatIllumination
EnableSeatIllumination
SetIlluminateSeat


ConferenceApiHandler.GetImageServerInfo Method

GetImageServerInfo Method

Gets the Uri of the image server.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "uri": <uri>
}
Remarks
Image server Uri is needed to access the background image and participant pictures.
See Also

Reference

DeleteImage
SaveImage
ListImages


ConferenceApiHandler.GetIndividualVotingResults Method

GetIndividualVotingResults Method

Gets individual voting results.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "votingResults":
    [
        {
            "participantId": <string>,
            "votingAnswer": "notVoted"|"yes"|"no"|"abstain"|"dnpv"|"for"|"against"|"present"|"voteCasted"|"A"|"B"|"C"|"D"
        }
    ]
}
Remarks
Requires:
  • canViewVoting permission.
  • Logged in user should have permission to view voting results.
Gets list of voting results of each participant.
See Also

Reference

GetSeatVotingResults
GetVotingState
GetVotingResults


ConferenceApiHandler.GetInterpretationLanguages Method

GetInterpretationLanguages Method

Gets the interpretation languages of the active meeting.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "languages":
    [
        {
            "abbreviation": <string>,
            "index": <int>,
            "label": <string>,
            "languageId": <string>
        }
    ]
}
Remarks
In order to execute this function the system should have DCNM-LIPM license
See Also

Reference

GetInterpretationRoutings
GetInterpreterBooths
GetInterpreterSeats


ConferenceApiHandler.GetInterpretationMetaFunctionStatus Method

GetInterpretationMetaFunctionStatus Method

Gets interpretation meta requests status from system.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "requestStatus":
    {
        "activeInterpretationMetaRequests":
        [
            "speakSlow"
        ],
        "seatMetaData":
        [
            {
                "seatId": <string>,
                "seatMetaRequests":
                [
                    "speakSlow"
                ]
            }
        ]
    }
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetInterpretationRoutings Method

GetInterpretationRoutings Method

Get list of all the active translation.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "routings":
    [
        {
            "autoRelayContribution": <bool>,
            "destinationLanguageId": <string>,
            "destinationLanguageQuality": "floor"|"plus"|"minus"|"minusMinus"|"unknown",
            "microphoneState": "off"|"activeOnOutputA"|"activeOnOutputB"|"activeOnOutputC",
            "seatId": <string>,
            "sourceLanguageId": <string>
        }
    ]
}
Remarks
Requires:
  • canViewInterpretation permission.
Gets the list of interpretation route details such as source and destination languages, microphone states and seat id.
See Also

Reference

Permission
SetInterpretationOutputPreset
GrantInterpretation


ConferenceApiHandler.GetInterpreterBooths Method

GetInterpreterBooths Method

Gets list of interpreter booths configured for active meeting.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "booths":
    [
        {
            "autoRelay": <bool>,
            "boothId": <string>,
            "boothNumber": <int>
        }
    ]
}
Remarks
Requires:
  • canViewInterpretation permission.

Booth is area/room where interpreter desks are installed. Gets the interpreter booths (numbers) configured for the active meeting and if one or more of the desks which belong to the booths are providing a language. This function can be used for enabling or disabling a booth in use indicator outside the booth.

To see if a booth is producing the auto-relay language, use GetInterpreterSeats to find all the seats in the booth and then GetInterpretationRoutings to find if any of those seats generates the auto-relay language.

See Also

Reference

Permission
GetInterpreterSeats
GetSeats
GetInterpretationRoutings


ConferenceApiHandler.GetInterpreterSeats Method

GetInterpreterSeats Method

Gets list of interpreter seats configured for active meeting.
Syntax
Json
  Remarks

            Requires:

  • canViewInterpretation permission.

To see if a seat is producing the auto-relay language, use GetInterpretationRoutings.

  See Also
Reference
Permission
GetInterpreterBooths
GetSeats
GetInterpretationRoutings


ConferenceApiHandler.GetMajorityResult Method

GetMajorityResult Method

Gets the majority result of the active voting.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "majorityResult":
    {
        "comparisonOperator": "greaterThan"|"greaterThanOrEqualTo"|"equals"|"lessThan"|"lessThanOrEqualTo",
        "denominatorValue": <int>,
        "isEnabled": <bool>,
        "numeratorValue": <int>,
        "status": "true"|"false"|"error",
        "thresholdValue": <int>
    }
}
Remarks
Requires:
  • canViewVoting permission.
  • Logged in user should have permission to view majority results.
See Also

Reference

Permission
GetVotingState
GetSeatVotingResults
GetVotingResults
GetIndividualVotingResults


ConferenceApiHandler.GetMasterVolume Method

GetMasterVolume Method

Gets the master volume of the DICENTIS System.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "volume": <int>
}
Remarks
Requires:
  • canControlMasterVolume permission.
See Also

Reference

Permission
SetMasterVolume
GetMasterVolumeRange


ConferenceApiHandler.GetMasterVolumeRange Method

GetMasterVolumeRange Method

Gets the master volume range (minimum and maximum) of the DICENTIS System
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "range":
    {
        "maximumVolume": <int>,
        "minimumVolume": <int>
    }
}
Remarks
Requires:
  • canControlMasterVolume permission.
See Also

Reference

Permission
GetMasterVolume


ConferenceApiHandler.GetMeetingInfo Method

GetMeetingInfo Method

Gets the information related to the active meeting.
Syntax
Json
Request:

Copy
{
    "meetingId": <string>
}

Response:

Copy
{
    "meetingInfo":
    {
        "agendaList":
        [
            {
                "agendaTopicId": <string>,
                "description": <string>,
                "discussionId": <string>,
                "meetingId": <string>,
                "state": "opened"|"closed",
                "subject": <string>
            }
        ],
        "autoOpenOnActivate": <bool>,
        "autoStartAgendaOnOpen": <bool>,
        "defaultDiscussionId": <string>,
        "description": <string>,
        "documentationRef": <string>,
        "identificationMethod": "fixed"|"userName"|"selectFromList"|"qRCode"|"externalSystem"|"nFC"|"nFCKeptAtDevice",
        "isDefault": <bool>,
        "meetingEndDate": <dateTime>,
        "meetingId": <string>,
        "meetingStartDate": <dateTime>,
        "state": "activated"|"deactivated"|"opened"|"closed",
        "title": <string>,
        "verificationMethod": "none"|"confirmation"|"password"|"pINCode"|"externalSystem"
    }
}
Remarks
Requires:
  • DCNM-LMPM
Gets active meeting information.
See Also

Reference

Meeting
GetParticipants
GetAgendaTopics
GetMeetings
GetVotings


ConferenceApiHandler.GetMeetings Method

GetMeetings Method

Gets the list of meeting's.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "meetings":
    [
        {
            "agendaList":
            [
                {
                    "agendaTopicId": <string>,
                    "description": <string>,
                    "discussionId": <string>,
                    "meetingId": <string>,
                    "state": "opened"|"closed",
                    "subject": <string>
                }
            ],
            "autoOpenOnActivate": <bool>,
            "autoStartAgendaOnOpen": <bool>,
            "defaultDiscussionId": <string>,
            "description": <string>,
            "documentationRef": <string>,
            "identificationMethod": "fixed"|"userName"|"selectFromList"|"qRCode"|"externalSystem"|"nFC"|"nFCKeptAtDevice",
            "isDefault": <bool>,
            "meetingEndDate": <dateTime>,
            "meetingId": <string>,
            "meetingStartDate": <dateTime>,
            "state": "activated"|"deactivated"|"opened"|"closed",
            "title": <string>,
            "verificationMethod": "none"|"confirmation"|"password"|"pINCode"|"externalSystem"
        }
    ]
}
Remarks
Requires:
  • DCNM-LMPM
Gets list of meetings.
See Also

Reference

Meetings
GetMeetingInfo
GetParticipants
GetAgendaTopics
GetVotings


ConferenceApiHandler.GetMicrophoneSensitivity Method

GetMicrophoneSensitivity Method

Gets microphone sensitivity for seat ids.
Syntax
Json
Request:

Copy
{
    "seatIds": [<string>]
}

Response:

Copy
{
    "seatMicrophoneSensitivities":
    [
        {
            "seatId": <string>,
            "seatName": <string>,
            "sensitivityValue": <int>
        }
    ]
}
Remarks
Requires:
  • CanControlMicrophoneSensitivity permission.
Retrieves microphone sensitivity for seats.
See Also

Reference

Permission
Get microphone sensitivity description
Updates microphone sensitivity
Updates microphone sensitivity


ConferenceApiHandler.GetMicrophoneSensitivityDescription Method

GetMicrophoneSensitivityDescription Method

Gets microphone sensitivity description from system.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "micSensitivityDescription":
    {
        "maximumMicrophoneSensitivity": <int>,
        "microphoneSensitivityStepSize": <int>,
        "minimumMicrophoneSensitivity": <int>
    }
}
Remarks
Requires:
  • CanControlMicrophoneSensitivity permission.
Retrieves microphone sensitivity description.
See Also

Reference

Permission
Get microphone sensitivity
Updates microphone sensitivity
Updates microphone sensitivity


ConferenceApiHandler.GetNotesFileList Method

GetNotesFileList Method

Get list of meeting and voting notes xml file details.
Syntax
Json
Request:

Copy
{
    "searchDateRange":
    {
        "endDate": <string>,
        "startDate": <string>
    }
}

Response:

Copy
{
    "fileData":
    [
        {
            "creationDateTime": <dateTime>,
            "fileName": <string>,
            "fileType": "unknown"|"meeting"|"voting",
            "isTampered": <bool>
        }
    ]
}
Remarks
Requires:
  • canViewSynoptic permission
See Also

Reference

Permission
Request to get list of files.
Deletes the given notes files
XSL transforms the specified notes file
To check the file is tampered or not


ConferenceApiHandler.GetParticipantAccessDeniedReasons Method

GetParticipantAccessDeniedReasons Method

Gets the participant access denied reasons
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "participantAccessDeniedReasonsInfo":
    {
        "accessDeniedReasons":
        [
            "noReason"|"invalidUserCredentials"|"notParticipantToMeeting"|"incorrectSeat"|"grantFailure"|
        ]
    }
}
See Also

Reference

Participant
GetParticipants


ConferenceApiHandler.GetParticipants Method

GetParticipants Method

Gets the list of participants assigned to the active meeting.
Syntax
Json
Request:

Copy
{
    "meetingId": <string>
}

Response:

Copy
{
    "participants":
    [
        {
            "canPrio": <bool>,
            "canVote": <bool>,
            "country": <string>,
            "email": <string>,
            "firstName": <string>,
            "group": <string>,
            "isAuthenticated": <bool>,
            "lastName": <string>,
            "middleName": <string>,
            "participantId": <string>,
            "participantType": "local"|"remote",
            "personId": <string>,
            "pictureUpdatedNumber": <int>,
            "region": <string>,
            "title": <string>,
            "visType": "none"|"buttonOperated"|"pttOperated",
            "voteWeight": <int>
        }
    ]
}
See Also

Reference

Participant
GetMeetingInfo
GetAgendaTopics
GetMeetings
GetVotings


ConferenceApiHandler.GetParticipantSeats Method

GetParticipantSeats Method

Gets the list of participant identifier along with assigned seat and seated seat identifier of the active meeting. A participant can be assigned to a seat during the meeting preparation. The participant becomes a seated participant when he logs in (identify and if configured verify) at a seat. When there is no identification method configured, then the assigned participant, immediately becomes a seated participant upon activating the meeting.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "participantSeats":
    [
        {
            "assignedSeatId": <string>,
            "participantId": <string>,
            "seatedSeatId": <string>
        }
    ]
}
See Also

Reference

GetParticipants


ConferenceApiHandler.GetPermissions Method

GetPermissions Method

Gets the permissions of the logged-in user
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "permissions":
    [
        "canManageMeeting"|"canEditSynoptic"|"canSelect"|"canAddDevicesToSeats"|"canViewSynoptic"|"canViewVoting"|"canEnableSeatIllumination"|
        "canSwitchSystemPowerOn"|"canSwitchSystemPowerOff"|"canViewRequestItems"|"canViewFirstRequestOnSeat"|"canDeactivateMicrophone"|
        "hasSpecialPermission"|"canControlInterpretation"|"canViewInterpretation"|"canControlMasterVolume"|"canPrepareMeetingAndAgenda"|
        "canViewMeetingNotes"|"canViewVotingNotes"|"canViewRemoteParticipants"|"canControlVoting"|"hasParticipantBasedLicense"|"canControlMicrophoneSensitivity"
    ]
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetPlugin Method

GetPlugin Method

Retrieve details of a specific plugin
Syntax
Json
Request:

Copy
{
    "pluginName": <string>
}

Response:

Copy
{
    "pluginDescriptionResponse":
    {
        "commands":
        [
            {
                "name": <string>
            }
        ],
        "events":
        [
            {
                "name": <string>
            }
        ],
        "interface": <string>,
        "name": <string>
    }
}
See Also

Reference

To register a plugin request.
To unregister a plugin request.
To send a plugin event.
To subscribe event.
To unsubscribe event
To send plugin command
Gets all the registered plugins
SynopticControl.ServerConferenceApiHandlerGetPluginResponse


ConferenceApiHandler.GetPluginCommands Method

GetPluginCommands Method

Gets the list of plugin commands
Syntax
Json
  See Also
Reference
SynopticControl.ServerConferenceApiHandlerGetPluginCommandsRequest
SynopticControl.ServerConferenceApiHandlerGetPluginCommandsResponse


ConferenceApiHandler.GetPluginEventData Method

GetPluginEventData Method

Gets the plugin event data
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "pluginEventsData": [<dcnmPluginEvent>]
}
See Also

Reference

SynopticControl.ServerConferenceApiHandlerGetPluginEventDataRequest
SynopticControl.ServerConferenceApiHandlerGetPluginEventDataResponse


ConferenceApiHandler.GetPlugins Method

GetPlugins Method

Retrieves all the plugins. Use GetPluginAsync to retrieve details of a specific plugin
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "plugins": [<string>]
}
See Also

Reference

SynopticControl.ServerConferenceApiHandlerGetPluginsRequest
To register a plugin request.
To unregister a plugin request.
To send a plugin event.
To subscribe event.
To unsubscribe event
To send plugin command
Gets registered plugin by plugin name
SynopticControl.ServerConferenceApiHandlerGetPluginsResponse


ConferenceApiHandler.GetPresentationState Method

GetPresentationState Method

Gets the current presentation state whether the presentation is enabled / disabled.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "isPresentationEnabled": <bool>
}
See Also

Reference

ActivatePresentation
DeactivatePresentation


ConferenceApiHandler.GetQuorumResult Method

GetQuorumResult Method

Gets the quorum result of the active meeting.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "quorumResult":
    {
        "comparisonOperator": "greaterThan"|"greaterThanOrEqualTo"|"equals"|"lessThan"|"lessThanOrEqualTo",
        "denominatorValue": <int>,
        "isEnabled": <bool>,
        "numeratorValue": <int>,
        "status": "true"|"false"|"error",
        "thresholdValue": <int>
    }
}
Remarks
Requires:
  • DCNM-LPD
See Also

Reference

Meeting
GetParticipants
GetAgendaTopics
GetMeetings
GetVotings


ConferenceApiHandler.GetRoomContactEmail Method

GetRoomContactEmail Method

Gets room contact email.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "roomContactEmail": <string>
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetRoomName Method

GetRoomName Method

Gets room name.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "roomName": <string>
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetSeats Method

GetSeats Method

Gets list of participant seats.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "seats":
    [
        {
            "assignedParticipantId": <string>,
            "attributes": [<string>],
            "canPrio": <bool>,
            "canVote": <bool>,
            "devices":
            [
                {
                    "capabilities":
                    [
                        "hasNone"|"hasPowerOn"|"hasPowerOff"|"hasVolumeControl"|"hasDualUse"
                    ],
                    "deviceState": "versionMismatch"|"error"|"operational",
                    "id": <string>,
                    "isFoundAtSeat": <bool>,
                    "isSelected": <bool>,
                    "name": <string>,
                    "serialNumber": <string>,
                    "subDeviceInstance": <int>,
                    "typeOf": "unknown"|"standardConferenceDevice"|"interpretationDevice"|"onvifCamera"|"audioPoweringSwitch"|
                        "meetingApplication"|"pTZOnvifCamera"|"videoSwitch"|"externalVideoSwitch"|"presentationDevice"|
                        "poweringSwitch"|"multimediaDevice"|"multimediaDeviceSimulator"|"videoStream"|"oMI"|"discussionDeviceBasic"|
                        "discussionDevice"|"discussionDeviceVoting"|"discussionDeviceLanguageSelection"|"discussionDeviceExtended"|
                        "sonyCameraDevice"|"panasonicCameraDevice"|"interpretationDeviceWithVideo"|"flushDeviceSelectLanguage"|,
                    "version": <string>
                }
            ],
            "foundDevices": [<string>],
            "hasVotingLicense": <bool>,
            "hideSeat": <bool>,
            "screenLine": <string>,
            "seatedParticipantId": <string>,
            "seatId": <string>,
            "seatName": <string>,
            "seatType": "local"|"remote",
            "status": "disconnected"|"connected"|"selected",
            "visType": "none"|"buttonOperated"|"pttOperated"
        }
    ]
}
Remarks
Requires:
  • canViewSynoptic permission.
Inorder to tell if a speaker list entry is for a remote participant follow the workaround.
  • Workaround: Use GetSeats to find all the seats. Use DcnmSpeakerInfo.SeatInfo.Id to find the seat in the list returned from GetSeats. Check if the seat has the "Remote" attribute. In synoptic, use the seats SeatType property.
See Also

Reference

Permission
SeatInfo
GetInterpreterSeats


ConferenceApiHandler.GetSeatVotingResults Method

GetSeatVotingResults Method

Gets seat voting results.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "votingResults":
    [
        {
            "seatId": <string>,
            "votingAnswer": "notVoted"|"yes"|"no"|"abstain"|"dnpv"|"for"|"against"|"present"|"voteCasted"|"A"|"B"|"C"|"D"
        }
    ]
}
Remarks
Requires:
  • canViewVoting permission.
  • Logged in user should have permission to view voting results.
Gets list of voting results of each seat.
See Also

Reference

GetIndividualVotingResults
GetVotingState
GetVotingResults


ConferenceApiHandler.GetSupportedHeadphones Method

GetSupportedHeadphones Method

Gets the collection of supported headphones for interpretation
Syntax
Json
  See Also
Reference
SynopticControl.ServerConferenceApiHandlerGetSupportedHeadphonesRequest
SynopticControl.ServerConferenceApiHandlerGetSupportedHeadphonesResponse


ConferenceApiHandler.GetSystemPowerMode Method

GetSystemPowerMode Method

Gets the power state of the system.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "powerMode": "poweredOn"|"poweredOff"|"poweringOn"|"poweringOff"
}
See Also

Reference

PowerMode
SetSystemPowerMode


ConferenceApiHandler.GetVotingInfo Method

GetVotingInfo Method

Gets the active voting.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "votingInfo":
    {
        "description": <string>,
        "documentationLink": <string>,
        "majorityVariables": [<string>],
        "meetingId": <string>,
        "referenceNumber": <string>,
        "state": "closed"|"ready"|"opened"|"onHold"|"done"|"canceled"|"accepted"|"rejected",
        "subject": <string>,
        "usePresentButton": <bool>,
        "useVoteWeight": <bool>,
        "voteMajorityInfo":
        {
            "isEnabled": <bool>,
            "majorityCondition": "greaterThan"|"greaterThanOrEqualTo"|"equals"|"lessThan"|"lessThanOrEqualTo",
            "majorityDenominatorExpression": <string>,
            "majorityNumeratorExpression": <string>,
            "majorityThresholdExpression": <string>
        },
        "votingAnswers":
        [
            "notVoted"|"yes"|"no"|"abstain"|"dnpv"|"for"|"against"|"present"|"voteCasted"|"A"|"B"|"C"|"D"
        ],
        "votingId": <string>,
        "votingTimeDuration": <int>,
        "votingTimerType": "noVotingTimer"|"keepVotingOpen"|"holdVotingRound"|"closeVotingRound"
    }
}
Remarks
Requires:
  • canViewVoting permission.
  • DCNM-LVPM
  • DCNM-LSVT
See Also

Reference

Permission
Voting information
GetSeatVotingResults
GetIndividualVotingResults
GetVotingResults
GetVotingResults


ConferenceApiHandler.GetVotingResults Method

GetVotingResults Method

Gets the voting results of the active voting.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "votingResults":
    [
        {
            "answer": "notVoted"|"yes"|"no"|"abstain"|"dnpv"|"for"|"against"|"present"|"voteCasted"|"A"|"B"|"C"|"D",
            "count": <int>
        }
    ]
}
Remarks
Requires:
  • canViewVoting permission.
Gets total count for each voting answer type.
See Also

Reference

Permission
GetVotingState
GetSeatVotingResults
GetIndividualVotingResults


ConferenceApiHandler.GetVotings Method

GetVotings Method

Gets the list of prepared voting's of the active meeting.
Syntax
Json
Request:

Copy
{
    "meetingId": <string>
}

Response:

Copy
{
    "votingList":
    [
        {
            "description": <string>,
            "documentationLink": <string>,
            "majorityVariables": [<string>],
            "meetingId": <string>,
            "referenceNumber": <string>,
            "state": "closed"|"ready"|"opened"|"onHold"|"done"|"canceled"|"accepted"|"rejected",
            "subject": <string>,
            "usePresentButton": <bool>,
            "useVoteWeight": <bool>,
            "voteMajorityInfo":
            {
                "isEnabled": <bool>,
                "majorityCondition": "greaterThan"|"greaterThanOrEqualTo"|"equals"|"lessThan"|"lessThanOrEqualTo",
                "majorityDenominatorExpression": <string>,
                "majorityNumeratorExpression": <string>,
                "majorityThresholdExpression": <string>
            },
            "votingAnswers":
            [
                "notVoted"|"yes"|"no"|"abstain"|"dnpv"|"for"|"against"|"present"|"voteCasted"|"A"|"B"|"C"|"D"
            ],
            "votingId": <string>,
            "votingTimeDuration": <int>,
            "votingTimerType": "noVotingTimer"|"keepVotingOpen"|"holdVotingRound"|"closeVotingRound"
        }
    ]
}
Remarks
Requires:
  • DCNM-LMPM
Gets list of voting information for active meeting.
See Also

Reference

Voting
GetMeetingInfo
GetParticipants
GetAgendaTopics
GetMeetings


ConferenceApiHandler.GetVotingState Method

GetVotingState Method

Gets the state of active voting.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "votingState": "closed"|"ready"|"opened"|"onHold"|"done"|"canceled"|"accepted"|"rejected"
}
Remarks
Requires:
  • canViewVoting permission.
  • DCNM-LVPM
  • DCNM-LSVT
See Also

Reference

Permission
Voting state
GetSeatVotingResults
GetIndividualVotingResults
GetVotingResults
GetVotingResults


ConferenceApiHandler.GrantInterpretation Method

GrantInterpretation Method

Grant the interpretation to the specified interpretation seat.
Syntax
Json
Request:

Copy
{
    "microphoneState": "off"|"activeOnOutputA"|"activeOnOutputB"|"activeOnOutputC",
    "seatId": <string>
}

Response:

Copy
{
}
Remarks
Requires:
  • canControlInterpretation permission.
Enable /disable interpretation microphone for the specified desk on specified output channel.
See Also

Reference

Permission
SetInterpretationOutputPreset
GetInterpretationRoutings


ConferenceApiHandler.GrantResponse Method

GrantResponse Method

Shifts the given seat(s) participant(s) to the responders list, and removes the oldest speaker in the responders list.
Syntax
Json
Request:

Copy
{
    "participantIds": [<string>],
    "seatIds": [<string>]
}

Response:

Copy
{
}
Remarks
Requires:
  • canManageMeeting permission.
Seat/Participant will be shifted to responders list.
See Also

Reference

Permission
GrantSpeech
RemoveSpeech
RequestSpeech
RequestResponse
RemoveResponse


ConferenceApiHandler.GrantSpeech Method

GrantSpeech Method

Adds the seat or participant to active speakers list.
Syntax
Json
Request:

Copy
{
    "participantIds": [<string>],
    "seatIds": [<string>]
}

Response:

Copy
{
}
Remarks
Requires:
  • canManageMeeting permission.
Seat/Participant will be shifted to active speakers if seat/participant is in responders queue or request to speak queue. If seat/participant is not in present responders or request to speaker list then seat will be added to active speaker list.
See Also

Reference

Permission
RemoveSpeech
RequestSpeech
RequestResponse
GrantResponse
RemoveResponse


ConferenceApiHandler.HoldVoting Method

HoldVoting Method

Hold the open voting
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
}
Remarks
Requires:
  • canControlVoting permission.
See Also

Reference

Permission
OpenVoting
CloseVoting
ResumeVoting
AbortVoting
RejectVoting
AcceptVoting


ConferenceApiHandler.IssueInterpreterMetaFunction Method

IssueInterpreterMetaFunction Method

Issues interpreter meta request from a seat.
Syntax
Json
Request:

Copy
{
    "request": <string>,
    "seatId": <string>
}

Response:

Copy
{
}
Remarks
Requires:
  • canControlInterpretation permission.
Issues speak slow from given seat.
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ListFiles Method

ListFiles Method

Lists the files.
Syntax
Json
Request:

Copy
{
    "attributes": [<string>]
}

Response:

Copy
{
    "fileInfoList":
    [
        {
            "fileId": <string>,
            "title": <string>
        }
    ]
}
Remarks
Attributes is used to retrieve all files with matching file attributes Attributes indicate what contents of file represent and can contain list of values like 'Bosch.Synoptic.Layout', 'Bosch.Synoptic.Index'
See Also

Reference

FileInfo
CreateFile
UpdateFile
DeleteFile
LoadFile


ConferenceApiHandler.ListImages Method

ListImages Method

Lists the images.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "images": [<string>]
}
Remarks
Lists background images URIs (relative) that are saved previously.
See Also

Reference

GetImageServerInfo
DeleteImage
SaveImage


ConferenceApiHandler.LoadFile Method

LoadFile Method

Opens the saved file.
Syntax
Json
Request:

Copy
{
    "fileId": <string>
}

Response:

Copy
{
    "fileInfo":
    {
        "attributes": [<string>],
        "fileId": <string>,
        "payload": <string>,
        "title": <string>
    }
}
Remarks
Requires:
  • canViewSynoptic permission.
This function allows to get the specified file's configuration such as, if any Seats added to layout, Background Image, Booths added to layout.
See Also

Reference

Permission
CreateFile
UpdateFile
DeleteFile


ConferenceApiHandler.Login Method

Login Method

Logs in the user
Syntax
Json
Request:

Copy
{
    "password": <string>,
    "token": <string>,
    "user": <string>
}

Response:

Copy
{
    "loggedIn": <bool>,
    "token": <string>
}
See Also

Reference

Logout


ConferenceApiHandler.Logout Method

Logout Method

Logs off the user
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
}
See Also

Reference

Login


ConferenceApiHandler.OpenAgenda Method

OpenAgenda Method

Open Agenda for current meeting.
Syntax
Json
Request:

Copy
{
    "agendaTopicId": <string>
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.OpenMeeting Method

OpenMeeting Method

To open active meeting.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.OpenVoting Method

OpenVoting Method

Open the active voting
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
}
Remarks
Requires:
  • canControlVoting permission.
See Also

Reference

Permission
CloseVoting
HoldVoting
ResumeVoting
AbortVoting
RejectVoting
AcceptVoting


ConferenceApiHandler.RaiseBoothNotification Method

RaiseBoothNotification Method

Raises a notification on a booth.
Syntax
Json
Request:

Copy
{
    "boothId": <string>,
    "notification": <string>
}

Response:

Copy
{
}
Remarks
Requires:
  • canControlInterpretation permission.
Raises a PhoneCall and/or Alarm notification for the given booth.
See Also

Reference

Permission


ConferenceApiHandler.RegisterEvents Method

RegisterEvents Method

This functions allows to register for the events (ex: Voting state changed, Permission changed) whose callbacks needs to be received, whenever the event is triggered
Syntax
Json
Request:

Copy
{
    "events":
    [
        "apiStateChanged"|"permissionsChanged"|"seatsChanged"|"discussionListChanged"|"discussionOptionsChanged"|"meetingInfoChanged"|"individualVotingResultsChanged"|
        "votingStateChanged"|"enableSeatIlluminationChanged"|"illuminatedSeatChanged"|"systemPowerModeChanged"|"agendaTopicsChanged"|"participantsChanged"|
        "votingScriptChanged"|"votingResultChanged"|"interpretationLanguagesChanged"|"interpretationRoutingsChanged"|"interpreterSeatsChanged"|
        "interpreterBoothsChanged"|"boothNotificationsChanged"|"masterVolumeChanged"|"masterVolumeRangeChanged"|"presentationStateChanged"|
        "fileChanged"|"participantSeatsChanged"|"quorumResultChanged"|"majorityResultChanged"|"votingInfoChanged"|"notesFileListChanged"|
        "interpretationMetaRequestStatusChanged"|"roomNameChanged"|"roomContactEmailChanged"|"pluginsChanged"|"pluginEventAvailable"|"pluginCommandAvailable"|
    ]
}

Response:

Copy
{
}
See Also

Reference

UnregisterEvents


ConferenceApiHandler.RegisterPlugin Method

RegisterPlugin Method

Register a plugin
Syntax
Json
Request:

Copy
{
    "pluginCommands":
    [
        {
            "name": <string>
        }
    ],
    "pluginEvents":
    [
        {
            "name": <string>
        }
    ],
    "pluginInterface": <string>,
    "pluginName": <string>
}

Response:

Copy
{
}
Remarks
The last plugin registered is notified by calling PluginAdded.
Plugin name is case sensitive.
See Also

Reference

SynopticControl.ServerConferenceApiHandlerRegisterPluginRequest
To unregister a plugin request.
To subscribe to a plugin event.
To unsubscribe a plugin event.
To send a plugin event.
To send plugin command.
Gets plugin by plugin name
Gets all the registered plugins
SynopticControl.ServerConferenceApiHandlerUnRegisterPluginResponse


ConferenceApiHandler.RejectVoting Method

RejectVoting Method

Reject the closed voting
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
}
Remarks
Requires:
  • canControlVoting permission.
See Also

Reference

Permission
OpenVoting
CloseVoting
HoldVoting
ResumeVoting
AbortVoting
AcceptVoting


ConferenceApiHandler.RemoveResponse Method

RemoveResponse Method

Cancels a request to respond of a participant or seat.
Syntax
Json
Request:

Copy
{
    "participantIds": [<string>],
    "seatIds": [<string>]
}

Response:

Copy
{
}
Remarks
Requires:
  • canManageMeeting permission.
Seat/Participant will be removed from responders list.
See Also

Reference

Permission
GrantSpeech
RemoveSpeech
RequestSpeech
RequestResponse
GrantResponse


ConferenceApiHandler.RemoveSeatFromDiscussionList Method

RemoveSeatFromDiscussionList Method

Removes the seat from active speakers list.
Syntax
Json
Request:

Copy
{
    "seatId": <string>
}

Response:

Copy
{
}
Remarks
Requires:
  • canManageMeeting permission.
Seat will be removed from active speakers list if the seat is an active speaker or responder.
See Also

Reference

Permission
AddSeatToSpeakers


ConferenceApiHandler.RemoveSpeech Method

RemoveSpeech Method

Removes the seat or participant from active speakers list.
Syntax
Json
Request:

Copy
{
    "participantIds": [<string>],
    "seatIds": [<string>]
}

Response:

Copy
{
}
Remarks
Requires:
  • canManageMeeting permission.
Seat/Participant will be removed from active speakers list.
See Also

Reference

Permission
RequestSpeech
GrantSpeech
RequestResponse
GrantResponse
RemoveResponse


ConferenceApiHandler.RequestResponse Method

RequestResponse Method

Adds the seat or participant to response request waiting list.
Syntax
Json
Request:

Copy
{
    "participantIds": [<string>],
    "seatIds": [<string>]
}

Response:

Copy
{
}
Remarks
Requires:
  • canManageMeeting permission.
Seat/Participant will be shifted to response request waiting list.
See Also

Reference

Permission
GrantSpeech
RemoveSpeech
RequestSpeech
GrantResponse
RemoveResponse


ConferenceApiHandler.RequestSpeech Method

RequestSpeech Method

Adds the seat or participant to waiting list.
Syntax
Json
Request:

Copy
{
    "participantIds": [<string>],
    "seatIds": [<string>]
}

Response:

Copy
{
}
Remarks
Requires:
  • canManageMeeting permission.
Seat/Participant will be shifted to speakers waiting list.
See Also

Reference

Permission
GrantSpeech
RemoveSpeech
RequestResponse
GrantResponse
RemoveResponse


ConferenceApiHandler.ResetMicrophoneSensitivity Method

ResetMicrophoneSensitivity Method

Resets microphone sensitivity for all seats.
Syntax
Json
Request:

Copy
{
    "seatIds": [<string>]
}

Response:

Copy
{
    "status": <bool>
}
Remarks
Requires:
  • CanControlMicrophoneSensitivity permission.
Reset microphone sensitivity for all seats.
See Also

Reference

Permission
Get microphone sensitivity description.
Get microphone sensitivity.
Updates microphone sensitivity.


ConferenceApiHandler.ResumeVoting Method

ResumeVoting Method

Resume the on hold voting
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
}
Remarks
Requires:
  • canControlVoting permission.
See Also

Reference

Permission
OpenVoting
CloseVoting
HoldVoting
AbortVoting
RejectVoting
AcceptVoting


ConferenceApiHandler.SaveImage Method

SaveImage Method

Saves the specified image.
Syntax
Json
Request:

Copy
{
    "imageData": <string>,
    "name": <string>
}

Response:

Copy
{
    "saveImageUri": <string>
}
Remarks
Requires:
  • canEditSynoptic permission.
The image will be used as background image for synoptic. The size of the image shall be less than 2 MB.
See Also

Reference

Permission
DeleteImage
ListImages


ConferenceApiHandler.SelectInterpretationFloor Method

SelectInterpretationFloor Method

Selects the floor language for interpretation seat.
Syntax
Json
Request:

Copy
{
    "seatId": <string>
}

Response:

Copy
{
}
Remarks
Requires:
  • canControlInterpretation permission.
Selects the input of specified IDESK to floor.
See Also

Reference

Permission
SelectRelay
SelectInputLanguage
GetInterpretationLanguages


ConferenceApiHandler.SelectInterpretationInputLanguage Method

SelectInterpretationInputLanguage Method

Sets and selects the input language on the preset for interpretation seat.
Syntax
Json
Request:

Copy
{
    "inputButton": "inputPresetA"|"inputPresetB"|"inputPresetC"|"inputPresetD"|"inputPresetE"|"inputPresetF"|"inputPresetG",
    "languageId": <string>,
    "seatId": <string>
}

Response:

Copy
{
}
Remarks
Requires:
  • canControlInterpretation permission.
Sets and selects the input preset of specified IDESK to either inputA through inputG by specifying the language id.
See Also

Reference

Permission
SelectFloor
SelectRelay
GetInterpretationLanguages


ConferenceApiHandler.SelectRelayInterpretation Method

SelectRelayInterpretation Method

Selects the relay language for interpretation seat.
Syntax
Json
Request:

Copy
{
    "seatId": <string>
}

Response:

Copy
{
}
Remarks
Requires:
  • canControlInterpretation permission.
Selects the input of specified IDESK to floor.
See Also

Reference

Permission
SelectFloor
SelectInputLanguage
GetInterpretationLanguages


ConferenceApiHandler.SendPluginCommand Method

SendPluginCommand Method

Send a command to a plugin
Syntax
Json
Request:

Copy
{
    "command": <string>,
    "parameters": <string>,
    "pluginName": <string>
}

Response:

Copy
{
    "response": <string>
}
See Also

Reference

SynopticControl.ServerConferenceApiHandlerSendPluginCommandRequest
To register a plugin request.
To unregister a plugin request.
To send a plugin event.
To subscribe event.
To unsubscribe event
Gets plugin by plugin name
Gets all the registered plugins
SynopticControl.ServerConferenceApiHandlerSendPluginCommandResponse


ConferenceApiHandler.SendPluginEvent Method

SendPluginEvent Method

Send a plugin event
Syntax
Json
Request:

Copy
{
    "event": <string>,
    "parameters": <string>,
    "pluginName": <string>
}

Response:

Copy
{
}
See Also

Reference

SynopticControl.ServerConferenceApiHandlerSendPluginEventRequest
To unregister a plugin request.
To register a plugin request.
To subscribe to a plugin event.
To unsubscribe a plugin event.
To send plugin command.
Gets plugin by plugin name
Gets all the registered plugins
SynopticControl.ServerConferenceApiHandlerSendPluginEventResponse


ConferenceApiHandler.SetIlluminateSeat Method

SetIlluminateSeat Method

Illuminates specified seat.
Syntax
Json
Request:

Copy
{
    "seatId": <string>,
    "setIlluminate": <bool>
}

Response:

Copy
{
}
Remarks
Requires:
  • canEnableSeatIllumination permission.
This function illuminates the specified seat (microphone LED and microphone button LED will be illuminated RED) when the system is in installation mode. This helps in identifying the seat while placing the icons on correct location in synoptic layout.
See Also

Reference

Permission
GetEnableSeatIllumination
EnableSeatIllumination


ConferenceApiHandler.SetInterpretationOutputPreset Method

SetInterpretationOutputPreset Method

Updates output preset for interpretation seat.
Syntax
Json
Request:

Copy
{
    "languageId": <string>,
    "outputButton": "outputPresetB"|"outputPresetC",
    "seatId": <string>
}

Response:

Copy
{
}
Remarks
Requires:
  • canControlInterpretation permission.
Sets the output preset of specified IDESK to either outputB or outputC by specifying the language id.
See Also

Reference

Permission
GrantInterpretation
GetInterpretationRoutings
GetInterpretationLanguages


ConferenceApiHandler.SetMasterVolume Method

SetMasterVolume Method

Sets the master volume of the system with the specified value(dB)
Syntax
Json
Request:

Copy
{
    "volume": <int>
}

Response:

Copy
{
}
Remarks
Requires:
  • canControlMasterVolume permission.
Master volume should be within range.
See Also

Reference

Permission
GetMasterVolume


ConferenceApiHandler.SetPluginCommandResult Method

SetPluginCommandResult Method

Sets the result of the command execution
Syntax
Json
Request:

Copy
{
    "correlationId": <string>,
    "result": <string>
}

Response:

Copy
{
}
See Also

Reference

SynopticControl.ServerConferenceApiHandlerSetPluginCommandResultRequest
SynopticControl.ServerConferenceApiHandlerSetPluginCommandResultResponse


ConferenceApiHandler.SetSystemPowerMode Method

SetSystemPowerMode Method

Sets the power mode of the system.
Syntax
Json
Request:

Copy
{
    "powerMode": "poweredOn"|"poweredOff"|"poweringOn"|"poweringOff"
}

Response:

Copy
{
}
Remarks
Requires:
  • canSwitchSystemPowerOn permission.
  • canSwitchSystemPowerOff permission.
poweredOn and poweredOff status can be set to system, poweringOn and poweringOff are intermediate state of the system.
See Also

Reference

Permission
PowerMode
GetSystemPowerMode


ConferenceApiHandler.SubscribePluginEvent Method

SubscribePluginEvent Method

Subscribe to an event coming from a plugin
Syntax
Json
Request:

Copy
{
    "eventName": <string>,
    "pluginName": <string>
}

Response:

Copy
{
}
Remarks
The last event sent by the plugin is notified to the handler soon after calling SubscribePluginEventAsync.
Multiple subscriptions to the same event can be subscribed to, as long as each subscription has a different handler.
It is possible to subscribe to events for plugins that are not registered.
See Also

Reference

SynopticControl.ServerConferenceApiHandlerSubscribePluginEventRequest
To register a plugin request.
To unregister a plugin request.
To send a plugin event.
To unsubscribe event.
To send plugin command.
Gets plugin by plugin name
Gets all the registered plugins
SynopticControl.ServerConferenceApiHandlerSubscribePluginEventResponse


ConferenceApiHandler.TransformNotesFile Method

TransformNotesFile Method

XSL transform the notes file.
Syntax
Json
Request:

Copy
{
    "fileName": <string>
}

Response:

Copy
{
    "notesHtml": <string>
}
Remarks
Requires either of:
  • canViewMeetingNotes permission or
  • canViewVotingNotes permission
See Also

Reference

Permission
Defines transform notes file request.
Get list of meeting and voting notes xml file details.
Deletes the given notes files
To check the file is tampered or not


ConferenceApiHandler.UnregisterEvents Method

UnregisterEvents Method

This functions allows to un register for the registered events
Syntax
Json
Request:

Copy
{
    "events":
    [
        "apiStateChanged"|"permissionsChanged"|"seatsChanged"|"discussionListChanged"|"discussionOptionsChanged"|"meetingInfoChanged"|"individualVotingResultsChanged"|
        "votingStateChanged"|"enableSeatIlluminationChanged"|"illuminatedSeatChanged"|"systemPowerModeChanged"|"agendaTopicsChanged"|"participantsChanged"|
        "votingScriptChanged"|"votingResultChanged"|"interpretationLanguagesChanged"|"interpretationRoutingsChanged"|"interpreterSeatsChanged"|
        "interpreterBoothsChanged"|"boothNotificationsChanged"|"masterVolumeChanged"|"masterVolumeRangeChanged"|"presentationStateChanged"|
        "fileChanged"|"participantSeatsChanged"|"quorumResultChanged"|"majorityResultChanged"|"votingInfoChanged"|"notesFileListChanged"|
        "interpretationMetaRequestStatusChanged"|"roomNameChanged"|"roomContactEmailChanged"|"pluginsChanged"|"pluginEventAvailable"|"pluginCommandAvailable"|
    ]
}

Response:

Copy
{
}
See Also

Reference

RegisterEvents


ConferenceApiHandler.UnRegisterPlugin Method

UnRegisterPlugin Method

Unregister a plugin
Syntax
Json
Request:

Copy
{
    "pluginName": <string>
}

Response:

Copy
{
}
Remarks
The last plugin unregistered is notified by calling PluginRemoved.
Plugin name is case sensitive.
See Also

Reference

SynopticControl.ServerConferenceApiHandlerUnRegisterPluginRequest
To register a plugin request.
To subscribe to a plugin event.
To unsubscribe a plugin event.
To send a plugin event.
To send plugin command.
Gets plugin by plugin name
Gets all the registered plugins
SynopticControl.ServerConferenceApiHandlerUnRegisterPluginResponse


ConferenceApiHandler.UnSubscribePluginEvent Method

UnSubscribePluginEvent Method

Unsubscribe from an event coming from a plugin
Syntax
Json
Request:

Copy
{
    "eventName": <string>,
    "pluginName": <string>
}

Response:

Copy
{
}
See Also

Reference

SynopticControl.ServerConferenceApiHandlerUnSubscribePluginEventRequest
To register a plugin request.
To unregister a plugin request.
To send a plugin event.
To subscribe event.
To send plugin command.
Gets plugin by plugin name
Gets all the registered plugins
SynopticControl.ServerConferenceApiHandlerUnSubscribePluginEventResponse


ConferenceApiHandler.UpdateFile Method

UpdateFile Method

Updates the specified file.
Syntax
Json
Request:

Copy
{
    "attributes": [<string>],
    "fileId": <string>,
    "payload": <string>,
    "title": <string>
}

Response:

Copy
{
}
Remarks
Requires:
  • canEditSynoptic permission.
File configuration includes layout information about seat (participant seat, interpreter seat, booths), background image. If configuration file exists then it updates file with latest information.
See Also

Reference

Permission
CreateFile
DeleteFile
LoadFile


ConferenceApiHandler.UpdateMicrophoneSensitivity Method

UpdateMicrophoneSensitivity Method

Update microphone sensitivity for seat ids.
Syntax
Json
Request:

Copy
{
    "seatMicrophoneSensitivity":
    [
        {
            "seatId": <string>,
            "seatName": <string>,
            "sensitivityValue": <int>
        }
    ]
}

Response:

Copy
{
    "status": <bool>
}
Remarks
Requires:
  • CanControlMicrophoneSensitivity permission.
Updates microphone sensitivity for seats.
See Also

Reference

Permission
Get microphone sensitivity description.
Get microphone sensitivity.
Get microphone sensitivity.


ConferenceApiHandler.ValidateJwtToken Method

ValidateJwtToken Method

Syntax
Json
Request
Response
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetInterpretationRoutingsResponse Class

ConferenceApiHandlerGetInterpretationRoutingsResponse Class

Represents the response for get interpretation routings
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetInterpretationRoutingsResponse
Syntax
Json
{ JsonClass:GetInterpretationRoutingsResponse		Routings:<type>,
 }

The ConferenceApiHandlerGetInterpretationRoutingsResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetInterpretationRoutingsResponse | Initializes a new instance of the ConferenceApiHandlerGetInterpretationRoutingsResponse class
Top
Properties
 | Name | Description
Public property | Routings | Gets or sets the interpretation routings.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


PluginHandler Constructor

Initializes the static fields of the PluginHandler class
Syntax
Json
{ Constructor:.cctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetInterpreterBooths Method

GetInterpreterBooths Method

Returns interpreter booths to requested clients.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "booths":
    [
        {
            "autoRelay": <bool>,
            "boothId": <string>,
            "boothNumber": <int>
        }
    ]
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.CloseMeeting Method

CloseMeeting Method

Close the active meeting.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.ShiftRequest Method

ShiftRequest Method

Shift the selected request.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


PowerMode Enumeration

The power modes
Syntax
Json
PowerMode:{
poweredOn
poweredOff
poweringOn
poweringOff}
Members
Member name | Value | Description
poweredOn | 0 | The power is on.
poweredOff | 1 | The power is off.
poweringOn | 2 | The power is being turned on.
poweringOff | 3 | The power is being turned off.
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


BoothNotificationInfo.GetHashCode Method

GetHashCode Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.BoothNotificationInfos Property

BoothNotificationInfos Property

Syntax
Json
{ Property:BoothNotificationInfos }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateSeatMicrophoneSensitivity Method

UpdateSeatMicrophoneSensitivity Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RaiseBoothNotificationRequest Class

ConferenceApiHandlerRaiseBoothNotificationRequest Class

Represents the request to raise notifications on a booth
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerRaiseBoothNotificationRequest
Syntax
Json
{ JsonClass:RaiseBoothNotificationRequest		BoothId:<type>,
    Notification:<type>,
 }

The ConferenceApiHandlerRaiseBoothNotificationRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerRaiseBoothNotificationRequest | Initializes a new instance of the ConferenceApiHandlerRaiseBoothNotificationRequest class
Top
Properties
 | Name | Description
Public property | BoothId |
Public property | Notification |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetIndividualCastVoteResults Method (ReadOnlyCollection(VotingResult))

GetIndividualCastVoteResults Method (ReadOnlyCollectionVotingResult)

 Bosch Logo
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


VoteMajorityInfo.MajorityThresholdExpression Property

MajorityThresholdExpression Property

Majority threshold to decide whether voting can be approved or not.
Syntax
Json
{ Property:MajorityThresholdExpression }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


PluginDescription.Commands Property

Commands Property

All the methods supported by this plugin
Syntax
Json
{ Property:Commands }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SystemLog.TraceWarning Method (String, Object[])

TraceWarning Method (String, Object)

 Bosch Logo
Forwards the warning event to the trace source.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DcnmApi.OnMeetingListChanged Method

OnMeetingListChanged Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceException Methods

The ConferenceException type exposes the following members.

Methods
 | Name | Description
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


IConferenceApiMethodCaller.Initialize Method

Initialize Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


InterpreterBoothInfo.GetHashCode Method

GetHashCode Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetAgendaTopicsRequest.MeetingId Property

MeetingId Property

The meeting identifier.
Syntax
Json
{ Property:MeetingId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpreterDeskInfo.AutomaticMicrophoneSelection Property

AutomaticMicrophoneSelection Property

Syntax
Json
{ Property:AutomaticMicrophoneSelection }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.SendPluginEvent Method

SendPluginEvent Method

Syntax
Json
Request:

Copy
{
    "event": <string>,
    "parameters": <string>,
    "pluginName": <string>
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnIndividualVotingResultUpdated Method

OnIndividualVotingResultUpdated Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.EventResponse Class

ConferenceApiHandlerEventResponse Class

Events response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerEventResponse
Syntax
Json
{ JsonClass:EventResponse		Events:<type>,
 }

The ConferenceApiHandlerEventResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerEventResponse | Initializes a new instance of the ConferenceApiHandlerEventResponse class
Top
Properties
 | Name | Description
Public property | Events | List of events
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiController.ErrorResponse Class

ConferenceApiControllerErrorResponse Class

The protocol message that holds the return parameters for error messages
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiControllerErrorResponse
Syntax
Json
{ JsonClass:ErrorResponse		Message:<type>,
 }

The ConferenceApiControllerErrorResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiControllerErrorResponse | Initializes a new instance of the ConferenceApiControllerErrorResponse class
Top
Properties
 | Name | Description
Public property | Message |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnMeetingCreated Method

OnMeetingCreated Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ListFilesRequest Constructor

ConferenceApiHandlerListFilesRequest Constructor

Initializes a new instance of the ConferenceApiHandlerListFilesRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetVotingStateResponse Class

ConferenceApiHandlerGetVotingStateResponse Class

Represents the get voting state response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetVotingStateResponse
Syntax
Json
{ JsonClass:GetVotingStateResponse		VotingState:<type>,
 }

The ConferenceApiHandlerGetVotingStateResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetVotingStateResponse | Initializes a new instance of the ConferenceApiHandlerGetVotingStateResponse class
Top
Properties
 | Name | Description
Public property | VotingState | Voting state
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceUsers.UserHasPermission Method

UserHasPermission Method

Checks given user permissions
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModelReader.DetermineVoteResultVisibilityForUser Method

DetermineVoteResultVisibilityForUser Method

Determine voting results visibility for user
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


EquipmentCapabilities Enumeration

Syntax
Json
EquipmentCapabilities:{
HasNone
HasPowerOn
HasPowerOff
HasVolumeControl
HasDualUse}
Members
Member name | Value | Description
HasNone | 0 |
HasPowerOn | 1 |
HasPowerOff | 2 |
HasVolumeControl | 3 |
HasDualUse | 4 |
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetInterpretationOutputPresetRequest Constructor

ConferenceApiHandlerSetInterpretationOutputPresetRequest Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerSetInterpretationOutputPresetRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


TransformNotesFileResponse Properties

The ConferenceApiHandlerTransformNotesFileResponse type exposes the following members.

Properties
 | Name | Description
Public property | NotesHtml | The transformed notes as html string
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RemoveSpeechRequest Constructor

ConferenceApiHandlerRemoveSpeechRequest Constructor

Initializes a new instance of the ConferenceApiHandlerRemoveSpeechRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


MeetingState Enumeration

State of the meeting
Syntax
Json
MeetingState:{
activated
deactivated
opened
closed}
Members
Member name | Value | Description
activated | 0 | Activated state
deactivated | 1 | Deactivated state
opened | 2 | Opened state
closed | 3 | Closed state
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SendPluginCommandRequest.PluginName Property

PluginName Property

The name of the Plugin
Syntax
Json
{ Property:PluginName }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SpeakerType Enumeration

Syntax
Json
SpeakerType:{
isSpeaker
isPrioritySpeaker
isResponder
isImportant
isRequest
isResponseRequest}
Members
Member name | Value | Description
isSpeaker | 0 | Indicates the current speaker is speaking.
isPrioritySpeaker | 1 | Indicates the current speaker is a priority speaker
isResponder | 2 | Indicates the current speaker is responding.
isImportant | 3 | Indicates the current speaker is important.
isRequest | 4 | Current request is a normal request
isResponseRequest | 5 | Current request is a response request.
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


MicrophoneSensitivity Properties

The MicrophoneSensitivity type exposes the following members.

Properties
 | Name | Description
Public property | SeatId | seat id.
Public property | SeatName | seat name.
Public property | SensitivityValue | Sensitivity value.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


MicrophoneSensitivity Methods

The MicrophoneSensitivity type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Clone the seat microphone sensitivity information
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceException Class

This class to return simple error messages to the client.
Inheritance Hierarchy
SystemObject
SystemException
SynopticControl.ServerConferenceException
Syntax
Json
{ JsonClass:ConferenceException		Message:<type>,
    Data:<type>,
    InnerException:<type>,
    TargetSite:<type>,
    StackTrace:<type>,
    HelpLink:<type>,
    Source:<type>,
    HResult:<type>,
 }

The ConferenceException type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceException | Initializes a new instance of the ConferenceException class.
Public method | ConferenceException(String) | Initializes a new instance of the ConferenceException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Protected method | ConferenceException(SerializationInfo, StreamingContext) | Initializes a new instance of the ConferenceException class with serialized data.
Public method | ConferenceException(String, Exception) | Initializes a new instance of the ConferenceException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SelectRelayInterpretationRequest Constructor

ConferenceApiHandlerSelectRelayInterpretationRequest Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerSelectRelayInterpretationRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetMasterVolumeResponse Constructor

ConferenceApiHandlerSetMasterVolumeResponse Constructor

Initializes a new instance of the ConferenceApiHandlerSetMasterVolumeResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ImageManagement.SaveImage Method

SaveImage Method

Uploads an image to the server. Requires canEditSynoptic rights
Syntax
Json
Request:

Copy
{
    "imageData": <string>,
    "name": <string>
}

Response:

Copy
{
    "saveImageUri": <string>
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SelectRelayInterpretationResponse Constructor

ConferenceApiHandlerSelectRelayInterpretationResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerSelectRelayInterpretationResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ActivateVotingRequest Properties

The ConferenceApiHandlerActivateVotingRequest type exposes the following members.

Properties
 | Name | Description
Public property | VotingId | The voting identifier
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpretationSeatMetaRequest Methods

The InterpretationSeatMetaRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetIlluminatedSeatRequest Constructor

ConferenceApiHandlerGetIlluminatedSeatRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetIlluminatedSeatRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpretationRoutingInfo.DestinationLanguageId Property

DestinationLanguageId Property

Gets or sets the destination language identifier.
Syntax
Json
{ Property:DestinationLanguageId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler Constructor

Constructor
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


IndividualVotingResult Constructor

Initializes a new instance of the IndividualVotingResult class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.TransformNotesFileRequest Class

ConferenceApiHandlerTransformNotesFileRequest Class

Defines transform notes file request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerTransformNotesFileRequest
Syntax
Json
{ JsonClass:TransformNotesFileRequest		FileName:<type>,
 }

The ConferenceApiHandlerTransformNotesFileRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerTransformNotesFileRequest | Initializes a new instance of the ConferenceApiHandlerTransformNotesFileRequest class
Top
Properties
 | Name | Description
Public property | FileName | The name of the notes file to XSL transform
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ActivateMeetingRequest Properties

The ConferenceApiHandlerActivateMeetingRequest type exposes the following members.

Properties
 | Name | Description
Public property | MeetingId | The meeting identifier.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AssemblyRedirect.OnAssemblyResolve Method

OnAssemblyResolve Method

Event handler called when a new assembly is resolved
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetAgendaTopicsRequest Constructor

ConferenceApiHandlerGetAgendaTopicsRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetAgendaTopicsRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.GetAgendaTopicsList Method

GetAgendaTopicsList Method

Get agenda topics for the given meetingId.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.EnableSeatIlluminationResponse Class

ConferenceApiHandlerEnableSeatIlluminationResponse Class

Represents the EnableSeatIllumination response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerEnableSeatIlluminationResponse
Syntax
Json
{ JsonClass:EnableSeatIlluminationResponse	 }

The ConferenceApiHandlerEnableSeatIlluminationResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerEnableSeatIlluminationResponse | Initializes a new instance of the ConferenceApiHandlerEnableSeatIlluminationResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ActivateMicrophoneRequest Constructor

ConferenceApiHandlerActivateMicrophoneRequest Constructor

Initializes a new instance of the ConferenceApiHandlerActivateMicrophoneRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SystemLog.TraceVerbose Method (String, Object[])

TraceVerbose Method (String, Object)

 Bosch Logo
Forwards the informational event to the trace source.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


GuiIdClass Properties

The GuiIdClass type exposes the following members.

Properties
 | Name | Description
Public property | Value |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


PluginDescription.Name Property

Name Property

Unique name of the plugin
Syntax
Json
{ Property:Name }
Remarks
By convention, the Name is in URI format.
plugin://[pluginName].[company].[topLevelDomain]:[instance]/[further description of plugin]
For eample: plugin://mailserver.boschsecuritysystems.com:0, plugin://hallmonitor.boschsecuritysystems.com:5
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.GetMicrophoneSensitivityStepSize Method

GetMicrophoneSensitivityStepSize Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


CreateCertificateResponse.CertificateHash Property

CertificateHash Property

Syntax
Json
{ Property:CertificateHash }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


VoteMajorityInfo.MajorityDenominatorExpression Property

MajorityDenominatorExpression Property

Hundred percent settings for majority.
Syntax
Json
{ Property:MajorityDenominatorExpression }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.OpenMeetingRequest Class

ConferenceApiHandlerOpenMeetingRequest Class

Represents the close meeting info request.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerOpenMeetingRequest
Syntax
Json
{ JsonClass:OpenMeetingRequest	 }

The ConferenceApiHandlerOpenMeetingRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerOpenMeetingRequest | Initializes a new instance of the ConferenceApiHandlerOpenMeetingRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AssemblyRedirect.LoadAssembly Method

LoadAssembly Method

Load a single assembly and its dependents into memory
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


InterpretationSeatMetaRequest.Equals Method

Equals Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SelectRelayInterpretationResponse Class

ConferenceApiHandlerSelectRelayInterpretationResponse Class

Represents the select relay interpretation response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerSelectRelayInterpretationResponse
Syntax
Json
{ JsonClass:SelectRelayInterpretationResponse	 }

The ConferenceApiHandlerSelectRelayInterpretationResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSelectRelayInterpretationResponse | Initializes a new instance of the ConferenceApiHandlerSelectRelayInterpretationResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetMajorityResultRequest Class

ConferenceApiHandlerGetMajorityResultRequest Class

Represents the get voting majority result request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetMajorityResultRequest
Syntax
Json
{ JsonClass:GetMajorityResultRequest	 }

The ConferenceApiHandlerGetMajorityResultRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetMajorityResultRequest | Initializes a new instance of the ConferenceApiHandlerGetMajorityResultRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.OpenVotingResponse Class

ConferenceApiHandlerOpenVotingResponse Class

Represents the open voting info response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerOpenVotingResponse
Syntax
Json
{ JsonClass:OpenVotingResponse	 }

The ConferenceApiHandlerOpenVotingResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerOpenVotingResponse | Initializes a new instance of the ConferenceApiHandlerOpenVotingResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnDevicesLostAtSeats Method

OnDevicesLostAtSeats Method

Handles devices that are lost at seats.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


Certificate Methods

The Certificate type exposes the following members.

Methods
Name | Description
AddCertificateExtensions(CertificateRequest, CertificatePurpose) |
AddCertificateExtensions(CertificateRequest, X509Certificate2) |
AddCertificateToStore |
AddUsersPermission |
AddUsersReadPermissionsForCertificate(String) |
AddUsersReadPermissionsForCertificate(String, String, Boolean) |
CertificateToPfx |
CreateCertificate |
CreateECDsaCertificate |
CreateECDsaCertificateRequest |
CreateRootAndServerCertificate |
CreateRootCertificateData |
CreateRootCertificatePfxCrtFiles |
CreateServerCertificatePfxFile |
ExportCertificatePublicKey |
ExportChainedCertificatePfx |
GenerateCertificatePfxByteArray |
GenerateECDsaCertificatePfxByteArray |
GenerateRootCertificateByteArray |
GetCertificate |
GetCertificateCollection2 |
GetCertificateFromLocalMachine |
GetCertificateStore |
GetOidCollection |
GetRootCertificateFromLocalMachine |
GetRootCertificateRequest |
GetSecurePassword |
GetServerCertificateFromLocalMachine |
GetServerCertificateRequest |
GetSigningCertificateFromStore |
GetSubjectAlternativeNameBuilder |
ImportCertificatesToLocalMachineStore |
InstallCertificateOnCertificateStore |
InstallRootCertificateFromCrtByteArray |
InstallRootCertificateFromCrtFile |
InstallServerCertificateFromPfxFile |
RemoveCertificate |
RemoveCertificateFromLocalMachine |
RetrieveCertificateData |
SaveRootCertificateFile |
ValidateCreateCertificateRequest |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.ResetMicrophoneSensitivity Method

ResetMicrophoneSensitivity Method

Syntax
Json
Request:

Copy
{
    "seatIds": [<string>]
}

Response:

Copy
{
    "status": <bool>
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.DeleteFileRequest Class

ConferenceApiHandlerDeleteFileRequest Class

Represents the delete file request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerDeleteFileRequest
Syntax
Json
{ JsonClass:DeleteFileRequest		FileId:<type>,
 }

The ConferenceApiHandlerDeleteFileRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerDeleteFileRequest | Initializes a new instance of the ConferenceApiHandlerDeleteFileRequest class
Top
Properties
 | Name | Description
Public property | FileId | File identifier
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


MajorityResultInfo.Status Property

Status Property

Majority reached status
Syntax
Json
{ Property:Status }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetSupportedHeadphonesResponse.SupportedHeadphones Property

SupportedHeadphones Property

Syntax
Json
{ Property:SupportedHeadphones }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.GetMinimumMicrophoneSensitivity Method

GetMinimumMicrophoneSensitivity Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetQuorumResultRequest Class

ConferenceApiHandlerGetQuorumResultRequest Class

Represents the get quorum result request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetQuorumResultRequest
Syntax
Json
{ JsonClass:GetQuorumResultRequest	 }

The ConferenceApiHandlerGetQuorumResultRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetQuorumResultRequest | Initializes a new instance of the ConferenceApiHandlerGetQuorumResultRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


MajorityResultInfo Operators

The MajorityResultInfo type exposes the following members.

Operators
Name | Description
Equality | Function to comapare two MajorityResultInfo objects are equal
Inequality | Function to comapare two MajorityResultInfo objects are unequal
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpreterBoothInfo.BoothId Property

BoothId Property

Gets or sets the booth identifier.
Syntax
Json
{ Property:BoothId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DeviceInfo.Id Property

Id Property

Syntax
Json
{ Property:Id }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DiscussionListEntry Constructor

Default constructor.
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


PluginHandler.GetPluginEventData Method

GetPluginEventData Method

Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "pluginEventsData": [<dcnmPluginEvent>]
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SystemLog Class

Represents a source log for an application to write system related event logs to.
Inheritance Hierarchy
SystemObject
SynopticControl.DiagnosticsSystemLog
Syntax
Json
{ JsonClass:SystemLog		Listeners:<type>,
    Switch:<type>,
 }

The SystemLog type exposes the following members.

Constructors
Name | Description
SystemLog |
Top
Properties
Name | Description
Listeners | Get the collection of trace listeners for the DebugLog
Switch | Gets or sets the source switch value.
Top
Methods
Name | Description
AddTraceListener | Adds the given trace listener to the list of listeners to this trace source.
LogEvent(TraceEventType, String) |
LogEvent(TraceEventType, String, Object) |
LogProcess |
RemoveTraceListener | Removes the given trace listener to the list of listeners to this trace source.
TraceError(String) | Forwards the error event to the trace source.
TraceError(String, Object) | Forwards the error event to the trace source.
TraceInfo(String) | Forwards the informational event to the trace source.
TraceInfo(String, Object) | Forwards the informational event to the trace source.
TraceResume | Logs the resume of a method/function/block
TraceStart | Logs the start of a method/function/block
TraceStop | Logs the end of a method/function/block
TraceSuspend | Logs the suspension of a method/function/block
TraceVerbose(String) | Forwards the informational event to the trace source.
TraceVerbose(String, Object) | Forwards the informational event to the trace source.
TraceWarning(String) | Forwards the warning event to the trace source.
TraceWarning(String, Object) | Forwards the warning event to the trace source.
Top
Fields
Name | Description
SOURCE_CATEGORY | The source name of this category
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AssemblyRedirect Methods

The AssemblyRedirect type exposes the following members.

Methods
Name | Description
Initialize | Ensure that this class is initialized
LoadAssembly | Load a single assembly and its dependents into memory
LoadDependentsForAssembly | Load a DLL and all its dependents
Log |
OnAssemblyResolve | Event handler called when a new assembly is resolved
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RequestSpeechRequest Class

ConferenceApiHandlerRequestSpeechRequest Class

Represents the request for the speech by seats and participants request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerRequestSpeechRequest
Syntax
Json
{ JsonClass:RequestSpeechRequest		ParticipantIds:<type>,
    SeatIds:<type>,
 }

The ConferenceApiHandlerRequestSpeechRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerRequestSpeechRequest | Initializes a new instance of the ConferenceApiHandlerRequestSpeechRequest class
Top
Properties
 | Name | Description
Public property | ParticipantIds | List of particpant identifiers.
Public property | SeatIds | List of seat identifiers.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.IsInRespondersList Method

IsInRespondersList Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


Bosch Namespaces

Namespaces
Namespace | Description
Bosch.Operational.AssemblyLoading |
Bosch.Security |


ConferenceModelReader.GetMicrophoneSensitivity Method

GetMicrophoneSensitivity Method

Syntax
Json
Request:

Copy
{
    "seatIds": [<string>]
}

Response:

Copy
{
    "seatMicrophoneSensitivities":
    [
        {
            "seatId": <string>,
            "seatName": <string>,
            "sensitivityValue": <int>
        }
    ]
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiController Methods

The ConferenceApiController type exposes the following members.

Methods
 | Name | Description
 | CreateCallableMethodsTable |
 | CreateDeserializerSettings |
 | CreateSerializerSettings |
Public method | Get | The actual Web API function
Private method | HandleMessage0 |
Protected method | ProcessRequest | Given a JSON message, interpret it, call a handler method and generate the JSON response
Private method | ProcessWebsocketSession | Wrapper needed by AcceptWebSocketRequest
Private method | Receive | The receive process
Public method | SendEvent | Send an event message
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileInfo.attributes Property

attributes Property

Attribute indicating file type like synoptic, index etc
Syntax
Json
{ Property:attributes }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiController Constructor

Initializes the static fields of the ConferenceApiController class
Syntax
Json
{ Constructor:.cctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileStore.GetFileInfo Method

GetFileInfo Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetInterpreterSeatsResponse.Seats Property

Seats Property

Gets or sets the interpreter seats.
Syntax
Json
{ Property:Seats }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.NotifyInterpretationRoutingsChangedOnClients Method

NotifyInterpretationRoutingsChangedOnClients Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.GetVoting Method

GetVoting Method

Constructs Voting object from DcnmVotingPreparationInfo
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.TryGetInterpreterLanguageFromLanguagesList Method

TryGetInterpreterLanguageFromLanguagesList Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.DeleteImageRequest.ImageName Property

ImageName Property

The name of the image.
Syntax
Json
{ Property:ImageName }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GrantResponseRequest Class

ConferenceApiHandlerGrantResponseRequest Class

Represents the requested responder to respond request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGrantResponseRequest
Syntax
Json
{ JsonClass:GrantResponseRequest		ParticipantIds:<type>,
    SeatIds:<type>,
 }

The ConferenceApiHandlerGrantResponseRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGrantResponseRequest | Initializes a new instance of the ConferenceApiHandlerGrantResponseRequest class
Top
Properties
 | Name | Description
Public property | ParticipantIds | List of particpant identifiers.
Public property | SeatIds | List of seat identifiers.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetInterpretationLanguagesRequest Class

ConferenceApiHandlerGetInterpretationLanguagesRequest Class

Represents the get interpretation languages request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetInterpretationLanguagesRequest
Syntax
Json
{ JsonClass:GetInterpretationLanguagesRequest	 }

The ConferenceApiHandlerGetInterpretationLanguagesRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetInterpretationLanguagesRequest | Initializes a new instance of the ConferenceApiHandlerGetInterpretationLanguagesRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetIndividualVotingResults Method

GetIndividualVotingResults Method

Get participant voting result
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "votingResults":
    [
        {
            "participantId": <string>,
            "votingAnswer": "notVoted"|"yes"|"no"|"abstain"|"dnpv"|"for"|"against"|"present"|"voteCasted"|"A"|"B"|"C"|"D"
        }
    ]
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetIlluminateSeatRequest Class

ConferenceApiHandlerSetIlluminateSeatRequest Class

Represents the set illuminate seat request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerSetIlluminateSeatRequest
Syntax
Json
{ JsonClass:SetIlluminateSeatRequest		SeatId:<type>,
    SetIlluminate:<type>,
 }

The ConferenceApiHandlerSetIlluminateSeatRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetIlluminateSeatRequest | Initializes a new instance of the ConferenceApiHandlerSetIlluminateSeatRequest class
Top
Properties
 | Name | Description
Public property | SeatId | The seat identifier
Public property | SetIlluminate | Set illuminate
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SynopticControl.JsonConverters Namespace

Classes
 | Class | Description
Public class | GuidConverter |


FileLogTraceListener Constructor (TextWriter, String)

Initializes a new instance of the FileLogTraceListener class with the specified name, using the stream as the recipient of the debugging and tracing output.
Syntax
Json
{ Constructor:.ctor }
Exceptions
Exception | Condition
ArgumentNullException | The stream is null.
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileLogTraceListener.WriteMessage Method

WriteMessage Method

Writes the specified message to the listener you create in the derived class.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


PluginHandler.NotifyPluginsChanged Method

NotifyPluginsChanged Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceUsers.Dispose Method

Dispose Method

Releases all resources used by the ConferenceUsers
Syntax
Json
Implements
IDisposableDispose
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetInterpretationMetaFunctionStatusResponse Constructor

ConferenceApiHandlerGetInterpretationMetaFunctionStatusResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerGetInterpretationMetaFunctionStatusResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ServerCertificateData.RootCertificateCrt Property

RootCertificateCrt Property

Syntax
Json
{ Property:RootCertificateCrt }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateSystemPowerMode Method

UpdateSystemPowerMode Method

Updates system power mode.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DcnmApi.OnMeetingDataPathUpdated Method

OnMeetingDataPathUpdated Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.DeactivateMicrophoneResponse Class

ConferenceApiHandlerDeactivateMicrophoneResponse Class

Represents the deactivation of the microphone response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerDeactivateMicrophoneResponse
Syntax
Json
{ JsonClass:DeactivateMicrophoneResponse	 }

The ConferenceApiHandlerDeactivateMicrophoneResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerDeactivateMicrophoneResponse | Initializes a new instance of the ConferenceApiHandlerDeactivateMicrophoneResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.OpenAgendaRequest.AgendaTopicId Property

AgendaTopicId Property

The agenda identifier.
Syntax
Json
{ Property:AgendaTopicId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel Class

Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceModel
Syntax
Json
{ JsonClass:ConferenceModel		AgendaTopicsList:<type>,
    BoothNotificationInfos:<type>,
    CanEnableSeatIIllumination:<type>,
    CanViewFirstRequestOnSeat:<type>,
    CanViewRequestItems:<type>,
    CanViewVoting:<type>,
    CurrentActiveMeetingId:<type>,
    CurrentSpeakerViewingOption:<type>,
    CurrentVoting:<type>,
    DiscussionMode:<type>,
    DiscussList:<type>,
    HasHybridLicense:<type>,
    HasMeetingPreparationAndManagementLicense:<type>,
    HasParticipantBasedLicense:<type>,
    HasParticipantDatabaseLicense:<type>,
    HasRemoteSubscriptionLicense:<type>,
    HasSpecialPermission:<type>,
    HasVotingPreparationAndManagementLicense:<type>,
    IlluminatedSeatId:<type>,
    IndividualVotingResults:<type>,
    Instance:<type>,
    InterpretationLanguages:<type>,
    InterpretationRoutingInfos:<type>,
    InterpreterBooths:<type>,
    InterpreterDesks:<type>,
    InterpreterMetaRequestStatus:<type>,
    InterpreterSettingsMeetingId:<type>,
    IsMeetingActive:<type>,
    IsMeetingUsingDefaultInterpretationSettings:<type>,
    IsVotingRunning:<type>,
    MajorityResult:<type>,
    MasterVolume:<type>,
    MaximumMasterVolume:<type>,
    MaxRequests:<type>,
    MaxResponses:<type>,
    MeetingStatusInfo:<type>,
    MinimumMasterVolume:<type>,
    ParticipantAccessDeniedInfo:<type>,
    ParticipantSeatsList:<type>,
    ParticipationInfoList:<type>,
    PresentationState:<type>,
    QuorumResult:<type>,
    RoomContactEmail:<type>,
    RoomName:<type>,
    SeatInfoList:<type>,
    SeatMicrophoneSensitivityList:<type>,
    SeatVotingResults:<type>,
    SystemPowerMode:<type>,
    Votes:<type>,
    Votings:<type>,
    VotingState:<type>,
    VotingStatusInfo:<type>,
 }

The ConferenceModel type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceModel | Initializes a new instance of the ConferenceModel class
Top
Properties
 | Name | Description
Protected property | AgendaTopicsList | Agenda topic status list placeholder.
Protected property | BoothNotificationInfos |
Protected property | CanEnableSeatIIllumination | Indicates can enable seat illumination
Protected property | CanViewFirstRequestOnSeat | Contains can view first request on seat
Protected property | CanViewRequestItems | Contains can view request items
Protected property | CanViewVoting | Contains can view voting permissions
Protected property | CurrentActiveMeetingId | Gets or sets the current active meeting identifier.
Public property | CurrentSpeakerViewingOption |
Protected property | CurrentVoting | Contains running voting inro
Protected property | DiscussionMode | Contains current active discussion mode.
Protected property | DiscussList |
Protected property | HasHybridLicense |
Protected property | HasMeetingPreparationAndManagementLicense |
Protected property | HasParticipantBasedLicense |
Protected property | HasParticipantDatabaseLicense |
Protected property | HasRemoteSubscriptionLicense |
Protected property | HasSpecialPermission | Contains special permission
Protected property | HasVotingPreparationAndManagementLicense |
Protected property | IlluminatedSeatId | Guid of the Illuminated seat
Protected property | IndividualVotingResults | Stores voting results of participants
 | Instance | Conference updater instance
Protected property | InterpretationLanguages |
Protected property | InterpretationRoutingInfos |
Protected property | InterpreterBooths |
Protected property | InterpreterDesks |
Protected property | InterpreterMetaRequestStatus |
Protected property | InterpreterSettingsMeetingId | Gets or sets the interpreter settings meeting identifier.
Protected property | IsMeetingActive | Indicates meeting active state
Protected property | IsMeetingUsingDefaultInterpretationSettings |
Protected property | IsVotingRunning | Indicates voting running state
Protected property | MajorityResult |
Protected property | MasterVolume |
Protected property | MaximumMasterVolume |
Protected property | MaxRequests | Contains max requests for current discussion.
Protected property | MaxResponses | Contains max responses for current discussion.
Protected property | MeetingStatusInfo | Contains meeting status information
Protected property | MinimumMasterVolume |
Protected property | ParticipantAccessDeniedInfo |
Protected property | ParticipantSeatsList |
Protected property | ParticipationInfoList | Participation info list placeholder.
Protected property | PresentationState |
Protected property | QuorumResult |
Protected property | RoomContactEmail | Contains room contact email information.
Protected property | RoomName | Contains room name information.
Public property | SeatInfoList | Contains seat information list
Protected property | SeatMicrophoneSensitivityList |
Protected property | SeatVotingResults | Stores voting results of seats
Protected property | SystemPowerMode | Contains system power state information
Protected property | Votes |
Protected property | Votings | Voting status list placeholder.
Protected property | VotingState | Contains voting state
Protected property | VotingStatusInfo | Indicates voting status info
Top
Methods
 | Name | Description
Protected method | AddCreatedMeeting | Adds created meeting to list of prepared meetings
Protected method | AddCreatedVoting | Adds created voting for list of prepared votings
Protected method | AddPreparedMeetings | Adds prepared meetings
Protected method | AddPreparedVotings | Adds prepared votings for meeting
Private method | ClearLastMinuteFlags |
Protected method | ClearStoredData |
Private method | ContainsInSeatsList | Checks if the seat already exists in the seats list.
Private method | ConvertToAgendaState |
Private method | ConvertToComparisonOperator |
Private method | CreateDiscussionListEntry |
Private method | CreateRequesterDiscussionListEntry |
Protected method | CreateSeatInfoList | Creats the seat info list
Protected method | CreateSeatMicrophoneSensitivityInfoList |
Protected method | DeleteBoothArea |
Protected method | DeletePreparedMeeting | Deletes prepared meeting info.
Protected method | DeletePreparedVoting | Deletes prepared voting
Protected method | DeleteSeatMicrophoneSensitivityInfo |
Protected method | DetermineIndividualVoteCastedResultsVisiblityForExternalSystem |
Protected method | DetermineMajorityResultVisiblityForUser | Determine majority results visibility for user
Protected method | DetermineQuorumResultVisiblity | Determine quorum results visibility for user
Private method | DetermineResultsVisiblityForUser |
Protected method | DetermineTotalVoteCastedResultsVisiblityForExternalSystem |
Protected method | DetermineTotalVoteResultVisiblityForUser | Determine total vote results visibility for user
Protected method | DetermineTotalVotesCastedVisibilityForUser | Determine total votes casted visibility for user
Protected method | DetermineVoteCastedVisiblityForUser | Determine vote casted visibility for user
Private method | DetermineVoteResultsVisiblityForVotingState | Determine voting results visibility based on voting state
Protected method | DetermineVoteResultVisiblityForUser | Determine voting results visibility for user
Public method | Dispose | Releases all resources used by the ConferenceModel
Protected method | GetAgendaTopicsList | Get agenda topics for the given meetingId.
Protected method | GetApiState |
Private method | GetDeskType |
Private method | GetDeviceIdsFoundAtSeat |
Private method | GetDeviceInfo |
Private method | GetDevicesAtSeat |
Private method | GetHeadphoneAndMicrophoneSelectionInfo |
Private method | GetInterpreterDeskInfo |
Protected method | GetMeetingInfo | Get meeting information for the given meetingId.
Protected method | GetMeetings | Get Meetings.
Protected method | GetParticipantAccessDeniedReasons |
Protected method | GetParticipationInfoList | Get participants list for the given meetingId.
Private method | GetPreferedDisplayOption | Gets the prefered display voting result option among the passed parameters
Private method | GetSeatInfo |
Private method | GetSeatMicrophoneSensitivity |
Protected method | GetSupportedHeadphones |
Private method | GetVoting | Constructs Voting object from DcnmVotingPreparationInfo
Protected method | GetVotings | Get votings for the given meetingId.
Protected method | Initialize | Initilizes conference updater.
Protected method | IsInDiscussionList |
Private method | IsLicenseAvailable |
Private method | MakeParticipantToSeats |
Private method | MakeSeatInfoListAndNotifyOnChange |
Private method | MakeSeatMicrophoneSensitivityListAndNotifyChange |
Private method | NotifyBoothNotificationsChangedOnClients |
Private method | NotifyDiscussListChangeOnClients |
Private method | NotifyInterpretationLanguagesChangedOnClients |
Private method | NotifyInterpretationMetaRequestChangedOnClients |
Private method | NotifyInterpretationRoutingsChangedOnClients |
Private method | NotifyInterpreterBoothInfoChangedOnClients |
Private method | NotifyInterpreterSeatInfoChangedOnClients |
Private method | NotifyMajorityResultChangedOnClients |
Private method | NotifyParticipantAttendanceSummaryChangedOnClients |
Private method | NotifyParticipantsInfoChangedOnClients | Sends participants info changed notification to connected clients
Private method | NotifySeatInfoChangedOnClients | Seats information change notification to connected clients
Private method | NotifySeatMicrophoneSensitivityChangedOnClients |
Private method | NotifyVotingInfoChangedOnClients |
Private method | NotifyVotingStateChangedOnClients |
Private method | OnRefreshSeatRightsTick | Requests participants list on system power cycle
Private method | OnTimerTick |
Private method | PrepareDiscussList |
Private method | ProcessSpeechTimerInterval |
Protected method | RequestAttendanceInfo |
Protected method | RequestVotingResult |
Protected method | SetWebClientDeviceCapabilities | Sets web client device capabilities
Private method | SetWebClientDeviceCapabilities(Guid) | Sets web client device capabilities to contain power off/on and volume control
Protected method | SetWebClientManageMeetingRights | Set can manage meeting rights to web client.
 | SetWebClientManageMeetingRights(DcnmSeatAssignmentInfo) | Sets web client manage meeting rights
Private method | StartSpeechTimer |
Protected method | TryGetInterpreterBoothFromBoothsList |
Protected method | TryGetInterpreterLanguageFromLanguagesList |
Protected method | TryGetInterpreterSeatFromSeatsList |
Private method | UpdateActiveVotingInfo |
Protected method | UpdateActualSpeaker |
Private method | UpdateActualSpeakerDetails |
Protected method | UpdateActualSpeakerVideo |
Protected method | UpdateAgendaTopicsReceived | Updates the agenda topics received. Important: does not work real-time. Use MeetingListChanged for now.
Private method | UpdateAndNotifyOnDeskInfoChanged |
Private method | UpdateAndNotifyOnSeatInfoChanged |
Protected method | UpdateApiState |
Protected method | UpdateApplicationMode | Updates application state
Protected method | UpdateAssignedParticipantsInfo |
Protected method | UpdateAudioSettings |
Protected method | UpdateAutoRelayForBooth |
Protected method | UpdateBoothAreas |
Protected method | UpdateBoothNotificationsList |
Protected method | UpdateDefaultVotingSettings |
Protected method | UpdateDiscussionOptions |
Protected method | UpdateEmptySeatsCreatedInfo | Updates the created empty seat information
Protected method | UpdateFoundDevicesInSeats | Updates the newly found or lost devices on seat
Protected method | UpdateHasHybridLicense |
Protected method | UpdateHasMeetingPreparationAndManagementLicense |
Protected method | UpdateHasParticipantBasedLicense |
Protected method | UpdateHasParticipantDatabaseLicense |
Protected method | UpdateHasRemoteSubscriptionLicense |
Protected method | UpdateHasVotingPreparationAndManagementLicense |
Protected method | UpdateIlluminatedSeat | Updates illuminated Seat Id
Protected method | UpdateImportantSpeakersList |
Protected method | UpdateIndividualVotingResults | Updates voting results.
Private method | UpdateIndividualVotingResultsOnClients | Sends notification to Updates voting results for client
Protected method | UpdateInterpretationLanguages |
Protected method | UpdateInterpretationMetaRequestStatus |
Protected method | UpdateInterpretationRoutingList |
Protected method | UpdateInterpreterSeatsInfo |
Protected method | UpdateMajorityResult |
Protected method | UpdateMeetingStatusInfo | Updates meeting state.
Protected method | UpdateMicrophoneSensitivityForCreatedSeat |
Protected method | UpdateMicrophoneSensitivityForUpdatedSeat |
Protected method | UpdateNotesListUpdated |
Protected method | UpdateParticipantAccessDeniedInfo |
Protected method | UpdateParticipantPictureUpdatedNumber | Update participant picture number for partcipant
Protected method | UpdateParticipantsForMeeting | Update list of participants for active meeting
Protected method | UpdateParticipantsReceived | Updates the participants received.
Protected method | UpdatePreparedMeeting | Updates prepared meeting info.
Protected method | UpdatePreparedVoting | Updates prepared voting
Protected method | UpdatePresentationState |
Protected method | UpdatePriorityList |
Protected method | UpdateQuorumResult |
Protected method | UpdateRequestsList |
Protected method | UpdateRequestToResponseOptions | Updates request to response options
Protected method | UpdateRequestToSpeakOptions | Updates request to speak options
Protected method | UpdateRespondersList |
Protected method | UpdateResponseRequestList |
Protected method | UpdateRoomContactEmailAndNotify |
Protected method | UpdateRoomNameAndNotify |
Private method | UpdateSeatedParticipantInfoOnSeat |
Private method | UpdateSeatInfo |
Protected method | UpdateSeatMicrophoneSensitivity |
Private method | UpdateSeatRights |
Protected method | UpdateSeatsAssignedInfo |
Protected method | UpdateSeatsConfigurationInfo | Updates the seat configuration information
Protected method | UpdateSeatsDeletedInfo | Updates the deleted seats information
Protected method | UpdateSeatsInfo | Updates the seat configuration information for default meeting.
Protected method | UpdateSeatsUnassigedInfo |
Protected method | UpdateSpeakersList |
Protected method | UpdateSpeakerViewingOptions |
Protected method | UpdateSpeechTimeOptions |
Private method | UpdateSpeechTimerOptions |
Protected method | UpdateSystemPowerMode | Updates system power mode.
Protected method | UpdateVotingResult | Updates the voting result.
Protected method | UpdateVotingScriptForMeetingReceived | Updates the voting script for meeting received.
Protected method | UpdateVotingStatus | Update voting state
Protected method | UpdateWebClientManageRight | Updates manage meeting rights for web client.
Private method | UpdateWebClientRights |
Top
Fields
 | Name | Description
Protected field | _webClient | Web clinet name when connected as device
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


PluginDescription.Events Property

Events Property

All the events that this plugin can generate
Syntax
Json
{ Property:Events }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.CancelImportantSpeaker Method

CancelImportantSpeaker Method

Remove important speaker from waiting/speaker list
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiAttribute Class

Only methods with this attibute can be called
Inheritance Hierarchy
SystemObject
SystemAttribute
SynopticControl.ServerConferenceApiAttribute
Syntax
Json
{ JsonClass:ConferenceApiAttribute		TypeId:<type>,
    LoginRequired:<type>,
 }

The ConferenceApiAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiAttribute | Initializes a new instance of the ConferenceApiAttribute class
Top
Properties
 | Name | Description
Public property | LoginRequired | This field needs to be false to be able to call the method without having logged in
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetEnableSeatIlluminationResponse Class

ConferenceApiHandlerGetEnableSeatIlluminationResponse Class

Represents the get enable seat illumination response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetEnableSeatIlluminationResponse
Syntax
Json
{ JsonClass:GetEnableSeatIlluminationResponse		Enable:<type>,
 }

The ConferenceApiHandlerGetEnableSeatIlluminationResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetEnableSeatIlluminationResponse | Initializes a new instance of the ConferenceApiHandlerGetEnableSeatIlluminationResponse class
Top
Properties
 | Name | Description
Public property | Enable | Enable
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConnectionTracker Class

Inheritance Hierarchy
SystemObject
Common.HubsConnectionTracker
Syntax
Json
{ JsonClass:ConnectionTracker		Instance:<type>,
 }

The ConnectionTracker type exposes the following members.

Constructors
 | Name | Description
 | ConnectionTracker |
Private method | ConnectionTracker | Initializes a new instance of the ConnectionTracker class
Top
Properties
Name | Description
Instance | Connection tracker instance
Top
Methods
 | Name | Description
Public method | AddConnection | Adds a conference connection
Protected method | Initialize |
Public method | RegisterEvents | Register events
Public method | RemoveConnection | Removes connection
Public method | ResetEvent | Indicate that the event has been processed and may be sent again
Public method | SendEvent(ConferenceEvent) | Send events to all clients
Public method | SendEvent(Guid, ConferenceEvent) | Send events to all clients where a specific user is logged in
Public method | UnregisterEvents | Unregister events
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiController Constructor

Constructor
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetInterpreterBoothsResponse Class

ConferenceApiHandlerGetInterpreterBoothsResponse Class

Represents the response for get interpreter booths
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetInterpreterBoothsResponse
Syntax
Json
{ JsonClass:GetInterpreterBoothsResponse		Booths:<type>,
 }

The ConferenceApiHandlerGetInterpreterBoothsResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetInterpreterBoothsResponse | Initializes a new instance of the ConferenceApiHandlerGetInterpreterBoothsResponse class
Top
Properties
 | Name | Description
Public property | Booths | Gets or sets the interpreter booths.
Top
Remarks
To determine if interpretation is active on an InterpreterBooth, use GetInterpreterSeats to find all the seats in the booth and then use GetInterpretationRoutings to obtain the InterpretationMicrophoneState of any seat in the booth
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetInterpretationRoutingsRequest Class

ConferenceApiHandlerGetInterpretationRoutingsRequest Class

Represents the request to get interpretation routings
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetInterpretationRoutingsRequest
Syntax
Json
{ JsonClass:GetInterpretationRoutingsRequest	 }

The ConferenceApiHandlerGetInterpretationRoutingsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetInterpretationRoutingsRequest | Initializes a new instance of the ConferenceApiHandlerGetInterpretationRoutingsRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.IsInDiscussionList Method

IsInDiscussionList Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


MajorityResultInfo.IsEnabled Property

IsEnabled Property

Indicates whether majority is enabled
Syntax
Json
{ Property:IsEnabled }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpretationMetaRequestStatus.SeatMetaData Property

SeatMetaData Property

Contains list of seat ids with active meta requests.
Syntax
Json
{ Property:SeatMetaData }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetSystemPowerModeRequest.PowerMode Property

PowerMode Property

Power mode
Syntax
Json
{ Property:PowerMode }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiAttribute.LoginRequired Property

LoginRequired Property

This field needs to be false to be able to call the method without having logged in
Syntax
Json
{ Property:LoginRequired }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceException Properties

The ConferenceException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.AbortVotingResponse Class

ConferenceApiHandlerAbortVotingResponse Class

Represents the abort voting info response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerAbortVotingResponse
Syntax
Json
{ JsonClass:AbortVotingResponse	 }

The ConferenceApiHandlerAbortVotingResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerAbortVotingResponse | Initializes a new instance of the ConferenceApiHandlerAbortVotingResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetDiscussionListResponse Constructor

ConferenceApiHandlerGetDiscussionListResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetDiscussionListResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SeatInfo Class

This contains the details of the seat
Inheritance Hierarchy
SystemObject
SynopticControl.CommonSeatInfo
Syntax
Json
{ JsonClass:SeatInfo		AssignedParticipantId:<type>,
    Attributes:<type>,
    CanPrio:<type>,
    CanVote:<type>,
    Devices:<type>,
    FoundDevices:<type>,
    HasVotingLicense:<type>,
    HideSeat:<type>,
    ScreenLine:<type>,
    SeatedParticipantId:<type>,
    SeatId:<type>,
    SeatName:<type>,
    SeatType:<type>,
    Status:<type>,
    VisType:<type>,
 }

The SeatInfo type exposes the following members.

Constructors
 | Name | Description
Public method | SeatInfo | Initializes a new instance of the SeatInfo class
Top
Properties
 | Name | Description
Public property | AssignedParticipantId | Id of participant assigned to seat
Public property | Attributes | The list of seat attributes
Public property | CanPrio | Indicates seat proiority capability
Public property | CanVote | Indicates seat canvote capability
Public property | Devices | The list of assigned Devices.
Public property | FoundDevices | Devices found at seat
Public property | HasVotingLicense |
Public property | HideSeat | Indicates seat visibility
Public property | ScreenLine | Seat screen line
Public property | SeatedParticipantId | Id of participant logged in at seat
Public property | SeatId | Unique identifier for seat
Public property | SeatName | Seat name
Public property | SeatType | The participant seat type.
Public property | Status | Indicates if seat has active device
Public property | VisType | Seat Vis type
Top
Methods
 | Name | Description
Public method | Clone | Clone the seat information
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | SetAttributesAndSeatType | Sets the attributes for seats and the type
Public method | SetDevices | Sets the devices
Public method | SetFoundDevices | Sets the found devices
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.MakeSeatInfoListAndNotifyOnChange Method

MakeSeatInfoListAndNotifyOnChange Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateRoomNameAndNotify Method

UpdateRoomNameAndNotify Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DcnmApi.DeactivateMeeting Method

DeactivateMeeting Method

Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.PluginEventHandler Method

PluginEventHandler Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RegisterPluginRequest Class

ConferenceApiHandlerRegisterPluginRequest Class

Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerRegisterPluginRequest
Syntax
Json
{ JsonClass:RegisterPluginRequest		PluginCommands:<type>,
    PluginEvents:<type>,
    PluginInterface:<type>,
    PluginName:<type>,
 }

The ConferenceApiHandlerRegisterPluginRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerRegisterPluginRequest | Initializes a new instance of the ConferenceApiHandlerRegisterPluginRequest class
Top
Properties
 | Name | Description
Public property | PluginCommands | The methods supported by this plugin
Public property | PluginEvents | The events that this plugin can generate
Public property | PluginInterface | Identifies the interface exposed by the plugin
Public property | PluginName | Unique name of the plugin
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel Properties

The ConferenceModel type exposes the following members.

Properties
 | Name | Description
Protected property | AgendaTopicsList | Agenda topic status list placeholder.
Protected property | BoothNotificationInfos |
Protected property | CanEnableSeatIIllumination | Indicates can enable seat illumination
Protected property | CanViewFirstRequestOnSeat | Contains can view first request on seat
Protected property | CanViewRequestItems | Contains can view request items
Protected property | CanViewVoting | Contains can view voting permissions
Protected property | CurrentActiveMeetingId | Gets or sets the current active meeting identifier.
Public property | CurrentSpeakerViewingOption |
Protected property | CurrentVoting | Contains running voting inro
Protected property | DiscussionMode | Contains current active discussion mode.
Protected property | DiscussList |
Protected property | HasHybridLicense |
Protected property | HasMeetingPreparationAndManagementLicense |
Protected property | HasParticipantBasedLicense |
Protected property | HasParticipantDatabaseLicense |
Protected property | HasRemoteSubscriptionLicense |
Protected property | HasSpecialPermission | Contains special permission
Protected property | HasVotingPreparationAndManagementLicense |
Protected property | IlluminatedSeatId | Guid of the Illuminated seat
Protected property | IndividualVotingResults | Stores voting results of participants
 | Instance | Conference updater instance
Protected property | InterpretationLanguages |
Protected property | InterpretationRoutingInfos |
Protected property | InterpreterBooths |
Protected property | InterpreterDesks |
Protected property | InterpreterMetaRequestStatus |
Protected property | InterpreterSettingsMeetingId | Gets or sets the interpreter settings meeting identifier.
Protected property | IsMeetingActive | Indicates meeting active state
Protected property | IsMeetingUsingDefaultInterpretationSettings |
Protected property | IsVotingRunning | Indicates voting running state
Protected property | MajorityResult |
Protected property | MasterVolume |
Protected property | MaximumMasterVolume |
Protected property | MaxRequests | Contains max requests for current discussion.
Protected property | MaxResponses | Contains max responses for current discussion.
Protected property | MeetingStatusInfo | Contains meeting status information
Protected property | MinimumMasterVolume |
Protected property | ParticipantAccessDeniedInfo |
Protected property | ParticipantSeatsList |
Protected property | ParticipationInfoList | Participation info list placeholder.
Protected property | PresentationState |
Protected property | QuorumResult |
Protected property | RoomContactEmail | Contains room contact email information.
Protected property | RoomName | Contains room name information.
Public property | SeatInfoList | Contains seat information list
Protected property | SeatMicrophoneSensitivityList |
Protected property | SeatVotingResults | Stores voting results of seats
Protected property | SystemPowerMode | Contains system power state information
Protected property | Votes |
Protected property | Votings | Voting status list placeholder.
Protected property | VotingState | Contains voting state
Protected property | VotingStatusInfo | Indicates voting status info
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateAudioSettings Method

UpdateAudioSettings Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetMasterVolumeResponse Class

ConferenceApiHandlerGetMasterVolumeResponse Class

Represents the get master volume response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetMasterVolumeResponse
Syntax
Json
{ JsonClass:GetMasterVolumeResponse		Volume:<type>,
 }

The ConferenceApiHandlerGetMasterVolumeResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetMasterVolumeResponse | Initializes a new instance of the ConferenceApiHandlerGetMasterVolumeResponse class
Top
Properties
 | Name | Description
Public property | Volume | Gets or sets the volume.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


VerificationMethod Enumeration

Verification method for the meeting
Syntax
Json
VerificationMethod:{
None
Confirmation
Password
PINCode
ExternalSystem}
Members
Member name | Value | Description
None | 0 | No verification required.
Confirmation | 1 | Verification by confirmation.
Password | 2 | Verification by password.
PINCode | 3 | Verification by PIN-code.
ExternalSystem | 4 | Verification by external system.
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Participant Properties

The Participant type exposes the following members.

Properties
 | Name | Description
Public property | CanPrio | Indicates whether participant can use priority or not.
Public property | CanVote | Gets a value indicating whether this instance can vote.
Public property | Country | Gets the country.
Public property | Email |
Public property | FirstName | Gets the first name.
Public property | Group | Gets the group.
Public property | IsAuthenticated | Gets a value indicating whether this instance is authenticated.
Public property | LastName | Gets the last name.
Public property | MiddleName | Gets the name of the middle.
Public property | ParticipantId | Gets the identifier.
Public property | ParticipantType |
Public property | PersonId | The person identifier.
Public property | PictureUpdatedNumber | PictureUpdatedNumber is used to retrieve latest version of person picture on client side
Public property | Region | Gets the region.
Public property | Title | Gets the title.
Public property | VisType | Gets the vis type of the participant.
Public property | VoteWeight | Gets the vote weight.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ParticipantAccessDeniedReasons Class

Class that contains the participant access denied reasons info
Inheritance Hierarchy
SystemObject
SynopticControl.CommonParticipantAccessDeniedReasons
Syntax
Json
{ JsonClass:ParticipantAccessDeniedReasons		AccessDeniedReasons:<type>,
 }

The ParticipantAccessDeniedReasons type exposes the following members.

Constructors
 | Name | Description
Public method | ParticipantAccessDeniedReasons | Initializes a new instance of the ParticipantAccessDeniedReasons class
Top
Properties
 | Name | Description
Public property | AccessDeniedReasons | Participant access denied reasons
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UpdateMicrophoneSensitivityRequest Constructor

ConferenceApiHandlerUpdateMicrophoneSensitivityRequest Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerUpdateMicrophoneSensitivityRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileLogTraceListener.GetEncodingWithFallback Method

GetEncodingWithFallback Method

Provides a failure-handling mechanism, called a fallback, for an input character that cannot be converted to an encoded output byte sequence.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetParticipantsRequest Constructor

ConferenceApiHandlerGetParticipantsRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetParticipantsRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ResetMicrophoneSensitivityRequest.SeatIds Property

SeatIds Property

List of seat ids to reset sensitivity level to 0. If the list count is 0 then will reset all the seats microphone sensitivity level to 0 in the system.
Syntax
Json
{ Property:SeatIds }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


BoothNotificationInfo Properties

The BoothNotificationInfo type exposes the following members.

Properties
 | Name | Description
Public property | BoothId | Gets or sets the booth identifier.
Public property | Notifications | Gets of sets the list of notification messages.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


UpdateMicrophoneSensitivityRequest Properties

The ConferenceApiHandlerUpdateMicrophoneSensitivityRequest type exposes the following members.

Properties
 | Name | Description
Public property | SeatMicrophoneSensitivity | List of seat ids with sensitivity value SeatMicrophoneSensitivity.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetDiscussionMode Method

GetDiscussionMode Method

Returns current discussion mode to requested clients.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


PluginHandler Properties

The PluginHandler type exposes the following members.

Properties
Name | Description
Instance |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SystemLog.TraceInfo Method (String, Object[])

TraceInfo Method (String, Object)

 Bosch Logo
Forwards the informational event to the trace source.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.EnableSeatIlluminationRequest Constructor

ConferenceApiHandlerEnableSeatIlluminationRequest Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerEnableSeatIlluminationRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader Properties

The ConferenceModelReader type exposes the following members.

Properties
 | Name | Description
Public property | CanDeactivateMicrophone | Contains can deactivate microphone
 | Instance | Conference model instance
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


RegisterPluginRequest Properties

The ConferenceApiHandlerRegisterPluginRequest type exposes the following members.

Properties
 | Name | Description
Public property | PluginCommands | The methods supported by this plugin
Public property | PluginEvents | The events that this plugin can generate
Public property | PluginInterface | Identifies the interface exposed by the plugin
Public property | PluginName | Unique name of the plugin
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetMasterVolumeRangeResponse Constructor

ConferenceApiHandlerGetMasterVolumeRangeResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetMasterVolumeRangeResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.CloseMeetingResponse Class

ConferenceApiHandlerCloseMeetingResponse Class

Represents the close meeting info response.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerCloseMeetingResponse
Syntax
Json
{ JsonClass:CloseMeetingResponse	 }

The ConferenceApiHandlerCloseMeetingResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerCloseMeetingResponse | Initializes a new instance of the ConferenceApiHandlerCloseMeetingResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.OpenVotingRequest Constructor

ConferenceApiHandlerOpenVotingRequest Constructor

Initializes a new instance of the ConferenceApiHandlerOpenVotingRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpreterDeskInfo.GetHashCode Method

GetHashCode Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


MajorityResultInfo Class

Defines majority result for voting
Inheritance Hierarchy
SystemObject
SynopticControl.CommonMajorityResultInfo
Syntax
Json
{ JsonClass:MajorityResultInfo		ComparisonOperator:<type>,
    DenominatorValue:<type>,
    IsEnabled:<type>,
    NumeratorValue:<type>,
    Status:<type>,
    ThresholdValue:<type>,
 }

The MajorityResultInfo type exposes the following members.

Constructors
 | Name | Description
Public method | MajorityResultInfo | Initializes instance of class
Top
Properties
 | Name | Description
Public property | ComparisonOperator | Comparision operator used in majority expression.
Public property | DenominatorValue | Majority denominator value
Public property | IsEnabled | Indicates whether majority is enabled
Public property | NumeratorValue | Majority numerator value
Public property | Status | Majority reached status
Public property | ThresholdValue | Majority threshold value
Top
Methods
 | Name | Description
Public method | Equals(Object) | Override Equals function in IEquatable (Overrides ObjectEquals(Object).)
Public method | Equals(MajorityResultInfo) | Function to compare MajorityResultInfo with other objects
Public method | GetHashCode | Override GetHashCode function in IEquatable (Overrides ObjectGetHashCode.)
Top
Operators
Name | Description
Equality | Function to comapare two MajorityResultInfo objects are equal
Inequality | Function to comapare two MajorityResultInfo objects are unequal
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ParticipantSeats Properties

The ParticipantSeats type exposes the following members.

Properties
 | Name | Description
Public property | AssignedSeatId |
Public property | ParticipantId |
Public property | SeatedSeatId |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


PluginHandler.NotifyPluginEvent Method

NotifyPluginEvent Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


FileInfo.Inequality Operator

Inequality Operator

Function to comapare two file info objects are unequal
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetPluginsRequest Class

ConferenceApiHandlerGetPluginsRequest Class

Get plugins request
Remarks
Gets all registered plugins
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetPluginsRequest
Syntax
Json
{ JsonClass:GetPluginsRequest	 }

The ConferenceApiHandlerGetPluginsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetPluginsRequest | Initializes a new instance of the ConferenceApiHandlerGetPluginsRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DiscussionListEntry.Equals Method

Equals Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModelReader Methods

The ConferenceModelReader type exposes the following members.

Methods
 | Name | Description
Protected method | ActivateMicrophone |
Protected method | CancelSpeaker |
Protected method | CloseMeeting | Close the active meeting.
Protected method | DeactivateMicrophone |
Protected method | DetermineMajorityResultVisibilityForUser |
Protected method | DetermineQuorumResultVisibility |
Protected method | DetermineTotalResultsHasValidVoteAnswers |
Protected method | DetermineTotalVoteResultVisibilityForUser |
Protected method | DetermineTotalVotesCastedVisibilityForUser |
Protected method | DetermineVoteCastedVisibilityForUser |
Protected method | DetermineVoteResultVisibilityForUser | Determine voting results visibility for user
Public method | Dispose | Cleansup after the object instance.
Protected method | GetApiState |
Protected method | GetBoothNotifications | Returns booth notifications to requested clients.
Public method | GetCurrentVotingInfo | Provides voting state.
Private method | GetDiscussInfoBySeatId | Returns discuss list.
Public method | GetDiscussionList | Returns prepared discussion list to requested clients.
Public method | GetDiscussionMode | Returns current discussion mode to requested clients.
Public method | GetEnableSeatIlluminationState | Gets enable seat illumination state.
Protected method | GetHybridLicenseActiveState |
Private method | GetIdsForDiscussionOperations |
Public method | GetIlluminatedSeatId | Gets Guid of the illuminated seat
Public method | GetImageServerInfo | Gets ImageServerInfo
Public method | GetIndividualCastVoteResults | Get seat individual cast vote results
Private method | GetIndividualCastVoteResults(ReadOnlyCollectionVotingResult) |
Public method | GetIndividualParticipantCastVoteResults | Get participant individual cast vote results
Private method | GetIndividualParticipantCastVoteResults(ReadOnlyCollectionIndividualVotingResult) |
Public method | GetIndividualVotingResults | Get participant voting result
Private method | GetIndividualVotingResults(ReadOnlyCollectionIndividualVotingResult) |
Protected method | GetInterpretationLanguages | Returns interpretation languages to requested clients.
Protected method | GetInterpretationMetaRequestStatus |
Protected method | GetInterpretationRoutings | Returns interpretation routings to requested clients.
Protected method | GetInterpreterBooths | Returns interpreter booths to requested clients.
Protected method | GetInterpreterMetaRequestType |
Protected method | GetInterpreterSeats | Returns interpreter seats to requested clients.
Public method | GetMajorityResult | Gets the voting majority result
Protected method | GetMasterVolume |
Protected method | GetMaximumMasterVolume |
Public method | GetMaxRequests | Returns max requests for current discussion.
Public method | GetMaxResponses | Returns max responses for current discussion.
Public method | GetMeetingInfo | Gets the meeting information.
Public method | GetMeetings | Gets the meetings information.
Public method | GetMicrophoneSensitivity |
Protected method | GetMinimumMasterVolume |
Protected method | GetParticipantAccessDeniedReasons |
Private method | GetParticipantIdFromSeatId | returns participant id from seatid
Public method | GetParticipants | Gets the participants.
Public method | GetParticipantSeats |
Public method | GetPresentationState | Gets the state of the presentation.
Public method | GetQuorumResult | Gets the meeting quorum result
Public method | GetRoomContactEmail | Gets room contact email
Public method | GetRoomName | Gets room name
Public method | GetSeatInfoList | Get seat list
Public method | GetSeatVotingResults | Get seat voting results
Private method | GetSeatVotingResults(ReadOnlyCollectionVotingResult) |
Protected method | GetSupportedHeadphones |
Public method | GetSystemPowerMode | Gets the power mode information of the system
Public method | GetTopics | Gets the topics.
Public method | GetTotalCastVoteResult |
Private method | GetTotalCastVoteResult(ReadOnlyCollectionVote) |
Private method | GetTotalVoteResult |
Public method | GetVotingResult | Gets the voting result.
Public method | GetVotings | Gets the votings.
Public method | GetVotingState | Provides voting state.
Protected method | GrantResponse |
Protected method | GrantSpeech(ListGuid) |
Protected method | GrantSpeech(Guid) |
Protected method | Initialize |
Public method | IsInInterpretationBoothList |
Public method | IsInInterpretationLanguageList |
Public method | IsInInterpretationOutputLanguageListOfDesk |
Public method | IsInInterpretationSeatList |
Public method | IsInRespondersList |
Public method | IsInSpeakerList |
Protected method | IsValidInterpreterMetaRequest |
Protected method | RemoveResponse |
Protected method | RemoveSpeech |
Protected method | RequestResponse |
Protected method | RequestSpeech |
Public method | SetImageServerInfo | Set the Imageserver info
Protected method | TryGetInterpreterSeatFromSeatsList |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateSeatsDeletedInfo Method

UpdateSeatsDeletedInfo Method

Updates the deleted seats information
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


SystemLog.Switch Property

Switch Property

Gets or sets the source switch value.
Syntax
Json
{ Property:Switch }
Exceptions
Exception | Condition
ArgumentNullException | Switch is set to null.
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpreterDeskInfo.Equals Method

Equals Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UnRegisterPluginResponse Constructor

ConferenceApiHandlerUnRegisterPluginResponse Constructor

Initializes a new instance of the ConferenceApiHandlerUnRegisterPluginResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.IssueInterpreterMetaFunctionRequest Class

ConferenceApiHandlerIssueInterpreterMetaFunctionRequest Class

 Bosch Logo
Represents issue interpreter meta function request.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerIssueInterpreterMetaFunctionRequest
Syntax
Json
{ JsonClass:IssueInterpreterMetaFunctionRequest		Request:<type>,
    SeatId:<type>,
 }

The ConferenceApiHandlerIssueInterpreterMetaFunctionRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerIssueInterpreterMetaFunctionRequest | Initializes a new instance of the ConferenceApiHandlerIssueInterpreterMetaFunctionRequest class
Top
Properties
 | Name | Description
Public property | Request |
Public property | SeatId |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GuiIdClass Constructor (Guid)

Initializes a new instance of the GuiIdClass class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.DeactivateMeetingRequest Class

ConferenceApiHandlerDeactivateMeetingRequest Class

Represents the deactivate meeting info request.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerDeactivateMeetingRequest
Syntax
Json
{ JsonClass:DeactivateMeetingRequest	 }

The ConferenceApiHandlerDeactivateMeetingRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerDeactivateMeetingRequest | Initializes a new instance of the ConferenceApiHandlerDeactivateMeetingRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.RequestVotingResult Method

RequestVotingResult Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.TryGetInterpreterSeatFromSeatsList Method

TryGetInterpreterSeatFromSeatsList Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetMeetingsRequest Constructor

ConferenceApiHandlerGetMeetingsRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetMeetingsRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Meeting.MeetingStartDate Property

MeetingStartDate Property

Gets the meeting start date.
Syntax
Json
{ Property:MeetingStartDate }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


RemoveSeatFromDiscussionListRequest Properties

The ConferenceApiHandlerRemoveSeatFromDiscussionListRequest type exposes the following members.

Properties
 | Name | Description
Public property | SeatId | The seat identifier.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetMeetingInfoRequest Constructor

ConferenceApiHandlerGetMeetingInfoRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetMeetingInfoRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SystemLog.TraceWarning Method

TraceWarning Method

Overload List
Name | Description
TraceWarning(String) | Forwards the warning event to the trace source.
TraceWarning(String, Object) | Forwards the warning event to the trace source.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetDiscussionOptionsResponse Constructor

ConferenceApiHandlerGetDiscussionOptionsResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetDiscussionOptionsResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetDiscussionListResponse.DiscussionList Property

DiscussionList Property

Holds the list of discussion list entries.
Syntax
Json
{ Property:DiscussionList }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpretationRoutingInfo.DestinationLanguageQuality Property

DestinationLanguageQuality Property

The interpretation quality of the destination language.
Syntax
Json
{ Property:DestinationLanguageQuality }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.GetParticipantAccessDeniedReasons Method

GetParticipantAccessDeniedReasons Method

Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "participantAccessDeniedReasonsInfo":
    {
        "accessDeniedReasons":
        [
            "noReason"|"invalidUserCredentials"|"notParticipantToMeeting"|"incorrectSeat"|"grantFailure"|
        ]
    }
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceException Events

The ConferenceException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.Instance Property

Instance Property

Conference model instance
Syntax
Json
{ Property:Instance }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileLogTraceListener.CreateLogFile Method

CreateLogFile Method

Create a log file
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


CheckNotesFileTamperedRequest Properties

The ConferenceApiHandlerCheckNotesFileTamperedRequest type exposes the following members.

Properties
 | Name | Description
Public property | FileName | The name of the notes file to check
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.CloseVotingRequest Class

ConferenceApiHandlerCloseVotingRequest Class

Represents the close voting info request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerCloseVotingRequest
Syntax
Json
{ JsonClass:CloseVotingRequest	 }

The ConferenceApiHandlerCloseVotingRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerCloseVotingRequest | Initializes a new instance of the ConferenceApiHandlerCloseVotingRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ActivateVotingResponse Class

ConferenceApiHandlerActivateVotingResponse Class

Represents the activate meeting info response.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerActivateVotingResponse
Syntax
Json
{ JsonClass:ActivateVotingResponse	 }

The ConferenceApiHandlerActivateVotingResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerActivateVotingResponse | Initializes a new instance of the ConferenceApiHandlerActivateVotingResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetRoomNameResponse.RoomName Property

RoomName Property

Syntax
Json
{ Property:RoomName }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.ActivateAdHocVoting Method

ActivateAdHocVoting Method

Syntax
Json
Request:

Copy
{
    "description": <string>,
    "number": <string>,
    "subject": <string>
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetMajorityResultResponse Properties

The ConferenceApiHandlerGetMajorityResultResponse type exposes the following members.

Properties
 | Name | Description
Public property | MajorityResult | Voting majority result
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Meeting.MeetingId Property

MeetingId Property

Gets the meeting identifier.
Syntax
Json
{ Property:MeetingId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


RootCertificateData Properties

The RootCertificateData type exposes the following members.

Properties
 | Name | Description
Public property | PrivatePfxData |
Public property | PublicCrtData |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateQuorumResult Method

UpdateQuorumResult Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


FileLogTraceListener Constructor (TextWriter)

Initializes a new instance of the FileLogTraceListener class, using the stream as the recipient of the debugging and tracing output.
Syntax
Json
{ Constructor:.ctor }
Exceptions
Exception | Condition
ArgumentNullException | The stream is null.
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GuiIdClass Constructor

Initializes a new instance of the GuiIdClass class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetSystemPowerModeResponse Properties

The ConferenceApiHandlerGetSystemPowerModeResponse type exposes the following members.

Properties
 | Name | Description
Public property | PowerMode | Power mode
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SendPluginCommandRequest.Command Property

Command Property

The name of the command
Syntax
Json
{ Property:Command }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.Instance Property

Instance Property

Conference updater instance
Syntax
Json
{ Property:Instance }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


MicrophoneSensitivity Constructor

Initializes a new instance of the MicrophoneSensitivity class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GrantSpeechRequest.ParticipantIds Property

ParticipantIds Property

List of particpant identifiers.
Syntax
Json
{ Property:ParticipantIds }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnBoothNotificationsChanged Method

OnBoothNotificationsChanged Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModelReader.DetermineMajorityResultVisibilityForUser Method

DetermineMajorityResultVisibilityForUser Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.TransformNotesFileResponse Class

ConferenceApiHandlerTransformNotesFileResponse Class

Defines transform notes file response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerTransformNotesFileResponse
Syntax
Json
{ JsonClass:TransformNotesFileResponse		NotesHtml:<type>,
 }

The ConferenceApiHandlerTransformNotesFileResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerTransformNotesFileResponse | Initializes a new instance of the ConferenceApiHandlerTransformNotesFileResponse class
Top
Properties
 | Name | Description
Public property | NotesHtml | The transformed notes as html string
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnInterpretationMetaRequestStatusChanged Method

OnInterpretationMetaRequestStatusChanged Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


BoothNotificationInfo.BoothId Property

BoothId Property

Gets or sets the booth identifier.
Syntax
Json
{ Property:BoothId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileInfoDetail.FileId Property

FileId Property

Id of the file
Syntax
Json
{ Property:FileId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GuidConverter.ReadJson Method

ReadJson Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetInterpretationLanguagesRequest Constructor

ConferenceApiHandlerGetInterpretationLanguagesRequest Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerGetInterpretationLanguagesRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetMeetingInfoResponse Properties

The ConferenceApiHandlerGetMeetingInfoResponse type exposes the following members.

Properties
 | Name | Description
Public property | MeetingInfo | Meeting info
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetParticipantsResponse Properties

The ConferenceApiHandlerGetParticipantsResponse type exposes the following members.

Properties
 | Name | Description
Public property | Participants | Participants list
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetPluginEventDataResponse Constructor

ConferenceApiHandlerGetPluginEventDataResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetPluginEventDataResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateApiState Method

UpdateApiState Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


GetParticipantsRequest Properties

The ConferenceApiHandlerGetParticipantsRequest type exposes the following members.

Properties
 | Name | Description
Public property | MeetingId | The meeting identifier.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


PluginDescription Properties

The PluginDescription type exposes the following members.

Properties
 | Name | Description
Public property | Commands | All the methods supported by this plugin
Public property | Events | All the events that this plugin can generate
Public property | Interface | Identifies the interface exposed by the plugin
Public property | Name | Unique name of the plugin
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.ReadSynopticLoginDetail Method

ReadSynopticLoginDetail Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.LoginRequest.User Property

User Property

User name
Syntax
Json
{ Property:User }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RequestSpeechRequest.ParticipantIds Property

ParticipantIds Property

List of particpant identifiers.
Syntax
Json
{ Property:ParticipantIds }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetPresentationStateResponse Properties

The ConferenceApiHandlerGetPresentationStateResponse type exposes the following members.

Properties
 | Name | Description
Public property | IsPresentationEnabled | Gets or sets the presentation state.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


NotesFileSearchCriteria Constructor

Initializes a new instance of the NotesFileSearchCriteria class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DeviceInfo.Capabilities Property

Capabilities Property

Syntax
Json
{ Property:Capabilities }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnImageWebserverInfoChanged Method

OnImageWebserverInfoChanged Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetMasterVolumeResponse Constructor

ConferenceApiHandlerGetMasterVolumeResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetMasterVolumeResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpreterDeskInfo.Headphone Property

Headphone Property

Syntax
Json
{ Property:Headphone }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LogOnModel Properties

The LogOnModel type exposes the following members.

Properties
 | Name | Description
Public property | name | Login user name
Public property | password | Login password
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.DeleteFileResponse Class

ConferenceApiHandlerDeleteFileResponse Class

Represents the delete file response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerDeleteFileResponse
Syntax
Json
{ JsonClass:DeleteFileResponse	 }

The ConferenceApiHandlerDeleteFileResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerDeleteFileResponse | Initializes a new instance of the ConferenceApiHandlerDeleteFileResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


NotesFileInfo Constructor

Initializes a new instance of the NotesFileInfo class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DisplayVotingResultOption Enumeration

Display voting result option.
Syntax
Json
DisplayVotingResultOption:{
Always
OnHoldOrClosed
OnAcceptedOrRejected
Never}
Members
Member name | Value | Description
Always | 0 | Voting result show alwyas.
OnHoldOrClosed | 1 | Voting result shown on hold or close of voting.
OnAcceptedOrRejected | 2 | Voting result shown on hold or accept or reject.
Never | 3 | Voting result never shown.
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateActualSpeaker Method

UpdateActualSpeaker Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


InterpreterBoothInfo.AutoRelay Property

AutoRelay Property

Gets or sets the indication if auto relay is enabled.
Syntax
Json
{ Property:AutoRelay }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnRoomContactEmailUpdated Method

OnRoomContactEmailUpdated Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ActivatePresentationResponse Class

ConferenceApiHandlerActivatePresentationResponse Class

Represents to activate the presentation response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerActivatePresentationResponse
Syntax
Json
{ JsonClass:ActivatePresentationResponse	 }

The ConferenceApiHandlerActivatePresentationResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerActivatePresentationResponse | Initializes a new instance of the ConferenceApiHandlerActivatePresentationResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetMicrophoneSensitivityDescriptionResponse Properties

The ConferenceApiHandlerGetMicrophoneSensitivityDescriptionResponse type exposes the following members.

Properties
 | Name | Description
Public property | MicSensitivityDescription |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdatePreparedVoting Method

UpdatePreparedVoting Method

Updates prepared voting
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetRoomName Method

GetRoomName Method

Gets room name
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "roomName": <string>
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateRoomContactEmailAndNotify Method

UpdateRoomContactEmailAndNotify Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConnectionState Fields

The ConnectionState type exposes the following members.

Fields
 | Name | Description
Public field | eventSent |
Public field | eventWhiteList |
Public field | uniqueConnectionId |
Public field | userId | User id
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateSpeakerViewingOptions Method

UpdateSpeakerViewingOptions Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


InterpretationRoutingInfo Properties

The InterpretationRoutingInfo type exposes the following members.

Properties
 | Name | Description
Public property | AutoRelayContribution | Gets or sets a value indicating whether this instance is contributing automatic relay.
Public property | DestinationLanguageId | Gets or sets the destination language identifier.
Public property | DestinationLanguageQuality | The interpretation quality of the destination language.
Public property | MicrophoneState | Gets or sets the state of the microphone.
Public property | SeatId | Gets or sets the seat identifier.
Public property | SourceLanguageId | Gets or sets the source language identifier.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.CreateFileResponse Class

ConferenceApiHandlerCreateFileResponse Class

Represents the create file response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerCreateFileResponse
Syntax
Json
{ JsonClass:CreateFileResponse		FileId:<type>,
 }

The ConferenceApiHandlerCreateFileResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerCreateFileResponse | Initializes a new instance of the ConferenceApiHandlerCreateFileResponse class
Top
Properties
 | Name | Description
Public property | FileId |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


MicrophoneSensitivityDescription.MinimumMicrophoneSensitivity Property

MinimumMicrophoneSensitivity Property

Minimum microphone sensitivity.
Syntax
Json
{ Property:MinimumMicrophoneSensitivity }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetInterpretationMetaFunctionStatusResponse Properties

The ConferenceApiHandlerGetInterpretationMetaFunctionStatusResponse type exposes the following members.

Properties
 | Name | Description
Public property | RequestStatus |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ActivateAdHocVotingResponse Constructor

ConferenceApiHandlerActivateAdHocVotingResponse Constructor

Initializes a new instance of the ConferenceApiHandlerActivateAdHocVotingResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.SetInterpretationOutPreset Method

SetInterpretationOutPreset Method

Sets the interpretation out preset.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


FileLogTraceListener.Write Method

Write Method

Overload List
 | Name | Description
Public method | Write(Object) | Writes the value of the object's ToString method to the listener you create when you implement the TraceListener class. (Inherited from TraceListener.)
Public method | Write(String) | Writes the specified message to the listener you create in the derived class. (Overrides TraceListenerWrite(String).)
Public method | Write(String, String) | Writes a category name and a message to the listener you create when you implement the TraceListener class. (Inherited from TraceListener.)
Public method | Write(Object, String) | Writes a category name and the value of the object's ToString method to the listener you create when you implement the TraceListener class. (Inherited from TraceListener.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConnectionTracker.UnregisterEvents Method

UnregisterEvents Method

Unregister events
Syntax
Json
Request:

Copy
{
    "events":
    [
        "apiStateChanged"|"permissionsChanged"|"seatsChanged"|"discussionListChanged"|"discussionOptionsChanged"|"meetingInfoChanged"|"individualVotingResultsChanged"|
        "votingStateChanged"|"enableSeatIlluminationChanged"|"illuminatedSeatChanged"|"systemPowerModeChanged"|"agendaTopicsChanged"|"participantsChanged"|
        "votingScriptChanged"|"votingResultChanged"|"interpretationLanguagesChanged"|"interpretationRoutingsChanged"|"interpreterSeatsChanged"|
        "interpreterBoothsChanged"|"boothNotificationsChanged"|"masterVolumeChanged"|"masterVolumeRangeChanged"|"presentationStateChanged"|
        "fileChanged"|"participantSeatsChanged"|"quorumResultChanged"|"majorityResultChanged"|"votingInfoChanged"|"notesFileListChanged"|
        "interpretationMetaRequestStatusChanged"|"roomNameChanged"|"roomContactEmailChanged"|"pluginsChanged"|"pluginEventAvailable"|"pluginCommandAvailable"|
    ]
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.IsVotingRunning Property

IsVotingRunning Property

Indicates voting running state
Syntax
Json
{ Property:IsVotingRunning }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.GetPlugins Method

GetPlugins Method

Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "plugins": [<string>]
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.IsMeetingUsingDefaultInterpretationSettings Property

IsMeetingUsingDefaultInterpretationSettings Property

Syntax
Json
{ Property:IsMeetingUsingDefaultInterpretationSettings }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnActiveMeetingStatusChanged Method

OnActiveMeetingStatusChanged Method

Called on meeting status changed.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.CheckNotesFileTamperedResponse.FileVerificationResponse Property

FileVerificationResponse Property

Result of document verification response.DocumentVerificationResponse
Syntax
Json
{ Property:FileVerificationResponse }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetMajorityResultResponse Class

ConferenceApiHandlerGetMajorityResultResponse Class

Represents the get voting majority result response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetMajorityResultResponse
Syntax
Json
{ JsonClass:GetMajorityResultResponse		MajorityResult:<type>,
 }

The ConferenceApiHandlerGetMajorityResultResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetMajorityResultResponse | Initializes a new instance of the ConferenceApiHandlerGetMajorityResultResponse class
Top
Properties
 | Name | Description
Public property | MajorityResult | Voting majority result
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DiscussionListEntry.SeatId Property

SeatId Property

Id of the seat
Syntax
Json
{ Property:SeatId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateBoothNotificationsList Method

UpdateBoothNotificationsList Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetIlluminatedSeatRequest Class

ConferenceApiHandlerGetIlluminatedSeatRequest Class

Represents the GetIlluminatedSeat request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetIlluminatedSeatRequest
Syntax
Json
{ JsonClass:GetIlluminatedSeatRequest	 }

The ConferenceApiHandlerGetIlluminatedSeatRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetIlluminatedSeatRequest | Initializes a new instance of the ConferenceApiHandlerGetIlluminatedSeatRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GrantResponseResponse Constructor

ConferenceApiHandlerGrantResponseResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGrantResponseResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.DetermineTotalResultsHasValidVoteAnswers Method

DetermineTotalResultsHasValidVoteAnswers Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModelReader.DetermineQuorumResultVisibility Method

DetermineQuorumResultVisibility Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


FileLogTraceListener.TraceData Method (TraceEventCache, String, TraceEventType, Int32, Object[])

TraceData Method (TraceEventCache, String, TraceEventType, Int32, Object)

 Bosch Logo
Writes trace information, an array of data objects and event information to the listener specific output.
Syntax
Json
  Remarks
  Note  Note
This method is not intended to be called directly by application code
            but by members of the Debug, Trace, and
            TraceSource classes to write trace data to output.

            The default implementation writes the values of the source, eventType and
            id parameters as a header. The data objects are converted to strings using
            the ToString method of each object. The eventCache data is written as a footer,
            the nature of the output data being dependent on the value of the
            TraceOutputOptions property.

  See Also
Reference
TraceListener class
TextWriterTraceListener class
Debug class
Trace class


ConferenceModelReader.GetParticipantAccessDeniedReasons Method

GetParticipantAccessDeniedReasons Method

Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "participantAccessDeniedReasonsInfo":
    {
        "accessDeniedReasons":
        [
            "noReason"|"invalidUserCredentials"|"notParticipantToMeeting"|"incorrectSeat"|"grantFailure"|
        ]
    }
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetMinimumMasterVolume Method

GetMinimumMasterVolume Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DcnmApi.OnDevicesFoundAtSeats Method

OnDevicesFoundAtSeats Method

Handles devices that are found at seats.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DcnmApi.SetMasterVolume Method

SetMasterVolume Method

Syntax
Json
Request:

Copy
{
    "volume": <int>
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetMaxResponses Method

GetMaxResponses Method

Returns max responses for current discussion.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


PluginHandler.SendPluginEvent Method

SendPluginEvent Method

Syntax
Json
Request:

Copy
{
    "event": <string>,
    "parameters": <string>,
    "pluginName": <string>
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ImageManagement Constructor

Initializes the static fields of the ImageManagement class
Syntax
Json
{ Constructor:.cctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.IlluminatedSeatId Property

IlluminatedSeatId Property

Guid of the Illuminated seat
Syntax
Json
{ Property:IlluminatedSeatId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.DeleteImageResponse Constructor

ConferenceApiHandlerDeleteImageResponse Constructor

Initializes a new instance of the ConferenceApiHandlerDeleteImageResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.CheckNotesFileTamperedResponse Constructor

ConferenceApiHandlerCheckNotesFileTamperedResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerCheckNotesFileTamperedResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SubscribePluginEventRequest.EventName Property

EventName Property

Event name to subscribe.
Syntax
Json
{ Property:EventName }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetMasterVolumeRequest Constructor

ConferenceApiHandlerGetMasterVolumeRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetMasterVolumeRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.ProcessSpeechTimerInterval Method

ProcessSpeechTimerInterval Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


SetSystemPowerModeRequest Properties

The ConferenceApiHandlerSetSystemPowerModeRequest type exposes the following members.

Properties
 | Name | Description
Public property | PowerMode | Power mode
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


IssueInterpreterMetaFunctionRequest Properties

The ConferenceApiHandlerIssueInterpreterMetaFunctionRequest type exposes the following members.

Properties
 | Name | Description
Public property | Request |
Public property | SeatId |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


MasterVolumeRange Class

Represents master volume range info
Inheritance Hierarchy
SystemObject
SynopticControl.CommonMasterVolumeRange
Syntax
Json
{ JsonClass:MasterVolumeRange		MaximumVolume:<type>,
    MinimumVolume:<type>,
 }

The MasterVolumeRange type exposes the following members.

Constructors
 | Name | Description
Public method | MasterVolumeRange | Initializes a new instance of the MasterVolumeRange class.
Top
Properties
 | Name | Description
Public property | MaximumVolume | Gets or sets the maximum volume.
Public property | MinimumVolume | Gets or sets the minimum volume.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


PluginDescription.Interface Property

Interface Property

Identifies the interface exposed by the plugin
Syntax
Json
{ Property:Interface }
Remarks
By convention, the interface identification in in URI format.
interface://[interfacename].[company].[topLevelDomain]/Version
Multiple interfaces may be exposed. The the Interface holds multiple URIs separated by a space.
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileStore.DeleteFile Method

DeleteFile Method

Deteles the configuration of a file from the server.
Syntax
Json
Request:

Copy
{
    "fileId": <string>
}

Response:

Copy
{
}
Remarks
DeleteFile requires canEditSynoptic permissions for the requesting client
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnBaseCapabilitiesChanged Method

OnBaseCapabilitiesChanged Method

Handles base capabilities changed
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


BoothNotificationInfo Class

Represents booth notification information
Inheritance Hierarchy
SystemObject
SynopticControl.CommonBoothNotificationInfo
Syntax
Json
{ JsonClass:BoothNotificationInfo		BoothId:<type>,
    Notifications:<type>,
 }

The BoothNotificationInfo type exposes the following members.

Constructors
 | Name | Description
Public method | BoothNotificationInfo | Initializes a new instance of the InterpretationRoutingInfo class.
Top
Properties
 | Name | Description
Public property | BoothId | Gets or sets the booth identifier.
Public property | Notifications | Gets of sets the list of notification messages.
Top
Methods
 | Name | Description
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.CancelInterpreterMetaFunctionResponse Class

ConferenceApiHandlerCancelInterpreterMetaFunctionResponse Class

 Bosch Logo
Represents cancel interpreter function response.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerCancelInterpreterMetaFunctionResponse
Syntax
Json
{ JsonClass:CancelInterpreterMetaFunctionResponse	 }

The ConferenceApiHandlerCancelInterpreterMetaFunctionResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerCancelInterpreterMetaFunctionResponse | Initializes a new instance of the ConferenceApiHandlerCancelInterpreterMetaFunctionResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ListImagesResponse Constructor

ConferenceApiHandlerListImagesResponse Constructor

Initializes a new instance of the ConferenceApiHandlerListImagesResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DiscussionListEntry.ShowSpeechTimer Property

ShowSpeechTimer Property

Indicates that speech time data is shown
Syntax
Json
{ Property:ShowSpeechTimer }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetVotingsRequest Constructor

ConferenceApiHandlerGetVotingsRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetVotingsRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RegisterPluginRequest.PluginCommands Property

PluginCommands Property

The methods supported by this plugin
Syntax
Json
{ Property:PluginCommands }
See Also

Reference

SynopticControl.CommonPluginCommandDescription


DcnmApi.UpdateRoomContactEmail Method

UpdateRoomContactEmail Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


VoteMajorityInfo Class

Holds voting majority information.
Inheritance Hierarchy
SystemObject
SynopticControl.CommonVoteMajorityInfo
Syntax
Json
{ JsonClass:VoteMajorityInfo		IsEnabled:<type>,
    MajorityCondition:<type>,
    MajorityDenominatorExpression:<type>,
    MajorityNumeratorExpression:<type>,
    MajorityThresholdExpression:<type>,
 }

The VoteMajorityInfo type exposes the following members.

Constructors
 | Name | Description
Public method | VoteMajorityInfo | Class holds voting majority information.
Top
Properties
 | Name | Description
Public property | IsEnabled | Flag indicates whether majority is enabled for voting.
Public property | MajorityCondition | Majority condition operator ComparisonOperators.
Public property | MajorityDenominatorExpression | Hundred percent settings for majority.
Public property | MajorityNumeratorExpression | In favor for majority.
Public property | MajorityThresholdExpression | Majority threshold to decide whether voting can be approved or not.
Top
Methods
 | Name | Description
Public method | Equals | Function to compare one VoteMajorityInfo object with other
Public method | GetHashCode | Override GetHashCode function in IEquatable (Overrides ObjectGetHashCode.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


PluginHandler Constructor

Initializes a new instance of the PluginHandler class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SystemLog Methods

The SystemLog type exposes the following members.

Methods
Name | Description
AddTraceListener | Adds the given trace listener to the list of listeners to this trace source.
LogEvent(TraceEventType, String) |
LogEvent(TraceEventType, String, Object) |
LogProcess |
RemoveTraceListener | Removes the given trace listener to the list of listeners to this trace source.
TraceError(String) | Forwards the error event to the trace source.
TraceError(String, Object) | Forwards the error event to the trace source.
TraceInfo(String) | Forwards the informational event to the trace source.
TraceInfo(String, Object) | Forwards the informational event to the trace source.
TraceResume | Logs the resume of a method/function/block
TraceStart | Logs the start of a method/function/block
TraceStop | Logs the end of a method/function/block
TraceSuspend | Logs the suspension of a method/function/block
TraceVerbose(String) | Forwards the informational event to the trace source.
TraceVerbose(String, Object) | Forwards the informational event to the trace source.
TraceWarning(String) | Forwards the warning event to the trace source.
TraceWarning(String, Object) | Forwards the warning event to the trace source.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetPluginCommandResultRequest.CorrelationId Property

CorrelationId Property

The correlation id
Syntax
Json
{ Property:CorrelationId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.CreateFileRequest.Title Property

Title Property

Title of the file
Syntax
Json
{ Property:Title }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SupportedHeadphoneTypes Class

Inheritance Hierarchy
SystemObject
SynopticControl.CommonSupportedHeadphoneTypes
Syntax
Json
{ JsonClass:SupportedHeadphoneTypes		HeadphoneDescription:<type>,
    Id:<type>,
 }

The SupportedHeadphoneTypes type exposes the following members.

Constructors
 | Name | Description
Public method | SupportedHeadphoneTypes | Initializes a new instance of the SupportedHeadphoneTypes class
Top
Properties
 | Name | Description
Public property | HeadphoneDescription |
Public property | Id |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Certificate Class

Inheritance Hierarchy
SystemObject
Bosch.SecurityCertificate
Syntax
Json
{ JsonClass:Certificate	 }

The Certificate type exposes the following members.

Methods
Name | Description
AddCertificateExtensions(CertificateRequest, CertificatePurpose) |
AddCertificateExtensions(CertificateRequest, X509Certificate2) |
AddCertificateToStore |
AddUsersPermission |
AddUsersReadPermissionsForCertificate(String) |
AddUsersReadPermissionsForCertificate(String, String, Boolean) |
CertificateToPfx |
CreateCertificate |
CreateECDsaCertificate |
CreateECDsaCertificateRequest |
CreateRootAndServerCertificate |
CreateRootCertificateData |
CreateRootCertificatePfxCrtFiles |
CreateServerCertificatePfxFile |
ExportCertificatePublicKey |
ExportChainedCertificatePfx |
GenerateCertificatePfxByteArray |
GenerateECDsaCertificatePfxByteArray |
GenerateRootCertificateByteArray |
GetCertificate |
GetCertificateCollection2 |
GetCertificateFromLocalMachine |
GetCertificateStore |
GetOidCollection |
GetRootCertificateFromLocalMachine |
GetRootCertificateRequest |
GetSecurePassword |
GetServerCertificateFromLocalMachine |
GetServerCertificateRequest |
GetSigningCertificateFromStore |
GetSubjectAlternativeNameBuilder |
ImportCertificatesToLocalMachineStore |
InstallCertificateOnCertificateStore |
InstallRootCertificateFromCrtByteArray |
InstallRootCertificateFromCrtFile |
InstallServerCertificateFromPfxFile |
RemoveCertificate |
RemoveCertificateFromLocalMachine |
RetrieveCertificateData |
SaveRootCertificateFile |
ValidateCreateCertificateRequest |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DeactivateMicrophoneRequest Properties

The ConferenceApiHandlerDeactivateMicrophoneRequest type exposes the following members.

Properties
 | Name | Description
Public property | ParticipantIds | List of participant identifiers.
Public property | SeatId | Obsolete. The seat identifier.
Public property | SeatIds | List of seat identifiers.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiMethodCaller(Response, Request).Initialize Method

Initialize Method

Syntax
Json
Implements
IConferenceApiMethodCallerInitialize(MethodInfo, JsonSerializer, JsonSerializer)
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


PluginHandler.AwaiterInfo.Awaiter Property

Awaiter Property

Syntax
Json
{ Property:Awaiter }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AuthenticateController.LogOn Method

LogOn Method

Authenticates user
Syntax
Json
  See Also
Reference
AuthenticateControllerLogOff


ServerCertificateData Properties

The ServerCertificateData type exposes the following members.

Properties
 | Name | Description
Public property | PrivatePfx |
Public property | RootCertificateCrt |
Public property | RootCertificateFriendlyName |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetMicrophoneSensitivityResponse.SeatMicrophoneSensitivities Property

SeatMicrophoneSensitivities Property

List of seat ids with sensitivity value MicrophoneSensitivity.
Syntax
Json
{ Property:SeatMicrophoneSensitivities }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi Properties

The DcnmApi type exposes the following members.

Properties
 | Name | Description
 | Instance | DcnmApi instance
Public property | SynopticUri | Gets and sets the synoptic uri
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


PluginDescription Constructor

Initializes a new instance of the PluginDescription class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SelectInterpretationInputLanguageResponse Constructor

ConferenceApiHandlerSelectInterpretationInputLanguageResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerSelectInterpretationInputLanguageResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.HoldVotingResponse Class

ConferenceApiHandlerHoldVotingResponse Class

Represents the hold voting info response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerHoldVotingResponse
Syntax
Json
{ JsonClass:HoldVotingResponse	 }

The ConferenceApiHandlerHoldVotingResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerHoldVotingResponse | Initializes a new instance of the ConferenceApiHandlerHoldVotingResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiMethodCaller(Response, Request) Constructor

ConferenceApiMethodCallerResponse, Request Constructor

Initializes a new instance of the ConferenceApiMethodCallerResponse, Request class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetPluginEventDataResponse Properties

The ConferenceApiHandlerGetPluginEventDataResponse type exposes the following members.

Properties
 | Name | Description
Public property | PluginEventsData | Collections of plugin events
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileStore.UpdateFile Method

UpdateFile Method

Saves the configuration of file.
Syntax
Json
Request:

Copy
{
    "attributes": [<string>],
    "fileId": <string>,
    "payload": <string>,
    "title": <string>
}

Response:

Copy
{
}
Remarks
Saves the configuration of file requires canEditSynoptic permissions for the requesting client
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpretationSeatMetaRequest.SeatMetaRequests Property

SeatMetaRequests Property

Gets or sets the seat metat data.
Syntax
Json
{ Property:SeatMetaRequests }
See Also

Reference

SynopticControl.CommonInterpretationMetaRequestType


ConferenceApiHandler.GetInterpreterSeatsRequest Constructor

ConferenceApiHandlerGetInterpreterSeatsRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetInterpreterSeatsRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DeleteNotesFilesRequest Properties

The ConferenceApiHandlerDeleteNotesFilesRequest type exposes the following members.

Properties
 | Name | Description
Public property | FileNames | The collection of file names to delete
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetPermissionsRequest Class

ConferenceApiHandlerGetPermissionsRequest Class

Parameters to GetPermissions
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetPermissionsRequest
Syntax
Json
{ JsonClass:GetPermissionsRequest	 }

The ConferenceApiHandlerGetPermissionsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetPermissionsRequest | Initializes a new instance of the ConferenceApiHandlerGetPermissionsRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetParticipantAccessDeniedReasonsResponse Class

ConferenceApiHandlerGetParticipantAccessDeniedReasonsResponse Class

 Bosch Logo
Represents the get participant access denied reasons response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetParticipantAccessDeniedReasonsResponse
Syntax
Json
{ JsonClass:GetParticipantAccessDeniedReasonsResponse		ParticipantAccessDeniedReasonsInfo:<type>,
 }

The ConferenceApiHandlerGetParticipantAccessDeniedReasonsResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetParticipantAccessDeniedReasonsResponse | Initializes a new instance of the ConferenceApiHandlerGetParticipantAccessDeniedReasonsResponse class
Top
Properties
 | Name | Description
Public property | ParticipantAccessDeniedReasonsInfo | Participants Access Denied Reason.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.DeactivateMicrophoneRequest.SeatIds Property

SeatIds Property

List of seat identifiers.
Syntax
Json
{ Property:SeatIds }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SynopticControl Namespaces

Main entry for the Conference protocol.
Namespaces
Namespace | Description
SynopticControl | This contains AuthController class which contains all methods related to User authentication such as Login/Logout.
SynopticControl.Common | This contains LoginModel , SeatInfo classes info.It also contains SynopticLayoutInfo details as well as permission enumeration details.
SynopticControl.Diagnostics |
SynopticControl.JsonConverters |
SynopticControl.Server | The Conference protocol Server


ConferenceModel.IsLicenseAvailable Method

IsLicenseAvailable Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DcnmApi.UpdateVotingsForMeeting Method

UpdateVotingsForMeeting Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiController Class

Controller for the conference API
Inheritance Hierarchy
SystemObject
ApiController
SynopticControl.ServerConferenceApiController
Syntax
Json
{ JsonClass:ConferenceApiController	 }

The ConferenceApiController type exposes the following members.

Constructors
 | Name | Description
 | ConferenceApiController |
Public method | ConferenceApiController | Constructor
Top
Methods
 | Name | Description
 | CreateCallableMethodsTable |
 | CreateDeserializerSettings |
 | CreateSerializerSettings |
Public method | Get | The actual Web API function
Private method | HandleMessage0 |
Protected method | ProcessRequest | Given a JSON message, interpret it, call a handler method and generate the JSON response
Private method | ProcessWebsocketSession | Wrapper needed by AcceptWebSocketRequest
Private method | Receive | The receive process
Public method | SendEvent | Send an event message
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UpdateMicrophoneSensitivityRequest Class

ConferenceApiHandlerUpdateMicrophoneSensitivityRequest Class

Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerUpdateMicrophoneSensitivityRequest
Syntax
Json
{ JsonClass:UpdateMicrophoneSensitivityRequest		SeatMicrophoneSensitivity:<type>,
 }

The ConferenceApiHandlerUpdateMicrophoneSensitivityRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerUpdateMicrophoneSensitivityRequest | Initializes a new instance of the ConferenceApiHandlerUpdateMicrophoneSensitivityRequest class
Top
Properties
 | Name | Description
Public property | SeatMicrophoneSensitivity | List of seat ids with sensitivity value SeatMicrophoneSensitivity.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RemoveResponseResponse Constructor

ConferenceApiHandlerRemoveResponseResponse Constructor

Initializes a new instance of the ConferenceApiHandlerRemoveResponseResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ActivateVotingResponse Constructor

ConferenceApiHandlerActivateVotingResponse Constructor

Initializes a new instance of the ConferenceApiHandlerActivateVotingResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


PluginEventSubscriptionData Properties

The PluginHandlerPluginEventSubscriptionData type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionId |
Public property | EventName |
Public property | PluginName |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


TransformNotesFileRequest Properties

The ConferenceApiHandlerTransformNotesFileRequest type exposes the following members.

Properties
 | Name | Description
Public property | FileName | The name of the notes file to XSL transform
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SystemLog Properties

The SystemLog type exposes the following members.

Properties
Name | Description
Listeners | Get the collection of trace listeners for the DebugLog
Switch | Gets or sets the source switch value.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


RegisterEventsRequest Properties

The ConferenceApiHandlerRegisterEventsRequest type exposes the following members.

Properties
 | Name | Description
Public property | Events | List of events registered
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RejectVotingResponse Class

ConferenceApiHandlerRejectVotingResponse Class

Represents the reject voting info response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerRejectVotingResponse
Syntax
Json
{ JsonClass:RejectVotingResponse	 }

The ConferenceApiHandlerRejectVotingResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerRejectVotingResponse | Initializes a new instance of the ConferenceApiHandlerRejectVotingResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateAndNotifyOnDeskInfoChanged Method

UpdateAndNotifyOnDeskInfoChanged Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


InterpretationRoutingInfo Class

Represents interpretation routing information
Inheritance Hierarchy
SystemObject
SynopticControl.CommonInterpretationRoutingInfo
Syntax
Json
{ JsonClass:InterpretationRoutingInfo		AutoRelayContribution:<type>,
    DestinationLanguageId:<type>,
    DestinationLanguageQuality:<type>,
    MicrophoneState:<type>,
    SeatId:<type>,
    SourceLanguageId:<type>,
 }

The InterpretationRoutingInfo type exposes the following members.

Constructors
 | Name | Description
Public method | InterpretationRoutingInfo | Initializes a new instance of the InterpretationRoutingInfo class.
Top
Properties
 | Name | Description
Public property | AutoRelayContribution | Gets or sets a value indicating whether this instance is contributing automatic relay.
Public property | DestinationLanguageId | Gets or sets the destination language identifier.
Public property | DestinationLanguageQuality | The interpretation quality of the destination language.
Public property | MicrophoneState | Gets or sets the state of the microphone.
Public property | SeatId | Gets or sets the seat identifier.
Public property | SourceLanguageId | Gets or sets the source language identifier.
Top
Methods
 | Name | Description
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RemoveSpeechResponse Class

ConferenceApiHandlerRemoveSpeechResponse Class

Represents the removal of the speech by seats and participants response.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerRemoveSpeechResponse
Syntax
Json
{ JsonClass:RemoveSpeechResponse	 }

The ConferenceApiHandlerRemoveSpeechResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerRemoveSpeechResponse | Initializes a new instance of the ConferenceApiHandlerRemoveSpeechResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.EventResponse Constructor

ConferenceApiHandlerEventResponse Constructor

Initializes a new instance of the ConferenceApiHandlerEventResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SendPluginEventRequest Constructor

ConferenceApiHandlerSendPluginEventRequest Constructor

Initializes a new instance of the ConferenceApiHandlerSendPluginEventRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateSeatsInfo Method

UpdateSeatsInfo Method

Updates the seat configuration information for default meeting.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DcnmApi.RequestMicrophoneActive Method

RequestMicrophoneActive Method

Request to activate the microphone of the participant with the specified id.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DcnmApi.EnableSeatIllumination Method

EnableSeatIllumination Method

Enable or disable seat illumination
Syntax
Json
Request:

Copy
{
    "enable": <bool>
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.DiscussList Property

DiscussList Property

Syntax
Json
{ Property:DiscussList }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


VotingResult Properties

The VotingResult type exposes the following members.

Properties
 | Name | Description
Public property | seatId | Seat id
Public property | votingAnswer | Voting answer for the seat
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RegisterEventsRequest.Events Property

Events Property

List of events registered
Syntax
Json
{ Property:Events }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Common.Hubs Namespace

This contains ConferenceHub class which contains all methods as part conference protocol.
Classes
 | Class | Description
Protected class | ConnectionTracker |


ConferenceApiHandler.GetParticipantsRequest.MeetingId Property

MeetingId Property

The meeting identifier.
Syntax
Json
{ Property:MeetingId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.DiscussionMode Property

DiscussionMode Property

Contains current active discussion mode.
Syntax
Json
{ Property:DiscussionMode }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


IConferenceApiMethodCaller.LoginRequired Property

LoginRequired Property

Syntax
Json
{ Property:LoginRequired }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetVotingsResponse Properties

The ConferenceApiHandlerGetVotingsResponse type exposes the following members.

Properties
 | Name | Description
Public property | VotingList | List of voting
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


VotingResult Constructor

Initializes a new instance of the VotingResult class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ActivateMeetingResponse Constructor

ConferenceApiHandlerActivateMeetingResponse Constructor

Initializes a new instance of the ConferenceApiHandlerActivateMeetingResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DiscussionListEntry.IsLastMinuteActivated Property

IsLastMinuteActivated Property

Indicates last minute activated state for the seat
Syntax
Json
{ Property:IsLastMinuteActivated }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SeatParticipants.SeatId Property

SeatId Property

Syntax
Json
{ Property:SeatId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.InterpreterSettingsMeetingId Property

InterpreterSettingsMeetingId Property

Gets or sets the interpreter settings meeting identifier.
Syntax
Json
{ Property:InterpreterSettingsMeetingId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Certificate.InstallRootCertificateFromCrtByteArray Method

InstallRootCertificateFromCrtByteArray Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


Meeting.MeetingEndDate Property

MeetingEndDate Property

Gets the meeting end date.
Syntax
Json
{ Property:MeetingEndDate }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AccessRights.ActivateMeeting Property

ActivateMeeting Property

Syntax
Json
{ Property:ActivateMeeting }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.DetermineTotalVotesCastedVisibilityForUser Method

DetermineTotalVotesCastedVisibilityForUser Method

Determine total votes casted visibility for user
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


RootCertificateData.PublicCrtData Property

PublicCrtData Property

Syntax
Json
{ Property:PublicCrtData }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ActivateAdHocVotingRequest.Number Property

Number Property

Voting number for the ad-hoc voting
Syntax
Json
{ Property:Number }
Remarks
The maximum characters supported is 50.
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpretationMetaRequestStatus Properties

The InterpretationMetaRequestStatus type exposes the following members.

Properties
 | Name | Description
Public property | ActiveInterpretationMetaRequests | Active interpretation meta request type.
Public property | SeatMetaData | Contains list of seat ids with active meta requests.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.GrantRequest Method

GrantRequest Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.AddCreatedVoting Method

AddCreatedVoting Method

Adds created voting for list of prepared votings
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


MajorityResultInfo.Equals Method (MajorityResultInfo)

Equals Method (MajorityResultInfo)

 Bosch Logo
Function to compare MajorityResultInfo with other objects
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


PluginCommandDescription Class

Inheritance Hierarchy
SystemObject
SynopticControl.CommonPluginCommandDescription
Syntax
Json
{ JsonClass:PluginCommandDescription		Name:<type>,
 }

The PluginCommandDescription type exposes the following members.

Constructors
 | Name | Description
Public method | PluginCommandDescription | Initializes a new instance of the PluginCommandDescription class
Top
Properties
 | Name | Description
Public property | Name | Name of the command
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SupportedHeadphoneTypes.HeadphoneDescription Property

HeadphoneDescription Property

Syntax
Json
{ Property:HeadphoneDescription }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GrantResponse Method

GrantResponse Method

Syntax
Json
Request:

Copy
{
    "participantIds": [<string>],
    "seatIds": [<string>]
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RegisterEventsRequest Class

ConferenceApiHandlerRegisterEventsRequest Class

Parameters to RegisterEvents
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerRegisterEventsRequest
Syntax
Json
{ JsonClass:RegisterEventsRequest		Events:<type>,
 }

The ConferenceApiHandlerRegisterEventsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerRegisterEventsRequest | Initializes a new instance of the ConferenceApiHandlerRegisterEventsRequest class
Top
Properties
 | Name | Description
Public property | Events | List of events registered
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnPluginsAdded Method

OnPluginsAdded Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


FileStore.Instance Property

Instance Property

File store instance
Syntax
Json
{ Property:Instance }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


VoteMajorityInfo.GetHashCode Method

GetHashCode Method

Override GetHashCode function in IEquatable
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetPluginRequest Constructor

ConferenceApiHandlerGetPluginRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetPluginRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnInterpretationRoutingListChanged Method

OnInterpretationRoutingListChanged Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


GetInterpretationRoutingsResponse Properties

The ConferenceApiHandlerGetInterpretationRoutingsResponse type exposes the following members.

Properties
 | Name | Description
Public property | Routings | Gets or sets the interpretation routings.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SubscribePluginEventRequest Properties

The ConferenceApiHandlerSubscribePluginEventRequest type exposes the following members.

Properties
 | Name | Description
Public property | EventName | Event name to subscribe.
Public property | PluginName | Plugin name to subscribe
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ActivatePresentationResponse Constructor

ConferenceApiHandlerActivatePresentationResponse Constructor

Initializes a new instance of the ConferenceApiHandlerActivatePresentationResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DiscussionListEntry.MicrophoneState Property

MicrophoneState Property

Uses DiscussionListState to contains mic state
Syntax
Json
{ Property:MicrophoneState }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.CanViewFirstRequestOnSeat Property

CanViewFirstRequestOnSeat Property

Contains can view first request on seat
Syntax
Json
{ Property:CanViewFirstRequestOnSeat }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.SetManageMeetingRights Method

SetManageMeetingRights Method

Sets the manage meeting rights
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DcnmApi Constructor

Initializes a new instance of the DcnmApi class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


CheckNotesFileTamperedResponse Properties

The ConferenceApiHandlerCheckNotesFileTamperedResponse type exposes the following members.

Properties
 | Name | Description
Public property | FileVerificationResponse | Result of document verification response.DocumentVerificationResponse
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.LogoutRequest Class

ConferenceApiHandlerLogoutRequest Class

Logout request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerLogoutRequest
Syntax
Json
{ JsonClass:LogoutRequest	 }

The ConferenceApiHandlerLogoutRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerLogoutRequest | Initializes a new instance of the ConferenceApiHandlerLogoutRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Voting.DocumentationLink Property

DocumentationLink Property

Gets the documentation URL.
Syntax
Json
{ Property:DocumentationLink }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpreterBoothInfo Class

Contains interpreter booth information
Inheritance Hierarchy
SystemObject
SynopticControl.CommonInterpreterBoothInfo
Syntax
Json
{ JsonClass:InterpreterBoothInfo		AutoRelay:<type>,
    BoothId:<type>,
    BoothNumber:<type>,
 }

The InterpreterBoothInfo type exposes the following members.

Constructors
 | Name | Description
Public method | InterpreterBoothInfo | Initializes a new instance of the InterpreterBoothInfo class.
Public method | InterpreterBoothInfo(Guid, Int32, Boolean) | Initializes a new instance of the InterpreterBoothInfo class.
Top
Properties
 | Name | Description
Public property | AutoRelay | Gets or sets the indication if auto relay is enabled.
Public property | BoothId | Gets or sets the booth identifier.
Public property | BoothNumber | Gets or sets the booth number.
Top
Methods
 | Name | Description
Public method | Clone | handles clone
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetParticipantSeatsResponse Constructor

ConferenceApiHandlerGetParticipantSeatsResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetParticipantSeatsResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.LogoutResponse Constructor

ConferenceApiHandlerLogoutResponse Constructor

Initializes a new instance of the ConferenceApiHandlerLogoutResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Helper.TryParseDate Method

TryParseDate Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.AgendaTopicsList Property

AgendaTopicsList Property

Agenda topic status list placeholder.
Syntax
Json
{ Property:AgendaTopicsList }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateHasVotingPreparationAndManagementLicense Method

UpdateHasVotingPreparationAndManagementLicense Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


Permission Enumeration

Contains user permissions
Syntax
Json
Permission:{
canManageMeeting
canEditSynoptic
canSelect
canAddDevicesToSeats
canViewSynoptic
canViewVoting
canEnableSeatIllumination
canSwitchSystemPowerOn
canSwitchSystemPowerOff
canViewRequestItems
canViewFirstRequestOnSeat
canDeactivateMicrophone
hasSpecialPermission
canControlInterpretation
canViewInterpretation
canControlMasterVolume
canPrepareMeetingAndAgenda
canViewMeetingNotes
canViewVotingNotes
canViewRemoteParticipants
canControlVoting
hasParticipantBasedLicense
canControlMicrophoneSensitivity}
Members
Member name | Value | Description
canManageMeeting | 0 | Permissions to manage meeting
canEditSynoptic | 1 | Permissions to edit synoptic
canSelect | 2 | Permissions to select
canAddDevicesToSeats | 3 | Permissions to add devices to seat
canViewSynoptic | 4 | Permissions to view synoptic
canViewVoting | 5 | Permissions to view voting
canEnableSeatIllumination | 6 | Permissions to enable seat Illumination
canSwitchSystemPowerOn | 7 | Permissions to power on the system
canSwitchSystemPowerOff | 8 | Permissions to power off the system
canViewRequestItems | 9 | Permissions to view the discuss waiting list
canViewFirstRequestOnSeat | 10 | Permissions to view first request on seat
canDeactivateMicrophone | 11 | Permissions to (de)activate the microphone on seat
hasSpecialPermission | 12 | Permissions for special access on seat
canControlInterpretation | 13 | Permissions to control interpretation
canViewInterpretation | 14 | Permissions to view interpreter desks and booths
canControlMasterVolume | 15 | Permissions to control master volume
canPrepareMeetingAndAgenda | 16 | Permissions to prepare meeting and agenda for a user group
canViewMeetingNotes | 17 | Permissions to view meeting notes
canViewVotingNotes | 18 | Permissions to view voting notes
canViewRemoteParticipants | 19 | Permission to view remote participants
canControlVoting | 20 | Permission to control voting
hasParticipantBasedLicense | 21 | Has participant based license
canControlMicrophoneSensitivity | 22 | permission to control microphone sensitivity
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


BoothNotificationInfo Methods

The BoothNotificationInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.GetVotingsForMeeting Method

GetVotingsForMeeting Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


FileInfoDetail Constructor

Initializes a new instance of the FileInfoDetail class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.Instance Property

Instance Property

DcnmApi instance
Syntax
Json
{ Property:Instance }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.NotifyInterpretationMetaRequestChangedOnClients Method

NotifyInterpretationMetaRequestChangedOnClients Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetSeatVotingResults Method (ReadOnlyCollection(VotingResult))

GetSeatVotingResults Method (ReadOnlyCollectionVotingResult)

 Bosch Logo
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "votingResults":
    [
        {
            "seatId": <string>,
            "votingAnswer": "notVoted"|"yes"|"no"|"abstain"|"dnpv"|"for"|"against"|"present"|"voteCasted"|"A"|"B"|"C"|"D"
        }
    ]
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnPluginsRemoved Method

OnPluginsRemoved Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetVotingStateRequest Constructor

ConferenceApiHandlerGetVotingStateRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetVotingStateRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SystemLog Fields

The SystemLog type exposes the following members.

Fields
Name | Description
SOURCE_CATEGORY | The source name of this category
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpreterBoothInfo Properties

The InterpreterBoothInfo type exposes the following members.

Properties
 | Name | Description
Public property | AutoRelay | Gets or sets the indication if auto relay is enabled.
Public property | BoothId | Gets or sets the booth identifier.
Public property | BoothNumber | Gets or sets the booth number.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.LoadFileRequest Constructor

ConferenceApiHandlerLoadFileRequest Constructor

Initializes a new instance of the ConferenceApiHandlerLoadFileRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RequestResponseRequest.SeatIds Property

SeatIds Property

List of seat identifiers.
Syntax
Json
{ Property:SeatIds }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateIlluminatedSeat Method

UpdateIlluminatedSeat Method

Updates illuminated Seat Id
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


MajorityResultInfo Methods

The MajorityResultInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Override Equals function in IEquatable (Overrides ObjectEquals(Object).)
Public method | Equals(MajorityResultInfo) | Function to compare MajorityResultInfo with other objects
Public method | GetHashCode | Override GetHashCode function in IEquatable (Overrides ObjectGetHashCode.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetMeetingInfoRequest.MeetingId Property

MeetingId Property

The meeting identifier.
Syntax
Json
{ Property:MeetingId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetInterpreterMetaRequestType Method

GetInterpreterMetaRequestType Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetApiStateResponse Constructor

ConferenceApiHandlerGetApiStateResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetApiStateResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetDiscussionOptionsResponse.MaxResponses Property

MaxResponses Property

Holds max responses for current discussion.
Syntax
Json
{ Property:MaxResponses }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ActivateAdHocVotingRequest Properties

The ConferenceApiHandlerActivateAdHocVotingRequest type exposes the following members.

Properties
 | Name | Description
Public property | Description | Voting description for the ad-hoc voting
Public property | Number | Voting number for the ad-hoc voting
Public property | Subject | Voting subject for the ad-hoc voting
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileLogTraceListener.WriteFooter Method

WriteFooter Method

Write the footer of the trace message which consists of several configured trace options
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.DetermineTotalVoteResultVisiblityForUser Method

DetermineTotalVoteResultVisiblityForUser Method

Determine total vote results visibility for user
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RequestSpeechRequest.SeatIds Property

SeatIds Property

List of seat identifiers.
Syntax
Json
{ Property:SeatIds }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConnectionState.eventWhiteList Field

eventWhiteList Field

Syntax
Json
{ Field:eventWhiteList }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetPluginCommandsRequest Constructor

ConferenceApiHandlerGetPluginCommandsRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetPluginCommandsRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ImageManagement Methods

The ImageManagement type exposes the following members.

Methods
 | Name | Description
Public method | DeleteImage | Deletes an image from the server. Requires canEditSynoptic rights
Public method | ListImages | Gets a list of all the images uploaded to the server
Public method | SaveImage | Uploads an image to the server. Requires canEditSynoptic rights
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


MajorityResultInfo.ComparisonOperator Property

ComparisonOperator Property

Comparision operator used in majority expression.
Syntax
Json
{ Property:ComparisonOperator }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Certificate.AddCertificateExtensions Method (CertificateRequest, CertificatePurpose)

AddCertificateExtensions Method (CertificateRequest, CertificatePurpose)

 Bosch Logo
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


InterpretationLanguage Class

Represents interpretation language
Inheritance Hierarchy
SystemObject
SynopticControl.CommonInterpretationLanguage
Syntax
Json
{ JsonClass:InterpretationLanguage		Abbreviation:<type>,
    Index:<type>,
    Label:<type>,
    LanguageId:<type>,
 }

The InterpretationLanguage type exposes the following members.

Constructors
 | Name | Description
Public method | InterpretationLanguage | Initializes a new instance of the InterpretationLanguage class.
Top
Properties
 | Name | Description
Public property | Abbreviation | Gets or sets the language abbreviation.
Public property | Index | Gets or sets the index of the language.
Public property | Label | Gets or sets the language label.
Public property | LanguageId | Gets or sets the language identifier.
Top
Methods
 | Name | Description
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.IsInInterpretationLanguageList Method

IsInInterpretationLanguageList Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiMethodCaller(Response, Request) Class

ConferenceApiMethodCallerResponse, Request Class

Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiMethodCallerResponse, Request
Syntax
Json
{ JsonClass:ConferenceApiMethodCaller		LoginRequired:<type>,
 }

Type Parameters

Response
Request

The ConferenceApiMethodCallerResponse, Request type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiMethodCallerResponse, Request | Initializes a new instance of the ConferenceApiMethodCallerResponse, Request class
Top
Properties
 | Name | Description
Public property | LoginRequired |
Top
Methods
 | Name | Description
Public method | Call |
Public method | Initialize |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.IssueInterpreterMetaFunctionRequest Constructor

ConferenceApiHandlerIssueInterpreterMetaFunctionRequest Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerIssueInterpreterMetaFunctionRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.UpdateMeetingDeskConfigurations Method

UpdateMeetingDeskConfigurations Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


GetAgendaTopicsRequest Properties

The ConferenceApiHandlerGetAgendaTopicsRequest type exposes the following members.

Properties
 | Name | Description
Public property | MeetingId | The meeting identifier.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Meeting.DefaultDiscussionId Property

DefaultDiscussionId Property

Syntax
Json
{ Property:DefaultDiscussionId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiController.ConferenceMessage Constructor

ConferenceApiControllerConferenceMessage Constructor

Initializes a new instance of the ConferenceApiControllerConferenceMessage class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpreterDeskInfo Constructor

Initializes a new instance of the InterpreterDeskInfo class.
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnRespondersListChanged Method

OnRespondersListChanged Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetMicrophoneSensitivityDescriptionRequest Constructor

ConferenceApiHandlerGetMicrophoneSensitivityDescriptionRequest Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerGetMicrophoneSensitivityDescriptionRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UpdateFileRequest.FileId Property

FileId Property

File identifier. Unique identification of the file
Syntax
Json
{ Property:FileId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.IndividualVotingResults Property

IndividualVotingResults Property

Stores voting results of participants
Syntax
Json
{ Property:IndividualVotingResults }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Voting.UsePresentButton Property

UsePresentButton Property

If this flag is true then present button will be enabled for voting round.
Syntax
Json
{ Property:UsePresentButton }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetParticipantAccessDeniedReasonsRequest Class

ConferenceApiHandlerGetParticipantAccessDeniedReasonsRequest Class

 Bosch Logo
Represents the get participant access denied reasons request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetParticipantAccessDeniedReasonsRequest
Syntax
Json
{ JsonClass:GetParticipantAccessDeniedReasonsRequest	 }

The ConferenceApiHandlerGetParticipantAccessDeniedReasonsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetParticipantAccessDeniedReasonsRequest | Initializes a new instance of the ConferenceApiHandlerGetParticipantAccessDeniedReasonsRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ActivatePresentationRequest Class

ConferenceApiHandlerActivatePresentationRequest Class

Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerActivatePresentationRequest
Syntax
Json
{ JsonClass:ActivatePresentationRequest	 }

The ConferenceApiHandlerActivatePresentationRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerActivatePresentationRequest | Initializes a new instance of the ConferenceApiHandlerActivatePresentationRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetPluginCommandResultRequest Class

ConferenceApiHandlerSetPluginCommandResultRequest Class

Represents the request for SetPluginCommandResult
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerSetPluginCommandResultRequest
Syntax
Json
{ JsonClass:SetPluginCommandResultRequest		CorrelationId:<type>,
    Result:<type>,
 }

The ConferenceApiHandlerSetPluginCommandResultRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetPluginCommandResultRequest | Initializes a new instance of the ConferenceApiHandlerSetPluginCommandResultRequest class
Top
Properties
 | Name | Description
Public property | CorrelationId | The correlation id
Public property | Result | The result of the command execution
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ResumeVotingResponse Constructor

ConferenceApiHandlerResumeVotingResponse Constructor

Initializes a new instance of the ConferenceApiHandlerResumeVotingResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Meeting.GetHashCode Method

GetHashCode Method

Serves as a default hash function.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


FileStore Constructor

Initializes the static fields of the FileStore class
Syntax
Json
{ Constructor:.cctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.DeactivateMicrophoneRequest.SeatId Property

SeatId Property

Note: This API is now obsolete.

The seat identifier.
Syntax
Json
{ Property:SeatId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RequestResponseResponse Constructor

ConferenceApiHandlerRequestResponseResponse Constructor

Initializes a new instance of the ConferenceApiHandlerRequestResponseResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpretationLanguage.Index Property

Index Property

Gets or sets the index of the language.
Syntax
Json
{ Property:Index }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UpdateFileRequest.Payload Property

Payload Property

The configuration of the layout. The format of the string is defined by the (AngularJs) application. The maximum length of the string is 65KBytes.
Syntax
Json
{ Property:Payload }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.GetLicenseInformation Method

GetLicenseInformation Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


QuorumResultInfo.IsEnabled Property

IsEnabled Property

Indicates whether quorum is enabled
Syntax
Json
{ Property:IsEnabled }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ParticipantSeatType Enumeration

Defines seat types
Syntax
Json
ParticipantSeatType:{
Local
Remote}
Members
Member name | Value | Description
Local | 0 |
Remote | 1 |
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetIndividualVotingResultsResponse Class

ConferenceApiHandlerGetIndividualVotingResultsResponse Class

Represents the get individual voting result response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetIndividualVotingResultsResponse
Syntax
Json
{ JsonClass:GetIndividualVotingResultsResponse		VotingResults:<type>,
 }

The ConferenceApiHandlerGetIndividualVotingResultsResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetIndividualVotingResultsResponse | Initializes a new instance of the ConferenceApiHandlerGetIndividualVotingResultsResponse class
Top
Properties
 | Name | Description
Public property | VotingResults | List of individual voting results
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetPresentationStateResponse Class

ConferenceApiHandlerGetPresentationStateResponse Class

Represents the get presentation state response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetPresentationStateResponse
Syntax
Json
{ JsonClass:GetPresentationStateResponse		IsPresentationEnabled:<type>,
 }

The ConferenceApiHandlerGetPresentationStateResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetPresentationStateResponse | Initializes a new instance of the ConferenceApiHandlerGetPresentationStateResponse class
Top
Properties
 | Name | Description
Public property | IsPresentationEnabled | Gets or sets the presentation state.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetNotesFileListResponse Class

ConferenceApiHandlerGetNotesFileListResponse Class

Represents the meeting voting notes file list response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetNotesFileListResponse
Syntax
Json
{ JsonClass:GetNotesFileListResponse		FileData:<type>,
 }

The ConferenceApiHandlerGetNotesFileListResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetNotesFileListResponse | Initializes a new instance of the ConferenceApiHandlerGetNotesFileListResponse class
Top
Properties
 | Name | Description
Public property | FileData | Holds the list of xml file list entries.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetMasterVolumeResponse.Volume Property

Volume Property

Gets or sets the volume.
Syntax
Json
{ Property:Volume }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UpdateFileResponse Class

ConferenceApiHandlerUpdateFileResponse Class

Represents the save file response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerUpdateFileResponse
Syntax
Json
{ JsonClass:UpdateFileResponse	 }

The ConferenceApiHandlerUpdateFileResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerUpdateFileResponse | Initializes a new instance of the ConferenceApiHandlerUpdateFileResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.SynopticUri Property

SynopticUri Property

Gets and sets the synoptic uri
Syntax
Json
{ Property:SynopticUri }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DocumentVerificationResponse.IsDocumentSigned Property

IsDocumentSigned Property

Indicates if file contains digital signature.
Syntax
Json
{ Property:IsDocumentSigned }
Remarks
Files with size exceeding 50 MB are not signed, hence this property returns 'false' for such files.
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.OpenAgendaRequest Class

ConferenceApiHandlerOpenAgendaRequest Class

Represents the open agenda topic request.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerOpenAgendaRequest
Syntax
Json
{ JsonClass:OpenAgendaRequest		AgendaTopicId:<type>,
 }

The ConferenceApiHandlerOpenAgendaRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerOpenAgendaRequest | Initializes a new instance of the ConferenceApiHandlerOpenAgendaRequest class
Top
Properties
 | Name | Description
Public property | AgendaTopicId | The agenda identifier.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpretationLanguage Constructor

Initializes a new instance of the InterpretationLanguage class.
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AccessRights Class

Inheritance Hierarchy
SystemObject
SynopticControl.CommonAccessRights
Syntax
Json
{ JsonClass:AccessRights		ActivateMeeting:<type>,
    AssignAccessRights:<type>,
    ConfigureSystem:<type>,
    PrepareMeetingAndAgenda:<type>,
 }

The AccessRights type exposes the following members.

Constructors
 | Name | Description
Public method | AccessRights | Initializes a new instance of the AccessRights class
Top
Properties
 | Name | Description
Public property | ActivateMeeting |
Public property | AssignAccessRights |
Public property | ConfigureSystem |
Public property | PrepareMeetingAndAgenda |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetPluginCommandResultResponse Class

ConferenceApiHandlerSetPluginCommandResultResponse Class

Represents the response of SetPluginCommandResult
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerSetPluginCommandResultResponse
Syntax
Json
{ JsonClass:SetPluginCommandResultResponse	 }

The ConferenceApiHandlerSetPluginCommandResultResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetPluginCommandResultResponse | Initializes a new instance of the ConferenceApiHandlerSetPluginCommandResultResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpreterDeskInfo.CLanguageId Property

CLanguageId Property

Gets or sets the C language identifier.
Syntax
Json
{ Property:CLanguageId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetMeetingsResponse Properties

The ConferenceApiHandlerGetMeetingsResponse type exposes the following members.

Properties
 | Name | Description
Public property | Meetings | List of meetings.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpreterBoothInfo.Clone Method

Clone Method

handles clone
Syntax
Json
Implements
ICloneableTClone
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetMeetingInfo Method

GetMeetingInfo Method

Gets the meeting information.
Syntax
Json
Request:

Copy
{
    "meetingId": <string>
}

Response:

Copy
{
    "meetingInfo":
    {
        "agendaList":
        [
            {
                "agendaTopicId": <string>,
                "description": <string>,
                "discussionId": <string>,
                "meetingId": <string>,
                "state": "opened"|"closed",
                "subject": <string>
            }
        ],
        "autoOpenOnActivate": <bool>,
        "autoStartAgendaOnOpen": <bool>,
        "defaultDiscussionId": <string>,
        "description": <string>,
        "documentationRef": <string>,
        "identificationMethod": "fixed"|"userName"|"selectFromList"|"qRCode"|"externalSystem"|"nFC"|"nFCKeptAtDevice",
        "isDefault": <bool>,
        "meetingEndDate": <dateTime>,
        "meetingId": <string>,
        "meetingStartDate": <dateTime>,
        "state": "activated"|"deactivated"|"opened"|"closed",
        "title": <string>,
        "verificationMethod": "none"|"confirmation"|"password"|"pINCode"|"externalSystem"
    }
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.DeletePreparedMeeting Method

DeletePreparedMeeting Method

Deletes prepared meeting info.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


PluginDescription Class

Describes a plugin
Inheritance Hierarchy
SystemObject
SynopticControl.CommonPluginDescription
Syntax
Json
{ JsonClass:PluginDescription		Commands:<type>,
    Events:<type>,
    Interface:<type>,
    Name:<type>,
 }

The PluginDescription type exposes the following members.

Constructors
 | Name | Description
Public method | PluginDescription | Initializes a new instance of the PluginDescription class
Top
Properties
 | Name | Description
Public property | Commands | All the methods supported by this plugin
Public property | Events | All the events that this plugin can generate
Public property | Interface | Identifies the interface exposed by the plugin
Public property | Name | Unique name of the plugin
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DiscussionListEntry.GetHashCode Method

GetHashCode Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ParticipantAccessDeniedReasons.AccessDeniedReasons Property

AccessDeniedReasons Property

Participant access denied reasons
Syntax
Json
{ Property:AccessDeniedReasons }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetPluginEventDataResponse.PluginEventsData Property

PluginEventsData Property

Collections of plugin events
Syntax
Json
{ Property:PluginEventsData }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.AddCreatedMeeting Method

AddCreatedMeeting Method

Adds created meeting to list of prepared meetings
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DcnmApi.UpdateRoomName Method

UpdateRoomName Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


SeatInfo.SetAttributesAndSeatType Method

SetAttributesAndSeatType Method

Sets the attributes for seats and the type
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


Participant.Country Property

Country Property

Gets the country.
Syntax
Json
{ Property:Country }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


MajorityResultInfo.ThresholdValue Property

ThresholdValue Property

Majority threshold value
Syntax
Json
{ Property:ThresholdValue }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


RootCertificateData Constructor

Initializes a new instance of the RootCertificateData class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ParticipantAccessDeniedReasons Constructor

Initializes a new instance of the ParticipantAccessDeniedReasons class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DocumentVerificationResponse.HasHashTag Property

HasHashTag Property

True if the file has hash tag in file (version before 3.6 files has hash tag).
Syntax
Json
{ Property:HasHashTag }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


VotingResult.votingAnswer Property

votingAnswer Property

Voting answer for the seat
Syntax
Json
{ Property:votingAnswer }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ApiLoginDetails.Api Property

Api Property

Syntax
Json
{ Property:Api }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateNotesListUpdated Method

UpdateNotesListUpdated Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


UnSubscribePluginEventRequest Properties

The ConferenceApiHandlerUnSubscribePluginEventRequest type exposes the following members.

Properties
 | Name | Description
Public property | EventName | Event name to unsubscribe from plugin
Public property | PluginName | The name of the Plugin
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


CertificateWrapper Methods

The CertificateWrapper type exposes the following members.

Methods
 | Name | Description
Public method | GetCertificate |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GrantSpeechRequest Class

ConferenceApiHandlerGrantSpeechRequest Class

Represents the grant of the speech by seats and participants request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGrantSpeechRequest
Syntax
Json
{ JsonClass:GrantSpeechRequest		ParticipantIds:<type>,
    SeatIds:<type>,
 }

The ConferenceApiHandlerGrantSpeechRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGrantSpeechRequest | Initializes a new instance of the ConferenceApiHandlerGrantSpeechRequest class
Top
Properties
 | Name | Description
Public property | ParticipantIds | List of particpant identifiers.
Public property | SeatIds | List of seat identifiers.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.CloseMeetingRequest Constructor

ConferenceApiHandlerCloseMeetingRequest Constructor

Initializes a new instance of the ConferenceApiHandlerCloseMeetingRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ListFilesResponse.FileInfoList Property

FileInfoList Property

List of file info
Syntax
Json
{ Property:FileInfoList }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ICertificateWrapper Interface

Syntax
Json
{ Interface:ICertificateWrapper }

The ICertificateWrapper type exposes the following members.

Methods
 | Name | Description
Public method | GetCertificate |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpreterDeskInfo.DeskType Property

DeskType Property

Gets the type of desk.
Syntax
Json
{ Property:DeskType }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DiscussionListEntry Properties

The DiscussionListEntry type exposes the following members.

Properties
 | Name | Description
Public property | ActiveImage | Indicates that participant picture is shown of the speaker.
Public property | ActiveVideo | Indicates that camera is pointed at the speaker.
Public property | IsFirst | Is first waiting speaker.
Public property | IsLastMinuteActivated | Indicates last minute activated state for the seat
Public property | MicrophoneState | Uses DiscussionListState to contains mic state
Public property | ParticipantId | Id of the partcipant
Public property | PersonInfoId | Id of the personinfo of the participant
Public property | RemainingSpeechDuration | Remaining speech duration of the speaker
Public property | ScreenLine | Seat name / participant name
Public property | SeatId | Id of the seat
Public property | ShowSpeechTimer | Indicates that speech time data is shown
Public property | SpeakerType | Uses EnumSpeakerType to contains speaker type
Public property | SpeechStartTime | Start time of the speech
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.RequestAttendanceInfo Method

RequestAttendanceInfo Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetDiscussionOptionsRequest Class

ConferenceApiHandlerGetDiscussionOptionsRequest Class

Represents the get discussion options request.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetDiscussionOptionsRequest
Syntax
Json
{ JsonClass:GetDiscussionOptionsRequest	 }

The ConferenceApiHandlerGetDiscussionOptionsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetDiscussionOptionsRequest | Initializes a new instance of the ConferenceApiHandlerGetDiscussionOptionsRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OpenAPI Method

OpenAPI Method

Opens API for use
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


Certificate.ImportCertificatesToLocalMachineStore Method

ImportCertificatesToLocalMachineStore Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UnRegisterPluginRequest Class

ConferenceApiHandlerUnRegisterPluginRequest Class

Unregister plugin request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerUnRegisterPluginRequest
Syntax
Json
{ JsonClass:UnRegisterPluginRequest		PluginName:<type>,
 }

The ConferenceApiHandlerUnRegisterPluginRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerUnRegisterPluginRequest | Initializes a new instance of the ConferenceApiHandlerUnRegisterPluginRequest class
Top
Properties
 | Name | Description
Public property | PluginName | The Plugin name to unregister
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.GetMeetings Method

GetMeetings Method

Get Meetings.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "meetings":
    [
        {
            "agendaList":
            [
                {
                    "agendaTopicId": <string>,
                    "description": <string>,
                    "discussionId": <string>,
                    "meetingId": <string>,
                    "state": "opened"|"closed",
                    "subject": <string>
                }
            ],
            "autoOpenOnActivate": <bool>,
            "autoStartAgendaOnOpen": <bool>,
            "defaultDiscussionId": <string>,
            "description": <string>,
            "documentationRef": <string>,
            "identificationMethod": "fixed"|"userName"|"selectFromList"|"qRCode"|"externalSystem"|"nFC"|"nFCKeptAtDevice",
            "isDefault": <bool>,
            "meetingEndDate": <dateTime>,
            "meetingId": <string>,
            "meetingStartDate": <dateTime>,
            "state": "activated"|"deactivated"|"opened"|"closed",
            "title": <string>,
            "verificationMethod": "none"|"confirmation"|"password"|"pINCode"|"externalSystem"
        }
    ]
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetDiscussionList Method

GetDiscussionList Method

Returns prepared discussion list to requested clients.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "discussionList":
    [
        {
            "activeImage": <bool>,
            "activeVideo": <bool>,
            "isFirst": <bool>,
            "isLastMinuteActivated": <bool>,
            "microphoneState": "off"|"on"|"mute",
            "participantId": <string>,
            "personInfoId": <string>,
            "remainingSpeechDuration": <int>,
            "screenLine": <string>,
            "seatId": <string>,
            "showSpeechTimer": <bool>,
            "speakerType": "isSpeaker"|"isPrioritySpeaker"|"isResponder"|"isImportant"|"isRequest"|"isResponseRequest",
            "speechStartTime": <int>
        }
    ],
    "referenceTime": <int>
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetRoomContactEmailRequest Constructor

ConferenceApiHandlerGetRoomContactEmailRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetRoomContactEmailRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


PluginCommandDescription Constructor

Initializes a new instance of the PluginCommandDescription class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Voting.State Property

State Property

Gets the state.
Syntax
Json
{ Property:State }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnImportantSpeakersListChanged Method

OnImportantSpeakersListChanged Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


FileLogTraceListener.TraceEvent Method (TraceEventCache, String, TraceEventType, Int32, String, Object[])

TraceEvent Method (TraceEventCache, String, TraceEventType, Int32, String, Object)

 Bosch Logo
Writes trace information, a formatted array of objects and event information to the listener specific output.
Syntax
Json
  Remarks
  Note  Note

            This method is not intended to be called directly by application code but by
            members of the Debug, Trace, and TraceSource
            classes to write trace data to output.

            The default implementation writes the values of the source, eventType
            and id parameters as a header. The args object array is converted
            to a string using the Format
            method, passing the format string
            and args array to format the string as the message portion of the trace.
            The eventCache data is written as a combination of header and footer,
            the nature of the output data being dependent on the value of the
            TraceOutputOptions property.

  See Also
Reference
TraceListener class
TextWriterTraceListener class
Debug class
Trace class


SeatInfo.CanPrio Property

CanPrio Property

Indicates seat proiority capability
Syntax
Json
{ Property:CanPrio }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetRoomContactEmailResponse Constructor

ConferenceApiHandlerGetRoomContactEmailResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetRoomContactEmailResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiController.SendEvent Method

SendEvent Method

Send an event message
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DcnmApi.CancelResponder Method

CancelResponder Method

Remove responder from responders list
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.DetermineVoteResultVisiblityForUser Method

DetermineVoteResultVisiblityForUser Method

Determine voting results visibility for user
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModelReader Constructor

Initializes a new instance of the ConferenceModelReader class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.GrantInterpretation Method

GrantInterpretation Method

Grants the interpretation.
Syntax
Json
Request:

Copy
{
    "microphoneState": "off"|"activeOnOutputA"|"activeOnOutputB"|"activeOnOutputC",
    "seatId": <string>
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiController.CreateDeserializerSettings Method

CreateDeserializerSettings Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


GetIlluminatedSeatResponse Properties

The ConferenceApiHandlerGetIlluminatedSeatResponse type exposes the following members.

Properties
 | Name | Description
Public property | SeatId | The seat identifier
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.AddSeatToSpeakersResponse Constructor

ConferenceApiHandlerAddSeatToSpeakersResponse Constructor

Initializes a new instance of the ConferenceApiHandlerAddSeatToSpeakersResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetInterpreterBoothsResponse Properties

The ConferenceApiHandlerGetInterpreterBoothsResponse type exposes the following members.

Properties
 | Name | Description
Public property | Booths | Gets or sets the interpreter booths.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SaveImageRequest.Name Property

Name Property

The name of the image
Syntax
Json
{ Property:Name }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.RequestMicrophoneInactive Method

RequestMicrophoneInactive Method

Request to deactivate the microphone of the participant with the specified id.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ListFilesRequest Properties

The ConferenceApiHandlerListFilesRequest type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Attributes is used to retrieve all files with matching file attributes Remarks Attributes indicate what contents of file represent and can contain list of values like 'Bosch.Synoptic.Layout', 'Bosch.Synoptic.Index'
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateSeatsConfigurationInfo Method

UpdateSeatsConfigurationInfo Method

Updates the seat configuration information
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetTotalVoteResult Method

GetTotalVoteResult Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DcnmApi.CloseMeeting Method

CloseMeeting Method

Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SpecialOperationType Enumeration

Defines the available VIP types within the system.
Syntax
Json
SpecialOperationType:{
none
buttonOperated
pttOperated}
Members
Member name | Value | Description
none | 0 | No Vip, regular participant
buttonOperated | 1 | VIP, Button operated
pttOperated | 2 | VIP, Push To Talk (PTT) operated
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiController.ConferenceMessage.messageId Property

messageId Property

Used to match requests with responses
Syntax
Json
{ Property:messageId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.PrepareDiscussList Method

PrepareDiscussList Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DeviceInfo.Version Property

Version Property

Syntax
Json
{ Property:Version }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RaiseBoothNotificationResponse Constructor

ConferenceApiHandlerRaiseBoothNotificationResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerRaiseBoothNotificationResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.CanViewVoting Property

CanViewVoting Property

Contains can view voting permissions
Syntax
Json
{ Property:CanViewVoting }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DiscussionListEntry Constructor

Overload List
 | Name | Description
Public method | DiscussionListEntry | Default constructor.
Public method | DiscussionListEntry(Guid, Guid, Guid, String, MicrophoneState, SpeakerType, Int32, Int32, Boolean, Boolean, Boolean) | Initializes a new instance of the DiscussionListEntry class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnVotingScriptForMeetingReceived Method

OnVotingScriptForMeetingReceived Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.CancelInterpreterMetaFunctionResponse Constructor

ConferenceApiHandlerCancelInterpreterMetaFunctionResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerCancelInterpreterMetaFunctionResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.SetWebClientDeviceCapabilities Method

SetWebClientDeviceCapabilities Method

Sets the web client device capabilities
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


GetDiscussionOptionsResponse Properties

The ConferenceApiHandlerGetDiscussionOptionsResponse type exposes the following members.

Properties
 | Name | Description
Public property | DiscussionMode | Holds the current discussion mode.
Public property | MaxRequests | Holds max requests for current discussion.
Public property | MaxResponses | Holds max responses for current discussion.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AuthenticateController Constructor

Initializes a new instance of the AuthenticateController class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetMeetingInfoResponse Constructor

ConferenceApiHandlerGetMeetingInfoResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetMeetingInfoResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ApiLoginDetails Constructor

Initializes a new instance of the ApiLoginDetails class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetMasterVolumeRequest Constructor

ConferenceApiHandlerSetMasterVolumeRequest Constructor

Initializes a new instance of the ConferenceApiHandlerSetMasterVolumeRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.NotifyInterpreterBoothInfoChangedOnClients Method

NotifyInterpreterBoothInfoChangedOnClients Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


GuiIdClass Class

Inheritance Hierarchy
SystemObject
SynopticControl.CommonGuiIdClass
Syntax
Json
{ JsonClass:GuiIdClass		Value:<type>,
 }

The GuiIdClass type exposes the following members.

Constructors
 | Name | Description
Protected method | GuiIdClass | Initializes a new instance of the GuiIdClass class
Protected method | GuiIdClass(Guid) | Initializes a new instance of the GuiIdClass class
Top
Properties
 | Name | Description
Public property | Value |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.AddPreparedVotings Method

AddPreparedVotings Method

Adds prepared votings for meeting
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


QuorumResultInfo.Status Property

Status Property

Quorum reached status
Syntax
Json
{ Property:Status }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetMicrophoneSensitivityRequest Properties

The ConferenceApiHandlerGetMicrophoneSensitivityRequest type exposes the following members.

Properties
 | Name | Description
Public property | SeatIds | List of seat ids to get sensitivity. It the list count is 0 then will retrieve all the seat microphone sensitivity in the system.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileInfoDetail.Title Property

Title Property

Title of the file
Syntax
Json
{ Property:Title }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetDiscussionListResponse Properties

The ConferenceApiHandlerGetDiscussionListResponse type exposes the following members.

Properties
 | Name | Description
Public property | DiscussionList | Holds the list of discussion list entries.
Public property | ReferenceTime | Holds the value of Environment.TickCount
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.GetParticipantsForMeeting Method

GetParticipantsForMeeting Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


PluginHandler.SetPluginCommandResult Method

SetPluginCommandResult Method

Syntax
Json
Request:

Copy
{
    "correlationId": <string>,
    "result": <string>
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.AcceptVotingResponse Constructor

ConferenceApiHandlerAcceptVotingResponse Constructor

Initializes a new instance of the ConferenceApiHandlerAcceptVotingResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateParticipantsReceived Method

UpdateParticipantsReceived Method

Updates the participants received.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


AgendaTopic.DiscussionId Property

DiscussionId Property

Gets the discussion identifier.
Syntax
Json
{ Property:DiscussionId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


CertificateWrapper Constructor

Initializes a new instance of the CertificateWrapper class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.RemoveResponse Method

RemoveResponse Method

Syntax
Json
Request:

Copy
{
    "participantIds": [<string>],
    "seatIds": [<string>]
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ActivateVotingRequest.VotingId Property

VotingId Property

The voting identifier
Syntax
Json
{ Property:VotingId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.CreateFileResponse Constructor

ConferenceApiHandlerCreateFileResponse Constructor

Initializes a new instance of the ConferenceApiHandlerCreateFileResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetMeetingInfoResponse Class

ConferenceApiHandlerGetMeetingInfoResponse Class

Represents the meeting info response.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetMeetingInfoResponse
Syntax
Json
{ JsonClass:GetMeetingInfoResponse		MeetingInfo:<type>,
 }

The ConferenceApiHandlerGetMeetingInfoResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetMeetingInfoResponse | Initializes a new instance of the ConferenceApiHandlerGetMeetingInfoResponse class
Top
Properties
 | Name | Description
Public property | MeetingInfo | Meeting info
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetVotingsRequest.MeetingId Property

MeetingId Property

The meeting identifier.
Syntax
Json
{ Property:MeetingId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateVotingScriptForMeetingReceived Method

UpdateVotingScriptForMeetingReceived Method

Updates the voting script for meeting received.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


CertificatePurpose Enumeration

Syntax
Json
CertificatePurpose:{
Identification
DocumentSigning}
Members
Member name | Value | Description
Identification | 0 |
DocumentSigning | 1 |
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SupportedHeadphoneTypes Properties

The SupportedHeadphoneTypes type exposes the following members.

Properties
 | Name | Description
Public property | HeadphoneDescription |
Public property | Id |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnActualSpeakerVideoChanged Method

OnActualSpeakerVideoChanged Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


PluginHandler.CancelWaitingCommands Method

CancelWaitingCommands Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.SetWebClientManageMeetingRights Method (DcnmSeatAssignmentInfo)

SetWebClientManageMeetingRights Method (DcnmSeatAssignmentInfo)

 Bosch Logo
Sets web client manage meeting rights
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ParticipantAccessDeniedReasons Properties

The ParticipantAccessDeniedReasons type exposes the following members.

Properties
 | Name | Description
Public property | AccessDeniedReasons | Participant access denied reasons
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AgendaTopic.Subject Property

Subject Property

Gets the subject.
Syntax
Json
{ Property:Subject }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ResetMicrophoneSensitivityRequest Constructor

ConferenceApiHandlerResetMicrophoneSensitivityRequest Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerResetMicrophoneSensitivityRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SeatInfo.Status Property

Status Property

Indicates if seat has active device
Syntax
Json
{ Property:Status }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AgendaTopic Class

This contains the details of the agenda
Inheritance Hierarchy
SystemObject
SynopticControl.CommonAgendaTopic
Syntax
Json
{ JsonClass:AgendaTopic		AgendaTopicId:<type>,
    Description:<type>,
    DiscussionId:<type>,
    MeetingId:<type>,
    State:<type>,
    Subject:<type>,
 }

The AgendaTopic type exposes the following members.

Constructors
 | Name | Description
Public method | AgendaTopic | Initializes a new instance of the AgendaTopic class.
Top
Properties
 | Name | Description
Public property | AgendaTopicId | Gets the agenda topic identifier.
Public property | Description | Gets the description.
Public property | DiscussionId | Gets the discussion identifier.
Public property | MeetingId | Gets the meeting identifier.
Public property | State | Gets the state of Agenda
Public property | Subject | Gets the subject.
Top
Methods
 | Name | Description
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileLogTraceListener.WriteLine Method (String)

WriteLine Method (String)

 Bosch Logo
Writes a message to the listener you create in the derived class, followed by a line terminator.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DeleteNotesFilesResponse Properties

The ConferenceApiHandlerDeleteNotesFilesResponse type exposes the following members.

Properties
 | Name | Description
Public property | Success |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SendPluginEventRequest Class

ConferenceApiHandlerSendPluginEventRequest Class

Request for get plugin by name
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerSendPluginEventRequest
Syntax
Json
{ JsonClass:SendPluginEventRequest		Event:<type>,
    Parameters:<type>,
    PluginName:<type>,
 }

The ConferenceApiHandlerSendPluginEventRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSendPluginEventRequest | Initializes a new instance of the ConferenceApiHandlerSendPluginEventRequest class
Top
Properties
 | Name | Description
Public property | Event | The name of the command.
Public property | Parameters | Parameters for command.
Public property | PluginName | The name of the Plugin
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetTopics Method

GetTopics Method

Gets the topics.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


Certificate.ExportCertificatePublicKey Method

ExportCertificatePublicKey Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetMeetingsResponse Class

ConferenceApiHandlerGetMeetingsResponse Class

Represents the meetings info response.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetMeetingsResponse
Syntax
Json
{ JsonClass:GetMeetingsResponse		Meetings:<type>,
 }

The ConferenceApiHandlerGetMeetingsResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetMeetingsResponse | Initializes a new instance of the ConferenceApiHandlerGetMeetingsResponse class
Top
Properties
 | Name | Description
Public property | Meetings | List of meetings.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ListImagesRequest Class

ConferenceApiHandlerListImagesRequest Class

Represents the list images request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerListImagesRequest
Syntax
Json
{ JsonClass:ListImagesRequest	 }

The ConferenceApiHandlerListImagesRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerListImagesRequest | Initializes a new instance of the ConferenceApiHandlerListImagesRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileLogTraceListener Properties

The FileLogTraceListener type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets the custom trace listener attributes defined in the application configuration file. (Inherited from TraceListener.)
Private property | CycleMode | Return configured cycle mode of the FileLogTraceListener
Public property | Filter | Gets or sets the trace filter for the trace listener. (Inherited from TraceListener.)
Public property | IndentLevel | Gets or sets the indent level. (Inherited from TraceListener.)
Public property | IndentSize | Gets or sets the number of spaces in an indent. (Inherited from TraceListener.)
Public property | IsThreadSafe | Gets a value indicating whether the trace listener is thread safe. (Inherited from TraceListener.)
Public property | Name | Gets or sets a name for this TraceListener. (Inherited from TraceListener.)
Protected property | NeedIndent | Gets or sets a value indicating whether to indent the output. (Inherited from TraceListener.)
Public property | TraceOutputOptions | Gets or sets the trace output options. (Inherited from TraceListener.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetVotingState Method

GetVotingState Method

Provides voting state.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "votingState": "closed"|"ready"|"opened"|"onHold"|"done"|"canceled"|"accepted"|"rejected"
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.SetIlluminateSeat Method

SetIlluminateSeat Method

Illuminates seat.
Syntax
Json
Request:

Copy
{
    "seatId": <string>,
    "setIlluminate": <bool>
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateMicrophoneSensitivityForCreatedSeat Method

UpdateMicrophoneSensitivityForCreatedSeat Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetVotingResultsResponse.VotingResults Property

VotingResults Property

List of voting results
Syntax
Json
{ Property:VotingResults }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.HasSpecialPermission Property

HasSpecialPermission Property

Contains special permission
Syntax
Json
{ Property:HasSpecialPermission }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateSpeechTimerOptions Method

UpdateSpeechTimerOptions Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DcnmApi.CancelSpeaker Method

CancelSpeaker Method

Remove speaker from waiting/speaker list
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DcnmApi.CancelInterpreterMetaFunction Method

CancelInterpreterMetaFunction Method

Syntax
Json
Request:

Copy
{
    "request": <string>,
    "seatId": <string>
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ApiClient Constructor

Initializes a new instance of the ApiClient class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.GetParticipationInfoList Method

GetParticipationInfoList Method

Get participants list for the given meetingId.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModelReader.IsInSpeakerList Method

IsInSpeakerList Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetSupportedHeadphonesResponse Class

ConferenceApiHandlerGetSupportedHeadphonesResponse Class

Represents the get supported headphones response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetSupportedHeadphonesResponse
Syntax
Json
{ JsonClass:GetSupportedHeadphonesResponse		SupportedHeadphones:<type>,
 }

The ConferenceApiHandlerGetSupportedHeadphonesResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetSupportedHeadphonesResponse | Initializes a new instance of the ConferenceApiHandlerGetSupportedHeadphonesResponse class
Top
Properties
 | Name | Description
Public property | SupportedHeadphones |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UnSubscribePluginEventResponse Constructor

ConferenceApiHandlerUnSubscribePluginEventResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerUnSubscribePluginEventResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetIndividualVotingResultsResponse.VotingResults Property

VotingResults Property

List of individual voting results
Syntax
Json
{ Property:VotingResults }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpretationMetaRequestType Enumeration

Syntax
Json
InterpretationMetaRequestType:{
SpeakSlow}
Members
Member name | Value | Description
SpeakSlow | 0 | Indicates meta request type speakslow
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetPresentationState Method

GetPresentationState Method

Gets the state of the presentation.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "isPresentationEnabled": <bool>
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


VoteMajorityInfo.IsEnabled Property

IsEnabled Property

Flag indicates whether majority is enabled for voting.
Syntax
Json
{ Property:IsEnabled }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileInfo.GetHashCode Method

GetHashCode Method

Override GetHashCode functuion in IEquatable
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetMeetingsResponse.Meetings Property

Meetings Property

List of meetings.
Syntax
Json
{ Property:Meetings }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetAgendaTopicsResponse Constructor

ConferenceApiHandlerGetAgendaTopicsResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetAgendaTopicsResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetSystemPowerModeResponse Class

ConferenceApiHandlerGetSystemPowerModeResponse Class

Response from GetSystemPowerModeResponse
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetSystemPowerModeResponse
Syntax
Json
{ JsonClass:GetSystemPowerModeResponse		PowerMode:<type>,
 }

The ConferenceApiHandlerGetSystemPowerModeResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetSystemPowerModeResponse | Initializes a new instance of the ConferenceApiHandlerGetSystemPowerModeResponse class
Top
Properties
 | Name | Description
Public property | PowerMode | Power mode
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UpdateMicrophoneSensitivityResponse Class

ConferenceApiHandlerUpdateMicrophoneSensitivityResponse Class

 Bosch Logo
Update microphone sensitivity response.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerUpdateMicrophoneSensitivityResponse
Syntax
Json
{ JsonClass:UpdateMicrophoneSensitivityResponse		Status:<type>,
 }

The ConferenceApiHandlerUpdateMicrophoneSensitivityResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerUpdateMicrophoneSensitivityResponse | Initializes a new instance of the ConferenceApiHandlerUpdateMicrophoneSensitivityResponse class
Top
Properties
 | Name | Description
Public property | Status | Status after sending request to update microphone sensitivity.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AgendaTopic Properties

The AgendaTopic type exposes the following members.

Properties
 | Name | Description
Public property | AgendaTopicId | Gets the agenda topic identifier.
Public property | Description | Gets the description.
Public property | DiscussionId | Gets the discussion identifier.
Public property | MeetingId | Gets the meeting identifier.
Public property | State | Gets the state of Agenda
Public property | Subject | Gets the subject.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetPluginRequest Class

ConferenceApiHandlerGetPluginRequest Class

Represents the get plugin request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetPluginRequest
Syntax
Json
{ JsonClass:GetPluginRequest		PluginName:<type>,
 }

The ConferenceApiHandlerGetPluginRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetPluginRequest | Initializes a new instance of the ConferenceApiHandlerGetPluginRequest class
Top
Properties
 | Name | Description
Public property | PluginName | The name of plugin.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConnectionTracker.Initialize Method

Initialize Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DeviceInfo.IsSelected Property

IsSelected Property

Syntax
Json
{ Property:IsSelected }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RemoveSpeechRequest Class

ConferenceApiHandlerRemoveSpeechRequest Class

Represents the removal of the speech by seats and participants request.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerRemoveSpeechRequest
Syntax
Json
{ JsonClass:RemoveSpeechRequest		ParticipantIds:<type>,
    SeatIds:<type>,
 }

The ConferenceApiHandlerRemoveSpeechRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerRemoveSpeechRequest | Initializes a new instance of the ConferenceApiHandlerRemoveSpeechRequest class
Top
Properties
 | Name | Description
Public property | ParticipantIds | List of particpant identifiers.
Public property | SeatIds | List of seat identifiers.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Participant.IsAuthenticated Property

IsAuthenticated Property

Gets a value indicating whether this instance is authenticated.
Syntax
Json
{ Property:IsAuthenticated }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpreterDeskInfo.Clone Method

Clone Method

handles clone
Syntax
Json
Implements
ICloneableTClone
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.NotifyVotingStateChangedOnClients Method

NotifyVotingStateChangedOnClients Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateSeatInfo Method

UpdateSeatInfo Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DcnmApi.OnSeatMicrophoneSensitivityUpdated Method

OnSeatMicrophoneSensitivityUpdated Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.DeactivateMeetingResponse Constructor

ConferenceApiHandlerDeactivateMeetingResponse Constructor

Initializes a new instance of the ConferenceApiHandlerDeactivateMeetingResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpretationRoutingInfo.Equals Method

Equals Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceUsers.UpdateUsersPermissions Method

UpdateUsersPermissions Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetRoomContactEmail Method

GetRoomContactEmail Method

Gets room contact email
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "roomContactEmail": <string>
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SendPluginEventRequest.PluginName Property

PluginName Property

The name of the Plugin
Syntax
Json
{ Property:PluginName }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.LoadFileResponse Constructor

ConferenceApiHandlerLoadFileResponse Constructor

Initializes a new instance of the ConferenceApiHandlerLoadFileResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UpdateMicrophoneSensitivityResponse.Status Property

Status Property

Status after sending request to update microphone sensitivity.
Syntax
Json
{ Property:Status }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.ClearLastMinuteFlags Method

ClearLastMinuteFlags Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


Voting Class

This contains the details of the Voting
Inheritance Hierarchy
SystemObject
SynopticControl.CommonVoting
Syntax
Json
{ JsonClass:Voting		Description:<type>,
    DocumentationLink:<type>,
    MajorityVariables:<type>,
    MeetingId:<type>,
    ReferenceNumber:<type>,
    State:<type>,
    Subject:<type>,
    UsePresentButton:<type>,
    UseVoteWeight:<type>,
    VoteMajorityInfo:<type>,
    VotingAnswers:<type>,
    VotingId:<type>,
    VotingTimeDuration:<type>,
    VotingTimerType:<type>,
 }

The Voting type exposes the following members.

Constructors
 | Name | Description
Public method | Voting | Initializes a new instance of the Voting class.
Top
Properties
 | Name | Description
Public property | Description | Gets the description.
Public property | DocumentationLink | Gets the documentation URL.
Public property | MajorityVariables | Gets the voting majority variables list.
Public property | MeetingId | Gets the meeting identifier.
Public property | ReferenceNumber | Gets the voting reference number.
Public property | State | Gets the state.
Public property | Subject | Gets the subject.
Public property | UsePresentButton | If this flag is true then present button will be enabled for voting round.
Public property | UseVoteWeight | Flag to set whether participant vote weight considered or not
Public property | VoteMajorityInfo | Gets the voting majority info.
Public property | VotingAnswers | Gets the voting answers.
Public property | VotingId | Gets the voting identifier.
Public property | VotingTimeDuration | Gets the duration of the voting time.
Public property | VotingTimerType | Gets the voting timer type info.
Top
Methods
 | Name | Description
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileInfo Methods

The FileInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Override Equals functuion in IEquatable (Overrides ValueTypeEquals(Object).)
Public method | Equals(FileInfo) | Function to comapare file info with other objects
Public method | GetHashCode | Override GetHashCode functuion in IEquatable (Overrides ValueTypeGetHashCode.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LoginResponse Properties

The ConferenceApiHandlerLoginResponse type exposes the following members.

Properties
 | Name | Description
Public property | LoggedIn | Loggeg in status
Public property | Token |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetVotingStateRequest Class

ConferenceApiHandlerGetVotingStateRequest Class

Represents the get voting state request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetVotingStateRequest
Syntax
Json
{ JsonClass:GetVotingStateRequest	 }

The ConferenceApiHandlerGetVotingStateRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetVotingStateRequest | Initializes a new instance of the ConferenceApiHandlerGetVotingStateRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetParticipantSeatsResponse Properties

The ConferenceApiHandlerGetParticipantSeatsResponse type exposes the following members.

Properties
 | Name | Description
Public property | ParticipantSeats | Participant Seats List.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DocumentVerificationResponse.IsTampered Property

IsTampered Property

True if the hash or signature check fails.
Syntax
Json
{ Property:IsTampered }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetInterpretationOutputPresetResponse Constructor

ConferenceApiHandlerSetInterpretationOutputPresetResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerSetInterpretationOutputPresetResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the ConferenceException class with serialized data.
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceUsers Class

Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceUsers
Syntax
Json
{ JsonClass:ConferenceUsers		Instance:<type>,
 }

The ConferenceUsers type exposes the following members.

Constructors
 | Name | Description
 | ConferenceUsers |
Public method | ConferenceUsers | Initializes a new instance of the ConferenceUsers class
Top
Properties
Name | Description
Instance |
Top
Methods
 | Name | Description
Protected method | AddUser | Add a user to the administration
Public method | Dispose | Releases all resources used by the ConferenceUsers
Protected method | GetUserPermission |
Protected method | Initialize |
Protected method | RemoveUser |
Protected method | UpdateUserPermission | Add user permissions to the user id
Protected method | UpdateUsersPermissions |
Protected method | UserHasPermission | Checks given user permissions
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnVotingCreated Method

OnVotingCreated Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ActivateMicrophoneResponse Class

ConferenceApiHandlerActivateMicrophoneResponse Class

Represents the activation of the microphone response.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerActivateMicrophoneResponse
Syntax
Json
{ JsonClass:ActivateMicrophoneResponse	 }

The ConferenceApiHandlerActivateMicrophoneResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerActivateMicrophoneResponse | Initializes a new instance of the ConferenceApiHandlerActivateMicrophoneResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.RequestParticipantsList Method

RequestParticipantsList Method

Request for participants list
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.MasterVolume Property

MasterVolume Property

Syntax
Json
{ Property:MasterVolume }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AuthenticateController Class

Contains methods that can be communicated to SignalR connections for login and logout
Inheritance Hierarchy
SystemObject
ApiController
SynopticControlAuthenticateController
Syntax
Json
{ JsonClass:AuthenticateController	 }

The AuthenticateController type exposes the following members.

Constructors
 | Name | Description
Public method | AuthenticateController | Initializes a new instance of the AuthenticateController class
Top
Methods
 | Name | Description
Public method | GetApiState | Gets Api connection state
Public method | LogOff | UnAuthenticates user
Public method | LogOn | Authenticates user
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnVotingUpdated Method

OnVotingUpdated Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


Meeting.Title Property

Title Property

Gets the title.
Syntax
Json
{ Property:Title }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.DeleteNotesFilesResponse Class

ConferenceApiHandlerDeleteNotesFilesResponse Class

Defines delete notes file response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerDeleteNotesFilesResponse
Syntax
Json
{ JsonClass:DeleteNotesFilesResponse		Success:<type>,
 }

The ConferenceApiHandlerDeleteNotesFilesResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerDeleteNotesFilesResponse | Initializes a new instance of the ConferenceApiHandlerDeleteNotesFilesResponse class
Top
Properties
 | Name | Description
Public property | Success |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Voting.Subject Property

Subject Property

Gets the subject.
Syntax
Json
{ Property:Subject }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.CheckNotesFileTamperedRequest Class

ConferenceApiHandlerCheckNotesFileTamperedRequest Class

Defines CheckNotesFileTampered request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerCheckNotesFileTamperedRequest
Syntax
Json
{ JsonClass:CheckNotesFileTamperedRequest		FileName:<type>,
 }

The ConferenceApiHandlerCheckNotesFileTamperedRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerCheckNotesFileTamperedRequest | Initializes a new instance of the ConferenceApiHandlerCheckNotesFileTamperedRequest class
Top
Properties
 | Name | Description
Public property | FileName | The name of the notes file to check
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RaiseBoothNotificationRequest.Notification Property

Notification Property

Syntax
Json
{ Property:Notification }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.LoginRequest.Token Property

Token Property

Syntax
Json
{ Property:Token }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


MicrophoneSensitivity.SeatName Property

SeatName Property

seat name.
Syntax
Json
{ Property:SeatName }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ICloneable(T) Methods

ICloneableT Methods

The ICloneableT generic type exposes the following members.

Methods
 | Name | Description
Public method | Clone | handles clone
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetMasterVolumeRangeResponse Class

ConferenceApiHandlerGetMasterVolumeRangeResponse Class

Represents the get master volume range response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetMasterVolumeRangeResponse
Syntax
Json
{ JsonClass:GetMasterVolumeRangeResponse		Range:<type>,
 }

The ConferenceApiHandlerGetMasterVolumeRangeResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetMasterVolumeRangeResponse | Initializes a new instance of the ConferenceApiHandlerGetMasterVolumeRangeResponse class
Top
Properties
 | Name | Description
Public property | Range | Gets or sets the master volume range.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateInterpreterSeatsInfo Method

UpdateInterpreterSeatsInfo Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


Voting.MeetingId Property

MeetingId Property

Gets the meeting identifier.
Syntax
Json
{ Property:MeetingId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetSeatsResponse Properties

The ConferenceApiHandlerGetSeatsResponse type exposes the following members.

Properties
 | Name | Description
Public property | Seats | List of seats
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ApiClient.Username Property

Username Property

Syntax
Json
{ Property:Username }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Certificate.GetSubjectAlternativeNameBuilder Method

GetSubjectAlternativeNameBuilder Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


InterpretationMetaRequestStatus.Equals Method

Equals Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DcnmApi.OnPresentationStateChanged Method

OnPresentationStateChanged Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceUsers Constructor

Initializes the static fields of the ConferenceUsers class
Syntax
Json
{ Constructor:.cctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpretationRoutingInfo Constructor

Initializes a new instance of the InterpretationRoutingInfo class.
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ParticipantSeats.AssignedSeatId Property

AssignedSeatId Property

Syntax
Json
{ Property:AssignedSeatId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Certificate.AddUsersReadPermissionsForCertificate Method (String)

AddUsersReadPermissionsForCertificate Method (String)

 Bosch Logo
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConnectionTracker.AddConnection Method

AddConnection Method

Adds a conference connection
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


Participant.VoteWeight Property

VoteWeight Property

Gets the vote weight.
Syntax
Json
{ Property:VoteWeight }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


MicrophoneSensitivityDescription.MicrophoneSensitivityStepSize Property

MicrophoneSensitivityStepSize Property

Microphone sensitivity step size.
Syntax
Json
{ Property:MicrophoneSensitivityStepSize }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ICloneable(T) Interface

ICloneableT Interface

Cloneable interface for deep copy list
Syntax
Json
{ Interface:ICloneable }

Type Parameters

T

The ICloneableT type exposes the following members.

Methods
 | Name | Description
Public method | Clone | handles clone
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SeatInfo Properties

The SeatInfo type exposes the following members.

Properties
 | Name | Description
Public property | AssignedParticipantId | Id of participant assigned to seat
Public property | Attributes | The list of seat attributes
Public property | CanPrio | Indicates seat proiority capability
Public property | CanVote | Indicates seat canvote capability
Public property | Devices | The list of assigned Devices.
Public property | FoundDevices | Devices found at seat
Public property | HasVotingLicense |
Public property | HideSeat | Indicates seat visibility
Public property | ScreenLine | Seat screen line
Public property | SeatedParticipantId | Id of participant logged in at seat
Public property | SeatId | Unique identifier for seat
Public property | SeatName | Seat name
Public property | SeatType | The participant seat type.
Public property | Status | Indicates if seat has active device
Public property | VisType | Seat Vis type
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Voting Constructor

Initializes a new instance of the Voting class.
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.ActivateMeeting Method

ActivateMeeting Method

Activate meeting request.
Syntax
Json
Request:

Copy
{
    "meetingId": <string>
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetMasterVolume Method

GetMasterVolume Method

Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "volume": <int>
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetIndividualParticipantCastVoteResults Method

GetIndividualParticipantCastVoteResults Method

Overload List
 | Name | Description
Public method | GetIndividualParticipantCastVoteResults | Get participant individual cast vote results
Private method | GetIndividualParticipantCastVoteResults(ReadOnlyCollectionIndividualVotingResult) |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetNotesFileListResponse Properties

The ConferenceApiHandlerGetNotesFileListResponse type exposes the following members.

Properties
 | Name | Description
Public property | FileData | Holds the list of xml file list entries.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetImageServerInfoRequest Class

ConferenceApiHandlerGetImageServerInfoRequest Class

Represents the get image server info request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetImageServerInfoRequest
Syntax
Json
{ JsonClass:GetImageServerInfoRequest	 }

The ConferenceApiHandlerGetImageServerInfoRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetImageServerInfoRequest | Initializes a new instance of the ConferenceApiHandlerGetImageServerInfoRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Participant.Email Property

Email Property

Syntax
Json
{ Property:Email }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceException Constructor (String, Exception)

Initializes a new instance of the ConferenceException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SendPluginEventRequest Properties

The ConferenceApiHandlerSendPluginEventRequest type exposes the following members.

Properties
 | Name | Description
Public property | Event | The name of the command.
Public property | Parameters | Parameters for command.
Public property | PluginName | The name of the Plugin
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SelectInterpretationFloorRequest Constructor

ConferenceApiHandlerSelectInterpretationFloorRequest Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerSelectInterpretationFloorRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RegisterPluginRequest.PluginEvents Property

PluginEvents Property

The events that this plugin can generate
Syntax
Json
{ Property:PluginEvents }
See Also

Reference

SynopticControl.CommonPluginEventDescription


ConferenceApiHandler.TransformNotesFileResponse Constructor

ConferenceApiHandlerTransformNotesFileResponse Constructor

Initializes a new instance of the ConferenceApiHandlerTransformNotesFileResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Voting.VotingAnswers Property

VotingAnswers Property

Gets the voting answers.
Syntax
Json
{ Property:VotingAnswers }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


BoothNotificationInfo.Notifications Property

Notifications Property

Gets of sets the list of notification messages.
Syntax
Json
{ Property:Notifications }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnParticipantAttendanceSummaryChanged Method

OnParticipantAttendanceSummaryChanged Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetInterpretationLanguagesResponse Constructor

ConferenceApiHandlerGetInterpretationLanguagesResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerGetInterpretationLanguagesResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Participant.Title Property

Title Property

Gets the title.
Syntax
Json
{ Property:Title }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetIlluminateSeatRequest Constructor

ConferenceApiHandlerSetIlluminateSeatRequest Constructor

Initializes a new instance of the ConferenceApiHandlerSetIlluminateSeatRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.HasMeetingPreparationAndManagementLicense Property

HasMeetingPreparationAndManagementLicense Property

Syntax
Json
{ Property:HasMeetingPreparationAndManagementLicense }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GuidConverter Properties

The GuidConverter type exposes the following members.

Properties
 | Name | Description
Public property | CanRead | Gets a value indicating whether this JsonConverter can read JSON. (Inherited from JsonConverter.)
Public property | CanWrite | Gets a value indicating whether this JsonConverter can write JSON. (Inherited from JsonConverter.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.LoginResponse.LoggedIn Property

LoggedIn Property

Loggeg in status
Syntax
Json
{ Property:LoggedIn }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ListFilesRequest Class

ConferenceApiHandlerListFilesRequest Class

Represents the file request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerListFilesRequest
Syntax
Json
{ JsonClass:ListFilesRequest		Attributes:<type>,
 }

The ConferenceApiHandlerListFilesRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerListFilesRequest | Initializes a new instance of the ConferenceApiHandlerListFilesRequest class
Top
Properties
 | Name | Description
Public property | Attributes | Attributes is used to retrieve all files with matching file attributes Remarks Attributes indicate what contents of file represent and can contain list of values like 'Bosch.Synoptic.Layout', 'Bosch.Synoptic.Index'
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


EnableSeatIlluminationRequest Properties

The ConferenceApiHandlerEnableSeatIlluminationRequest type exposes the following members.

Properties
 | Name | Description
Public property | Enable | Enable
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.SetWebClientManageMeetingRights Method

SetWebClientManageMeetingRights Method

Overload List
 | Name | Description
Protected method | SetWebClientManageMeetingRights | Set can manage meeting rights to web client.
 | SetWebClientManageMeetingRights(DcnmSeatAssignmentInfo) | Sets web client manage meeting rights
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetImageServerInfoResponse.Uri Property

Uri Property

The uri of the image server
Syntax
Json
{ Property:Uri }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateSpeechTimeOptions Method

UpdateSpeechTimeOptions Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetVotingResultsResponse Constructor

ConferenceApiHandlerGetVotingResultsResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetVotingResultsResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SelectInterpretationFloorRequest.SeatId Property

SeatId Property

Syntax
Json
{ Property:SeatId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetSeatsResponse Constructor

ConferenceApiHandlerGetSeatsResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetSeatsResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Vote Constructor

Initializes a new instance of the Vote class.
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.ProcessApiOpenResponse Method

ProcessApiOpenResponse Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DocumentVerificationResponse Properties

The DocumentVerificationResponse type exposes the following members.

Properties
 | Name | Description
Public property | HasHashTag | True if the file has hash tag in file (version before 3.6 files has hash tag).
Public property | IsAuthenticatedUsingCertificate | True if the signature failed to authenticate with root certificate on the system.
Public property | IsDocumentSigned | Indicates if file contains digital signature.
Public property | IsTampered | True if the hash or signature check fails.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.NotifyMajorityResultChangedOnClients Method

NotifyMajorityResultChangedOnClients Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


PluginHandler.UnRegisterPlugin Method

UnRegisterPlugin Method

Syntax
Json
Request:

Copy
{
    "pluginName": <string>
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Startup Methods

The Startup type exposes the following members.

Methods
 | Name | Description
Public method | Configuration | configures Web API. The Startup class is specified as a type parameter in the WebApp.Start method.
Public method | Stop |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.GetDeskType Method

GetDeskType Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateDefaultVotingSettings Method

UpdateDefaultVotingSettings Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.CloseMeetingRequest Class

ConferenceApiHandlerCloseMeetingRequest Class

Represents the close meeting info request.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerCloseMeetingRequest
Syntax
Json
{ JsonClass:CloseMeetingRequest	 }

The ConferenceApiHandlerCloseMeetingRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerCloseMeetingRequest | Initializes a new instance of the ConferenceApiHandlerCloseMeetingRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Vote.Answer Property

Answer Property

Gets the voting answer.
Syntax
Json
{ Property:Answer }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SelectInterpretationInputLanguageRequest.SeatId Property

SeatId Property

Syntax
Json
{ Property:SeatId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpretationQualityType Enumeration

This is for holding the quality type of
Syntax
Json
InterpretationQualityType:{
Floor
Plus
Minus
MinusMinus
Unknown}
Members
Member name | Value | Description
Floor | 0 | Floor copy done for the language
Plus | 1 | Interpreted by listening to the floor (direct interpretation)
Minus | 2 | Interpreted by listening to an interpreter (indirect interpretation)
MinusMinus | 3 | Interpreted by listening to a chain of interpreters (multi interpretation)
Unknown | 4 | Interpreted by listening to an interpreter with an unknown quality (external sources without quality indication)
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.LoadFileResponse.FileInfo Property

FileInfo Property

File info
Syntax
Json
{ Property:FileInfo }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnSpeakersListChanged Method

OnSpeakersListChanged Method

On change of speakerlist
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SelectInterpretationFloorResponse Class

ConferenceApiHandlerSelectInterpretationFloorResponse Class

Represents the select floor response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerSelectInterpretationFloorResponse
Syntax
Json
{ JsonClass:SelectInterpretationFloorResponse	 }

The ConferenceApiHandlerSelectInterpretationFloorResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSelectInterpretationFloorResponse | Initializes a new instance of the ConferenceApiHandlerSelectInterpretationFloorResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GrantSpeech Method (Guid)

GrantSpeech Method (Guid)

 Bosch Logo
Syntax
Json
Request:

Copy
{
    "participantIds": [<string>],
    "seatIds": [<string>]
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RemoveSeatFromDiscussionListResponse Class

ConferenceApiHandlerRemoveSeatFromDiscussionListResponse Class

 Bosch Logo
Represents the removal of seat from discussion list response.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerRemoveSeatFromDiscussionListResponse
Syntax
Json
{ JsonClass:RemoveSeatFromDiscussionListResponse	 }

The ConferenceApiHandlerRemoveSeatFromDiscussionListResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerRemoveSeatFromDiscussionListResponse | Initializes a new instance of the ConferenceApiHandlerRemoveSeatFromDiscussionListResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RequestSpeechRequest Constructor

ConferenceApiHandlerRequestSpeechRequest Constructor

Initializes a new instance of the ConferenceApiHandlerRequestSpeechRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileLogTraceListener.Write Method (String)

Write Method (String)

 Bosch Logo
Writes the specified message to the listener you create in the derived class.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetNotesFileListRequest Constructor

ConferenceApiHandlerGetNotesFileListRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetNotesFileListRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetNotesFileListRequest.SearchDateRange Property

SearchDateRange Property

The file search criteria of type NotesFileSearchCriteria
Syntax
Json
{ Property:SearchDateRange }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Vote Properties

The Vote type exposes the following members.

Properties
 | Name | Description
Public property | Answer | Gets the voting answer.
Public property | Count | Gets the count.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


CancelInterpreterMetaFunctionRequest Properties

The ConferenceApiHandlerCancelInterpreterMetaFunctionRequest type exposes the following members.

Properties
 | Name | Description
Public property | Request |
Public property | SeatId |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetDiscussionListRequest Class

ConferenceApiHandlerGetDiscussionListRequest Class

Represents the get discussion list request.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetDiscussionListRequest
Syntax
Json
{ JsonClass:GetDiscussionListRequest	 }

The ConferenceApiHandlerGetDiscussionListRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetDiscussionListRequest | Initializes a new instance of the ConferenceApiHandlerGetDiscussionListRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel Fields

The ConferenceModel type exposes the following members.

Fields
 | Name | Description
Protected field | _webClient | Web clinet name when connected as device
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ActivateMicrophoneRequest.ParticipantIds Property

ParticipantIds Property

List of participant identifiers.
Syntax
Json
{ Property:ParticipantIds }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetPluginCommandResultResponse Constructor

ConferenceApiHandlerSetPluginCommandResultResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerSetPluginCommandResultResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel._webClient Field

_webClient Field

Web clinet name when connected as device
Syntax
Json
{ Field:_webClient }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ResumeVotingRequest Class

ConferenceApiHandlerResumeVotingRequest Class

Represents the resume voting info request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerResumeVotingRequest
Syntax
Json
{ JsonClass:ResumeVotingRequest	 }

The ConferenceApiHandlerResumeVotingRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerResumeVotingRequest | Initializes a new instance of the ConferenceApiHandlerResumeVotingRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.SubscribePluginEvent Method

SubscribePluginEvent Method

Syntax
Json
Request:

Copy
{
    "eventName": <string>,
    "pluginName": <string>
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetVotingsResponse.VotingList Property

VotingList Property

List of voting
Syntax
Json
{ Property:VotingList }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetPluginResponse Properties

The ConferenceApiHandlerGetPluginResponse type exposes the following members.

Properties
 | Name | Description
Public property | PluginDescriptionResponse | Plugin description
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnEquipmentPowerStateChanged Method

OnEquipmentPowerStateChanged Method

Handles system power state changed
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


LogOnModel.name Property

name Property

Login user name
Syntax
Json
{ Property:name }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


QuorumResultInfo.NumeratorValue Property

NumeratorValue Property

Quorum numerator value
Syntax
Json
{ Property:NumeratorValue }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.DeactivateMicrophone Method

DeactivateMicrophone Method

Syntax
Json
Request:

Copy
{
    "participantIds": [<string>],
    "seatId": <string>,
    "seatIds": [<string>]
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AccessDeniedReason Enumeration

Represents various access denied reasons
Syntax
Json
AccessDeniedReason:{
noReason
invalidUserCredentials
notParticipantToMeeting
incorrectSeat
grantFailure
insufficientLicense}
Members
Member name | Value | Description
noReason | 0 | No reason
invalidUserCredentials | 1 | Invalid user credential
notParticipantToMeeting | 2 | Not a participant for the meeting
incorrectSeat | 3 | Incorrect seat
grantFailure | 4 | Grant failure
insufficientLicense | 5 | Insufficient license
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Voting Methods

The Voting type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


IConferenceApiMethodCaller.Call Method

Call Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.CancelInterpreterMetaFunctionRequest Constructor

ConferenceApiHandlerCancelInterpreterMetaFunctionRequest Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerCancelInterpreterMetaFunctionRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


RootCertificateData Class

Inheritance Hierarchy
SystemObject
Bosch.SecurityRootCertificateData
Syntax
Json
{ JsonClass:RootCertificateData		PrivatePfxData:<type>,
    PublicCrtData:<type>,
 }

The RootCertificateData type exposes the following members.

Constructors
 | Name | Description
Public method | RootCertificateData | Initializes a new instance of the RootCertificateData class
Top
Properties
 | Name | Description
Public property | PrivatePfxData |
Public property | PublicCrtData |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.LoadFileResponse Class

ConferenceApiHandlerLoadFileResponse Class

Represents the open file response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerLoadFileResponse
Syntax
Json
{ JsonClass:LoadFileResponse		FileInfo:<type>,
 }

The ConferenceApiHandlerLoadFileResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerLoadFileResponse | Initializes a new instance of the ConferenceApiHandlerLoadFileResponse class
Top
Properties
 | Name | Description
Public property | FileInfo | File info
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


PluginHandler.ConnectionIdAndPluginInstance.ConnectionId Property

ConnectionId Property

Syntax
Json
{ Property:ConnectionId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SaveImageResponse.SaveImageUri Property

SaveImageUri Property

The uri of the saved image.
Syntax
Json
{ Property:SaveImageUri }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SelectInterpretationInputLanguageRequest.LanguageId Property

LanguageId Property

Syntax
Json
{ Property:LanguageId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LoadFileResponse Properties

The ConferenceApiHandlerLoadFileResponse type exposes the following members.

Properties
 | Name | Description
Public property | FileInfo | File info
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetPresentationStateRequest Constructor

ConferenceApiHandlerGetPresentationStateRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetPresentationStateRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ListFilesResponse Constructor

ConferenceApiHandlerListFilesResponse Constructor

Initializes a new instance of the ConferenceApiHandlerListFilesResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AwaiterInfo Properties

The PluginHandlerAwaiterInfo type exposes the following members.

Properties
 | Name | Description
Public property | Awaiter |
Public property | PluginName |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.CheckNotesFileTamperedRequest Constructor

ConferenceApiHandlerCheckNotesFileTamperedRequest Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerCheckNotesFileTamperedRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetDiscussionOptionsResponse.DiscussionMode Property

DiscussionMode Property

Holds the current discussion mode.
Syntax
Json
{ Property:DiscussionMode }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.LoginRequest Constructor

ConferenceApiHandlerLoginRequest Constructor

Initializes a new instance of the ConferenceApiHandlerLoginRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpreterBoothInfo Constructor

Overload List
 | Name | Description
Public method | InterpreterBoothInfo | Initializes a new instance of the InterpreterBoothInfo class.
Public method | InterpreterBoothInfo(Guid, Int32, Boolean) | Initializes a new instance of the InterpreterBoothInfo class.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetPresentationStateResponse.IsPresentationEnabled Property

IsPresentationEnabled Property

Gets or sets the presentation state.
Syntax
Json
{ Property:IsPresentationEnabled }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpretationLanguage Methods

The InterpretationLanguage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AccessRights.PrepareMeetingAndAgenda Property

PrepareMeetingAndAgenda Property

Syntax
Json
{ Property:PrepareMeetingAndAgenda }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DiscussionListEntry.IsFirst Property

IsFirst Property

Is first waiting speaker.
Syntax
Json
{ Property:IsFirst }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.SetSystemPowerMode Method

SetSystemPowerMode Method

Sets the system power mode to power on
Syntax
Json
Request:

Copy
{
    "powerMode": "poweredOn"|"poweredOff"|"poweringOn"|"poweringOff"
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


MicrophoneSensitivity.Equals Method

Equals Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


QuorumResultInfo.DenominatorValue Property

DenominatorValue Property

Quorum denominator value
Syntax
Json
{ Property:DenominatorValue }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateRequestsList Method

UpdateRequestsList Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.InterpretationRoutingInfos Property

InterpretationRoutingInfos Property

Syntax
Json
{ Property:InterpretationRoutingInfos }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Participant.Region Property

Region Property

Gets the region.
Syntax
Json
{ Property:Region }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GrantSpeechRequest Constructor

ConferenceApiHandlerGrantSpeechRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGrantSpeechRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


QuorumResultInfo.Equality Operator

Equality Operator

Function to comapare two QuorumResultInfo objects are equal
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.NotifyDiscussListChangeOnClients Method

NotifyDiscussListChangeOnClients Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.TransformNotesFileResponse.NotesHtml Property

NotesHtml Property

The transformed notes as html string
Syntax
Json
{ Property:NotesHtml }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateRequestToResponseOptions Method

UpdateRequestToResponseOptions Method

Updates request to response options
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateEmptySeatsCreatedInfo Method

UpdateEmptySeatsCreatedInfo Method

Updates the created empty seat information
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RejectVotingRequest Constructor

ConferenceApiHandlerRejectVotingRequest Constructor

Initializes a new instance of the ConferenceApiHandlerRejectVotingRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AssemblyRedirect Constructor

Initializes a new instance of the AssemblyRedirect class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetMicrophoneSensitivityResponse Class

ConferenceApiHandlerGetMicrophoneSensitivityResponse Class

Get microphone sensitivity response.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetMicrophoneSensitivityResponse
Syntax
Json
{ JsonClass:GetMicrophoneSensitivityResponse		SeatMicrophoneSensitivities:<type>,
 }

The ConferenceApiHandlerGetMicrophoneSensitivityResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetMicrophoneSensitivityResponse | Initializes a new instance of the ConferenceApiHandlerGetMicrophoneSensitivityResponse class
Top
Properties
 | Name | Description
Public property | SeatMicrophoneSensitivities | List of seat ids with sensitivity value MicrophoneSensitivity.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


PluginHandler.AwaiterInfo.PluginName Property

PluginName Property

Syntax
Json
{ Property:PluginName }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileLogTraceListener.TraceEvent Method

TraceEvent Method

Writes trace and event information to the listener specific output. (Inherited from TraceListener.)
Overload List
 | Name | Description
Public method | TraceEvent(TraceEventCache, String, TraceEventType, Int32) | Writes trace and event information to the listener specific output. (Inherited from TraceListener.)
Public method | TraceEvent(TraceEventCache, String, TraceEventType, Int32, String) | Writes trace information, a message, and event information to the listener specific output. (Overrides TraceListenerTraceEvent(TraceEventCache, String, TraceEventType, Int32, String).)
Public method | TraceEvent(TraceEventCache, String, TraceEventType, Int32, String, Object) | Writes trace information, a formatted array of objects and event information to the listener specific output. (Overrides TraceListenerTraceEvent(TraceEventCache, String, TraceEventType, Int32, String, Object).)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.IsInInterpretationSeatList Method

IsInInterpretationSeatList Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DeviceInfo.Name Property

Name Property

Syntax
Json
{ Property:Name }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


CreateCertificateRequest.Purpose Property

Purpose Property

Syntax
Json
{ Property:Purpose }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UpdateMicrophoneSensitivityResponse Constructor

ConferenceApiHandlerUpdateMicrophoneSensitivityResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerUpdateMicrophoneSensitivityResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Vote.Count Property

Count Property

Gets the count.
Syntax
Json
{ Property:Count }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Certificate.GetCertificateFromLocalMachine Method

GetCertificateFromLocalMachine Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


NotesFileInfo.FileName Property

FileName Property

Name of the xml file.
Syntax
Json
{ Property:FileName }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetVotingStateResponse Constructor

ConferenceApiHandlerGetVotingStateResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetVotingStateResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.MaxResponses Property

MaxResponses Property

Contains max responses for current discussion.
Syntax
Json
{ Property:MaxResponses }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Voting.VotingTimerType Property

VotingTimerType Property

Gets the voting timer type info.
Syntax
Json
{ Property:VotingTimerType }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnSeatsCreated Method

OnSeatsCreated Method

Handles seats that are created.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


PluginCommandDescription.Name Property

Name Property

Name of the command
Syntax
Json
{ Property:Name }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnApplicationModeStateChanged Method

OnApplicationModeStateChanged Method

Updates application mode
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


MicrophoneSensitivityDescription Constructor

Initializes a new instance of the MicrophoneSensitivityDescription class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetSeatVotingResults Method

GetSeatVotingResults Method

Get seat voting results
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "votingResults":
    [
        {
            "seatId": <string>,
            "votingAnswer": "notVoted"|"yes"|"no"|"abstain"|"dnpv"|"for"|"against"|"present"|"voteCasted"|"A"|"B"|"C"|"D"
        }
    ]
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.GetSeatInfo Method

GetSeatInfo Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.GetMeetingInfo Method

GetMeetingInfo Method

Get meeting information for the given meetingId.
Syntax
Json
Request:

Copy
{
    "meetingId": <string>
}

Response:

Copy
{
    "meetingInfo":
    {
        "agendaList":
        [
            {
                "agendaTopicId": <string>,
                "description": <string>,
                "discussionId": <string>,
                "meetingId": <string>,
                "state": "opened"|"closed",
                "subject": <string>
            }
        ],
        "autoOpenOnActivate": <bool>,
        "autoStartAgendaOnOpen": <bool>,
        "defaultDiscussionId": <string>,
        "description": <string>,
        "documentationRef": <string>,
        "identificationMethod": "fixed"|"userName"|"selectFromList"|"qRCode"|"externalSystem"|"nFC"|"nFCKeptAtDevice",
        "isDefault": <bool>,
        "meetingEndDate": <dateTime>,
        "meetingId": <string>,
        "meetingStartDate": <dateTime>,
        "state": "activated"|"deactivated"|"opened"|"closed",
        "title": <string>,
        "verificationMethod": "none"|"confirmation"|"password"|"pINCode"|"externalSystem"
    }
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.LoggedIn Property

LoggedIn Property

Are we currently logged in?
Syntax
Json
{ Property:LoggedIn }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpretationRoutingInfo.AutoRelayContribution Property

AutoRelayContribution Property

Gets or sets a value indicating whether this instance is contributing automatic relay.
Syntax
Json
{ Property:AutoRelayContribution }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpreterDeskInfo.SetBLanguageList Method

SetBLanguageList Method

Sets the B language list.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


Certificate.CreateRootCertificateData Method

CreateRootCertificateData Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.LoginResponse Class

ConferenceApiHandlerLoginResponse Class

Response from Login
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerLoginResponse
Syntax
Json
{ JsonClass:LoginResponse		LoggedIn:<type>,
    Token:<type>,
 }

The ConferenceApiHandlerLoginResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerLoginResponse | Initializes a new instance of the ConferenceApiHandlerLoginResponse class
Top
Properties
 | Name | Description
Public property | LoggedIn | Loggeg in status
Public property | Token |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ActivateAdHocVotingRequest.Subject Property

Subject Property

Voting subject for the ad-hoc voting
Syntax
Json
{ Property:Subject }
Remarks
The maximum characters supported is 50.
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.GetParticipantGroupPermissions Method

GetParticipantGroupPermissions Method

Gets participant group permissions
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DcnmApi.OnAudioSettingsChanged Method

OnAudioSettingsChanged Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GrantSpeechResponse Class

ConferenceApiHandlerGrantSpeechResponse Class

Represents the grant of the speech by seats and participants response.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGrantSpeechResponse
Syntax
Json
{ JsonClass:GrantSpeechResponse	 }

The ConferenceApiHandlerGrantSpeechResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGrantSpeechResponse | Initializes a new instance of the ConferenceApiHandlerGrantSpeechResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileLogTraceListener.TraceData Method

TraceData Method

Writes trace data to the listener specific output.
Overload List
 | Name | Description
Public method | TraceData(TraceEventCache, String, TraceEventType, Int32, Object) | Writes trace information, a data object and event information to the listener specific output. (Overrides TraceListenerTraceData(TraceEventCache, String, TraceEventType, Int32, Object).)
Public method | TraceData(TraceEventCache, String, TraceEventType, Int32, Object) | Writes trace information, an array of data objects and event information to the listener specific output. (Overrides TraceListenerTraceData(TraceEventCache, String, TraceEventType, Int32, Object).)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


QuorumResultInfo Methods

The QuorumResultInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Override Equals function in IEquatable (Overrides ObjectEquals(Object).)
Public method | Equals(QuorumResultInfo) | Function to compare QuorumResultInfo with other objects
Public method | GetHashCode | Override GetHashCode function in IEquatable (Overrides ObjectGetHashCode.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceException Constructor

Overload List
 | Name | Description
Public method | ConferenceException | Initializes a new instance of the ConferenceException class.
Public method | ConferenceException(String) | Initializes a new instance of the ConferenceException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Protected method | ConferenceException(SerializationInfo, StreamingContext) | Initializes a new instance of the ConferenceException class with serialized data.
Public method | ConferenceException(String, Exception) | Initializes a new instance of the ConferenceException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SeatInfo.SetDevices Method

SetDevices Method

Sets the devices
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DcnmApi.OnAreaDeleted Method

OnAreaDeleted Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DcnmApi.OnRequestToResponseOptionsChanged Method

OnRequestToResponseOptionsChanged Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SelectRelayInterpretationRequest Class

ConferenceApiHandlerSelectRelayInterpretationRequest Class

Represents the request to select relay interpretation
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerSelectRelayInterpretationRequest
Syntax
Json
{ JsonClass:SelectRelayInterpretationRequest		SeatId:<type>,
 }

The ConferenceApiHandlerSelectRelayInterpretationRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSelectRelayInterpretationRequest | Initializes a new instance of the ConferenceApiHandlerSelectRelayInterpretationRequest class
Top
Properties
 | Name | Description
Public property | SeatId |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpretationSeatMetaRequest Class

Inheritance Hierarchy
SystemObject
SynopticControl.CommonInterpretationSeatMetaRequest
Syntax
Json
{ JsonClass:InterpretationSeatMetaRequest		SeatId:<type>,
    SeatMetaRequests:<type>,
 }

The InterpretationSeatMetaRequest type exposes the following members.

Constructors
 | Name | Description
Public method | InterpretationSeatMetaRequest | Initializes a new instance of the InterpretationSeatMetaRequest class
Top
Properties
 | Name | Description
Public property | SeatId | Gets or sets the seat identifier.
Public property | SeatMetaRequests | Gets or sets the seat metat data.
Top
Methods
 | Name | Description
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetTotalCastVoteResult Method

GetTotalCastVoteResult Method

Overload List
 | Name | Description
Public method | GetTotalCastVoteResult |
Private method | GetTotalCastVoteResult(ReadOnlyCollectionVote) |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateImportantSpeakersList Method

UpdateImportantSpeakersList Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


GetImageServerInfoResponse Properties

The ConferenceApiHandlerGetImageServerInfoResponse type exposes the following members.

Properties
 | Name | Description
Public property | Uri | The uri of the image server
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


OutputPresetButton Enumeration

Syntax
Json
OutputPresetButton:{
OutputPresetB
OutputPresetC}
Members
Member name | Value | Description
OutputPresetB | 0 | The output preset for B
OutputPresetC | 1 | The output preset for C
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AddSeatToSpeakersRequest Properties

The ConferenceApiHandlerAddSeatToSpeakersRequest type exposes the following members.

Properties
 | Name | Description
Public property | SeatId | The seat identifier.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileLogTraceListener Class

Represents a trace listener which writes to a file. Use this trace listener in the app.config file as following:
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.DiagnosticsTraceListener
SynopticControl.DiagnosticsFileLogTraceListener
Syntax
Json
{ JsonClass:FileLogTraceListener		Attributes:<type>,
    Name:<type>,
    IsThreadSafe:<type>,
    IndentLevel:<type>,
    IndentSize:<type>,
    Filter:<type>,
    NeedIndent:<type>,
    TraceOutputOptions:<type>,
    CycleMode:<type>,
 }

The FileLogTraceListener type exposes the following members.

Constructors
 | Name | Description
Public method | FileLogTraceListener | Flush the write stream
Public method | FileLogTraceListener(TextWriter) | Initializes a new instance of the FileLogTraceListener class, using the stream as the recipient of the debugging and tracing output.
Public method | FileLogTraceListener(String) | Initializes a new instance of the TextWriterTraceListener class, using the file as the recipient of the debugging and tracing output.
Public method | FileLogTraceListener(TextWriter, String) | Initializes a new instance of the FileLogTraceListener class with the specified name, using the stream as the recipient of the debugging and tracing output.
Top
Properties
 | Name | Description
Public property | Attributes | Gets the custom trace listener attributes defined in the application configuration file. (Inherited from TraceListener.)
Private property | CycleMode | Return configured cycle mode of the FileLogTraceListener
Public property | Filter | Gets or sets the trace filter for the trace listener. (Inherited from TraceListener.)
Public property | IndentLevel | Gets or sets the indent level. (Inherited from TraceListener.)
Public property | IndentSize | Gets or sets the number of spaces in an indent. (Inherited from TraceListener.)
Public property | IsThreadSafe | Gets a value indicating whether the trace listener is thread safe. (Inherited from TraceListener.)
Public property | Name | Gets or sets a name for this TraceListener. (Inherited from TraceListener.)
Protected property | NeedIndent | Gets or sets a value indicating whether to indent the output. (Inherited from TraceListener.)
Public property | TraceOutputOptions | Gets or sets the trace output options. (Inherited from TraceListener.)
Top
Methods
 | Name | Description
Public method | Close | When overridden in a derived class, closes the output stream so it no longer receives tracing or debugging output. (Inherited from TraceListener.)
Private method | CreateLogFile | Create a log file
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Private method | DetermineLogFileName | Determine the log file name which depends on the configured Cycle attribute of the FileLogListener
Public method | Dispose | Releases all resources used by the TraceListener. (Inherited from TraceListener.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the TraceListener and optionally releases the managed resources. (Inherited from TraceListener.)
Private method | EnsureWriter | In case no writer is present a new writer will be created. The configured cycle determines if a new log file needs to be created.
Public method | Fail(String) | Emits an error message to the listener you create when you implement the TraceListener class. (Inherited from TraceListener.)
Public method | Fail(String, String) | Emits an error message and a detailed error message to the listener you create when you implement the TraceListener class. (Inherited from TraceListener.)
Public method | Flush | (Overrides TraceListenerFlush.)
 | GetEncodingWithFallback | Provides a failure-handling mechanism, called a fallback, for an input character that cannot be converted to an encoded output byte sequence.
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetSupportedAttributes | Gets the custom attributes supported by the trace listener. (Overrides TraceListenerGetSupportedAttributes.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | IsEnabled | Check fuction for the TraceOutputOptions.
Protected method | MemberwiseClone | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | TraceData(TraceEventCache, String, TraceEventType, Int32, Object) | Writes trace information, a data object and event information to the listener specific output. (Overrides TraceListenerTraceData(TraceEventCache, String, TraceEventType, Int32, Object).)
Public method | TraceData(TraceEventCache, String, TraceEventType, Int32, Object) | Writes trace information, an array of data objects and event information to the listener specific output. (Overrides TraceListenerTraceData(TraceEventCache, String, TraceEventType, Int32, Object).)
Public method | TraceEvent(TraceEventCache, String, TraceEventType, Int32) | Writes trace and event information to the listener specific output. (Inherited from TraceListener.)
Public method | TraceEvent(TraceEventCache, String, TraceEventType, Int32, String) | Writes trace information, a message, and event information to the listener specific output. (Overrides TraceListenerTraceEvent(TraceEventCache, String, TraceEventType, Int32, String).)
Public method | TraceEvent(TraceEventCache, String, TraceEventType, Int32, String, Object) | Writes trace information, a formatted array of objects and event information to the listener specific output. (Overrides TraceListenerTraceEvent(TraceEventCache, String, TraceEventType, Int32, String, Object).)
Public method | TraceTransfer | Writes trace information, a message, a related activity identity and event information to the listener specific output. (Inherited from TraceListener.)
Public method | Write(Object) | Writes the value of the object's ToString method to the listener you create when you implement the TraceListener class. (Inherited from TraceListener.)
Public method | Write(String) | Writes the specified message to the listener you create in the derived class. (Overrides TraceListenerWrite(String).)
Public method | Write(String, String) | Writes a category name and a message to the listener you create when you implement the TraceListener class. (Inherited from TraceListener.)
Public method | Write(Object, String) | Writes a category name and the value of the object's ToString method to the listener you create when you implement the TraceListener class. (Inherited from TraceListener.)
Private method | WriteFooter | Write the footer of the trace message which consists of several configured trace options
Private method | WriteHeader | Write the header of the trace message which consists of several configured trace options and the trace message itself.
Protected method | WriteIndent | Writes the indent to the listener you create when you implement this class, and resets the NeedIndent property to . (Inherited from TraceListener.)
Public method | WriteLine(Object) | Writes the value of the object's ToString method to the listener you create when you implement the TraceListener class, followed by a line terminator. (Inherited from TraceListener.)
Public method | WriteLine(String) | Writes a message to the listener you create in the derived class, followed by a line terminator. (Overrides TraceListenerWriteLine(String).)
Public method | WriteLine(String, String) | Writes a category name and a message to the listener you create when you implement the TraceListener class, followed by a line terminator. (Inherited from TraceListener.)
Public method | WriteLine(Object, String) | Writes a category name and the value of the object's ToString method to the listener you create when you implement the TraceListener class, followed by a line terminator. (Inherited from TraceListener.)
Private method | WriteLineMessage | Writes a message to the listener you create in the derived class, followed by a line terminator.
Private method | WriteMessage | Writes the specified message to the listener you create in the derived class.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RejectVotingResponse Constructor

ConferenceApiHandlerRejectVotingResponse Constructor

Initializes a new instance of the ConferenceApiHandlerRejectVotingResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


QuorumResultInfo Operators

The QuorumResultInfo type exposes the following members.

Operators
Name | Description
Equality | Function to comapare two QuorumResultInfo objects are equal
Inequality | Function to comapare two QuorumResultInfo objects are unequal
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SetInterpretationOutputPresetRequest Properties

The ConferenceApiHandlerSetInterpretationOutputPresetRequest type exposes the following members.

Properties
 | Name | Description
Public property | LanguageId |
Public property | OutputButton |
Public property | SeatId |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateHasHybridLicense Method

UpdateHasHybridLicense Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DcnmApi.LogOnDcnmServer Method

LogOnDcnmServer Method

Gets User security claims info for user
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.EnableSeatIlluminationResponse Constructor

ConferenceApiHandlerEnableSeatIlluminationResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerEnableSeatIlluminationResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateRequestToSpeakOptions Method

UpdateRequestToSpeakOptions Method

Updates request to speak options
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetSystemPowerModeResponse Constructor

ConferenceApiHandlerSetSystemPowerModeResponse Constructor

Initializes a new instance of the ConferenceApiHandlerSetSystemPowerModeResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


PluginHandler.Instance Property

Instance Property

Syntax
Json
{ Property:Instance }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.CreateFileResponse.FileId Property

FileId Property

Syntax
Json
{ Property:FileId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpretationLanguage.Abbreviation Property

Abbreviation Property

Gets or sets the language abbreviation.
Syntax
Json
{ Property:Abbreviation }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.UpdateMeetingBoothConfigurations Method

UpdateMeetingBoothConfigurations Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


SystemLog.TraceSuspend Method

TraceSuspend Method

Logs the suspension of a method/function/block
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetInterpretationMetaRequestStatus Method

GetInterpretationMetaRequestStatus Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetSystemPowerMode Method

GetSystemPowerMode Method

Gets the power mode information of the system
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "powerMode": "poweredOn"|"poweredOff"|"poweringOn"|"poweringOff"
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Participant.Equals Method

Equals Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


FileLogTraceListener.TraceData Method (TraceEventCache, String, TraceEventType, Int32, Object)

TraceData Method (TraceEventCache, String, TraceEventType, Int32, Object)

 Bosch Logo
Writes trace information, a data object and event information to the listener specific output.
Syntax
Json
  Remarks
  Note  Note
This method is not intended to be called directly by application code
            but by members of the Debug, Trace, and TraceSource classes to write trace
            data to output.

            The default implementation writes the eventCache, source, eventType and id
            parameters in the header and footer of the trace.
            The data parameter is written as the body of the trace message.
            The ToString method of the data object is used to convert the object to a String.

  See Also
Reference
TraceListener class
TextWriterTraceListener class
Debug class
Trace class


OpenAgendaRequest Properties

The ConferenceApiHandlerOpenAgendaRequest type exposes the following members.

Properties
 | Name | Description
Public property | AgendaTopicId | The agenda identifier.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnParticipantsListChanged Method

OnParticipantsListChanged Method

Called when participant list is changed
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler Class

The actual processing of conference messages
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandler
Syntax
Json
{ JsonClass:ConferenceApiHandler		LoggedIn:<type>,
 }

The ConferenceApiHandler type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandler | Constructor
Top
Properties
 | Name | Description
Public property | LoggedIn | Are we currently logged in?
Top
Methods
 | Name | Description
Private method | AbortVoting | Abort the open voting
Private method | AcceptVoting | Accept the closed voting
Private method | ActivateAdHocVoting | Activate an ad-hoc voting
Private method | ActivateMeeting | To activate a meeting.
Private method | ActivateMicrophone | Un-mutes the microphone for the specified seat.
Private method | ActivatePresentation | Activate the presentation screen of the device.
Private method | ActivateVoting | Activate a voting
Private method | AddSeatToSpeakers | Adds the seat to active speakers list.
Private method | CancelInterpreterMetaFunction | Cancel interpreter meta request from a seat.
Private method | CanExecutePresentationPlugin |
Private method | CheckforLicense |
Private method | CheckIfNoNullOrEmptyGuids |
Private method | CheckNotesFileTampered | Check whether the notes file is tampered with and its certifcate is valid
Private method | CloseAgenda | Close Agenda for current meeting.
Private method | CloseMeeting | To close active meeting.
Private method | CloseVoting | Close the open voting
Private method | ConvertStringsToGuids |
Private method | CreateFile | Creates the specified file.
Private method | CreatePluginDescription |
Private method | DeactivateMeeting | To deactivate active meeting.
Private method | DeactivateMicrophone | Mutes the microphone for the specified seat.
Private method | DeactivatePresentation | De-Activate the presentation screen of the device.
Private method | DeleteFile | Deletes saved files.
Private method | DeleteImage | Deletes the specified image.
Private method | DeleteNotesFiles | Deletes the notes files.
Private method | EnableSeatIllumination | Enables or disables seat illumination mode.
Private method | ExecutePluginCommand |
Private method | GenerateJwtToken |
Private method | GetAgendaTopics | Gets the list of agenda topics information for the active meeting.
Private method | GetBoothNotifications | Gets the booth notifications from the system.
Private method | GetDiscussionList | Gets the list of speakers, requests, request responders, important and priority speakers of the active discussion.
Private method | GetDiscussionOptions | Gets the discussion options of the active discussion.
Private method | GetEnableSeatIllumination | Gets state whether system is in installation mode or not.
Private method | GetIlluminatedSeat | Gets identifier of the illuminated seat.
Private method | GetImageServerInfo | Gets the Uri of the image server.
Private method | GetIndividualVotingResults | Gets individual voting results.
Private method | GetInterpretationLanguages | Gets the interpretation languages of the active meeting.
Private method | GetInterpretationMetaFunctionStatus | Gets interpretation meta requests status from system.
Private method | GetInterpretationRoutings | Get list of all the active translation.
Private method | GetInterpreterBooths | Gets list of interpreter booths configured for active meeting.
Private method | GetInterpreterSeats | Gets list of interpreter seats configured for active meeting.
Private method | GetMajorityResult | Gets the majority result of the active voting.
Private method | GetMasterVolume | Gets the master volume of the DICENTIS System.
Private method | GetMasterVolumeRange | Gets the master volume range (minimum and maximum) of the DICENTIS System
Private method | GetMeetingInfo | Gets the information related to the active meeting.
Private method | GetMeetings | Gets the list of meeting's.
Private method | GetMicrophoneSensitivity | Gets microphone sensitivity for seat ids.
Private method | GetMicrophoneSensitivityDescription | Gets microphone sensitivity description from system.
Private method | GetNotesFileList | Get list of meeting and voting notes xml file details.
Private method | GetParticipantAccessDeniedReasons | Gets the participant access denied reasons
Private method | GetParticipants | Gets the list of participants assigned to the active meeting.
Private method | GetParticipantSeats | Gets the list of participant identifier along with assigned seat and seated seat identifier of the active meeting. A participant can be assigned to a seat during the meeting preparation. The participant becomes a seated participant when he logs in (identify and if configured verify) at a seat. When there is no identification method configured, then the assigned participant, immediately becomes a seated participant upon activating the meeting.
Private method | GetPermissions | Gets the permissions of the logged-in user
Private method | GetPlugin | Retrieve details of a specific plugin
Private method | GetPluginCommands | Gets the list of plugin commands
Private method | GetPluginEventData | Gets the plugin event data
Private method | GetPlugins | Retrieves all the plugins. Use GetPluginAsync to retrieve details of a specific plugin
Private method | GetPresentationState | Gets the current presentation state whether the presentation is enabled / disabled.
Private method | GetQuorumResult | Gets the quorum result of the active meeting.
Private method | GetRoomContactEmail | Gets room contact email.
Private method | GetRoomName | Gets room name.
Private method | GetSeats | Gets list of participant seats.
Private method | GetSeatVotingResults | Gets seat voting results.
Private method | GetSupportedHeadphones | Gets the collection of supported headphones for interpretation
Private method | GetSystemPowerMode | Gets the power state of the system.
Private method | GetVotingInfo | Gets the active voting.
Private method | GetVotingResults | Gets the voting results of the active voting.
Private method | GetVotings | Gets the list of prepared voting's of the active meeting.
Private method | GetVotingState | Gets the state of active voting.
Private method | GrantInterpretation | Grant the interpretation to the specified interpretation seat.
Private method | GrantResponse | Shifts the given seat(s) participant(s) to the responders list, and removes the oldest speaker in the responders list.
Private method | GrantSpeech | Adds the seat or participant to active speakers list.
Private method | HoldVoting | Hold the open voting
Private method | IssueInterpreterMetaFunction | Issues interpreter meta request from a seat.
Private method | ListFiles | Lists the files.
Private method | ListImages | Lists the images.
Private method | LoadFile | Opens the saved file.
Private method | Login | Logs in the user
Private method | Logout | Logs off the user
Private method | OpenAgenda | Open Agenda for current meeting.
Private method | OpenMeeting | To open active meeting.
Private method | OpenVoting | Open the active voting
Private method | RaiseBoothNotification | Raises a notification on a booth.
Private method | RegisterEvents | This functions allows to register for the events (ex: Voting state changed, Permission changed) whose callbacks needs to be received, whenever the event is triggered
Private method | RegisterPlugin | Register a plugin
Private method | RejectVoting | Reject the closed voting
Private method | RemoveResponse | Cancels a request to respond of a participant or seat.
Private method | RemoveSeatFromDiscussionList | Removes the seat from active speakers list.
Private method | RemoveSpeech | Removes the seat or participant from active speakers list.
Private method | RequestResponse | Adds the seat or participant to response request waiting list.
Private method | RequestSpeech | Adds the seat or participant to waiting list.
Private method | ResetMicrophoneSensitivity | Resets microphone sensitivity for all seats.
Private method | ResumeVoting | Resume the on hold voting
Private method | SaveImage | Saves the specified image.
Private method | SelectInterpretationFloor | Selects the floor language for interpretation seat.
Private method | SelectInterpretationInputLanguage | Sets and selects the input language on the preset for interpretation seat.
Private method | SelectRelayInterpretation | Selects the relay language for interpretation seat.
Private method | SendPluginCommand | Send a command to a plugin
Private method | SendPluginEvent | Send a plugin event
Private method | SetIlluminateSeat | Illuminates specified seat.
Private method | SetInterpretationOutputPreset | Updates output preset for interpretation seat.
Private method | SetMasterVolume | Sets the master volume of the system with the specified value(dB)
Private method | SetPluginCommandResult | Sets the result of the command execution
Private method | SetSystemPowerMode | Sets the power mode of the system.
Private method | SubscribePluginEvent | Subscribe to an event coming from a plugin
Private method | TransformNotesFile | XSL transform the notes file.
Private method | UnregisterEvents | This functions allows to un register for the registered events
Private method | UnRegisterPlugin | Unregister a plugin
Private method | UnSubscribePluginEvent | Unsubscribe from an event coming from a plugin
Private method | UpdateFile | Updates the specified file.
Private method | UpdateMicrophoneSensitivity | Update microphone sensitivity for seat ids.
Private method | ValidateJwtToken |
Top
See Also

Reference

SynopticControl.ServerIConferenceConnection


ConferenceApiHandler.DeleteNotesFilesResponse Constructor

ConferenceApiHandlerDeleteNotesFilesResponse Constructor

Initializes a new instance of the ConferenceApiHandlerDeleteNotesFilesResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AssemblyRedirect Constructor

Default constructor for class. Load all dependent assemblies immediately and get them from the location I expect them to be in .Net ensures that this static constructor only gets called once
Syntax
Json
{ Constructor:.cctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SeatInfo.ScreenLine Property

ScreenLine Property

Seat screen line
Syntax
Json
{ Property:ScreenLine }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceUsers Constructor

Initializes a new instance of the ConferenceUsers class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DiscussionListEntry.RemainingSpeechDuration Property

RemainingSpeechDuration Property

Remaining speech duration of the speaker
Syntax
Json
{ Property:RemainingSpeechDuration }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetInterpretationRoutings Method

GetInterpretationRoutings Method

Returns interpretation routings to requested clients.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "routings":
    [
        {
            "autoRelayContribution": <bool>,
            "destinationLanguageId": <string>,
            "destinationLanguageQuality": "floor"|"plus"|"minus"|"minusMinus"|"unknown",
            "microphoneState": "off"|"activeOnOutputA"|"activeOnOutputB"|"activeOnOutputC",
            "seatId": <string>,
            "sourceLanguageId": <string>
        }
    ]
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ApiClient Class

Inheritance Hierarchy
SystemObject
SynopticControl.CommonApiClient
Syntax
Json
{ JsonClass:ApiClient		AccessRights:<type>,
    Password:<type>,
    ServerAddress:<type>,
    Username:<type>,
 }

The ApiClient type exposes the following members.

Constructors
 | Name | Description
Public method | ApiClient | Initializes a new instance of the ApiClient class
Top
Properties
 | Name | Description
Public property | AccessRights |
Public property | Password |
Public property | ServerAddress |
Public property | Username |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.HasParticipantDatabaseLicense Property

HasParticipantDatabaseLicense Property

Syntax
Json
{ Property:HasParticipantDatabaseLicense }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RemoveResponseRequest.SeatIds Property

SeatIds Property

List of seat identifiers.
Syntax
Json
{ Property:SeatIds }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RequestResponseResponse Class

ConferenceApiHandlerRequestResponseResponse Class

Represents the reponse to the speaker by seats and participants response.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerRequestResponseResponse
Syntax
Json
{ JsonClass:RequestResponseResponse	 }

The ConferenceApiHandlerRequestResponseResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerRequestResponseResponse | Initializes a new instance of the ConferenceApiHandlerRequestResponseResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AccessRights Properties

The AccessRights type exposes the following members.

Properties
 | Name | Description
Public property | ActivateMeeting |
Public property | AssignAccessRights |
Public property | ConfigureSystem |
Public property | PrepareMeetingAndAgenda |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Participant.CanVote Property

CanVote Property

Gets a value indicating whether this instance can vote.
Syntax
Json
{ Property:CanVote }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


MicrophoneSensitivity.GetHashCode Method

GetHashCode Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


Bosch.Security Namespace

Classes
 | Class | Description
Public class | Certificate |
Public class | CreateCertificateRequest |
Public class | CreateCertificateResponse |
Public class | RootCertificateData |
Public class | ServerCertificateData |
Enumerations
 | Enumeration | Description
Public enumeration | CertificatePurpose |


ConferenceApiHandler.UnregisterEventsResponse Constructor

ConferenceApiHandlerUnregisterEventsResponse Constructor

Initializes a new instance of the ConferenceApiHandlerUnregisterEventsResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetSeatVotingResultsResponse Constructor

ConferenceApiHandlerGetSeatVotingResultsResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetSeatVotingResultsResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.ConvertToComparisonOperator Method

ConvertToComparisonOperator Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


InterpretationLanguage.Label Property

Label Property

Gets or sets the language label.
Syntax
Json
{ Property:Label }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetPermissionsResponse.Permissions Property

Permissions Property

Permissions list
Syntax
Json
{ Property:Permissions }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.HasRemoteSubscriptionLicense Property

HasRemoteSubscriptionLicense Property

Syntax
Json
{ Property:HasRemoteSubscriptionLicense }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetSeatVotingResultsResponse Class

ConferenceApiHandlerGetSeatVotingResultsResponse Class

Represents the get seat voting result response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetSeatVotingResultsResponse
Syntax
Json
{ JsonClass:GetSeatVotingResultsResponse		VotingResults:<type>,
 }

The ConferenceApiHandlerGetSeatVotingResultsResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetSeatVotingResultsResponse | Initializes a new instance of the ConferenceApiHandlerGetSeatVotingResultsResponse class
Top
Properties
 | Name | Description
Public property | VotingResults | List of voting results
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.DeactivatePresentation Method

DeactivatePresentation Method

Deactivate the presentation.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.ParticipantSeatsList Property

ParticipantSeatsList Property

Syntax
Json
{ Property:ParticipantSeatsList }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UnregisterEventsRequest.Events Property

Events Property

List of unregistered events
Syntax
Json
{ Property:Events }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.UpdateBoothInUseInfo Method

UpdateBoothInUseInfo Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.DeactivateMicrophoneResponse Constructor

ConferenceApiHandlerDeactivateMicrophoneResponse Constructor

Initializes a new instance of the ConferenceApiHandlerDeactivateMicrophoneResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetBoothNotificationsResponse Class

ConferenceApiHandlerGetBoothNotificationsResponse Class

Represents the get booth notifications response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetBoothNotificationsResponse
Syntax
Json
{ JsonClass:GetBoothNotificationsResponse		Notifications:<type>,
 }

The ConferenceApiHandlerGetBoothNotificationsResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetBoothNotificationsResponse | Initializes a new instance of the ConferenceApiHandlerGetBoothNotificationsResponse class
Top
Properties
 | Name | Description
Public property | Notifications | Gets or sets the booth notifications.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


PluginHandler.ConnectionIdAndPluginInstance Constructor

PluginHandlerConnectionIdAndPluginInstance Constructor

Initializes a new instance of the PluginHandlerConnectionIdAndPluginInstance class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.CloseVotingResponse Constructor

ConferenceApiHandlerCloseVotingResponse Constructor

Initializes a new instance of the ConferenceApiHandlerCloseVotingResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetInterpreterSeatsResponse Class

ConferenceApiHandlerGetInterpreterSeatsResponse Class

Represents the response for get interpreter seats
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetInterpreterSeatsResponse
Syntax
Json
{ JsonClass:GetInterpreterSeatsResponse		Seats:<type>,
 }

The ConferenceApiHandlerGetInterpreterSeatsResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetInterpreterSeatsResponse | Initializes a new instance of the ConferenceApiHandlerGetInterpreterSeatsResponse class
Top
Properties
 | Name | Description
Public property | Seats | Gets or sets the interpreter seats.
Top
Remarks
To determine if interpretation is active on an InterpreterDesk, use GetInterpretationRoutings to obtain the InterpretationMicrophoneState for the corresponding interpreter desk
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnSeatsDeleted Method

OnSeatsDeleted Method

Handles seats that are deleted.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.DeleteNotesFilesRequest Constructor

ConferenceApiHandlerDeleteNotesFilesRequest Constructor

Initializes a new instance of the ConferenceApiHandlerDeleteNotesFilesRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateInterpretationLanguages Method

UpdateInterpretationLanguages Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModelReader.GrantSpeech Method

GrantSpeech Method

Overload List
 | Name | Description
Protected method | GrantSpeech(ListGuid) |
Protected method | GrantSpeech(Guid) |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ApiClient.Password Property

Password Property

Syntax
Json
{ Property:Password }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.InterpreterDesks Property

InterpreterDesks Property

Syntax
Json
{ Property:InterpreterDesks }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetQuorumResultResponse Properties

The ConferenceApiHandlerGetQuorumResultResponse type exposes the following members.

Properties
 | Name | Description
Public property | QuorumResult | Quorum Result.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


PluginHandler.CachePluginEvents Method

CachePluginEvents Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


VoteMajorityInfo.MajorityCondition Property

MajorityCondition Property

Majority condition operator ComparisonOperators.
Syntax
Json
{ Property:MajorityCondition }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


CreateCertificateResponse Class

Inheritance Hierarchy
SystemObject
Bosch.SecurityCreateCertificateResponse
Syntax
Json
{ JsonClass:CreateCertificateResponse		CertificateHash:<type>,
    PublicCrtData:<type>,
    StoreName:<type>,
    Success:<type>,
 }

The CreateCertificateResponse type exposes the following members.

Constructors
 | Name | Description
Public method | CreateCertificateResponse | Initializes a new instance of the CreateCertificateResponse class
Top
Properties
 | Name | Description
Public property | CertificateHash |
Public property | PublicCrtData |
Public property | StoreName |
Public property | Success |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnSpeechTimerOptionsChanged Method

OnSpeechTimerOptionsChanged Method

Updates speech time options
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


PluginHandler.PluginEventSubscriptionData.EventName Property

EventName Property

Syntax
Json
{ Property:EventName }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetPermissionsResponse Class

ConferenceApiHandlerGetPermissionsResponse Class

Response from GetPermissions
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetPermissionsResponse
Syntax
Json
{ JsonClass:GetPermissionsResponse		Permissions:<type>,
 }

The ConferenceApiHandlerGetPermissionsResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetPermissionsResponse | Initializes a new instance of the ConferenceApiHandlerGetPermissionsResponse class
Top
Properties
 | Name | Description
Public property | Permissions | Permissions list
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SeatInfo.Attributes Property

Attributes Property

The list of seat attributes
Syntax
Json
{ Property:Attributes }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateActiveVotingInfo Method

UpdateActiveVotingInfo Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.DeactivateMeetingRequest Constructor

ConferenceApiHandlerDeactivateMeetingRequest Constructor

Initializes a new instance of the ConferenceApiHandlerDeactivateMeetingRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SeatInfo.FoundDevices Property

FoundDevices Property

Devices found at seat
Syntax
Json
{ Property:FoundDevices }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SystemLog.TraceWarning Method (String)

TraceWarning Method (String)

 Bosch Logo
Forwards the warning event to the trace source.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.DeleteNotesFilesRequest.FileNames Property

FileNames Property

The collection of file names to delete
Syntax
Json
{ Property:FileNames }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.NotifySeatInfoChangedOnClients Method

NotifySeatInfoChangedOnClients Method

Seats information change notification to connected clients
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


CreateCertificateRequest Class

Inheritance Hierarchy
SystemObject
Bosch.SecurityCreateCertificateRequest
Syntax
Json
{ JsonClass:CreateCertificateRequest		DnsNames:<type>,
    ForceAddCertificateToStore:<type>,
    IPAddresses:<type>,
    Purpose:<type>,
    RootCertificateName:<type>,
    ServerCertificateName:<type>,
 }

The CreateCertificateRequest type exposes the following members.

Constructors
 | Name | Description
Public method | CreateCertificateRequest | Initializes a new instance of the CreateCertificateRequest class
Top
Properties
 | Name | Description
Public property | DnsNames |
Public property | ForceAddCertificateToStore |
Public property | IPAddresses |
Public property | Purpose |
Public property | RootCertificateName |
Public property | ServerCertificateName |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.CancelInterpreterMetaFunctionRequest Class

ConferenceApiHandlerCancelInterpreterMetaFunctionRequest Class

 Bosch Logo
Represents cancel interpreter meta function request.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerCancelInterpreterMetaFunctionRequest
Syntax
Json
{ JsonClass:CancelInterpreterMetaFunctionRequest		Request:<type>,
    SeatId:<type>,
 }

The ConferenceApiHandlerCancelInterpreterMetaFunctionRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerCancelInterpreterMetaFunctionRequest | Initializes a new instance of the ConferenceApiHandlerCancelInterpreterMetaFunctionRequest class
Top
Properties
 | Name | Description
Public property | Request |
Public property | SeatId |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.ParticipantAccessDeniedInfo Property

ParticipantAccessDeniedInfo Property

Syntax
Json
{ Property:ParticipantAccessDeniedInfo }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiMethodCaller(Response, Request) Properties

ConferenceApiMethodCallerResponse, Request Properties

The ConferenceApiMethodCallerResponse, Request generic type exposes the following members.

Properties
 | Name | Description
Public property | LoginRequired |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AuthenticateController.GetApiState Method

GetApiState Method

Gets Api connection state
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetApiStateRequest Constructor

ConferenceApiHandlerGetApiStateRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetApiStateRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Certificate.AddCertificateExtensions Method

AddCertificateExtensions Method

Overload List
Name | Description
AddCertificateExtensions(CertificateRequest, CertificatePurpose) |
AddCertificateExtensions(CertificateRequest, X509Certificate2) |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetIndividualParticipantCastVoteResults Method (ReadOnlyCollection(IndividualVotingResult))

GetIndividualParticipantCastVoteResults Method (ReadOnlyCollectionIndividualVotingResult)

 Bosch Logo
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.HoldVotingRequest Class

ConferenceApiHandlerHoldVotingRequest Class

Represents the hold voting info request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerHoldVotingRequest
Syntax
Json
{ JsonClass:HoldVotingRequest	 }

The ConferenceApiHandlerHoldVotingRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerHoldVotingRequest | Initializes a new instance of the ConferenceApiHandlerHoldVotingRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetParticipantsResponse Class

ConferenceApiHandlerGetParticipantsResponse Class

Represents the get participant response.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetParticipantsResponse
Syntax
Json
{ JsonClass:GetParticipantsResponse		Participants:<type>,
 }

The ConferenceApiHandlerGetParticipantsResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetParticipantsResponse | Initializes a new instance of the ConferenceApiHandlerGetParticipantsResponse class
Top
Properties
 | Name | Description
Public property | Participants | Participants list
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GrantInterpretationRequest Class

ConferenceApiHandlerGrantInterpretationRequest Class

Represents the grant interpretation request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGrantInterpretationRequest
Syntax
Json
{ JsonClass:GrantInterpretationRequest		MicrophoneState:<type>,
    SeatId:<type>,
 }

The ConferenceApiHandlerGrantInterpretationRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGrantInterpretationRequest | Initializes a new instance of the ConferenceApiHandlerGrantInterpretationRequest class
Top
Properties
 | Name | Description
Public property | MicrophoneState | Gets or sets the state of the interpretation microphone.
Public property | SeatId | Gets or sets the seat identifier.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RegisterPluginRequest Constructor

ConferenceApiHandlerRegisterPluginRequest Constructor

Initializes a new instance of the ConferenceApiHandlerRegisterPluginRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpretationLanguage.Equals Method

Equals Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetInterpreterBoothsResponse.Booths Property

Booths Property

Gets or sets the interpreter booths.
Syntax
Json
{ Property:Booths }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SubscribePluginEventResponse Class

ConferenceApiHandlerSubscribePluginEventResponse Class

Response for subscribing to plugin event
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerSubscribePluginEventResponse
Syntax
Json
{ JsonClass:SubscribePluginEventResponse	 }

The ConferenceApiHandlerSubscribePluginEventResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSubscribePluginEventResponse | Initializes a new instance of the ConferenceApiHandlerSubscribePluginEventResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetPluginRequest Properties

The ConferenceApiHandlerGetPluginRequest type exposes the following members.

Properties
 | Name | Description
Public property | PluginName | The name of plugin.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceUsers.RemoveUser Method

RemoveUser Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.DetermineVoteResultsVisiblityForVotingState Method

DetermineVoteResultsVisiblityForVotingState Method

Determine voting results visibility based on voting state
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.CreateSeatMicrophoneSensitivityInfoList Method

CreateSeatMicrophoneSensitivityInfoList Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


Participant.VisType Property

VisType Property

Gets the vis type of the participant.
Syntax
Json
{ Property:VisType }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SelectInterpretationInputLanguageRequest Constructor

ConferenceApiHandlerSelectInterpretationInputLanguageRequest Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerSelectInterpretationInputLanguageRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetParticipantAccessDeniedReasonsResponse.ParticipantAccessDeniedReasonsInfo Property

ParticipantAccessDeniedReasonsInfo Property

Participants Access Denied Reason.
Syntax
Json
{ Property:ParticipantAccessDeniedReasonsInfo }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


MajorityResultInfo.GetHashCode Method

GetHashCode Method

Override GetHashCode function in IEquatable
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RequestSpeechResponse Class

ConferenceApiHandlerRequestSpeechResponse Class

Represents the request for the speech by seats and participants response.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerRequestSpeechResponse
Syntax
Json
{ JsonClass:RequestSpeechResponse	 }

The ConferenceApiHandlerRequestSpeechResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerRequestSpeechResponse | Initializes a new instance of the ConferenceApiHandlerRequestSpeechResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


UpdateMicrophoneSensitivityResponse Properties

The ConferenceApiHandlerUpdateMicrophoneSensitivityResponse type exposes the following members.

Properties
 | Name | Description
Public property | Status | Status after sending request to update microphone sensitivity.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.DeactivateMicrophoneRequest Class

ConferenceApiHandlerDeactivateMicrophoneRequest Class

Represents the deactivation of the microphone request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerDeactivateMicrophoneRequest
Syntax
Json
{ JsonClass:DeactivateMicrophoneRequest		ParticipantIds:<type>,
    SeatId:<type>,
    SeatIds:<type>,
 }

The ConferenceApiHandlerDeactivateMicrophoneRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerDeactivateMicrophoneRequest | Initializes a new instance of the ConferenceApiHandlerDeactivateMicrophoneRequest class
Top
Properties
 | Name | Description
Public property | ParticipantIds | List of participant identifiers.
Public property | SeatId | Obsolete. The seat identifier.
Public property | SeatIds | List of seat identifiers.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.MakeParticipantToSeats Method

MakeParticipantToSeats Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.Dispose Method

Dispose Method

Releases all resources used by the ConferenceModel
Syntax
Json
Implements
IDisposableDispose
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConnectionTracker.ResetEvent Method

ResetEvent Method

Indicate that the event has been processed and may be sent again
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetMeetingsResponse Constructor

ConferenceApiHandlerGetMeetingsResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetMeetingsResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.DetermineMajorityResultVisiblityForUser Method

DetermineMajorityResultVisiblityForUser Method

Determine majority results visibility for user
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ICertificateWrapper Methods

The ICertificateWrapper type exposes the following members.

Methods
 | Name | Description
Public method | GetCertificate |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileStore.CreateFile Method

CreateFile Method

Syntax
Json
Request:

Copy
{
    "attributes": [<string>],
    "payload": <string>,
    "title": <string>
}

Response:

Copy
{
    "fileId": <string>
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateVotingResult Method

UpdateVotingResult Method

Updates the voting result.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.EnableSeatIlluminationRequest.Enable Property

Enable Property

Enable
Syntax
Json
{ Property:Enable }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.Initialize Method

Initialize Method

Initilizes conference updater.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


QuorumResultInfo Class

Defines quorum result for a meeting
Inheritance Hierarchy
SystemObject
SynopticControl.CommonQuorumResultInfo
Syntax
Json
{ JsonClass:QuorumResultInfo		ComparisonOperator:<type>,
    DenominatorValue:<type>,
    IsEnabled:<type>,
    NumeratorValue:<type>,
    Status:<type>,
    ThresholdValue:<type>,
 }

The QuorumResultInfo type exposes the following members.

Constructors
 | Name | Description
Public method | QuorumResultInfo | Initializes instance of class
Top
Properties
 | Name | Description
Public property | ComparisonOperator | Comparision operator used in quorum expression.
Public property | DenominatorValue | Quorum denominator value
Public property | IsEnabled | Indicates whether quorum is enabled
Public property | NumeratorValue | Quorum numerator value
Public property | Status | Quorum reached status
Public property | ThresholdValue | Quorum threshold value
Top
Methods
 | Name | Description
Public method | Equals(Object) | Override Equals function in IEquatable (Overrides ObjectEquals(Object).)
Public method | Equals(QuorumResultInfo) | Function to compare QuorumResultInfo with other objects
Public method | GetHashCode | Override GetHashCode function in IEquatable (Overrides ObjectGetHashCode.)
Top
Operators
Name | Description
Equality | Function to comapare two QuorumResultInfo objects are equal
Inequality | Function to comapare two QuorumResultInfo objects are unequal
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SendPluginCommandInfo Class

Inheritance Hierarchy
SystemObject
SynopticControl.ServerSendPluginCommandInfo
Syntax
Json
{ JsonClass:SendPluginCommandInfo		CorrelationId:<type>,
    PluginCommand:<type>,
 }

The SendPluginCommandInfo type exposes the following members.

Constructors
 | Name | Description
Public method | SendPluginCommandInfo | Initializes a new instance of the SendPluginCommandInfo class
Top
Properties
 | Name | Description
Public property | CorrelationId |
Public property | PluginCommand |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetDiscussionListResponse.ReferenceTime Property

ReferenceTime Property

Holds the value of Environment.TickCount
Syntax
Json
{ Property:ReferenceTime }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ImageManagement Class

ImageManagement class
Inheritance Hierarchy
SystemObject
SynopticControl.ServerImageManagement
Syntax
Json
{ JsonClass:ImageManagement	 }

The ImageManagement type exposes the following members.

Constructors
 | Name | Description
 | ImageManagement |
Public method | ImageManagement | Initializes a new instance of the ImageManagement class
Top
Methods
 | Name | Description
Public method | DeleteImage | Deletes an image from the server. Requires canEditSynoptic rights
Public method | ListImages | Gets a list of all the images uploaded to the server
Public method | SaveImage | Uploads an image to the server. Requires canEditSynoptic rights
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ImageManagement Constructor

Initializes a new instance of the ImageManagement class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiController.Get Method

Get Method

The actual Web API function
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


FileStore.GetFile Method

GetFile Method

Gets file info
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ServerCertificateData Constructor

Initializes a new instance of the ServerCertificateData class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpretationSeatMetaRequest.SeatId Property

SeatId Property

Gets or sets the seat identifier.
Syntax
Json
{ Property:SeatId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetAgendaTopicsResponse.AgendaTopics Property

AgendaTopics Property

List of agenda topics.
Syntax
Json
{ Property:AgendaTopics }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpretationRoutingInfo.SeatId Property

SeatId Property

Gets or sets the seat identifier.
Syntax
Json
{ Property:SeatId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.LoadFileRequest.FileId Property

FileId Property

File identifier. Unique identification of the file
Syntax
Json
{ Property:FileId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.HoldVotingResponse Constructor

ConferenceApiHandlerHoldVotingResponse Constructor

Initializes a new instance of the ConferenceApiHandlerHoldVotingResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnMeetingDeskInfoChanged Method

OnMeetingDeskInfoChanged Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


MajorityResultInfo.Inequality Operator

Inequality Operator

Function to comapare two MajorityResultInfo objects are unequal
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


SeatInfo Constructor

Initializes a new instance of the SeatInfo class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Helper Methods

The Helper type exposes the following members.

Methods
Name | Description
TryParseDate |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.IsValidUserId Method

IsValidUserId Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


IConferenceApiMethodCaller Interface

Syntax
Json
{ Interface:IConferenceApiMethodCaller }

The IConferenceApiMethodCaller type exposes the following members.

Properties
 | Name | Description
Public property | LoginRequired |
Top
Methods
 | Name | Description
Public method | Call |
Public method | Initialize |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.CreateRequesterDiscussionListEntry Method

CreateRequesterDiscussionListEntry Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.InterpretationLanguages Property

InterpretationLanguages Property

Syntax
Json
{ Property:InterpretationLanguages }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.CreateFileRequest.Payload Property

Payload Property

The configuration of the layout. The format of the string is defined by the (AngularJs) application. The maximum length of the string is 65KBytes.
Syntax
Json
{ Property:Payload }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


VoteMajorityInfo Properties

The VoteMajorityInfo type exposes the following members.

Properties
 | Name | Description
Public property | IsEnabled | Flag indicates whether majority is enabled for voting.
Public property | MajorityCondition | Majority condition operator ComparisonOperators.
Public property | MajorityDenominatorExpression | Hundred percent settings for majority.
Public property | MajorityNumeratorExpression | In favor for majority.
Public property | MajorityThresholdExpression | Majority threshold to decide whether voting can be approved or not.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.AddPreparedMeetings Method

AddPreparedMeetings Method

Adds prepared meetings
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiAttribute Methods

The ConferenceApiAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetInterpreterSeatsResponse Constructor

ConferenceApiHandlerGetInterpreterSeatsResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetInterpreterSeatsResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiAttribute Properties

The ConferenceApiAttribute type exposes the following members.

Properties
 | Name | Description
Public property | LoginRequired | This field needs to be false to be able to call the method without having logged in
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetSeatsResponse Class

ConferenceApiHandlerGetSeatsResponse Class

Response from GetSeats
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetSeatsResponse
Syntax
Json
{ JsonClass:GetSeatsResponse		Seats:<type>,
 }

The ConferenceApiHandlerGetSeatsResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetSeatsResponse | Initializes a new instance of the ConferenceApiHandlerGetSeatsResponse class
Top
Properties
 | Name | Description
Public property | Seats | List of seats
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RequestSpeechResponse Constructor

ConferenceApiHandlerRequestSpeechResponse Constructor

Initializes a new instance of the ConferenceApiHandlerRequestSpeechResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetMajorityResultResponse Constructor

ConferenceApiHandlerGetMajorityResultResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetMajorityResultResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SelectRelayInterpretationRequest.SeatId Property

SeatId Property

Syntax
Json
{ Property:SeatId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RemoveResponseResponse Class

ConferenceApiHandlerRemoveResponseResponse Class

Represents the removal of requested responder response.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerRemoveResponseResponse
Syntax
Json
{ JsonClass:RemoveResponseResponse	 }

The ConferenceApiHandlerRemoveResponseResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerRemoveResponseResponse | Initializes a new instance of the ConferenceApiHandlerRemoveResponseResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetMajorityResultResponse.MajorityResult Property

MajorityResult Property

Voting majority result
Syntax
Json
{ Property:MajorityResult }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.HasVotingPreparationAndManagementLicense Property

HasVotingPreparationAndManagementLicense Property

Syntax
Json
{ Property:HasVotingPreparationAndManagementLicense }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetSeatVotingResults Method

GetSeatVotingResults Method

Overload List
 | Name | Description
Public method | GetSeatVotingResults | Get seat voting results
Private method | GetSeatVotingResults(ReadOnlyCollectionVotingResult) |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Certificate.ValidateCreateCertificateRequest Method

ValidateCreateCertificateRequest Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


CreateCertificateRequest.ForceAddCertificateToStore Property

ForceAddCertificateToStore Property

Syntax
Json
{ Property:ForceAddCertificateToStore }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.CloseVotingRequest Constructor

ConferenceApiHandlerCloseVotingRequest Constructor

Initializes a new instance of the ConferenceApiHandlerCloseVotingRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.DeleteNotesFilesResponse.Success Property

Success Property

Syntax
Json
{ Property:Success }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateWebClientManageRight Method

UpdateWebClientManageRight Method

Updates manage meeting rights for web client.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


GetRoomContactEmailResponse Properties

The ConferenceApiHandlerGetRoomContactEmailResponse type exposes the following members.

Properties
 | Name | Description
Public property | RoomContactEmail |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SendPluginCommandRequest Class

ConferenceApiHandlerSendPluginCommandRequest Class

Request for sending plugin command.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerSendPluginCommandRequest
Syntax
Json
{ JsonClass:SendPluginCommandRequest		Command:<type>,
    Parameters:<type>,
    PluginName:<type>,
 }

The ConferenceApiHandlerSendPluginCommandRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSendPluginCommandRequest | Initializes a new instance of the ConferenceApiHandlerSendPluginCommandRequest class
Top
Properties
 | Name | Description
Public property | Command | The name of the command
Public property | Parameters | Parameters for command.
Public property | PluginName | The name of the Plugin
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.DeleteSeatMicrophoneSensitivityInfo Method

DeleteSeatMicrophoneSensitivityInfo Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


Certificate.GetSecurePassword Method

GetSecurePassword Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


PluginEventDescription.Name Property

Name Property

Name of the event
Syntax
Json
{ Property:Name }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AssemblyRedirect.Log Method

Log Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DcnmApi.GetParticipantPermissions Method

GetParticipantPermissions Method

Gets participants permissions.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


Certificate.CreateCertificate Method

CreateCertificate Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.DeactivatePresentationResponse Class

ConferenceApiHandlerDeactivatePresentationResponse Class

Represents to deactivate the presentation response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerDeactivatePresentationResponse
Syntax
Json
{ JsonClass:DeactivatePresentationResponse	 }

The ConferenceApiHandlerDeactivatePresentationResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerDeactivatePresentationResponse | Initializes a new instance of the ConferenceApiHandlerDeactivatePresentationResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceException Constructor (String)

Initializes a new instance of the ConferenceException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.CurrentVoting Property

CurrentVoting Property

Contains running voting inro
Syntax
Json
{ Property:CurrentVoting }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.CloseAgendaResponse Class

ConferenceApiHandlerCloseAgendaResponse Class

Represents the close agenda topic response.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerCloseAgendaResponse
Syntax
Json
{ JsonClass:CloseAgendaResponse	 }

The ConferenceApiHandlerCloseAgendaResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerCloseAgendaResponse | Initializes a new instance of the ConferenceApiHandlerCloseAgendaResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SeatParticipants Constructor

Initializes a new instance of the SeatParticipants class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetImageServerInfo Method

GetImageServerInfo Method

Gets ImageServerInfo
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "uri": <uri>
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


RemoveSpeechRequest Properties

The ConferenceApiHandlerRemoveSpeechRequest type exposes the following members.

Properties
 | Name | Description
Public property | ParticipantIds | List of particpant identifiers.
Public property | SeatIds | List of seat identifiers.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetParticipants Method

GetParticipants Method

Gets the participants.
Syntax
Json
Request:

Copy
{
    "meetingId": <string>
}

Response:

Copy
{
    "participants":
    [
        {
            "canPrio": <bool>,
            "canVote": <bool>,
            "country": <string>,
            "email": <string>,
            "firstName": <string>,
            "group": <string>,
            "isAuthenticated": <bool>,
            "lastName": <string>,
            "middleName": <string>,
            "participantId": <string>,
            "participantType": "local"|"remote",
            "personId": <string>,
            "pictureUpdatedNumber": <int>,
            "region": <string>,
            "title": <string>,
            "visType": "none"|"buttonOperated"|"pttOperated",
            "voteWeight": <int>
        }
    ]
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Certificate.AddUsersPermission Method

AddUsersPermission Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetIlluminatedSeatResponse.SeatId Property

SeatId Property

The seat identifier
Syntax
Json
{ Property:SeatId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpreterDeskInfo.DeskNumber Property

DeskNumber Property

Gets or sets the desk number.
Syntax
Json
{ Property:DeskNumber }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GrantResponseRequest.SeatIds Property

SeatIds Property

List of seat identifiers.
Syntax
Json
{ Property:SeatIds }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Participant.MiddleName Property

MiddleName Property

Gets the name of the middle.
Syntax
Json
{ Property:MiddleName }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetInterpretationLanguagesResponse.Languages Property

Languages Property

Gets or sets the interpretation languages.
Syntax
Json
{ Property:Languages }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DeviceInfo.SerialNumber Property

SerialNumber Property

Syntax
Json
{ Property:SerialNumber }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AgendaTopic.State Property

State Property

Gets the state of Agenda
Syntax
Json
{ Property:State }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnMajorityResultUpdated Method

OnMajorityResultUpdated Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetSeatsResponse.Seats Property

Seats Property

List of seats
Syntax
Json
{ Property:Seats }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DiscussionListEntry Class

Contains various states of discussion list entry
Inheritance Hierarchy
SystemObject
SynopticControl.CommonDiscussionListEntry
Syntax
Json
{ JsonClass:DiscussionListEntry		ActiveImage:<type>,
    ActiveVideo:<type>,
    IsFirst:<type>,
    IsLastMinuteActivated:<type>,
    MicrophoneState:<type>,
    ParticipantId:<type>,
    PersonInfoId:<type>,
    RemainingSpeechDuration:<type>,
    ScreenLine:<type>,
    SeatId:<type>,
    ShowSpeechTimer:<type>,
    SpeakerType:<type>,
    SpeechStartTime:<type>,
 }

The DiscussionListEntry type exposes the following members.

Constructors
 | Name | Description
Public method | DiscussionListEntry | Default constructor.
Public method | DiscussionListEntry(Guid, Guid, Guid, String, MicrophoneState, SpeakerType, Int32, Int32, Boolean, Boolean, Boolean) | Initializes a new instance of the DiscussionListEntry class
Top
Properties
 | Name | Description
Public property | ActiveImage | Indicates that participant picture is shown of the speaker.
Public property | ActiveVideo | Indicates that camera is pointed at the speaker.
Public property | IsFirst | Is first waiting speaker.
Public property | IsLastMinuteActivated | Indicates last minute activated state for the seat
Public property | MicrophoneState | Uses DiscussionListState to contains mic state
Public property | ParticipantId | Id of the partcipant
Public property | PersonInfoId | Id of the personinfo of the participant
Public property | RemainingSpeechDuration | Remaining speech duration of the speaker
Public property | ScreenLine | Seat name / participant name
Public property | SeatId | Id of the seat
Public property | ShowSpeechTimer | Indicates that speech time data is shown
Public property | SpeakerType | Uses EnumSpeakerType to contains speaker type
Public property | SpeechStartTime | Start time of the speech
Top
Methods
 | Name | Description
Public method | Clone | Clone the discussion list entry information
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SystemLog.LogEvent Method (TraceEventType, String, Object[])

LogEvent Method (TraceEventType, String, Object)

 Bosch Logo
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.AbortVotingRequest Class

ConferenceApiHandlerAbortVotingRequest Class

Represents the abort voting info request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerAbortVotingRequest
Syntax
Json
{ JsonClass:AbortVotingRequest	 }

The ConferenceApiHandlerAbortVotingRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerAbortVotingRequest | Initializes a new instance of the ConferenceApiHandlerAbortVotingRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.DeactivateMicrophoneRequest.ParticipantIds Property

ParticipantIds Property

List of participant identifiers.
Syntax
Json
{ Property:ParticipantIds }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateHasRemoteSubscriptionLicense Method

UpdateHasRemoteSubscriptionLicense Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


GrantResponseRequest Properties

The ConferenceApiHandlerGrantResponseRequest type exposes the following members.

Properties
 | Name | Description
Public property | ParticipantIds | List of particpant identifiers.
Public property | SeatIds | List of seat identifiers.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SystemLog.TraceError Method (String, Object[])

TraceError Method (String, Object)

 Bosch Logo
Forwards the error event to the trace source.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.CheckNotesFileTamperedRequest.FileName Property

FileName Property

The name of the notes file to check
Syntax
Json
{ Property:FileName }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileInfo.Equals Method (Object)

Equals Method (Object)

 Bosch Logo
Override Equals functuion in IEquatable
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


AgendaTopic.AgendaTopicId Property

AgendaTopicId Property

Gets the agenda topic identifier.
Syntax
Json
{ Property:AgendaTopicId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


CreateCertificateResponse.StoreName Property

StoreName Property

Syntax
Json
{ Property:StoreName }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


QuorumResultInfo.ThresholdValue Property

ThresholdValue Property

Quorum threshold value
Syntax
Json
{ Property:ThresholdValue }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Vote Class

Vote
Inheritance Hierarchy
SystemObject
SynopticControl.CommonVote
Syntax
Json
{ JsonClass:Vote		Answer:<type>,
    Count:<type>,
 }

The Vote type exposes the following members.

Constructors
 | Name | Description
Public method | Vote | Initializes a new instance of the Vote class.
Top
Properties
 | Name | Description
Public property | Answer | Gets the voting answer.
Public property | Count | Gets the count.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdatePreparedMeeting Method

UpdatePreparedMeeting Method

Updates prepared meeting info.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetSystemPowerModeRequest Constructor

ConferenceApiHandlerGetSystemPowerModeRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetSystemPowerModeRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.AcceptVotingRequest Constructor

ConferenceApiHandlerAcceptVotingRequest Constructor

Initializes a new instance of the ConferenceApiHandlerAcceptVotingRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateAutoRelayForBooth Method

UpdateAutoRelayForBooth Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


SystemLog.TraceInfo Method

TraceInfo Method

Overload List
Name | Description
TraceInfo(String) | Forwards the informational event to the trace source.
TraceInfo(String, Object) | Forwards the informational event to the trace source.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


CreateCertificateRequest.DnsNames Property

DnsNames Property

Syntax
Json
{ Property:DnsNames }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Participant.LastName Property

LastName Property

Gets the last name.
Syntax
Json
{ Property:LastName }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GrantSpeechResponse Constructor

ConferenceApiHandlerGrantSpeechResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGrantSpeechResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SeatInfo.HasVotingLicense Property

HasVotingLicense Property

Syntax
Json
{ Property:HasVotingLicense }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


RequestResponseRequest Properties

The ConferenceApiHandlerRequestResponseRequest type exposes the following members.

Properties
 | Name | Description
Public property | ParticipantIds | List of particpant identifiers.
Public property | SeatIds | List of seat identifiers.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SystemLog.TraceInfo Method (String)

TraceInfo Method (String)

 Bosch Logo
Forwards the informational event to the trace source.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


FileStore.GetXmlDataFiles Method

GetXmlDataFiles Method

Gets all stored xml files from data folder
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


VotingAnswer Enumeration

Contains voting answer options
Syntax
Json
VotingAnswer:{
notVoted
yes
no
abstain
dnpv
for
against
present
voteCasted
A
B
C
D}
Members
Member name | Value | Description
notVoted | 0 | No voting answer provided yet
yes | 1 | Voting answer is yes
no | 2 | Voting answer is no
abstain | 3 | Voting answer is abstain
dnpv | 4 | Voting answer is DNPV (Do Not Participate in Vote)
for | 5 | Voting answer is for
against | 6 | Voting answer is against
present | 7 | Voting answer is present
voteCasted | 8 | Vote is casted
A | 9 | Voting answer is A
B | 10 | Voting answer is B
C | 11 | Voting answer is C
D | 12 | Voting answer is D
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ActivateMicrophoneRequest Properties

The ConferenceApiHandlerActivateMicrophoneRequest type exposes the following members.

Properties
 | Name | Description
Public property | ParticipantIds | List of participant identifiers.
Public property | SeatId | Obsolete. The seat identifier.
Public property | SeatIds | List of seat identifiers.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ParticipantSeats Class

Inheritance Hierarchy
SystemObject
SynopticControl.CommonParticipantSeats
Syntax
Json
{ JsonClass:ParticipantSeats		AssignedSeatId:<type>,
    ParticipantId:<type>,
    SeatedSeatId:<type>,
 }

The ParticipantSeats type exposes the following members.

Constructors
 | Name | Description
Public method | ParticipantSeats | Initializes a new instance of the ParticipantSeats class
Top
Properties
 | Name | Description
Public property | AssignedSeatId |
Public property | ParticipantId |
Public property | SeatedSeatId |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DeleteImageRequest Properties

The ConferenceApiHandlerDeleteImageRequest type exposes the following members.

Properties
 | Name | Description
Public property | ImageName | The name of the image.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetSystemPowerModeResponse Constructor

ConferenceApiHandlerGetSystemPowerModeResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetSystemPowerModeResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RegisterEventsResponse Class

ConferenceApiHandlerRegisterEventsResponse Class

Respoonse from RegisterEvents
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerRegisterEventsResponse
Syntax
Json
{ JsonClass:RegisterEventsResponse	 }

The ConferenceApiHandlerRegisterEventsResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerRegisterEventsResponse | Initializes a new instance of the ConferenceApiHandlerRegisterEventsResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GuidConverter.CanConvert Method

CanConvert Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetSupportedHeadphones Method

GetSupportedHeadphones Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.ClearStoredData Method

ClearStoredData Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


NotesFileSearchCriteria.EndDate Property

EndDate Property

End date for the file search in the string format of 'yyyy-MM-dd'
Syntax
Json
{ Property:EndDate }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.PresentationState Property

PresentationState Property

Syntax
Json
{ Property:PresentationState }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SeatInfo Methods

The SeatInfo type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Clone the seat information
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | SetAttributesAndSeatType | Sets the attributes for seats and the type
Public method | SetDevices | Sets the devices
Public method | SetFoundDevices | Sets the found devices
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetSystemPowerModeRequest Class

ConferenceApiHandlerSetSystemPowerModeRequest Class

Parameters to SetSystemPowerModeRequest
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerSetSystemPowerModeRequest
Syntax
Json
{ JsonClass:SetSystemPowerModeRequest		PowerMode:<type>,
 }

The ConferenceApiHandlerSetSystemPowerModeRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetSystemPowerModeRequest | Initializes a new instance of the ConferenceApiHandlerSetSystemPowerModeRequest class
Top
Properties
 | Name | Description
Public property | PowerMode | Power mode
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DeviceInfo Constructor

Default constructor
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Voting.UseVoteWeight Property

UseVoteWeight Property

Flag to set whether participant vote weight considered or not
Syntax
Json
{ Property:UseVoteWeight }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ActivateVotingRequest Constructor

ConferenceApiHandlerActivateVotingRequest Constructor

Initializes a new instance of the ConferenceApiHandlerActivateVotingRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.GetAgendaTopicsForMeeting Method

GetAgendaTopicsForMeeting Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConnectionState.userId Field

userId Field

User id
Syntax
Json
{ Field:userId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Certificate.RemoveCertificateFromLocalMachine Method

RemoveCertificateFromLocalMachine Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetPermissionsRequest Constructor

ConferenceApiHandlerGetPermissionsRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetPermissionsRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpreterDeskInfo.BLanguageId Property

BLanguageId Property

Gets or sets the B language identifier.
Syntax
Json
{ Property:BLanguageId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SelectInterpretationInputLanguageRequest Properties

The ConferenceApiHandlerSelectInterpretationInputLanguageRequest type exposes the following members.

Properties
 | Name | Description
Public property | InputButton |
Public property | LanguageId |
Public property | SeatId |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.GetPreferedDisplayOption Method

GetPreferedDisplayOption Method

Gets the prefered display voting result option among the passed parameters
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


Certificate.SaveRootCertificateFile Method

SaveRootCertificateFile Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UnRegisterPluginRequest Constructor

ConferenceApiHandlerUnRegisterPluginRequest Constructor

Initializes a new instance of the ConferenceApiHandlerUnRegisterPluginRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileStore Properties

The FileStore type exposes the following members.

Properties
Name | Description
Instance | File store instance
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


IConferenceApiMethodCaller Methods

The IConferenceApiMethodCaller type exposes the following members.

Methods
 | Name | Description
Public method | Call |
Public method | Initialize |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetVotingResultsRequest Constructor

ConferenceApiHandlerGetVotingResultsRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetVotingResultsRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.OpenAgendaResponse Constructor

ConferenceApiHandlerOpenAgendaResponse Constructor

Initializes a new instance of the ConferenceApiHandlerOpenAgendaResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler Properties

The ConferenceApiHandler type exposes the following members.

Properties
 | Name | Description
Public property | LoggedIn | Are we currently logged in?
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.CloseAgenda Method

CloseAgenda Method

Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.NotifyBoothNotificationsChangedOnClients Method

NotifyBoothNotificationsChangedOnClients Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


GetPluginCommandsResponse Properties

The ConferenceApiHandlerGetPluginCommandsResponse type exposes the following members.

Properties
 | Name | Description
Public property | PluginCommands | Collection of plugin commands that are waiting to be executed
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetInterpreterSeats Method

GetInterpreterSeats Method

Returns interpreter seats to requested clients.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SaveImageRequest Constructor

ConferenceApiHandlerSaveImageRequest Constructor

Initializes a new instance of the ConferenceApiHandlerSaveImageRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceUsers.GetUserPermission Method

GetUserPermission Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


VotingResult Class

Voting result type
Inheritance Hierarchy
SystemObject
SynopticControl.CommonVotingResult
Syntax
Json
{ JsonClass:VotingResult		seatId:<type>,
    votingAnswer:<type>,
 }

The VotingResult type exposes the following members.

Constructors
 | Name | Description
Public method | VotingResult | Initializes a new instance of the VotingResult class
Top
Properties
 | Name | Description
Public property | seatId | Seat id
Public property | votingAnswer | Voting answer for the seat
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.SelectInputLanguage Method

SelectInputLanguage Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ListFilesResponse Class

ConferenceApiHandlerListFilesResponse Class

Represents the list file response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerListFilesResponse
Syntax
Json
{ JsonClass:ListFilesResponse		FileInfoList:<type>,
 }

The ConferenceApiHandlerListFilesResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerListFilesResponse | Initializes a new instance of the ConferenceApiHandlerListFilesResponse class
Top
Properties
 | Name | Description
Public property | FileInfoList | List of file info
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetVotingsResponse Constructor

ConferenceApiHandlerGetVotingsResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetVotingsResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AgendaTopic.MeetingId Property

MeetingId Property

Gets the meeting identifier.
Syntax
Json
{ Property:MeetingId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ActivateMeetingRequest Class

ConferenceApiHandlerActivateMeetingRequest Class

Represents the activate meeting info request.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerActivateMeetingRequest
Syntax
Json
{ JsonClass:ActivateMeetingRequest		MeetingId:<type>,
 }

The ConferenceApiHandlerActivateMeetingRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerActivateMeetingRequest | Initializes a new instance of the ConferenceApiHandlerActivateMeetingRequest class
Top
Properties
 | Name | Description
Public property | MeetingId | The meeting identifier.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SystemLog.TraceStart Method

TraceStart Method

Logs the start of a method/function/block
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


SystemLog.LogEvent Method

LogEvent Method

Overload List
Name | Description
LogEvent(TraceEventType, String) |
LogEvent(TraceEventType, String, Object) |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.GetSeats Method

GetSeats Method

Get the seat info list
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "seats":
    [
        {
            "assignedParticipantId": <string>,
            "attributes": [<string>],
            "canPrio": <bool>,
            "canVote": <bool>,
            "devices":
            [
                {
                    "capabilities":
                    [
                        "hasNone"|"hasPowerOn"|"hasPowerOff"|"hasVolumeControl"|"hasDualUse"
                    ],
                    "deviceState": "versionMismatch"|"error"|"operational",
                    "id": <string>,
                    "isFoundAtSeat": <bool>,
                    "isSelected": <bool>,
                    "name": <string>,
                    "serialNumber": <string>,
                    "subDeviceInstance": <int>,
                    "typeOf": "unknown"|"standardConferenceDevice"|"interpretationDevice"|"onvifCamera"|"audioPoweringSwitch"|
                        "meetingApplication"|"pTZOnvifCamera"|"videoSwitch"|"externalVideoSwitch"|"presentationDevice"|
                        "poweringSwitch"|"multimediaDevice"|"multimediaDeviceSimulator"|"videoStream"|"oMI"|"discussionDeviceBasic"|
                        "discussionDevice"|"discussionDeviceVoting"|"discussionDeviceLanguageSelection"|"discussionDeviceExtended"|
                        "sonyCameraDevice"|"panasonicCameraDevice"|"interpretationDeviceWithVideo"|"flushDeviceSelectLanguage"|,
                    "version": <string>
                }
            ],
            "foundDevices": [<string>],
            "hasVotingLicense": <bool>,
            "hideSeat": <bool>,
            "screenLine": <string>,
            "seatedParticipantId": <string>,
            "seatId": <string>,
            "seatName": <string>,
            "seatType": "local"|"remote",
            "status": "disconnected"|"connected"|"selected",
            "visType": "none"|"buttonOperated"|"pttOperated"
        }
    ]
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SupportedHeadphoneTypes.Id Property

Id Property

Syntax
Json
{ Property:Id }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetMeetingsRequest Class

ConferenceApiHandlerGetMeetingsRequest Class

Represents the meetings info request.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetMeetingsRequest
Syntax
Json
{ JsonClass:GetMeetingsRequest	 }

The ConferenceApiHandlerGetMeetingsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetMeetingsRequest | Initializes a new instance of the ConferenceApiHandlerGetMeetingsRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateHasParticipantBasedLicense Method

UpdateHasParticipantBasedLicense Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ActivateMicrophoneRequest Class

ConferenceApiHandlerActivateMicrophoneRequest Class

Represents the activation of the microphone request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerActivateMicrophoneRequest
Syntax
Json
{ JsonClass:ActivateMicrophoneRequest		ParticipantIds:<type>,
    SeatId:<type>,
    SeatIds:<type>,
 }

The ConferenceApiHandlerActivateMicrophoneRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerActivateMicrophoneRequest | Initializes a new instance of the ConferenceApiHandlerActivateMicrophoneRequest class
Top
Properties
 | Name | Description
Public property | ParticipantIds | List of participant identifiers.
Public property | SeatId | Obsolete. The seat identifier.
Public property | SeatIds | List of seat identifiers.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DeviceInfo Properties

The DeviceInfo type exposes the following members.

Properties
 | Name | Description
Public property | Capabilities |
Public property | DeviceState |
Public property | Id |
Public property | IsFoundAtSeat |
Public property | IsSelected |
Public property | Name |
Public property | SerialNumber |
Public property | SubDeviceInstance |
Public property | TypeOf |
Public property | Version |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetImageServerInfoResponse Class

ConferenceApiHandlerGetImageServerInfoResponse Class

Represents the get image server info response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetImageServerInfoResponse
Syntax
Json
{ JsonClass:GetImageServerInfoResponse		Uri:<type>,
 }

The ConferenceApiHandlerGetImageServerInfoResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetImageServerInfoResponse | Initializes a new instance of the ConferenceApiHandlerGetImageServerInfoResponse class
Top
Properties
 | Name | Description
Public property | Uri | The uri of the image server
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetPresentationStateResponse Constructor

ConferenceApiHandlerGetPresentationStateResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetPresentationStateResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetMeetingInfoResponse.MeetingInfo Property

MeetingInfo Property

Meeting info
Syntax
Json
{ Property:MeetingInfo }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.NotifyInterpretationLanguagesChangedOnClients Method

NotifyInterpretationLanguagesChangedOnClients Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateActualSpeakerVideo Method

UpdateActualSpeakerVideo Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


Certificate.GetSigningCertificateFromStore Method

GetSigningCertificateFromStore Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ErrorResponse Properties

The ConferenceApiControllerErrorResponse type exposes the following members.

Properties
 | Name | Description
Public property | Message |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetPluginResponse Class

ConferenceApiHandlerGetPluginResponse Class

Response for get plugin request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetPluginResponse
Syntax
Json
{ JsonClass:GetPluginResponse		PluginDescriptionResponse:<type>,
 }

The ConferenceApiHandlerGetPluginResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetPluginResponse | Initializes a new instance of the ConferenceApiHandlerGetPluginResponse class
Top
Properties
 | Name | Description
Public property | PluginDescriptionResponse | Plugin description
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.UpdatePowerStateInformation Method

UpdatePowerStateInformation Method

Updates system power state information
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


InterpretationLanguage.LanguageId Property

LanguageId Property

Gets or sets the language identifier.
Syntax
Json
{ Property:LanguageId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Meeting.Description Property

Description Property

Gets the description.
Syntax
Json
{ Property:Description }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.SetWebClientManageMeetingRights Method

SetWebClientManageMeetingRights Method

Set can manage meeting rights to web client.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


SynopticControl.Diagnostics Namespace

Classes
 | Class | Description
Public class | FileLogTraceListener | Represents a trace listener which writes to a file. Use this trace listener in the app.config file as following:
Public class | SystemLog | Represents a source log for an application to write system related event logs to.
Enumerations
 | Enumeration | Description
Public enumeration | CycleMode | Types of cycle modes.


ConferenceApiHandler.SetMasterVolumeRequest Class

ConferenceApiHandlerSetMasterVolumeRequest Class

Represents the set master volume request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerSetMasterVolumeRequest
Syntax
Json
{ JsonClass:SetMasterVolumeRequest		Volume:<type>,
 }

The ConferenceApiHandlerSetMasterVolumeRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetMasterVolumeRequest | Initializes a new instance of the ConferenceApiHandlerSetMasterVolumeRequest class
Top
Properties
 | Name | Description
Public property | Volume | Gets or sets the volume.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Startup.Configuration Method

Configuration Method

configures Web API. The Startup class is specified as a type parameter in the WebApp.Start method.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiController.ConferenceMessage Class

ConferenceApiControllerConferenceMessage Class

Definition of a conference message
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiControllerConferenceMessage
Syntax
Json
{ JsonClass:ConferenceMessage		messageId:<type>,
    Operation:<type>,
    Parameters:<type>,
 }

The ConferenceApiControllerConferenceMessage type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiControllerConferenceMessage | Initializes a new instance of the ConferenceApiControllerConferenceMessage class
Top
Properties
 | Name | Description
Public property | messageId | Used to match requests with responses
Public property | Operation | The operation to perform, or that has been performed
Public property | Parameters | JSON formated parameters to the operation
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


PluginHandler.PluginEventSubscriptionData.PluginName Property

PluginName Property

Syntax
Json
{ Property:PluginName }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


PluginEventDescription Class

Inheritance Hierarchy
SystemObject
SynopticControl.CommonPluginEventDescription
Syntax
Json
{ JsonClass:PluginEventDescription		Name:<type>,
 }

The PluginEventDescription type exposes the following members.

Constructors
 | Name | Description
Public method | PluginEventDescription | Initializes a new instance of the PluginEventDescription class
Top
Properties
 | Name | Description
Public property | Name | Name of the event
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DocumentVerificationResponse.IsAuthenticatedUsingCertificate Property

IsAuthenticatedUsingCertificate Property

True if the signature failed to authenticate with root certificate on the system.
Syntax
Json
{ Property:IsAuthenticatedUsingCertificate }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.IssueInterpreterMetaFunctionRequest.Request Property

Request Property

Syntax
Json
{ Property:Request }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


QuorumResultInfo Properties

The QuorumResultInfo type exposes the following members.

Properties
 | Name | Description
Public property | ComparisonOperator | Comparision operator used in quorum expression.
Public property | DenominatorValue | Quorum denominator value
Public property | IsEnabled | Indicates whether quorum is enabled
Public property | NumeratorValue | Quorum numerator value
Public property | Status | Quorum reached status
Public property | ThresholdValue | Quorum threshold value
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


NotesFileType Enumeration

Notes file type
Syntax
Json
NotesFileType:{
Unknown
Meeting
Voting}
Members
Member name | Value | Description
Unknown | 0 | Represent file type is unknown
Meeting | 1 | Represents file is meeting notes xml.
Voting | 2 | Represents file is voting notes xml.
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.Initialize Method

Initialize Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.MakeSeatMicrophoneSensitivityListAndNotifyChange Method

MakeSeatMicrophoneSensitivityListAndNotifyChange Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetMicrophoneSensitivityRequest Constructor

ConferenceApiHandlerGetMicrophoneSensitivityRequest Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerGetMicrophoneSensitivityRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileInfo Operators

The FileInfo type exposes the following members.

Operators
Name | Description
Equality | Function to comapare two file info objects are equal
Inequality | Function to comapare two file info objects are unequal
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileLogTraceListener.Flush Method

Flush Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RemoveResponseRequest.ParticipantIds Property

ParticipantIds Property

List of particpant identifiers.
Syntax
Json
{ Property:ParticipantIds }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.GetPlugin Method

GetPlugin Method

Syntax
Json
Request:

Copy
{
    "pluginName": <string>
}

Response:

Copy
{
    "pluginDescriptionResponse":
    {
        "commands":
        [
            {
                "name": <string>
            }
        ],
        "events":
        [
            {
                "name": <string>
            }
        ],
        "interface": <string>,
        "name": <string>
    }
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


PluginHandler.SubscribePluginEvents Method

SubscribePluginEvents Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetTotalCastVoteResult Method (ReadOnlyCollection(Vote))

GetTotalCastVoteResult Method (ReadOnlyCollectionVote)

 Bosch Logo
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


Participant.Group Property

Group Property

Gets the group.
Syntax
Json
{ Property:Group }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Certificate.AddCertificateToStore Method

AddCertificateToStore Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


SeatInfo.SeatType Property

SeatType Property

The participant seat type.
Syntax
Json
{ Property:SeatType }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SelectRelayInterpretationRequest Properties

The ConferenceApiHandlerSelectRelayInterpretationRequest type exposes the following members.

Properties
 | Name | Description
Public property | SeatId |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.HasHybridLicense Property

HasHybridLicense Property

Syntax
Json
{ Property:HasHybridLicense }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SeatInfo.HideSeat Property

HideSeat Property

Indicates seat visibility
Syntax
Json
{ Property:HideSeat }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.GetMaximumMicrophoneSensitivity Method

GetMaximumMicrophoneSensitivity Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiController.ConferenceMessage.Parameters Property

Parameters Property

JSON formated parameters to the operation
Syntax
Json
{ Property:Parameters }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetInterpretationRoutingsRequest Constructor

ConferenceApiHandlerGetInterpretationRoutingsRequest Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerGetInterpretationRoutingsRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpretationRoutingInfo.GetHashCode Method

GetHashCode Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


SeatParticipants Properties

The SeatParticipants type exposes the following members.

Properties
 | Name | Description
Public property | AssignedParticipantId |
Public property | SeatedParticipantId |
Public property | SeatId |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


MicrophoneSensitivity.SensitivityValue Property

SensitivityValue Property

Sensitivity value.
Syntax
Json
{ Property:SensitivityValue }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetParticipantsResponse Constructor

ConferenceApiHandlerGetParticipantsResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetParticipantsResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetIndividualVotingResults Method (ReadOnlyCollection(IndividualVotingResult))

GetIndividualVotingResults Method (ReadOnlyCollectionIndividualVotingResult)

 Bosch Logo
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "votingResults":
    [
        {
            "participantId": <string>,
            "votingAnswer": "notVoted"|"yes"|"no"|"abstain"|"dnpv"|"for"|"against"|"present"|"voteCasted"|"A"|"B"|"C"|"D"
        }
    ]
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetParticipantsRequest Class

ConferenceApiHandlerGetParticipantsRequest Class

Represents the request for get participant.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetParticipantsRequest
Syntax
Json
{ JsonClass:GetParticipantsRequest		MeetingId:<type>,
 }

The ConferenceApiHandlerGetParticipantsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetParticipantsRequest | Initializes a new instance of the ConferenceApiHandlerGetParticipantsRequest class
Top
Properties
 | Name | Description
Public property | MeetingId | The meeting identifier.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetMicrophoneSensitivityRequest Class

ConferenceApiHandlerGetMicrophoneSensitivityRequest Class

Get microphone sensitivity request.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetMicrophoneSensitivityRequest
Syntax
Json
{ JsonClass:GetMicrophoneSensitivityRequest		SeatIds:<type>,
 }

The ConferenceApiHandlerGetMicrophoneSensitivityRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetMicrophoneSensitivityRequest | Initializes a new instance of the ConferenceApiHandlerGetMicrophoneSensitivityRequest class
Top
Properties
 | Name | Description
Public property | SeatIds | List of seat ids to get sensitivity. It the list count is 0 then will retrieve all the seat microphone sensitivity in the system.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


IConferenceConnection Methods

The IConferenceConnection type exposes the following members.

Methods
 | Name | Description
Public method | SendEvent | Send an event to a client
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RaiseBoothNotificationResponse Class

ConferenceApiHandlerRaiseBoothNotificationResponse Class

Represents the raise notifications on a booth response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerRaiseBoothNotificationResponse
Syntax
Json
{ JsonClass:RaiseBoothNotificationResponse	 }

The ConferenceApiHandlerRaiseBoothNotificationResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerRaiseBoothNotificationResponse | Initializes a new instance of the ConferenceApiHandlerRaiseBoothNotificationResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetPluginsResponse.Plugins Property

Plugins Property

The collection of names of plugin
Syntax
Json
{ Property:Plugins }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpreterBoothInfo Constructor

Initializes a new instance of the InterpreterBoothInfo class.
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.GetDeviceInfo Method

GetDeviceInfo Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.RequestAttendanceInfo Method

RequestAttendanceInfo Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetVotingsRequest Class

ConferenceApiHandlerGetVotingsRequest Class

Represents the info voting request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetVotingsRequest
Syntax
Json
{ JsonClass:GetVotingsRequest		MeetingId:<type>,
 }

The ConferenceApiHandlerGetVotingsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetVotingsRequest | Initializes a new instance of the ConferenceApiHandlerGetVotingsRequest class
Top
Properties
 | Name | Description
Public property | MeetingId | The meeting identifier.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.SeatMicrophoneSensitivityList Property

SeatMicrophoneSensitivityList Property

Syntax
Json
{ Property:SeatMicrophoneSensitivityList }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.Initialize Method

Initialize Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DcnmApi.UpdateMicrophoneSensitivity Method

UpdateMicrophoneSensitivity Method

Syntax
Json
Request:

Copy
{
    "seatMicrophoneSensitivity":
    [
        {
            "seatId": <string>,
            "seatName": <string>,
            "sensitivityValue": <int>
        }
    ]
}

Response:

Copy
{
    "status": <bool>
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetDiscussionOptionsResponse.MaxRequests Property

MaxRequests Property

Holds max requests for current discussion.
Syntax
Json
{ Property:MaxRequests }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.LoginRequest Class

ConferenceApiHandlerLoginRequest Class

Parameters to Login
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerLoginRequest
Syntax
Json
{ JsonClass:LoginRequest		Password:<type>,
    Token:<type>,
    User:<type>,
 }

The ConferenceApiHandlerLoginRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerLoginRequest | Initializes a new instance of the ConferenceApiHandlerLoginRequest class
Top
Properties
 | Name | Description
Public property | Password | Password
Public property | Token |
Public property | User | User name
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ResetMicrophoneSensitivityResponse.Status Property

Status Property

Status after sending request to resetting microphone sensitivity for all seats.
Syntax
Json
{ Property:Status }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetIlluminatedSeatId Method

GetIlluminatedSeatId Method

Gets Guid of the illuminated seat
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


MasterVolumeRange.MinimumVolume Property

MinimumVolume Property

Gets or sets the minimum volume.
Syntax
Json
{ Property:MinimumVolume }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Meeting.AutoOpenOnActivate Property

AutoOpenOnActivate Property

Syntax
Json
{ Property:AutoOpenOnActivate }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.DeactivateMeetingResponse Class

ConferenceApiHandlerDeactivateMeetingResponse Class

Represents the deactivate meeting info response.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerDeactivateMeetingResponse
Syntax
Json
{ JsonClass:DeactivateMeetingResponse	 }

The ConferenceApiHandlerDeactivateMeetingResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerDeactivateMeetingResponse | Initializes a new instance of the ConferenceApiHandlerDeactivateMeetingResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetVotingStateResponse.VotingState Property

VotingState Property

Voting state
Syntax
Json
{ Property:VotingState }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.Votes Property

Votes Property

Syntax
Json
{ Property:Votes }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SendPluginCommandRequest.Parameters Property

Parameters Property

Parameters for command.
Syntax
Json
{ Property:Parameters }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetParticipantAccessDeniedReasonsResponse Constructor

ConferenceApiHandlerGetParticipantAccessDeniedReasonsResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerGetParticipantAccessDeniedReasonsResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceMessage Properties

The ConferenceApiControllerConferenceMessage type exposes the following members.

Properties
 | Name | Description
Public property | messageId | Used to match requests with responses
Public property | Operation | The operation to perform, or that has been performed
Public property | Parameters | JSON formated parameters to the operation
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.LoginRequest.Password Property

Password Property

Password
Syntax
Json
{ Property:Password }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.CurrentActiveMeetingId Property

CurrentActiveMeetingId Property

Gets or sets the current active meeting identifier.
Syntax
Json
{ Property:CurrentActiveMeetingId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceException Constructor

Initializes a new instance of the ConferenceException class.
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiController.HandleMessage0 Method

HandleMessage0 Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


SupportedHeadphoneTypes Constructor

Initializes a new instance of the SupportedHeadphoneTypes class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SystemLog.LogEvent Method (TraceEventType, String)

LogEvent Method (TraceEventType, String)

 Bosch Logo
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DcnmApi.SelectRelay Method

SelectRelay Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ActivatePresentationRequest Constructor

ConferenceApiHandlerActivatePresentationRequest Constructor

Initializes a new instance of the ConferenceApiHandlerActivatePresentationRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetRoomNameRequest Constructor

ConferenceApiHandlerGetRoomNameRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetRoomNameRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.CloseVotingResponse Class

ConferenceApiHandlerCloseVotingResponse Class

Represents the close voting info response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerCloseVotingResponse
Syntax
Json
{ JsonClass:CloseVotingResponse	 }

The ConferenceApiHandlerCloseVotingResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerCloseVotingResponse | Initializes a new instance of the ConferenceApiHandlerCloseVotingResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetIndividualVotingResults Method

GetIndividualVotingResults Method

Overload List
 | Name | Description
Public method | GetIndividualVotingResults | Get participant voting result
Private method | GetIndividualVotingResults(ReadOnlyCollectionIndividualVotingResult) |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UnRegisterPluginResponse Class

ConferenceApiHandlerUnRegisterPluginResponse Class

Unregister plugin response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerUnRegisterPluginResponse
Syntax
Json
{ JsonClass:UnRegisterPluginResponse	 }

The ConferenceApiHandlerUnRegisterPluginResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerUnRegisterPluginResponse | Initializes a new instance of the ConferenceApiHandlerUnRegisterPluginResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AgendaTopic.Description Property

Description Property

Gets the description.
Syntax
Json
{ Property:Description }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


CycleMode Enumeration

Types of cycle modes.
Syntax
Json
CycleMode:{
None
EachDay
EachWeek
EachMonth}
Members
Member name | Value | Description
None | 0 | No cycle mode
EachDay | 1 | Log file cycle mode each day
EachWeek | 2 | Log file cycle mode each week
EachMonth | 3 | Log file cycle mode each month
Remarks
The default cycle is no cycle. The following cycles are supported:
value | Description
null (not defined in config file) | The destination file does not follow a cycle and shall grow to the disk limit.
Day | The destination file cycles each day within a month. This implies that there will be maximum 31 file created.
Week | The destination file cycles each week with the the year. This implies that there will be maximum 53 files created.
Month | The destination file cycles each month with the the year. This implies that there will be maximum 12 files created.
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetMicrophoneSensitivityDescriptionRequest Class

ConferenceApiHandlerGetMicrophoneSensitivityDescriptionRequest Class

 Bosch Logo
Microphone sensitivity description request.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetMicrophoneSensitivityDescriptionRequest
Syntax
Json
{ JsonClass:GetMicrophoneSensitivityDescriptionRequest	 }

The ConferenceApiHandlerGetMicrophoneSensitivityDescriptionRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetMicrophoneSensitivityDescriptionRequest | Initializes a new instance of the ConferenceApiHandlerGetMicrophoneSensitivityDescriptionRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ActivateMicrophoneResponse Constructor

ConferenceApiHandlerActivateMicrophoneResponse Constructor

Initializes a new instance of the ConferenceApiHandlerActivateMicrophoneResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateBoothAreas Method

UpdateBoothAreas Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateParticipantPictureUpdatedNumber Method

UpdateParticipantPictureUpdatedNumber Method

Update participant picture number for partcipant
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


VoteMajorityInfo.Equals Method

Equals Method

Function to compare one VoteMajorityInfo object with other
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RequestResponseRequest.ParticipantIds Property

ParticipantIds Property

List of particpant identifiers.
Syntax
Json
{ Property:ParticipantIds }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetSupportedHeadphonesRequest Constructor

ConferenceApiHandlerGetSupportedHeadphonesRequest Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerGetSupportedHeadphonesRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateResponseRequestList Method

UpdateResponseRequestList Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


LoadFileRequest Properties

The ConferenceApiHandlerLoadFileRequest type exposes the following members.

Properties
 | Name | Description
Public property | FileId | File identifier. Unique identification of the file
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpreterDeskInfo Class

Contains interpreter desk information.
Inheritance Hierarchy
SystemObject
SynopticControl.CommonInterpreterDeskInfo
Syntax
Json
{ JsonClass:InterpreterDeskInfo		ALanguageId:<type>,
    AutomaticMicrophoneSelection:<type>,
    BLanguageId:<type>,
    BLanguageList:<type>,
    BoothId:<type>,
    CLanguageId:<type>,
    CLanguageList:<type>,
    DeskNumber:<type>,
    DeskType:<type>,
    Headphone:<type>,
    SeatId:<type>,
    Status:<type>,
 }

The InterpreterDeskInfo type exposes the following members.

Constructors
 | Name | Description
Public method | InterpreterDeskInfo | Initializes a new instance of the InterpreterDeskInfo class.
Public method | InterpreterDeskInfo(Guid, Guid, Int32, EnumDeskType, ValueTupleSupportedHeadphoneTypes, Boolean) | Initializes a new instance of the InterpreterDeskInfo class.
Top
Properties
 | Name | Description
Public property | ALanguageId | Gets or sets the A language identifier.
Public property | AutomaticMicrophoneSelection |
Public property | BLanguageId | Gets or sets the B language identifier.
Public property | BLanguageList | Gets the B language list.
Public property | BoothId | Gets or sets the booth identifier.
Public property | CLanguageId | Gets or sets the C language identifier.
Public property | CLanguageList | Gets the C language list.
Public property | DeskNumber | Gets or sets the desk number.
Public property | DeskType | Gets the type of desk.
Public property | Headphone |
Public property | SeatId | Gets or sets the seat identifier.
Public property | Status | Gets or sets the status.
Top
Methods
 | Name | Description
Public method | Clone | handles clone
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | SetBLanguageList | Sets the B language list.
Public method | SetCLanguageList | Sets the C language list.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Certificate.AddUsersReadPermissionsForCertificate Method (String, String, Boolean)

AddUsersReadPermissionsForCertificate Method (String, String, Boolean)

 Bosch Logo
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


MajorityResultInfo.Equals Method (Object)

Equals Method (Object)

 Bosch Logo
Override Equals function in IEquatable
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.GetSupportedHeadphones Method

GetSupportedHeadphones Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.StartSpeechTimer Method

StartSpeechTimer Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


Participant.ParticipantId Property

ParticipantId Property

Gets the identifier.
Syntax
Json
{ Property:ParticipantId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


VoteMajorityInfo Constructor

Class holds voting majority information.
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RequestResponseRequest Constructor

ConferenceApiHandlerRequestResponseRequest Constructor

Initializes a new instance of the ConferenceApiHandlerRequestResponseRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RemoveSeatFromDiscussionListRequest Class

ConferenceApiHandlerRemoveSeatFromDiscussionListRequest Class

 Bosch Logo
Represents the removal of seat from discussion list request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerRemoveSeatFromDiscussionListRequest
Syntax
Json
{ JsonClass:RemoveSeatFromDiscussionListRequest		SeatId:<type>,
 }

The ConferenceApiHandlerRemoveSeatFromDiscussionListRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerRemoveSeatFromDiscussionListRequest | Initializes a new instance of the ConferenceApiHandlerRemoveSeatFromDiscussionListRequest class
Top
Properties
 | Name | Description
Public property | SeatId | The seat identifier.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetMasterVolumeResponse Class

ConferenceApiHandlerSetMasterVolumeResponse Class

Represents the set master volume response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerSetMasterVolumeResponse
Syntax
Json
{ JsonClass:SetMasterVolumeResponse	 }

The ConferenceApiHandlerSetMasterVolumeResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetMasterVolumeResponse | Initializes a new instance of the ConferenceApiHandlerSetMasterVolumeResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.DeleteNotesFilesRequest Class

ConferenceApiHandlerDeleteNotesFilesRequest Class

Defines delete notes file request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerDeleteNotesFilesRequest
Syntax
Json
{ JsonClass:DeleteNotesFilesRequest		FileNames:<type>,
 }

The ConferenceApiHandlerDeleteNotesFilesRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerDeleteNotesFilesRequest | Initializes a new instance of the ConferenceApiHandlerDeleteNotesFilesRequest class
Top
Properties
 | Name | Description
Public property | FileNames | The collection of file names to delete
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Meeting.AgendaList Property

AgendaList Property

Gets the agenda list.
Syntax
Json
{ Property:AgendaList }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateActualSpeakerDetails Method

UpdateActualSpeakerDetails Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.DetermineVoteCastedVisiblityForUser Method

DetermineVoteCastedVisiblityForUser Method

Determine vote casted visibility for user
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


PluginHandler.HandleRemoveConnection Method

HandleRemoveConnection Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


GetMicrophoneSensitivityResponse Properties

The ConferenceApiHandlerGetMicrophoneSensitivityResponse type exposes the following members.

Properties
 | Name | Description
Public property | SeatMicrophoneSensitivities | List of seat ids with sensitivity value MicrophoneSensitivity.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiController.CreateSerializerSettings Method

CreateSerializerSettings Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


Certificate.CertificateToPfx Method

CertificateToPfx Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DcnmApi.RaiseBoothNotification Method

RaiseBoothNotification Method

Syntax
Json
Request:

Copy
{
    "boothId": <string>,
    "notification": <string>
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiController.ErrorResponse.Message Property

Message Property

Syntax
Json
{ Property:Message }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ApiClient.ServerAddress Property

ServerAddress Property

Syntax
Json
{ Property:ServerAddress }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiController.ConferenceMessage.Operation Property

Operation Property

The operation to perform, or that has been performed
Syntax
Json
{ Property:Operation }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetRoomContactEmailResponse Class

ConferenceApiHandlerGetRoomContactEmailResponse Class

Response from GetRoomContactEmail.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetRoomContactEmailResponse
Syntax
Json
{ JsonClass:GetRoomContactEmailResponse		RoomContactEmail:<type>,
 }

The ConferenceApiHandlerGetRoomContactEmailResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetRoomContactEmailResponse | Initializes a new instance of the ConferenceApiHandlerGetRoomContactEmailResponse class
Top
Properties
 | Name | Description
Public property | RoomContactEmail |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ICertificateWrapper.GetCertificate Method

GetCertificate Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DcnmApi.TransformNotesFile Method

TransformNotesFile Method

Syntax
Json
Request:

Copy
{
    "fileName": <string>
}

Response:

Copy
{
    "notesHtml": <string>
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateSeatedParticipantInfoOnSeat Method

UpdateSeatedParticipantInfoOnSeat Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DeviceInfo.SubDeviceInstance Property

SubDeviceInstance Property

Syntax
Json
{ Property:SubDeviceInstance }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RemoveSpeechRequest.SeatIds Property

SeatIds Property

List of seat identifiers.
Syntax
Json
{ Property:SeatIds }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.DeleteBoothArea Method

DeleteBoothArea Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetInterpretationOutputPresetRequest.SeatId Property

SeatId Property

Syntax
Json
{ Property:SeatId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


PluginEventDescription Properties

The PluginEventDescription type exposes the following members.

Properties
 | Name | Description
Public property | Name | Name of the event
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpretationSeatMetaRequest.GetHashCode Method

GetHashCode Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DcnmApi.DeleteNotesFiles Method

DeleteNotesFiles Method

Syntax
Json
Request:

Copy
{
    "fileNames": [<string>]
}

Response:

Copy
{
    "success": <bool>
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LogOnModel Class

Defines model for login
Inheritance Hierarchy
SystemObject
SynopticControl.CommonLogOnModel
Syntax
Json
{ JsonClass:LogOnModel		name:<type>,
    password:<type>,
 }

The LogOnModel type exposes the following members.

Constructors
 | Name | Description
Public method | LogOnModel | Initializes a new instance of the LogOnModel class
Top
Properties
 | Name | Description
Public property | name | Login user name
Public property | password | Login password
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Certificate.ExportChainedCertificatePfx Method

ExportChainedCertificatePfx Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetSeatsRequest Constructor

ConferenceApiHandlerGetSeatsRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetSeatsRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


MicrophoneSensitivityDescription Class

Inheritance Hierarchy
SystemObject
SynopticControl.CommonMicrophoneSensitivityDescription
Syntax
Json
{ JsonClass:MicrophoneSensitivityDescription		MaximumMicrophoneSensitivity:<type>,
    MicrophoneSensitivityStepSize:<type>,
    MinimumMicrophoneSensitivity:<type>,
 }

The MicrophoneSensitivityDescription type exposes the following members.

Constructors
 | Name | Description
Public method | MicrophoneSensitivityDescription | Initializes a new instance of the MicrophoneSensitivityDescription class
Top
Properties
 | Name | Description
Public property | MaximumMicrophoneSensitivity | Maximum microphone sensitivity.
Public property | MicrophoneSensitivityStepSize | Microphone sensitivity step size.
Public property | MinimumMicrophoneSensitivity | Minimum microphone sensitivity.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.HasParticipantBasedLicense Property

HasParticipantBasedLicense Property

Syntax
Json
{ Property:HasParticipantBasedLicense }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.UpdateSeatsInfo Method

UpdateSeatsInfo Method

Updated seats information for default meeting.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetInterpretationLanguagesResponse Class

ConferenceApiHandlerGetInterpretationLanguagesResponse Class

Represents the get interpretation languages response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetInterpretationLanguagesResponse
Syntax
Json
{ JsonClass:GetInterpretationLanguagesResponse		Languages:<type>,
 }

The ConferenceApiHandlerGetInterpretationLanguagesResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetInterpretationLanguagesResponse | Initializes a new instance of the ConferenceApiHandlerGetInterpretationLanguagesResponse class
Top
Properties
 | Name | Description
Public property | Languages | Gets or sets the interpretation languages.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.CloseAgendaRequest Class

ConferenceApiHandlerCloseAgendaRequest Class

Represents the close agenda topic request.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerCloseAgendaRequest
Syntax
Json
{ JsonClass:CloseAgendaRequest	 }

The ConferenceApiHandlerCloseAgendaRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerCloseAgendaRequest | Initializes a new instance of the ConferenceApiHandlerCloseAgendaRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


MicrophoneSensitivity.SeatId Property

SeatId Property

seat id.
Syntax
Json
{ Property:SeatId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Participant.FirstName Property

FirstName Property

Gets the first name.
Syntax
Json
{ Property:FirstName }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileLogTraceListener.DetermineLogFileName Method

DetermineLogFileName Method

Determine the log file name which depends on the configured Cycle attribute of the FileLogListener
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetAgendaTopicsResponse Class

ConferenceApiHandlerGetAgendaTopicsResponse Class

Represents the agenda topic response.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetAgendaTopicsResponse
Syntax
Json
{ JsonClass:GetAgendaTopicsResponse		AgendaTopics:<type>,
 }

The ConferenceApiHandlerGetAgendaTopicsResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetAgendaTopicsResponse | Initializes a new instance of the ConferenceApiHandlerGetAgendaTopicsResponse class
Top
Properties
 | Name | Description
Public property | AgendaTopics | List of agenda topics.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.CreateFileRequest.Attributes Property

Attributes Property

Attribute indicating file type and can only have values "synoptic" or "index"
Syntax
Json
{ Property:Attributes }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DiscussionListEntry.ActiveVideo Property

ActiveVideo Property

Indicates that camera is pointed at the speaker.
Syntax
Json
{ Property:ActiveVideo }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ResetMicrophoneSensitivityResponse Properties

The ConferenceApiHandlerResetMicrophoneSensitivityResponse type exposes the following members.

Properties
 | Name | Description
Public property | Status | Status after sending request to resetting microphone sensitivity for all seats.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ServerCertificateData Class

Inheritance Hierarchy
SystemObject
Bosch.SecurityServerCertificateData
Syntax
Json
{ JsonClass:ServerCertificateData		PrivatePfx:<type>,
    RootCertificateCrt:<type>,
    RootCertificateFriendlyName:<type>,
 }

The ServerCertificateData type exposes the following members.

Constructors
 | Name | Description
Public method | ServerCertificateData | Initializes a new instance of the ServerCertificateData class
Top
Properties
 | Name | Description
Public property | PrivatePfx |
Public property | RootCertificateCrt |
Public property | RootCertificateFriendlyName |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.EventResponse.Events Property

Events Property

List of events
Syntax
Json
{ Property:Events }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetTotalCastVoteResult Method

GetTotalCastVoteResult Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


MicrophoneSensitivityDescription.MaximumMicrophoneSensitivity Property

MaximumMicrophoneSensitivity Property

Maximum microphone sensitivity.
Syntax
Json
{ Property:MaximumMicrophoneSensitivity }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.OpenMeetingRequest Constructor

ConferenceApiHandlerOpenMeetingRequest Constructor

Initializes a new instance of the ConferenceApiHandlerOpenMeetingRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetParticipantSeats Method

GetParticipantSeats Method

Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "participantSeats":
    [
        {
            "assignedSeatId": <string>,
            "participantId": <string>,
            "seatedSeatId": <string>
        }
    ]
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConnectionState Class

Inheritance Hierarchy
SystemObject
SynopticControl.CommonConnectionState
Syntax
Json
{ JsonClass:ConnectionState	 }

The ConnectionState type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionState | Initializes a new instance of the ConnectionState class
Top
Fields
 | Name | Description
Public field | eventSent |
Public field | eventWhiteList |
Public field | uniqueConnectionId |
Public field | userId | User id
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.DeleteImageRequest Constructor

ConferenceApiHandlerDeleteImageRequest Constructor

Initializes a new instance of the ConferenceApiHandlerDeleteImageRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetIndividualCastVoteResults Method

GetIndividualCastVoteResults Method

Get seat individual cast vote results
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


InterpreterDeskInfo Methods

The InterpreterDeskInfo type exposes the following members.

Methods
 | Name | Description
Public method | Clone | handles clone
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | SetBLanguageList | Sets the B language list.
Public method | SetCLanguageList | Sets the C language list.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GuidConverter.WriteJson Method

WriteJson Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DcnmApi Constructor

Initializes the static fields of the DcnmApi class
Syntax
Json
{ Constructor:.cctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.SendPluginCommand Method

SendPluginCommand Method

Syntax
Json
Request:

Copy
{
    "command": <string>,
    "parameters": <string>,
    "pluginName": <string>
}

Response:

Copy
{
    "response": <string>
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetVotingsRequest Properties

The ConferenceApiHandlerGetVotingsRequest type exposes the following members.

Properties
 | Name | Description
Public property | MeetingId | The meeting identifier.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpreterDeskInfo.BoothId Property

BoothId Property

Gets or sets the booth identifier.
Syntax
Json
{ Property:BoothId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.GetMicrophoneSensitivity Method

GetMicrophoneSensitivity Method

Syntax
Json
Request:

Copy
{
    "seatIds": [<string>]
}

Response:

Copy
{
    "seatMicrophoneSensitivities":
    [
        {
            "seatId": <string>,
            "seatName": <string>,
            "sensitivityValue": <int>
        }
    ]
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetMaxRequests Method

GetMaxRequests Method

Returns max requests for current discussion.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetBoothNotificationsResponse.Notifications Property

Notifications Property

Gets or sets the booth notifications.
Syntax
Json
{ Property:Notifications }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


PluginHandler.PluginEventSubscriptionData Class

PluginHandlerPluginEventSubscriptionData Class

Inheritance Hierarchy
SystemObject
SynopticControl.ServerPluginHandlerPluginEventSubscriptionData
Syntax
Json
{ JsonClass:PluginEventSubscriptionData		ConnectionId:<type>,
    EventName:<type>,
    PluginName:<type>,
 }

The PluginHandlerPluginEventSubscriptionData type exposes the following members.

Constructors
 | Name | Description
Public method | PluginHandlerPluginEventSubscriptionData | Initializes a new instance of the PluginHandlerPluginEventSubscriptionData class
Top
Properties
 | Name | Description
Public property | ConnectionId |
Public property | EventName |
Public property | PluginName |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.DetermineTotalVotesCastedVisibilityForUser Method

DetermineTotalVotesCastedVisibilityForUser Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DcnmApi.OnInterpretationLanguagesChanged Method

OnInterpretationLanguagesChanged Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetPluginsResponse Class

ConferenceApiHandlerGetPluginsResponse Class

Response for get plugins request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetPluginsResponse
Syntax
Json
{ JsonClass:GetPluginsResponse		Plugins:<type>,
 }

The ConferenceApiHandlerGetPluginsResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetPluginsResponse | Initializes a new instance of the ConferenceApiHandlerGetPluginsResponse class
Top
Properties
 | Name | Description
Public property | Plugins | The collection of names of plugin
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.LogoutRequest Constructor

ConferenceApiHandlerLogoutRequest Constructor

Initializes a new instance of the ConferenceApiHandlerLogoutRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SeatInfo.Devices Property

Devices Property

The list of assigned Devices.
Syntax
Json
{ Property:Devices }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConnectionTracker.SendEvent Method (ConferenceEvent)

SendEvent Method (ConferenceEvent)

 Bosch Logo
Send events to all clients
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DcnmApi.ResumeVoting Method

ResumeVoting Method

Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SeatParticipants Class

Inheritance Hierarchy
SystemObject
SynopticControl.CommonSeatParticipants
Syntax
Json
{ JsonClass:SeatParticipants		AssignedParticipantId:<type>,
    SeatedParticipantId:<type>,
    SeatId:<type>,
 }

The SeatParticipants type exposes the following members.

Constructors
 | Name | Description
Public method | SeatParticipants | Initializes a new instance of the SeatParticipants class
Top
Properties
 | Name | Description
Public property | AssignedParticipantId |
Public property | SeatedParticipantId |
Public property | SeatId |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileLogTraceListener.CycleMode Property

CycleMode Property

Return configured cycle mode of the FileLogTraceListener
Syntax
Json
{ Property:CycleMode }
Remarks
Because the FileLogTraceListener is created during startup there is no initialization hook to convert the cycle string to a mode. Initialization is therefor done here when this function is first called.
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ActivateMeetingRequest.MeetingId Property

MeetingId Property

The meeting identifier.
Syntax
Json
{ Property:MeetingId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnPriorityListChanged Method

OnPriorityListChanged Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


InterpreterDeskInfo.SetCLanguageList Method

SetCLanguageList Method

Sets the C language list.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConnectionTracker.SendEvent Method

SendEvent Method

Overload List
 | Name | Description
Public method | SendEvent(ConferenceEvent) | Send events to all clients
Public method | SendEvent(Guid, ConferenceEvent) | Send events to all clients where a specific user is logged in
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetPluginCommandResultRequest.Result Property

Result Property

The result of the command execution
Syntax
Json
{ Property:Result }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetIndividualParticipantCastVoteResults Method

GetIndividualParticipantCastVoteResults Method

Get participant individual cast vote results
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


AssemblyRedirect Class

Redirects assembly loads to the installation folder.
Inheritance Hierarchy
SystemObject
Bosch.Operational.AssemblyLoadingAssemblyRedirect
Syntax
Json
{ JsonClass:AssemblyRedirect	 }

The AssemblyRedirect type exposes the following members.

Constructors
 | Name | Description
 | AssemblyRedirect | Default constructor for class. Load all dependent assemblies immediately and get them from the location I expect them to be in .Net ensures that this static constructor only gets called once
Public method | AssemblyRedirect | Initializes a new instance of the AssemblyRedirect class
Top
Methods
Name | Description
Initialize | Ensure that this class is initialized
LoadAssembly | Load a single assembly and its dependents into memory
LoadDependentsForAssembly | Load a DLL and all its dependents
Log |
OnAssemblyResolve | Event handler called when a new assembly is resolved
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.Dispose Method

Dispose Method

Releases all resources used by the DcnmApi
Syntax
Json
Implements
IDisposableDispose
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


SystemLog.TraceVerbose Method (String)

TraceVerbose Method (String)

 Bosch Logo
Forwards the informational event to the trace source.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.DeleteImageRequest Class

ConferenceApiHandlerDeleteImageRequest Class

Represents the delete image request.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerDeleteImageRequest
Syntax
Json
{ JsonClass:DeleteImageRequest		ImageName:<type>,
 }

The ConferenceApiHandlerDeleteImageRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerDeleteImageRequest | Initializes a new instance of the ConferenceApiHandlerDeleteImageRequest class
Top
Properties
 | Name | Description
Public property | ImageName | The name of the image.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetInterpretationRoutingsResponse Constructor

ConferenceApiHandlerGetInterpretationRoutingsResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerGetInterpretationRoutingsResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GrantResponseRequest.ParticipantIds Property

ParticipantIds Property

List of particpant identifiers.
Syntax
Json
{ Property:ParticipantIds }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnMeetingDeleted Method

OnMeetingDeleted Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModelReader.GrantSpeech Method (List(Guid))

GrantSpeech Method (ListGuid)

 Bosch Logo
Syntax
Json
Request:

Copy
{
    "participantIds": [<string>],
    "seatIds": [<string>]
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateMeetingStatusInfo Method

UpdateMeetingStatusInfo Method

Updates meeting state.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetSeatInfoList Method

GetSeatInfoList Method

Get seat list
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.LoginResponse.Token Property

Token Property

Syntax
Json
{ Property:Token }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileInfo.fileId Property

fileId Property

Id of the file
Syntax
Json
{ Property:fileId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpreterDeskInfo.SeatId Property

SeatId Property

Gets or sets the seat identifier.
Syntax
Json
{ Property:SeatId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Certificate.RetrieveCertificateData Method

RetrieveCertificateData Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.DeleteFileRequest Constructor

ConferenceApiHandlerDeleteFileRequest Constructor

Initializes a new instance of the ConferenceApiHandlerDeleteFileRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GuiIdClass.Value Property

Value Property

Syntax
Json
{ Property:Value }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnOpenStateChanged Method

OnOpenStateChanged Method

Handles the opened state changed reported by the API.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DcnmApi.OnParticipantsUpdated Method

OnParticipantsUpdated Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetParticipantSeatsRequest Class

ConferenceApiHandlerGetParticipantSeatsRequest Class

Represents the get participants seat info request.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetParticipantSeatsRequest
Syntax
Json
{ JsonClass:GetParticipantSeatsRequest	 }

The ConferenceApiHandlerGetParticipantSeatsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetParticipantSeatsRequest | Initializes a new instance of the ConferenceApiHandlerGetParticipantSeatsRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.CancelInterpreterMetaFunctionRequest.Request Property

Request Property

Syntax
Json
{ Property:Request }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetRoomContactEmailResponse.RoomContactEmail Property

RoomContactEmail Property

Syntax
Json
{ Property:RoomContactEmail }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UpdateFileResponse Constructor

ConferenceApiHandlerUpdateFileResponse Constructor

Initializes a new instance of the ConferenceApiHandlerUpdateFileResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.RequestSpeech Method

RequestSpeech Method

Syntax
Json
Request:

Copy
{
    "participantIds": [<string>],
    "seatIds": [<string>]
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DiscussionListEntry.SpeakerType Property

SpeakerType Property

Uses EnumSpeakerType to contains speaker type
Syntax
Json
{ Property:SpeakerType }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Certificate.CreateRootCertificatePfxCrtFiles Method

CreateRootCertificatePfxCrtFiles Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SelectInterpretationFloorRequest Class

ConferenceApiHandlerSelectInterpretationFloorRequest Class

Represents the request to select either floor
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerSelectInterpretationFloorRequest
Syntax
Json
{ JsonClass:SelectInterpretationFloorRequest		SeatId:<type>,
 }

The ConferenceApiHandlerSelectInterpretationFloorRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSelectInterpretationFloorRequest | Initializes a new instance of the ConferenceApiHandlerSelectInterpretationFloorRequest class
Top
Properties
 | Name | Description
Public property | SeatId |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetBoothNotificationsRequest Class

ConferenceApiHandlerGetBoothNotificationsRequest Class

Represents the get booth notifications request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetBoothNotificationsRequest
Syntax
Json
{ JsonClass:GetBoothNotificationsRequest	 }

The ConferenceApiHandlerGetBoothNotificationsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetBoothNotificationsRequest | Initializes a new instance of the ConferenceApiHandlerGetBoothNotificationsRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.SystemPowerMode Property

SystemPowerMode Property

Contains system power state information
Syntax
Json
{ Property:SystemPowerMode }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


IConferenceConnection.SendEvent Method

SendEvent Method

Send an event to a client
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


CreateCertificateRequest Constructor

Initializes a new instance of the CreateCertificateRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SelectInterpretationFloorResponse Constructor

ConferenceApiHandlerSelectInterpretationFloorResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerSelectInterpretationFloorResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


PluginHandler.ConnectionIdAndPluginInstance Class

PluginHandlerConnectionIdAndPluginInstance Class

Inheritance Hierarchy
SystemObject
SynopticControl.ServerPluginHandlerConnectionIdAndPluginInstance
Syntax
Json
{ JsonClass:ConnectionIdAndPluginInstance		ConnectionId:<type>,
    PluginInstance:<type>,
 }

The PluginHandlerConnectionIdAndPluginInstance type exposes the following members.

Constructors
 | Name | Description
Public method | PluginHandlerConnectionIdAndPluginInstance | Initializes a new instance of the PluginHandlerConnectionIdAndPluginInstance class
Top
Properties
 | Name | Description
Public property | ConnectionId |
Public property | PluginInstance |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Certificate.GenerateCertificatePfxByteArray Method

GenerateCertificatePfxByteArray Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


PluginHandler.GetPlugins Method

GetPlugins Method

Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "plugins": [<string>]
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceUsers.Initialize Method

Initialize Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateParticipantsForMeeting Method

UpdateParticipantsForMeeting Method

Update list of participants for active meeting
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


Certificate.CreateECDsaCertificateRequest Method

CreateECDsaCertificateRequest Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


PluginEventDescription Constructor

Initializes a new instance of the PluginEventDescription class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ApiLoginDetails Properties

The ApiLoginDetails type exposes the following members.

Properties
 | Name | Description
Public property | Api |
Public property | Schema |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.CancelResponseRequest Method

CancelResponseRequest Method

Cancels response request.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


MasterVolumeRange Properties

The MasterVolumeRange type exposes the following members.

Properties
 | Name | Description
Public property | MaximumVolume | Gets or sets the maximum volume.
Public property | MinimumVolume | Gets or sets the minimum volume.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.CreateFileRequest Class

ConferenceApiHandlerCreateFileRequest Class

Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerCreateFileRequest
Syntax
Json
{ JsonClass:CreateFileRequest		Attributes:<type>,
    Payload:<type>,
    Title:<type>,
 }

The ConferenceApiHandlerCreateFileRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerCreateFileRequest | Initializes a new instance of the ConferenceApiHandlerCreateFileRequest class
Top
Properties
 | Name | Description
Public property | Attributes | Attribute indicating file type and can only have values "synoptic" or "index"
Public property | Payload | The configuration of the layout. The format of the string is defined by the (AngularJs) application. The maximum length of the string is 65KBytes.
Public property | Title | Title of the file
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateFoundDevicesInSeats Method

UpdateFoundDevicesInSeats Method

Updates the newly found or lost devices on seat
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetVotingInfoRequest Constructor

ConferenceApiHandlerGetVotingInfoRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetVotingInfoRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.MeetingStatusInfo Property

MeetingStatusInfo Property

Contains meeting status information
Syntax
Json
{ Property:MeetingStatusInfo }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


MasterVolumeRange Constructor

Initializes a new instance of the MasterVolumeRange class.
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


PluginHandler.GetPlugin Method

GetPlugin Method

Syntax
Json
Request:

Copy
{
    "pluginName": <string>
}

Response:

Copy
{
    "pluginDescriptionResponse":
    {
        "commands":
        [
            {
                "name": <string>
            }
        ],
        "events":
        [
            {
                "name": <string>
            }
        ],
        "interface": <string>,
        "name": <string>
    }
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnRequestsListChanged Method

OnRequestsListChanged Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


LoginRequest Properties

The ConferenceApiHandlerLoginRequest type exposes the following members.

Properties
 | Name | Description
Public property | Password | Password
Public property | Token |
Public property | User | User name
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SeatInfo.VisType Property

VisType Property

Seat Vis type
Syntax
Json
{ Property:VisType }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.GetMajorityVariables Method

GetMajorityVariables Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetSystemPowerModeResponse.PowerMode Property

PowerMode Property

Power mode
Syntax
Json
{ Property:PowerMode }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnActualSpeakerChanged Method

OnActualSpeakerChanged Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


GetRoomNameResponse Properties

The ConferenceApiHandlerGetRoomNameResponse type exposes the following members.

Properties
 | Name | Description
Public property | RoomName |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DiscussionListEntry.ScreenLine Property

ScreenLine Property

Seat name / participant name
Syntax
Json
{ Property:ScreenLine }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetVotingInfoRequest Class

ConferenceApiHandlerGetVotingInfoRequest Class

Represents the get voting info request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetVotingInfoRequest
Syntax
Json
{ JsonClass:GetVotingInfoRequest	 }

The ConferenceApiHandlerGetVotingInfoRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetVotingInfoRequest | Initializes a new instance of the ConferenceApiHandlerGetVotingInfoRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileStore Class

FileStore class
Inheritance Hierarchy
SystemObject
SynopticControl.ServerFileStore
Syntax
Json
{ JsonClass:FileStore		Instance:<type>,
 }

The FileStore type exposes the following members.

Constructors
 | Name | Description
 | FileStore |
Public method | FileStore | Initializes a new instance of the FileStore class
Top
Properties
Name | Description
Instance | File store instance
Top
Methods
 | Name | Description
Public method | CreateFile |
Public method | DeleteFile | Deteles the configuration of a file from the server.
Private method | GetFile | Gets file info
 | GetFileInfo |
Private method | GetXmlDataFiles | Gets all stored xml files from data folder
Public method | ListFiles | Get the description of all the stored files
Public method | LoadFile | Get the detailed information for a specific file layout
Public method | UpdateFile | Saves the configuration of file.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnVotingStatusChanged Method

OnVotingStatusChanged Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


GetVotingInfoResponse Properties

The ConferenceApiHandlerGetVotingInfoResponse type exposes the following members.

Properties
 | Name | Description
Public property | VotingInfo | Voting info
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UnSubscribePluginEventRequest.PluginName Property

PluginName Property

The name of the Plugin
Syntax
Json
{ Property:PluginName }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateParticipantAccessDeniedInfo Method

UpdateParticipantAccessDeniedInfo Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.CreateSeatInfoList Method

CreateSeatInfoList Method

Creats the seat info list
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


Certificate.GetCertificate Method

GetCertificate Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


InterpreterDeskInfo Constructor

Overload List
 | Name | Description
Public method | InterpreterDeskInfo | Initializes a new instance of the InterpreterDeskInfo class.
Public method | InterpreterDeskInfo(Guid, Guid, Int32, EnumDeskType, ValueTupleSupportedHeadphoneTypes, Boolean) | Initializes a new instance of the InterpreterDeskInfo class.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SaveImageRequest.ImageData Property

ImageData Property

The image data
Syntax
Json
{ Property:ImageData }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnRoomNameUpdated Method

OnRoomNameUpdated Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.LogoutResponse Class

ConferenceApiHandlerLogoutResponse Class

Logout response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerLogoutResponse
Syntax
Json
{ JsonClass:LogoutResponse	 }

The ConferenceApiHandlerLogoutResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerLogoutResponse | Initializes a new instance of the ConferenceApiHandlerLogoutResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DeleteFileRequest Properties

The ConferenceApiHandlerDeleteFileRequest type exposes the following members.

Properties
 | Name | Description
Public property | FileId | File identifier
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ActivateMicrophoneRequest.SeatId Property

SeatId Property

Note: This API is now obsolete.

The seat identifier.
Syntax
Json
{ Property:SeatId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.GetPermission Method

GetPermission Method

Gets permissions of the user
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetApiStateResponse Class

ConferenceApiHandlerGetApiStateResponse Class

Response from GetApiState
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetApiStateResponse
Syntax
Json
{ JsonClass:GetApiStateResponse		Online:<type>,
 }

The ConferenceApiHandlerGetApiStateResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetApiStateResponse | Initializes a new instance of the ConferenceApiHandlerGetApiStateResponse class
Top
Properties
 | Name | Description
Public property | Online | Online
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetVotingResult Method

GetVotingResult Method

Gets the voting result.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetPluginEventDataRequest Constructor

ConferenceApiHandlerGetPluginEventDataRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetPluginEventDataRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetMasterVolumeRangeResponse Properties

The ConferenceApiHandlerGetMasterVolumeRangeResponse type exposes the following members.

Properties
 | Name | Description
Public property | Range | Gets or sets the master volume range.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpreterDeskInfo Constructor (Guid, Guid, Int32, EnumDeskType, ValueTuple(SupportedHeadphoneTypes, Boolean))

InterpreterDeskInfo Constructor (Guid, Guid, Int32, EnumDeskType, ValueTupleSupportedHeadphoneTypes, Boolean)

 Bosch Logo
Initializes a new instance of the InterpreterDeskInfo class.
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OpenVoting Method

OpenVoting Method

Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.DeactivatePresentationResponse Constructor

ConferenceApiHandlerDeactivatePresentationResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerDeactivatePresentationResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpreterDeskInfo.BLanguageList Property

BLanguageList Property

Gets the B language list.
Syntax
Json
{ Property:BLanguageList }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConnectionTracker Constructor

Initializes the static fields of the ConnectionTracker class
Syntax
Json
{ Constructor:.cctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetIlluminateSeatRequest.SeatId Property

SeatId Property

The seat identifier
Syntax
Json
{ Property:SeatId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Certificate.CreateRootAndServerCertificate Method

CreateRootAndServerCertificate Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


GetSeatVotingResultsResponse Properties

The ConferenceApiHandlerGetSeatVotingResultsResponse type exposes the following members.

Properties
 | Name | Description
Public property | VotingResults | List of voting results
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateInterpretationMetaRequestStatus Method

UpdateInterpretationMetaRequestStatus Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.OpenAgendaResponse Class

ConferenceApiHandlerOpenAgendaResponse Class

Represents the open agenda topic response.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerOpenAgendaResponse
Syntax
Json
{ JsonClass:OpenAgendaResponse	 }

The ConferenceApiHandlerOpenAgendaResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerOpenAgendaResponse | Initializes a new instance of the ConferenceApiHandlerOpenAgendaResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SeatInfo.AssignedParticipantId Property

AssignedParticipantId Property

Id of participant assigned to seat
Syntax
Json
{ Property:AssignedParticipantId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ActivateMeetingRequest Constructor

ConferenceApiHandlerActivateMeetingRequest Constructor

Initializes a new instance of the ConferenceApiHandlerActivateMeetingRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


NotesFileSearchCriteria Class

Class represents date for selecting note files.
Inheritance Hierarchy
SystemObject
SynopticControl.CommonNotesFileSearchCriteria
Syntax
Json
{ JsonClass:NotesFileSearchCriteria		EndDate:<type>,
    StartDate:<type>,
 }

The NotesFileSearchCriteria type exposes the following members.

Constructors
 | Name | Description
Public method | NotesFileSearchCriteria | Initializes a new instance of the NotesFileSearchCriteria class
Top
Properties
 | Name | Description
Public property | EndDate | End date for the file search in the string format of 'yyyy-MM-dd'
Public property | StartDate | Start date for the file search in the string format of 'yyyy-MM-dd'
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Voting.VotingTimeDuration Property

VotingTimeDuration Property

Gets the duration of the voting time.
Syntax
Json
{ Property:VotingTimeDuration }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateSeatRights Method

UpdateSeatRights Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DcnmApi.RequestVotingResult Method

RequestVotingResult Method

Request for voting results.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


LogOnModel Constructor

Initializes a new instance of the LogOnModel class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Certificate.GetServerCertificateFromLocalMachine Method

GetServerCertificateFromLocalMachine Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateInterpretationRoutingList Method

UpdateInterpretationRoutingList Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


InterpretationMetaRequestStatus Methods

The InterpretationMetaRequestStatus type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DiscussionListEntry.SpeechStartTime Property

SpeechStartTime Property

Start time of the speech
Syntax
Json
{ Property:SpeechStartTime }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Voting.VotingId Property

VotingId Property

Gets the voting identifier.
Syntax
Json
{ Property:VotingId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.TryGetInterpreterSeatFromSeatsList Method

TryGetInterpreterSeatFromSeatsList Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


GrantInterpretationRequest Properties

The ConferenceApiHandlerGrantInterpretationRequest type exposes the following members.

Properties
 | Name | Description
Public property | MicrophoneState | Gets or sets the state of the interpretation microphone.
Public property | SeatId | Gets or sets the seat identifier.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetParticipantAccessDeniedReasonsRequest Constructor

ConferenceApiHandlerGetParticipantAccessDeniedReasonsRequest Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerGetParticipantAccessDeniedReasonsRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.NotifyInterpreterSeatInfoChangedOnClients Method

NotifyInterpreterSeatInfoChangedOnClients Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetPluginCommandsResponse.PluginCommands Property

PluginCommands Property

Collection of plugin commands that are waiting to be executed
Syntax
Json
{ Property:PluginCommands }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SystemLog.RemoveTraceListener Method

RemoveTraceListener Method

Removes the given trace listener to the list of listeners to this trace source.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


FileInfo.payload Property

payload Property

Configuration of the file
Syntax
Json
{ Property:payload }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


MicrophoneSensitivity.Clone Method

Clone Method

Clone the seat microphone sensitivity information
Syntax
Json
Implements
ICloneableTClone
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


Participant.GetHashCode Method

GetHashCode Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


Participant.PersonId Property

PersonId Property

The person identifier.
Syntax
Json
{ Property:PersonId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UnSubscribePluginEventResponse Class

ConferenceApiHandlerUnSubscribePluginEventResponse Class

Response for unsubscribing to plugin event
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerUnSubscribePluginEventResponse
Syntax
Json
{ JsonClass:UnSubscribePluginEventResponse	 }

The ConferenceApiHandlerUnSubscribePluginEventResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerUnSubscribePluginEventResponse | Initializes a new instance of the ConferenceApiHandlerUnSubscribePluginEventResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SystemLog.TraceStop Method

TraceStop Method

Logs the end of a method/function/block
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


SeatInfo.Equals Method

Equals Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


VoteMajorityInfo.MajorityNumeratorExpression Property

MajorityNumeratorExpression Property

In favor for majority.
Syntax
Json
{ Property:MajorityNumeratorExpression }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetVotingStateResponse Properties

The ConferenceApiHandlerGetVotingStateResponse type exposes the following members.

Properties
 | Name | Description
Public property | VotingState | Voting state
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.OpenMeetingResponse Constructor

ConferenceApiHandlerOpenMeetingResponse Constructor

Initializes a new instance of the ConferenceApiHandlerOpenMeetingResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.OpenAgendaRequest Constructor

ConferenceApiHandlerOpenAgendaRequest Constructor

Initializes a new instance of the ConferenceApiHandlerOpenAgendaRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SystemLog.TraceResume Method

TraceResume Method

Logs the resume of a method/function/block
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModelReader.IsValidInterpreterMetaRequest Method

IsValidInterpreterMetaRequest Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModelReader.RequestResponse Method

RequestResponse Method

Syntax
Json
Request:

Copy
{
    "participantIds": [<string>],
    "seatIds": [<string>]
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetAgendaTopicsResponse Properties

The ConferenceApiHandlerGetAgendaTopicsResponse type exposes the following members.

Properties
 | Name | Description
Public property | AgendaTopics | List of agenda topics.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


BoothNotificationInfo.Equals Method

Equals Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateDiscussionOptions Method

UpdateDiscussionOptions Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.IssueInterpreterMetaFunctionRequest.SeatId Property

SeatId Property

Syntax
Json
{ Property:SeatId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UpdateFileRequest Class

ConferenceApiHandlerUpdateFileRequest Class

Represents the save file request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerUpdateFileRequest
Syntax
Json
{ JsonClass:UpdateFileRequest		Attributes:<type>,
    FileId:<type>,
    Payload:<type>,
    Title:<type>,
 }

The ConferenceApiHandlerUpdateFileRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerUpdateFileRequest | Initializes a new instance of the ConferenceApiHandlerUpdateFileRequest class
Top
Properties
 | Name | Description
Public property | Attributes | Attributes indicate what contents of file represent and can contain list of values like 'Bosch.Synoptic.Layout', 'Bosch.Synoptic.Index'
Public property | FileId | File identifier. Unique identification of the file
Public property | Payload | The configuration of the layout. The format of the string is defined by the (AngularJs) application. The maximum length of the string is 65KBytes.
Public property | Title | Title of the file
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SaveImageResponse Class

ConferenceApiHandlerSaveImageResponse Class

Represents the save image response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerSaveImageResponse
Syntax
Json
{ JsonClass:SaveImageResponse		SaveImageUri:<type>,
 }

The ConferenceApiHandlerSaveImageResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSaveImageResponse | Initializes a new instance of the ConferenceApiHandlerSaveImageResponse class
Top
Properties
 | Name | Description
Public property | SaveImageUri | The uri of the saved image.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


QuorumResultInfo.Inequality Operator

Inequality Operator

Function to comapare two QuorumResultInfo objects are unequal
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.ConvertToAgendaState Method

ConvertToAgendaState Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GrantResponseRequest Constructor

ConferenceApiHandlerGrantResponseRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGrantResponseRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SeatInfo.GetHashCode Method

GetHashCode Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


Voting.Description Property

Description Property

Gets the description.
Syntax
Json
{ Property:Description }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnSeatSelected Method

OnSeatSelected Method

On seat illuminated.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.SeatVotingResults Property

SeatVotingResults Property

Stores voting results of seats
Syntax
Json
{ Property:SeatVotingResults }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetPluginsRequest Constructor

ConferenceApiHandlerGetPluginsRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetPluginsRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SeatInfo.SeatedParticipantId Property

SeatedParticipantId Property

Id of participant logged in at seat
Syntax
Json
{ Property:SeatedParticipantId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SelectInterpretationInputLanguageResponse Class

ConferenceApiHandlerSelectInterpretationInputLanguageResponse Class

 Bosch Logo
Represents the select input language response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerSelectInterpretationInputLanguageResponse
Syntax
Json
{ JsonClass:SelectInterpretationInputLanguageResponse	 }

The ConferenceApiHandlerSelectInterpretationInputLanguageResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSelectInterpretationInputLanguageResponse | Initializes a new instance of the ConferenceApiHandlerSelectInterpretationInputLanguageResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


PluginHandler.GetPluginCommands Method

GetPluginCommands Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetPluginEventDataRequest Class

ConferenceApiHandlerGetPluginEventDataRequest Class

Represents the GetPluginEventDataRequest
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetPluginEventDataRequest
Syntax
Json
{ JsonClass:GetPluginEventDataRequest	 }

The ConferenceApiHandlerGetPluginEventDataRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetPluginEventDataRequest | Initializes a new instance of the ConferenceApiHandlerGetPluginEventDataRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Meeting Properties

The Meeting type exposes the following members.

Properties
 | Name | Description
Public property | AgendaList | Gets the agenda list.
Public property | AutoOpenOnActivate |
Public property | AutoStartAgendaOnOpen |
Public property | DefaultDiscussionId |
Public property | Description | Gets the description.
Public property | DocumentationRef |
Public property | IdentificationMethod | The identification mode for the meeting.
Public property | IsDefault | Gets a value indicating whether this instance is default.
Public property | MeetingEndDate | Gets the meeting end date.
Public property | MeetingId | Gets the meeting identifier.
Public property | MeetingStartDate | Gets the meeting start date.
Public property | State | Gets the state.
Public property | Title | Gets the title.
Public property | VerificationMethod | The verification mode for the meeting.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdatePresentationState Method

UpdatePresentationState Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.CloseAgendaResponse Constructor

ConferenceApiHandlerCloseAgendaResponse Constructor

Initializes a new instance of the ConferenceApiHandlerCloseAgendaResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetNotesFileListRequest Class

ConferenceApiHandlerGetNotesFileListRequest Class

Represents the meeting and voting notes file list request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetNotesFileListRequest
Syntax
Json
{ JsonClass:GetNotesFileListRequest		SearchDateRange:<type>,
 }

The ConferenceApiHandlerGetNotesFileListRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetNotesFileListRequest | Initializes a new instance of the ConferenceApiHandlerGetNotesFileListRequest class
Top
Properties
 | Name | Description
Public property | SearchDateRange | The file search criteria of type NotesFileSearchCriteria
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


QuorumResultInfo.Equals Method (Object)

Equals Method (Object)

 Bosch Logo
Override Equals function in IEquatable
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


CreateCertificateResponse Properties

The CreateCertificateResponse type exposes the following members.

Properties
 | Name | Description
Public property | CertificateHash |
Public property | PublicCrtData |
Public property | StoreName |
Public property | Success |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Helper Class

Inheritance Hierarchy
SystemObject
SynopticControl.CommonHelper
Syntax
Json
{ JsonClass:Helper	 }

The Helper type exposes the following members.

Methods
Name | Description
TryParseDate |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpretationRoutingInfo.SourceLanguageId Property

SourceLanguageId Property

Gets or sets the source language identifier.
Syntax
Json
{ Property:SourceLanguageId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetInterpreterSeatsResponse Properties

The ConferenceApiHandlerGetInterpreterSeatsResponse type exposes the following members.

Properties
 | Name | Description
Public property | Seats | Gets or sets the interpreter seats.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.ActivateVoting Method

ActivateVoting Method

Syntax
Json
Request:

Copy
{
    "votingId": <string>
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileStore.ListFiles Method

ListFiles Method

Get the description of all the stored files
Syntax
Json
Request:

Copy
{
    "attributes": [<string>]
}

Response:

Copy
{
    "fileInfoList":
    [
        {
            "fileId": <string>,
            "title": <string>
        }
    ]
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ImageManagement.DeleteImage Method

DeleteImage Method

Deletes an image from the server. Requires canEditSynoptic rights
Syntax
Json
Request:

Copy
{
    "imageName": <string>
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GuidConverter Class

Inheritance Hierarchy
SystemObject
Newtonsoft.JsonJsonConverter
SynopticControl.JsonConvertersGuidConverter
Syntax
Json
{ JsonClass:GuidConverter		CanRead:<type>,
    CanWrite:<type>,
 }

The GuidConverter type exposes the following members.

Constructors
 | Name | Description
Public method | GuidConverter | Initializes a new instance of the GuidConverter class
Top
Properties
 | Name | Description
Public property | CanRead | Gets a value indicating whether this JsonConverter can read JSON. (Inherited from JsonConverter.)
Public property | CanWrite | Gets a value indicating whether this JsonConverter can write JSON. (Inherited from JsonConverter.)
Top
Methods
 | Name | Description
Public method | CanConvert | (Overrides JsonConverterCanConvert(Type).)
Public method | ReadJson | (Overrides JsonConverterReadJson(JsonReader, Type, Object, JsonSerializer).)
Public method | WriteJson | (Overrides JsonConverterWriteJson(JsonWriter, Object, JsonSerializer).)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SetIlluminateSeatRequest Properties

The ConferenceApiHandlerSetIlluminateSeatRequest type exposes the following members.

Properties
 | Name | Description
Public property | SeatId | The seat identifier
Public property | SetIlluminate | Set illuminate
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


CreateCertificateRequest.RootCertificateName Property

RootCertificateName Property

Syntax
Json
{ Property:RootCertificateName }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnMeetingUpdated Method

OnMeetingUpdated Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


Startup.Stop Method

Stop Method

Syntax
Json
Implements
IRegisteredObjectStop(Boolean)
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


GetPluginsResponse Properties

The ConferenceApiHandlerGetPluginsResponse type exposes the following members.

Properties
 | Name | Description
Public property | Plugins | The collection of names of plugin
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UnSubscribePluginEventRequest.EventName Property

EventName Property

Event name to unsubscribe from plugin
Syntax
Json
{ Property:EventName }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConnectionIdAndPluginInstance Properties

The PluginHandlerConnectionIdAndPluginInstance type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionId |
Public property | PluginInstance |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.OpenMeetingResponse Class

ConferenceApiHandlerOpenMeetingResponse Class

Represents the open meeting info response.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerOpenMeetingResponse
Syntax
Json
{ JsonClass:OpenMeetingResponse	 }

The ConferenceApiHandlerOpenMeetingResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerOpenMeetingResponse | Initializes a new instance of the ConferenceApiHandlerOpenMeetingResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileLogTraceListener.WriteLine Method

WriteLine Method

Overload List
 | Name | Description
Public method | WriteLine(Object) | Writes the value of the object's ToString method to the listener you create when you implement the TraceListener class, followed by a line terminator. (Inherited from TraceListener.)
Public method | WriteLine(String) | Writes a message to the listener you create in the derived class, followed by a line terminator. (Overrides TraceListenerWriteLine(String).)
Public method | WriteLine(String, String) | Writes a category name and a message to the listener you create when you implement the TraceListener class, followed by a line terminator. (Inherited from TraceListener.)
Public method | WriteLine(Object, String) | Writes a category name and the value of the object's ToString method to the listener you create when you implement the TraceListener class, followed by a line terminator. (Inherited from TraceListener.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetRoomContactEmailRequest Class

ConferenceApiHandlerGetRoomContactEmailRequest Class

Parameters to GetRoomContactEmail.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetRoomContactEmailRequest
Syntax
Json
{ JsonClass:GetRoomContactEmailRequest	 }

The ConferenceApiHandlerGetRoomContactEmailRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetRoomContactEmailRequest | Initializes a new instance of the ConferenceApiHandlerGetRoomContactEmailRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.CreateDiscussionListEntry Method

CreateDiscussionListEntry Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.RoomContactEmail Property

RoomContactEmail Property

Contains room contact email information.
Syntax
Json
{ Property:RoomContactEmail }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnVotingDeleted Method

OnVotingDeleted Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetPresentationStateRequest Class

ConferenceApiHandlerGetPresentationStateRequest Class

Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetPresentationStateRequest
Syntax
Json
{ JsonClass:GetPresentationStateRequest	 }

The ConferenceApiHandlerGetPresentationStateRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetPresentationStateRequest | Initializes a new instance of the ConferenceApiHandlerGetPresentationStateRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GrantSpeechRequest Properties

The ConferenceApiHandlerGrantSpeechRequest type exposes the following members.

Properties
 | Name | Description
Public property | ParticipantIds | List of particpant identifiers.
Public property | SeatIds | List of seat identifiers.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Startup Constructor

Initializes the static fields of the Startup class
Syntax
Json
{ Constructor:.cctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetParticipantSeatsResponse Class

ConferenceApiHandlerGetParticipantSeatsResponse Class

Represents the get participants seat info response.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetParticipantSeatsResponse
Syntax
Json
{ JsonClass:GetParticipantSeatsResponse		ParticipantSeats:<type>,
 }

The ConferenceApiHandlerGetParticipantSeatsResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetParticipantSeatsResponse | Initializes a new instance of the ConferenceApiHandlerGetParticipantSeatsResponse class
Top
Properties
 | Name | Description
Public property | ParticipantSeats | Participant Seats List.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateMicrophoneSensitivityForUpdatedSeat Method

UpdateMicrophoneSensitivityForUpdatedSeat Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DiscussionListEntry.PersonInfoId Property

PersonInfoId Property

Id of the personinfo of the participant
Syntax
Json
{ Property:PersonInfoId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetRoomNameResponse Constructor

ConferenceApiHandlerGetRoomNameResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetRoomNameResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SelectInterpretationInputLanguageRequest Class

ConferenceApiHandlerSelectInterpretationInputLanguageRequest Class

 Bosch Logo
Represents the request to select the language on an input
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerSelectInterpretationInputLanguageRequest
Syntax
Json
{ JsonClass:SelectInterpretationInputLanguageRequest		InputButton:<type>,
    LanguageId:<type>,
    SeatId:<type>,
 }

The ConferenceApiHandlerSelectInterpretationInputLanguageRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSelectInterpretationInputLanguageRequest | Initializes a new instance of the ConferenceApiHandlerSelectInterpretationInputLanguageRequest class
Top
Properties
 | Name | Description
Public property | InputButton |
Public property | LanguageId |
Public property | SeatId |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnDiscussionOptionsChanged Method

OnDiscussionOptionsChanged Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetMicrophoneSensitivityDescriptionResponse Class

ConferenceApiHandlerGetMicrophoneSensitivityDescriptionResponse Class

 Bosch Logo
Microphone sensitivity description response.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetMicrophoneSensitivityDescriptionResponse
Syntax
Json
{ JsonClass:GetMicrophoneSensitivityDescriptionResponse		MicSensitivityDescription:<type>,
 }

The ConferenceApiHandlerGetMicrophoneSensitivityDescriptionResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetMicrophoneSensitivityDescriptionResponse | Initializes a new instance of the ConferenceApiHandlerGetMicrophoneSensitivityDescriptionResponse class
Top
Properties
 | Name | Description
Public property | MicSensitivityDescription |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SendPluginCommandResponse.Response Property

Response Property

The response of the command execution
Syntax
Json
{ Property:Response }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.GetDeviceIdsFoundAtSeat Method

GetDeviceIdsFoundAtSeat Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


Voting.GetHashCode Method

GetHashCode Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


NotesFileSearchCriteria.StartDate Property

StartDate Property

Start date for the file search in the string format of 'yyyy-MM-dd'
Syntax
Json
{ Property:StartDate }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


RootCertificateData.PrivatePfxData Property

PrivatePfxData Property

Syntax
Json
{ Property:PrivatePfxData }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


NotesFileInfo Properties

The NotesFileInfo type exposes the following members.

Properties
 | Name | Description
Public property | CreationDateTime | File creation date time.
Public property | FileName | Name of the xml file.
Public property | FileType | Indicates whether its a meeting or voting xml.
Public property | IsTampered |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileInfoDetail Class

This contains the details of the file
Inheritance Hierarchy
SystemObject
SynopticControl.CommonFileInfoDetail
Syntax
Json
{ JsonClass:FileInfoDetail		FileId:<type>,
    Title:<type>,
 }

The FileInfoDetail type exposes the following members.

Constructors
 | Name | Description
Public method | FileInfoDetail | Initializes a new instance of the FileInfoDetail class
Top
Properties
 | Name | Description
Public property | FileId | Id of the file
Public property | Title | Title of the file
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.AddSeatToSpeakersResponse Class

ConferenceApiHandlerAddSeatToSpeakersResponse Class

Represents the speaker response.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerAddSeatToSpeakersResponse
Syntax
Json
{ JsonClass:AddSeatToSpeakersResponse	 }

The ConferenceApiHandlerAddSeatToSpeakersResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerAddSeatToSpeakersResponse | Initializes a new instance of the ConferenceApiHandlerAddSeatToSpeakersResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetPluginCommandsResponse Class

ConferenceApiHandlerGetPluginCommandsResponse Class

Represents the response of GetPluginCommands
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetPluginCommandsResponse
Syntax
Json
{ JsonClass:GetPluginCommandsResponse		PluginCommands:<type>,
 }

The ConferenceApiHandlerGetPluginCommandsResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetPluginCommandsResponse | Initializes a new instance of the ConferenceApiHandlerGetPluginCommandsResponse class
Top
Properties
 | Name | Description
Public property | PluginCommands | Collection of plugin commands that are waiting to be executed
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DeviceInfo.TypeOf Property

TypeOf Property

Syntax
Json
{ Property:TypeOf }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GuidConverter Constructor

Initializes a new instance of the GuidConverter class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.EnableSeatIlluminationRequest Class

ConferenceApiHandlerEnableSeatIlluminationRequest Class

Represents the EnableSeatIllumination request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerEnableSeatIlluminationRequest
Syntax
Json
{ JsonClass:EnableSeatIlluminationRequest		Enable:<type>,
 }

The ConferenceApiHandlerEnableSeatIlluminationRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerEnableSeatIlluminationRequest | Initializes a new instance of the ConferenceApiHandlerEnableSeatIlluminationRequest class
Top
Properties
 | Name | Description
Public property | Enable | Enable
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.OpenVotingResponse Constructor

ConferenceApiHandlerOpenVotingResponse Constructor

Initializes a new instance of the ConferenceApiHandlerOpenVotingResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Meeting Class

This contains the details of the meeting
Inheritance Hierarchy
SystemObject
SynopticControl.CommonMeeting
Syntax
Json
{ JsonClass:Meeting		AgendaList:<type>,
    AutoOpenOnActivate:<type>,
    AutoStartAgendaOnOpen:<type>,
    DefaultDiscussionId:<type>,
    Description:<type>,
    DocumentationRef:<type>,
    IdentificationMethod:<type>,
    IsDefault:<type>,
    MeetingEndDate:<type>,
    MeetingId:<type>,
    MeetingStartDate:<type>,
    State:<type>,
    Title:<type>,
    VerificationMethod:<type>,
 }

The Meeting type exposes the following members.

Properties
 | Name | Description
Public property | AgendaList | Gets the agenda list.
Public property | AutoOpenOnActivate |
Public property | AutoStartAgendaOnOpen |
Public property | DefaultDiscussionId |
Public property | Description | Gets the description.
Public property | DocumentationRef |
Public property | IdentificationMethod | The identification mode for the meeting.
Public property | IsDefault | Gets a value indicating whether this instance is default.
Public property | MeetingEndDate | Gets the meeting end date.
Public property | MeetingId | Gets the meeting identifier.
Public property | MeetingStartDate | Gets the meeting start date.
Public property | State | Gets the state.
Public property | Title | Gets the title.
Public property | VerificationMethod | The verification mode for the meeting.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to current object. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Serves as a default hash function. (Overrides ObjectGetHashCode.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetInterpreterBoothsRequest Constructor

ConferenceApiHandlerGetInterpreterBoothsRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetInterpreterBoothsRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetInterpretationMetaFunctionStatusRequest Class

ConferenceApiHandlerGetInterpretationMetaFunctionStatusRequest Class

 Bosch Logo
Represents get speak slow status request.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetInterpretationMetaFunctionStatusRequest
Syntax
Json
{ JsonClass:GetInterpretationMetaFunctionStatusRequest	 }

The ConferenceApiHandlerGetInterpretationMetaFunctionStatusRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetInterpretationMetaFunctionStatusRequest | Initializes a new instance of the ConferenceApiHandlerGetInterpretationMetaFunctionStatusRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ActivateVotingRequest Class

ConferenceApiHandlerActivateVotingRequest Class

Represents the activate voting info request.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerActivateVotingRequest
Syntax
Json
{ JsonClass:ActivateVotingRequest		VotingId:<type>,
 }

The ConferenceApiHandlerActivateVotingRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerActivateVotingRequest | Initializes a new instance of the ConferenceApiHandlerActivateVotingRequest class
Top
Properties
 | Name | Description
Public property | VotingId | The voting identifier
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SelectInterpretationInputLanguageRequest.InputButton Property

InputButton Property

Syntax
Json
{ Property:InputButton }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdatePriorityList Method

UpdatePriorityList Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


Participant Class

This contains the details of the participant
Inheritance Hierarchy
SystemObject
SynopticControl.CommonParticipant
Syntax
Json
{ JsonClass:Participant		CanPrio:<type>,
    CanVote:<type>,
    Country:<type>,
    Email:<type>,
    FirstName:<type>,
    Group:<type>,
    IsAuthenticated:<type>,
    LastName:<type>,
    MiddleName:<type>,
    ParticipantId:<type>,
    ParticipantType:<type>,
    PersonId:<type>,
    PictureUpdatedNumber:<type>,
    Region:<type>,
    Title:<type>,
    VisType:<type>,
    VoteWeight:<type>,
 }

The Participant type exposes the following members.

Constructors
 | Name | Description
Public method | Participant | Initializes a new instance of the Participant class.
Top
Properties
 | Name | Description
Public property | CanPrio | Indicates whether participant can use priority or not.
Public property | CanVote | Gets a value indicating whether this instance can vote.
Public property | Country | Gets the country.
Public property | Email |
Public property | FirstName | Gets the first name.
Public property | Group | Gets the group.
Public property | IsAuthenticated | Gets a value indicating whether this instance is authenticated.
Public property | LastName | Gets the last name.
Public property | MiddleName | Gets the name of the middle.
Public property | ParticipantId | Gets the identifier.
Public property | ParticipantType |
Public property | PersonId | The person identifier.
Public property | PictureUpdatedNumber | PictureUpdatedNumber is used to retrieve latest version of person picture on client side
Public property | Region | Gets the region.
Public property | Title | Gets the title.
Public property | VisType | Gets the vis type of the participant.
Public property | VoteWeight | Gets the vote weight.
Top
Methods
 | Name | Description
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Certificate.InstallCertificateOnCertificateStore Method

InstallCertificateOnCertificateStore Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


SynopticControl Namespace

This contains AuthController class which contains all methods related to User authentication such as Login/Logout.
Classes
 | Class | Description
Public class | AuthenticateController | Contains methods that can be communicated to SignalR connections for login and logout
Protected class | DcnmApi | Provide api functionality for synopitc and acts as wrapper for MainWindowsApi
Public class | Startup | Sets start up configurations.


ConferenceModel.MaxRequests Property

MaxRequests Property

Contains max requests for current discussion.
Syntax
Json
{ Property:MaxRequests }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.DetermineIndividualVoteCastedResultsVisiblityForExternalSystem Method

DetermineIndividualVoteCastedResultsVisiblityForExternalSystem Method

Bosch Logo
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


InterpreterBoothInfo.BoothNumber Property

BoothNumber Property

Gets or sets the booth number.
Syntax
Json
{ Property:BoothNumber }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RemoveSeatFromDiscussionListRequest.SeatId Property

SeatId Property

The seat identifier.
Syntax
Json
{ Property:SeatId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.CurrentSpeakerViewingOption Property

CurrentSpeakerViewingOption Property

Syntax
Json
{ Property:CurrentSpeakerViewingOption }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ComparisonOperators Enumeration

Syntax
Json
ComparisonOperators:{
GreaterThan
GreaterThanOrEqualTo
Equals
LessThan
LessThanOrEqualTo}
Members
Member name | Value | Description
GreaterThan | 0 | Used to indicate LHS > RHS
GreaterThanOrEqualTo | 1 | Used to indicate LHS >= RHS
Equals | 2 | Used to indicate LHS = RHS
LessThan | 3 | Used to indicates LHS < RHS.
LessThanOrEqualTo | 4 | Used to indicate LHS <= RHS
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


MajorityResultInfo.Equality Operator

Equality Operator

Function to comapare two MajorityResultInfo objects are equal
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetSeatsRequest Class

ConferenceApiHandlerGetSeatsRequest Class

Parameters to GetSeats
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetSeatsRequest
Syntax
Json
{ JsonClass:GetSeatsRequest	 }

The ConferenceApiHandlerGetSeatsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetSeatsRequest | Initializes a new instance of the ConferenceApiHandlerGetSeatsRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetParticipantsResponse.Participants Property

Participants Property

Participants list
Syntax
Json
{ Property:Participants }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RegisterPluginRequest.PluginName Property

PluginName Property

Unique name of the plugin
Syntax
Json
{ Property:PluginName }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetInterpretationOutputPresetRequest.OutputButton Property

OutputButton Property

Syntax
Json
{ Property:OutputButton }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetEnableSeatIlluminationResponse.Enable Property

Enable Property

Enable
Syntax
Json
{ Property:Enable }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AgendaTopic Constructor

Initializes a new instance of the AgendaTopic class.
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

SynopticControl.CommonAgendaState


DcnmApi.OnAreaUpdated Method

OnAreaUpdated Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


Participant.ParticipantType Property

ParticipantType Property

Syntax
Json
{ Property:ParticipantType }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.QuorumResult Property

QuorumResult Property

Syntax
Json
{ Property:QuorumResult }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.LoginResponse Constructor

ConferenceApiHandlerLoginResponse Constructor

Initializes a new instance of the ConferenceApiHandlerLoginResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetIndividualVotingResultsResponse Properties

The ConferenceApiHandlerGetIndividualVotingResultsResponse type exposes the following members.

Properties
 | Name | Description
Public property | VotingResults | List of individual voting results
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetAgendaTopicsRequest Class

ConferenceApiHandlerGetAgendaTopicsRequest Class

Represents the agenda topic request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetAgendaTopicsRequest
Syntax
Json
{ JsonClass:GetAgendaTopicsRequest		MeetingId:<type>,
 }

The ConferenceApiHandlerGetAgendaTopicsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetAgendaTopicsRequest | Initializes a new instance of the ConferenceApiHandlerGetAgendaTopicsRequest class
Top
Properties
 | Name | Description
Public property | MeetingId | The meeting identifier.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


PluginHandler.ConnectionIdAndPluginInstance.PluginInstance Property

PluginInstance Property

Syntax
Json
{ Property:PluginInstance }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.ShiftResponseRequest Method

ShiftResponseRequest Method

Shift the selected response request.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConnectionTracker.SendEvent Method (Guid, ConferenceEvent)

SendEvent Method (Guid, ConferenceEvent)

 Bosch Logo
Send events to all clients where a specific user is logged in
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


BoothNotificationInfo Constructor

Initializes a new instance of the InterpretationRoutingInfo class.
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetPluginResponse.PluginDescriptionResponse Property

PluginDescriptionResponse Property

Plugin description
Syntax
Json
{ Property:PluginDescriptionResponse }
See Also

Reference

SynopticControl.CommonPluginDescription


NotesFileInfo.CreationDateTime Property

CreationDateTime Property

File creation date time.
Syntax
Json
{ Property:CreationDateTime }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SynopticControl.Server Namespace

The Conference protocol Server
Classes
 | Class | Description
Public class | CertificateWrapper |
Protected class | ConferenceApiAttribute | Only methods with this attibute can be called
Public class | ConferenceApiController | Controller for the conference API
Private class | ConferenceApiControllerConferenceMessage | Definition of a conference message
Private class | ConferenceApiControllerErrorResponse | The protocol message that holds the return parameters for error messages
Public class | ConferenceApiHandler | The actual processing of conference messages
Private class | ConferenceApiHandlerAbortVotingRequest | Represents the abort voting info request
Private class | ConferenceApiHandlerAbortVotingResponse | Represents the abort voting info response
Private class | ConferenceApiHandlerAcceptVotingRequest | Represents the accept voting info request
Private class | ConferenceApiHandlerAcceptVotingResponse | Represents the accept voting info response
Private class | ConferenceApiHandlerActivateAdHocVotingRequest | Represents the activate ad-hoc voting info request.
Private class | ConferenceApiHandlerActivateAdHocVotingResponse | Represents the activate ad-hoc meeting info response.
Private class | ConferenceApiHandlerActivateMeetingRequest | Represents the activate meeting info request.
Private class | ConferenceApiHandlerActivateMeetingResponse | Represents the activate meeting info response.
Private class | ConferenceApiHandlerActivateMicrophoneRequest | Represents the activation of the microphone request
Private class | ConferenceApiHandlerActivateMicrophoneResponse | Represents the activation of the microphone response.
Private class | ConferenceApiHandlerActivatePresentationRequest |
Private class | ConferenceApiHandlerActivatePresentationResponse | Represents to activate the presentation response
Private class | ConferenceApiHandlerActivateVotingRequest | Represents the activate voting info request.
Private class | ConferenceApiHandlerActivateVotingResponse | Represents the activate meeting info response.
Private class | ConferenceApiHandlerAddSeatToSpeakersRequest | Represents the speaker request
Private class | ConferenceApiHandlerAddSeatToSpeakersResponse | Represents the speaker response.
Private class | ConferenceApiHandlerCancelInterpreterMetaFunctionRequest | Represents cancel interpreter meta function request.
Private class | ConferenceApiHandlerCancelInterpreterMetaFunctionResponse | Represents cancel interpreter function response.
Private class | ConferenceApiHandlerCheckNotesFileTamperedRequest | Defines CheckNotesFileTampered request
Private class | ConferenceApiHandlerCheckNotesFileTamperedResponse | Defines CheckNotesFileTampered response
Private class | ConferenceApiHandlerCloseAgendaRequest | Represents the close agenda topic request.
Private class | ConferenceApiHandlerCloseAgendaResponse | Represents the close agenda topic response.
Private class | ConferenceApiHandlerCloseMeetingRequest | Represents the close meeting info request.
Private class | ConferenceApiHandlerCloseMeetingResponse | Represents the close meeting info response.
Private class | ConferenceApiHandlerCloseVotingRequest | Represents the close voting info request
Private class | ConferenceApiHandlerCloseVotingResponse | Represents the close voting info response
Private class | ConferenceApiHandlerCreateFileRequest |
Private class | ConferenceApiHandlerCreateFileResponse | Represents the create file response
Private class | ConferenceApiHandlerDeactivateMeetingRequest | Represents the deactivate meeting info request.
Private class | ConferenceApiHandlerDeactivateMeetingResponse | Represents the deactivate meeting info response.
Private class | ConferenceApiHandlerDeactivateMicrophoneRequest | Represents the deactivation of the microphone request
Private class | ConferenceApiHandlerDeactivateMicrophoneResponse | Represents the deactivation of the microphone response
Private class | ConferenceApiHandlerDeactivatePresentationRequest |
Private class | ConferenceApiHandlerDeactivatePresentationResponse | Represents to deactivate the presentation response
Private class | ConferenceApiHandlerDeleteFileRequest | Represents the delete file request
Private class | ConferenceApiHandlerDeleteFileResponse | Represents the delete file response
Private class | ConferenceApiHandlerDeleteImageRequest | Represents the delete image request.
Private class | ConferenceApiHandlerDeleteImageResponse | Represents the delete image response
Private class | ConferenceApiHandlerDeleteNotesFilesRequest | Defines delete notes file request
Private class | ConferenceApiHandlerDeleteNotesFilesResponse | Defines delete notes file response
Private class | ConferenceApiHandlerEnableSeatIlluminationRequest | Represents the EnableSeatIllumination request
Private class | ConferenceApiHandlerEnableSeatIlluminationResponse | Represents the EnableSeatIllumination response
Private class | ConferenceApiHandlerEventResponse | Events response
Private class | ConferenceApiHandlerGetAgendaTopicsRequest | Represents the agenda topic request
Private class | ConferenceApiHandlerGetAgendaTopicsResponse | Represents the agenda topic response.
Private class | ConferenceApiHandlerGetApiStateRequest | Parameters to GetApiState
Private class | ConferenceApiHandlerGetApiStateResponse | Response from GetApiState
Private class | ConferenceApiHandlerGetBoothNotificationsRequest | Represents the get booth notifications request
Private class | ConferenceApiHandlerGetBoothNotificationsResponse | Represents the get booth notifications response
Private class | ConferenceApiHandlerGetDiscussionListRequest | Represents the get discussion list request.
Private class | ConferenceApiHandlerGetDiscussionListResponse | Represents the get discussion list response.
Private class | ConferenceApiHandlerGetDiscussionOptionsRequest | Represents the get discussion options request.
Private class | ConferenceApiHandlerGetDiscussionOptionsResponse | Represents the get discussion options response.
Private class | ConferenceApiHandlerGetEnableSeatIlluminationRequest | Represents the get enable seat illumination request
Private class | ConferenceApiHandlerGetEnableSeatIlluminationResponse | Represents the get enable seat illumination response
Private class | ConferenceApiHandlerGetIlluminatedSeatRequest | Represents the GetIlluminatedSeat request
Private class | ConferenceApiHandlerGetIlluminatedSeatResponse | Represents the GetIlluminatedSeat response
Private class | ConferenceApiHandlerGetImageServerInfoRequest | Represents the get image server info request
Private class | ConferenceApiHandlerGetImageServerInfoResponse | Represents the get image server info response
Private class | ConferenceApiHandlerGetIndividualVotingResultsRequest | Represents the get individual voting result request
Private class | ConferenceApiHandlerGetIndividualVotingResultsResponse | Represents the get individual voting result response
Private class | ConferenceApiHandlerGetInterpretationLanguagesRequest | Represents the get interpretation languages request
Private class | ConferenceApiHandlerGetInterpretationLanguagesResponse | Represents the get interpretation languages response
Private class | ConferenceApiHandlerGetInterpretationMetaFunctionStatusRequest | Represents get speak slow status request.
Private class | ConferenceApiHandlerGetInterpretationMetaFunctionStatusResponse | Represents get speak slow status response.
Private class | ConferenceApiHandlerGetInterpretationRoutingsRequest | Represents the request to get interpretation routings
Private class | ConferenceApiHandlerGetInterpretationRoutingsResponse | Represents the response for get interpretation routings
Private class | ConferenceApiHandlerGetInterpreterBoothsRequest | Represents the request to get interpreter booths
Private class | ConferenceApiHandlerGetInterpreterBoothsResponse | Represents the response for get interpreter booths
Private class | ConferenceApiHandlerGetInterpreterSeatsRequest | Represents the request to get interpreter seats
Private class | ConferenceApiHandlerGetInterpreterSeatsResponse | Represents the response for get interpreter seats
Private class | ConferenceApiHandlerGetMajorityResultRequest | Represents the get voting majority result request
Private class | ConferenceApiHandlerGetMajorityResultResponse | Represents the get voting majority result response
Private class | ConferenceApiHandlerGetMasterVolumeRangeRequest | Represents the get master volume range request
Private class | ConferenceApiHandlerGetMasterVolumeRangeResponse | Represents the get master volume range response
Private class | ConferenceApiHandlerGetMasterVolumeRequest | Represents the get master volume request
Private class | ConferenceApiHandlerGetMasterVolumeResponse | Represents the get master volume response
Private class | ConferenceApiHandlerGetMeetingInfoRequest | Represents the meeting info request
Private class | ConferenceApiHandlerGetMeetingInfoResponse | Represents the meeting info response.
Private class | ConferenceApiHandlerGetMeetingsRequest | Represents the meetings info request.
Private class | ConferenceApiHandlerGetMeetingsResponse | Represents the meetings info response.
Private class | ConferenceApiHandlerGetMicrophoneSensitivityDescriptionRequest | Microphone sensitivity description request.
Private class | ConferenceApiHandlerGetMicrophoneSensitivityDescriptionResponse | Microphone sensitivity description response.
Private class | ConferenceApiHandlerGetMicrophoneSensitivityRequest | Get microphone sensitivity request.
Private class | ConferenceApiHandlerGetMicrophoneSensitivityResponse | Get microphone sensitivity response.
Private class | ConferenceApiHandlerGetNotesFileListRequest | Represents the meeting and voting notes file list request
Private class | ConferenceApiHandlerGetNotesFileListResponse | Represents the meeting voting notes file list response
Private class | ConferenceApiHandlerGetParticipantAccessDeniedReasonsRequest | Represents the get participant access denied reasons request
Private class | ConferenceApiHandlerGetParticipantAccessDeniedReasonsResponse | Represents the get participant access denied reasons response
Private class | ConferenceApiHandlerGetParticipantSeatsRequest | Represents the get participants seat info request.
Private class | ConferenceApiHandlerGetParticipantSeatsResponse | Represents the get participants seat info response.
Private class | ConferenceApiHandlerGetParticipantsRequest | Represents the request for get participant.
Private class | ConferenceApiHandlerGetParticipantsResponse | Represents the get participant response.
Private class | ConferenceApiHandlerGetPermissionsRequest | Parameters to GetPermissions
Private class | ConferenceApiHandlerGetPermissionsResponse | Response from GetPermissions
Private class | ConferenceApiHandlerGetPluginCommandsRequest | Represent the request for GetPluginCommands
Private class | ConferenceApiHandlerGetPluginCommandsResponse | Represents the response of GetPluginCommands
Private class | ConferenceApiHandlerGetPluginEventDataRequest | Represents the GetPluginEventDataRequest
Private class | ConferenceApiHandlerGetPluginEventDataResponse | Represents the GetPluginEventDataResponse
Private class | ConferenceApiHandlerGetPluginRequest | Represents the get plugin request
Private class | ConferenceApiHandlerGetPluginResponse | Response for get plugin request
Private class | ConferenceApiHandlerGetPluginsRequest | Get plugins request Remarks Gets all registered plugins
Private class | ConferenceApiHandlerGetPluginsResponse | Response for get plugins request
Private class | ConferenceApiHandlerGetPresentationStateRequest |
Private class | ConferenceApiHandlerGetPresentationStateResponse | Represents the get presentation state response
Private class | ConferenceApiHandlerGetQuorumResultRequest | Represents the get quorum result request
Private class | ConferenceApiHandlerGetQuorumResultResponse | Represents the get quorum result response
Private class | ConferenceApiHandlerGetRoomContactEmailRequest | Parameters to GetRoomContactEmail.
Private class | ConferenceApiHandlerGetRoomContactEmailResponse | Response from GetRoomContactEmail.
Private class | ConferenceApiHandlerGetRoomNameRequest | Parameters to GetRoomName.
Private class | ConferenceApiHandlerGetRoomNameResponse | Response from GetRoomName
Private class | ConferenceApiHandlerGetSeatsRequest | Parameters to GetSeats
Private class | ConferenceApiHandlerGetSeatsResponse | Response from GetSeats
Private class | ConferenceApiHandlerGetSeatVotingResultsRequest | Represents the get seat voting result request
Private class | ConferenceApiHandlerGetSeatVotingResultsResponse | Represents the get seat voting result response
Private class | ConferenceApiHandlerGetSupportedHeadphonesRequest | Represents the get supported headphones request
Private class | ConferenceApiHandlerGetSupportedHeadphonesResponse | Represents the get supported headphones response
Private class | ConferenceApiHandlerGetSystemPowerModeRequest | Parameters to GetSystemPowerModeRequest
Private class | ConferenceApiHandlerGetSystemPowerModeResponse | Response from GetSystemPowerModeResponse
Private class | ConferenceApiHandlerGetVotingInfoRequest | Represents the get voting info request
Private class | ConferenceApiHandlerGetVotingInfoResponse | Represents the get voting info response
Private class | ConferenceApiHandlerGetVotingResultsRequest | Represents the get voting results request
Private class | ConferenceApiHandlerGetVotingResultsResponse | Represents the get voting results response
Private class | ConferenceApiHandlerGetVotingsRequest | Represents the info voting request
Private class | ConferenceApiHandlerGetVotingsResponse | Represents the voting info response
Private class | ConferenceApiHandlerGetVotingStateRequest | Represents the get voting state request
Private class | ConferenceApiHandlerGetVotingStateResponse | Represents the get voting state response
Private class | ConferenceApiHandlerGrantInterpretationRequest | Represents the grant interpretation request
Private class | ConferenceApiHandlerGrantInterpretationResponse | Represents the grant interpretation response
Private class | ConferenceApiHandlerGrantResponseRequest | Represents the requested responder to respond request
Private class | ConferenceApiHandlerGrantResponseResponse | Represents the requested responder to respond response.
Private class | ConferenceApiHandlerGrantSpeechRequest | Represents the grant of the speech by seats and participants request
Private class | ConferenceApiHandlerGrantSpeechResponse | Represents the grant of the speech by seats and participants response.
Private class | ConferenceApiHandlerHoldVotingRequest | Represents the hold voting info request
Private class | ConferenceApiHandlerHoldVotingResponse | Represents the hold voting info response
Private class | ConferenceApiHandlerIssueInterpreterMetaFunctionRequest | Represents issue interpreter meta function request.
Private class | ConferenceApiHandlerIssueInterpreterMetaFunctionResponse | Represents issue interpreter meta function response.
Private class | ConferenceApiHandlerListFilesRequest | Represents the file request
Private class | ConferenceApiHandlerListFilesResponse | Represents the list file response
Private class | ConferenceApiHandlerListImagesRequest | Represents the list images request
Private class | ConferenceApiHandlerListImagesResponse | Represents the list images response
Private class | ConferenceApiHandlerLoadFileRequest | Represents the open file request
Private class | ConferenceApiHandlerLoadFileResponse | Represents the open file response
Private class | ConferenceApiHandlerLoginRequest | Parameters to Login
Private class | ConferenceApiHandlerLoginResponse | Response from Login
Private class | ConferenceApiHandlerLogoutRequest | Logout request
Private class | ConferenceApiHandlerLogoutResponse | Logout response
Private class | ConferenceApiHandlerOpenAgendaRequest | Represents the open agenda topic request.
Private class | ConferenceApiHandlerOpenAgendaResponse | Represents the open agenda topic response.
Private class | ConferenceApiHandlerOpenMeetingRequest | Represents the close meeting info request.
Private class | ConferenceApiHandlerOpenMeetingResponse | Represents the open meeting info response.
Private class | ConferenceApiHandlerOpenVotingRequest | Represents the open voting info request
Private class | ConferenceApiHandlerOpenVotingResponse | Represents the open voting info response
Private class | ConferenceApiHandlerRaiseBoothNotificationRequest | Represents the request to raise notifications on a booth
Private class | ConferenceApiHandlerRaiseBoothNotificationResponse | Represents the raise notifications on a booth response
Private class | ConferenceApiHandlerRegisterEventsRequest | Parameters to RegisterEvents
Private class | ConferenceApiHandlerRegisterEventsResponse | Respoonse from RegisterEvents
Private class | ConferenceApiHandlerRegisterPluginRequest |
Private class | ConferenceApiHandlerRegisterPluginResponse | Represents the register plugin response
Private class | ConferenceApiHandlerRejectVotingRequest | Represents the reject voting info request
Private class | ConferenceApiHandlerRejectVotingResponse | Represents the reject voting info response
Private class | ConferenceApiHandlerRemoveResponseRequest | Represents the removal of requested responder request
Private class | ConferenceApiHandlerRemoveResponseResponse | Represents the removal of requested responder response.
Private class | ConferenceApiHandlerRemoveSeatFromDiscussionListRequest | Represents the removal of seat from discussion list request
Private class | ConferenceApiHandlerRemoveSeatFromDiscussionListResponse | Represents the removal of seat from discussion list response.
Private class | ConferenceApiHandlerRemoveSpeechRequest | Represents the removal of the speech by seats and participants request.
Private class | ConferenceApiHandlerRemoveSpeechResponse | Represents the removal of the speech by seats and participants response.
Private class | ConferenceApiHandlerRequestResponseRequest | Represents the reponse to the speaker by seats and participants request
Private class | ConferenceApiHandlerRequestResponseResponse | Represents the reponse to the speaker by seats and participants response.
Private class | ConferenceApiHandlerRequestSpeechRequest | Represents the request for the speech by seats and participants request
Private class | ConferenceApiHandlerRequestSpeechResponse | Represents the request for the speech by seats and participants response.
Private class | ConferenceApiHandlerResetMicrophoneSensitivityRequest | Reset seat microphone sensitivity level to 0.
Private class | ConferenceApiHandlerResetMicrophoneSensitivityResponse | Reset microphone sensitivity response.
Private class | ConferenceApiHandlerResumeVotingRequest | Represents the resume voting info request
Private class | ConferenceApiHandlerResumeVotingResponse | Represents the resume voting info response
Private class | ConferenceApiHandlerSaveImageRequest | Represents the save image request
Private class | ConferenceApiHandlerSaveImageResponse | Represents the save image response
Private class | ConferenceApiHandlerSelectInterpretationFloorRequest | Represents the request to select either floor
Private class | ConferenceApiHandlerSelectInterpretationFloorResponse | Represents the select floor response
Private class | ConferenceApiHandlerSelectInterpretationInputLanguageRequest | Represents the request to select the language on an input
Private class | ConferenceApiHandlerSelectInterpretationInputLanguageResponse | Represents the select input language response
Private class | ConferenceApiHandlerSelectRelayInterpretationRequest | Represents the request to select relay interpretation
Private class | ConferenceApiHandlerSelectRelayInterpretationResponse | Represents the select relay interpretation response
Private class | ConferenceApiHandlerSendPluginCommandRequest | Request for sending plugin command.
Private class | ConferenceApiHandlerSendPluginCommandResponse | Response for send plugin command .
Private class | ConferenceApiHandlerSendPluginEventRequest | Request for get plugin by name
Private class | ConferenceApiHandlerSendPluginEventResponse | Response for send plugin Event .
Private class | ConferenceApiHandlerSetIlluminateSeatRequest | Represents the set illuminate seat request
Private class | ConferenceApiHandlerSetIlluminateSeatResponse | Represents the set illuminate seat response
Private class | ConferenceApiHandlerSetInterpretationOutputPresetRequest | Represents the set interpretation out preset request
Private class | ConferenceApiHandlerSetInterpretationOutputPresetResponse | Represents the set interpretation out preset response
Private class | ConferenceApiHandlerSetMasterVolumeRequest | Represents the set master volume request
Private class | ConferenceApiHandlerSetMasterVolumeResponse | Represents the set master volume response
Private class | ConferenceApiHandlerSetPluginCommandResultRequest | Represents the request for SetPluginCommandResult
Private class | ConferenceApiHandlerSetPluginCommandResultResponse | Represents the response of SetPluginCommandResult
Private class | ConferenceApiHandlerSetSystemPowerModeRequest | Parameters to SetSystemPowerModeRequest
Private class | ConferenceApiHandlerSetSystemPowerModeResponse | Response from SetSystemPowerModeResponse
Private class | ConferenceApiHandlerSubscribePluginEventRequest | Request for subscribing to plugin event
Private class | ConferenceApiHandlerSubscribePluginEventResponse | Response for subscribing to plugin event
Private class | ConferenceApiHandlerTransformNotesFileRequest | Defines transform notes file request
Private class | ConferenceApiHandlerTransformNotesFileResponse | Defines transform notes file response
Private class | ConferenceApiHandlerUnregisterEventsRequest | Parameters to UnRegisterEvents
Private class | ConferenceApiHandlerUnregisterEventsResponse | Respoonse from UnRegisterEvents
Private class | ConferenceApiHandlerUnRegisterPluginRequest | Unregister plugin request
Private class | ConferenceApiHandlerUnRegisterPluginResponse | Unregister plugin response
Private class | ConferenceApiHandlerUnSubscribePluginEventRequest | Request for unsubscribing to plugin event
Private class | ConferenceApiHandlerUnSubscribePluginEventResponse | Response for unsubscribing to plugin event
Private class | ConferenceApiHandlerUpdateFileRequest | Represents the save file request
Private class | ConferenceApiHandlerUpdateFileResponse | Represents the save file response
Private class | ConferenceApiHandlerUpdateMicrophoneSensitivityRequest |
Private class | ConferenceApiHandlerUpdateMicrophoneSensitivityResponse | Update microphone sensitivity response.
Protected class | ConferenceApiMethodCallerResponse, Request |
Public class | ConferenceException | This class to return simple error messages to the client.
Protected class | ConferenceModel |
Protected class | ConferenceModelReader | Create model for conference functions.
Protected class | ConferenceUsers |
Public class | FileStore | FileStore class
Public class | ImageManagement | ImageManagement class
Public class | PluginHandler |
Private class | PluginHandlerAwaiterInfo |
Private class | PluginHandlerConnectionIdAndPluginInstance |
Private class | PluginHandlerPluginEventSubscriptionData |
Protected class | SendPluginCommandInfo |
Interfaces
 | Interface | Description
Public interface | ICertificateWrapper |
Protected interface | IConferenceApiMethodCaller |
Protected interface | IConferenceConnection | Interface to send conference events


DcnmApi.RegisterWebApplication Method

RegisterWebApplication Method

Updates the latest web application info
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


Meeting.DocumentationRef Property

DocumentationRef Property

Syntax
Json
{ Property:DocumentationRef }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


UnregisterEventsRequest Properties

The ConferenceApiHandlerUnregisterEventsRequest type exposes the following members.

Properties
 | Name | Description
Public property | Events | List of unregistered events
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


IndividualVotingResult.participantId Property

participantId Property

participant id
Syntax
Json
{ Property:participantId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


MajorityResultInfo Constructor

Initializes instance of class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

SynopticControl.CommonMajorityResultInfo


ConferenceApiHandler.GetApiStateRequest Class

ConferenceApiHandlerGetApiStateRequest Class

Parameters to GetApiState
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetApiStateRequest
Syntax
Json
{ JsonClass:GetApiStateRequest	 }

The ConferenceApiHandlerGetApiStateRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetApiStateRequest | Initializes a new instance of the ConferenceApiHandlerGetApiStateRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiMethodCaller(Response, Request).Call Method

Call Method

Syntax
Json
Implements
IConferenceApiMethodCallerCall(Object, JToken)
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


VotingTimerType Enumeration

Syntax
Json
VotingTimerType:{
NoVotingTimer
KeepVotingOpen
HoldVotingRound
CloseVotingRound}
Members
Member name | Value | Description
NoVotingTimer | 0 | No need to use voting timer.
KeepVotingOpen | 1 | Need to keep voting open when voting time is reached.
HoldVotingRound | 2 | Need to hold voting round when voting time is reached..
CloseVotingRound | 3 | Need to close voting round when voting time is reached.
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UnSubscribePluginEventRequest Class

ConferenceApiHandlerUnSubscribePluginEventRequest Class

Request for unsubscribing to plugin event
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerUnSubscribePluginEventRequest
Syntax
Json
{ JsonClass:UnSubscribePluginEventRequest		EventName:<type>,
    PluginName:<type>,
 }

The ConferenceApiHandlerUnSubscribePluginEventRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerUnSubscribePluginEventRequest | Initializes a new instance of the ConferenceApiHandlerUnSubscribePluginEventRequest class
Top
Properties
 | Name | Description
Public property | EventName | Event name to unsubscribe from plugin
Public property | PluginName | The name of the Plugin
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AssemblyRedirect.LoadDependentsForAssembly Method

LoadDependentsForAssembly Method

Load a DLL and all its dependents
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateHasMeetingPreparationAndManagementLicense Method

UpdateHasMeetingPreparationAndManagementLicense Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


IConferenceApiMethodCaller Properties

The IConferenceApiMethodCaller type exposes the following members.

Properties
 | Name | Description
Public property | LoginRequired |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


RequestSpeechRequest Properties

The ConferenceApiHandlerRequestSpeechRequest type exposes the following members.

Properties
 | Name | Description
Public property | ParticipantIds | List of particpant identifiers.
Public property | SeatIds | List of seat identifiers.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SendPluginEventResponse Constructor

ConferenceApiHandlerSendPluginEventResponse Constructor

Initializes a new instance of the ConferenceApiHandlerSendPluginEventResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetSupportedHeadphonesResponse Constructor

ConferenceApiHandlerGetSupportedHeadphonesResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerGetSupportedHeadphonesResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetSupportedHeadphonesResponse Properties

The ConferenceApiHandlerGetSupportedHeadphonesResponse type exposes the following members.

Properties
 | Name | Description
Public property | SupportedHeadphones |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetQuorumResult Method

GetQuorumResult Method

Gets the meeting quorum result
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "quorumResult":
    {
        "comparisonOperator": "greaterThan"|"greaterThanOrEqualTo"|"equals"|"lessThan"|"lessThanOrEqualTo",
        "denominatorValue": <int>,
        "isEnabled": <bool>,
        "numeratorValue": <int>,
        "status": "true"|"false"|"error",
        "thresholdValue": <int>
    }
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RegisterPluginResponse Constructor

ConferenceApiHandlerRegisterPluginResponse Constructor

Initializes a new instance of the ConferenceApiHandlerRegisterPluginResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UnregisterEventsResponse Class

ConferenceApiHandlerUnregisterEventsResponse Class

Respoonse from UnRegisterEvents
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerUnregisterEventsResponse
Syntax
Json
{ JsonClass:UnregisterEventsResponse	 }

The ConferenceApiHandlerUnregisterEventsResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerUnregisterEventsResponse | Initializes a new instance of the ConferenceApiHandlerUnregisterEventsResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateSeatsUnassigedInfo Method

UpdateSeatsUnassigedInfo Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.CloseAgendaRequest Constructor

ConferenceApiHandlerCloseAgendaRequest Constructor

Initializes a new instance of the ConferenceApiHandlerCloseAgendaRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetPluginCommandsRequest Class

ConferenceApiHandlerGetPluginCommandsRequest Class

Represent the request for GetPluginCommands
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetPluginCommandsRequest
Syntax
Json
{ JsonClass:GetPluginCommandsRequest	 }

The ConferenceApiHandlerGetPluginCommandsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetPluginCommandsRequest | Initializes a new instance of the ConferenceApiHandlerGetPluginCommandsRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ICloneable(T).Clone Method

Clone Method

handles clone
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


Certificate.GetOidCollection Method

GetOidCollection Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateAssignedParticipantsInfo Method

UpdateAssignedParticipantsInfo Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


CertificateWrapper.GetCertificate Method

GetCertificate Method

Syntax
Json
Implements
ICertificateWrapperGetCertificate(StoreName, String)
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


CertificateWrapper Class

Inheritance Hierarchy
SystemObject
SynopticControl.ServerCertificateWrapper
Syntax
Json
{ JsonClass:CertificateWrapper	 }

The CertificateWrapper type exposes the following members.

Constructors
 | Name | Description
Public method | CertificateWrapper | Initializes a new instance of the CertificateWrapper class
Top
Methods
 | Name | Description
Public method | GetCertificate |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetIlluminateSeatRequest.SetIlluminate Property

SetIlluminate Property

Set illuminate
Syntax
Json
{ Property:SetIlluminate }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpretationRoutingInfo.MicrophoneState Property

MicrophoneState Property

Gets or sets the state of the microphone.
Syntax
Json
{ Property:MicrophoneState }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetRoomNameResponse Class

ConferenceApiHandlerGetRoomNameResponse Class

Response from GetRoomName
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetRoomNameResponse
Syntax
Json
{ JsonClass:GetRoomNameResponse		RoomName:<type>,
 }

The ConferenceApiHandlerGetRoomNameResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetRoomNameResponse | Initializes a new instance of the ConferenceApiHandlerGetRoomNameResponse class
Top
Properties
 | Name | Description
Public property | RoomName |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetPluginCommandsResponse Constructor

ConferenceApiHandlerGetPluginCommandsResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetPluginCommandsResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UnregisterEventsRequest Constructor

ConferenceApiHandlerUnregisterEventsRequest Constructor

Initializes a new instance of the ConferenceApiHandlerUnregisterEventsRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpretationMetaRequestStatus.ActiveInterpretationMetaRequests Property

ActiveInterpretationMetaRequests Property

Active interpretation meta request type.
Syntax
Json
{ Property:ActiveInterpretationMetaRequests }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.CanViewRequestItems Property

CanViewRequestItems Property

Contains can view request items
Syntax
Json
{ Property:CanViewRequestItems }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetInterpreterBoothsRequest Class

ConferenceApiHandlerGetInterpreterBoothsRequest Class

Represents the request to get interpreter booths
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetInterpreterBoothsRequest
Syntax
Json
{ JsonClass:GetInterpreterBoothsRequest	 }

The ConferenceApiHandlerGetInterpreterBoothsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetInterpreterBoothsRequest | Initializes a new instance of the ConferenceApiHandlerGetInterpreterBoothsRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ActivateMicrophoneRequest.SeatIds Property

SeatIds Property

List of seat identifiers.
Syntax
Json
{ Property:SeatIds }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetImageServerInfoRequest Constructor

ConferenceApiHandlerGetImageServerInfoRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetImageServerInfoRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.ActivateMicrophone Method

ActivateMicrophone Method

Syntax
Json
Request:

Copy
{
    "participantIds": [<string>],
    "seatId": <string>,
    "seatIds": [<string>]
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SendPluginCommandInfo Properties

The SendPluginCommandInfo type exposes the following members.

Properties
 | Name | Description
Public property | CorrelationId |
Public property | PluginCommand |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileStore.LoadFile Method

LoadFile Method

Get the detailed information for a specific file layout
Syntax
Json
Request:

Copy
{
    "fileId": <string>
}

Response:

Copy
{
    "fileInfo":
    {
        "attributes": [<string>],
        "fileId": <string>,
        "payload": <string>,
        "title": <string>
    }
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RaiseBoothNotificationRequest.BoothId Property

BoothId Property

Syntax
Json
{ Property:BoothId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.ReadDataFromJsonFile Method

ReadDataFromJsonFile Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


FileInfoDetail Properties

The FileInfoDetail type exposes the following members.

Properties
 | Name | Description
Public property | FileId | Id of the file
Public property | Title | Title of the file
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.InterpreterBooths Property

InterpreterBooths Property

Syntax
Json
{ Property:InterpreterBooths }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Participant Constructor

Initializes a new instance of the Participant class.
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetEnableSeatIlluminationRequest Constructor

ConferenceApiHandlerGetEnableSeatIlluminationRequest Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerGetEnableSeatIlluminationRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetMasterVolumeRangeRequest Constructor

ConferenceApiHandlerGetMasterVolumeRangeRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetMasterVolumeRangeRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnDevicesAssignedToSeats Method

OnDevicesAssignedToSeats Method

Handles devices that are assigned to seats.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


InterpreterDeskInfo.ALanguageId Property

ALanguageId Property

Gets or sets the A language identifier.
Syntax
Json
{ Property:ALanguageId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpreterDeskInfo.Status Property

Status Property

Gets or sets the status.
Syntax
Json
{ Property:Status }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileLogTraceListener.EnsureWriter Method

EnsureWriter Method

In case no writer is present a new writer will be created. The configured cycle determines if a new log file needs to be created.
Syntax
Json
  Remarks
The writer creater is based on the filename as given, added with a
            number based on the "Cycle" option of this listener. When no cycle is programmed
            for this listener, only the filename is used. If the result file is not accessable
            (due to not mentioned reasons), a new file will be created, having the original name, added with a GUID.
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ListImagesResponse.Images Property

Images Property

List of images
Syntax
Json
{ Property:Images }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SaveImageRequest Properties

The ConferenceApiHandlerSaveImageRequest type exposes the following members.

Properties
 | Name | Description
Public property | ImageData | The image data
Public property | Name | The name of the image
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


EnumDeskType Enumeration

Syntax
Json
EnumDeskType:{
Dicentis
Omneo
Dante}
Members
Member name | Value | Description
Dicentis | 0 |
Omneo | 1 |
Dante | 2 |
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ActivateMeetingResponse Class

ConferenceApiHandlerActivateMeetingResponse Class

Represents the activate meeting info response.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerActivateMeetingResponse
Syntax
Json
{ JsonClass:ActivateMeetingResponse	 }

The ConferenceApiHandlerActivateMeetingResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerActivateMeetingResponse | Initializes a new instance of the ConferenceApiHandlerActivateMeetingResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.DetermineVoteCastedVisibilityForUser Method

DetermineVoteCastedVisibilityForUser Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DeviceInfo Class

Contains device information
Inheritance Hierarchy
SystemObject
SynopticControl.CommonDeviceInfo
Syntax
Json
{ JsonClass:DeviceInfo		Capabilities:<type>,
    DeviceState:<type>,
    Id:<type>,
    IsFoundAtSeat:<type>,
    IsSelected:<type>,
    Name:<type>,
    SerialNumber:<type>,
    SubDeviceInstance:<type>,
    TypeOf:<type>,
    Version:<type>,
 }

The DeviceInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DeviceInfo | Default constructor
Top
Properties
 | Name | Description
Public property | Capabilities |
Public property | DeviceState |
Public property | Id |
Public property | IsFoundAtSeat |
Public property | IsSelected |
Public property | Name |
Public property | SerialNumber |
Public property | SubDeviceInstance |
Public property | TypeOf |
Public property | Version |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetInterpretationMetaFunctionStatusResponse.RequestStatus Property

RequestStatus Property

Syntax
Json
{ Property:RequestStatus }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpretationLanguage Properties

The InterpretationLanguage type exposes the following members.

Properties
 | Name | Description
Public property | Abbreviation | Gets or sets the language abbreviation.
Public property | Index | Gets or sets the index of the language.
Public property | Label | Gets or sets the language label.
Public property | LanguageId | Gets or sets the language identifier.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetDiscussionListRequest Constructor

ConferenceApiHandlerGetDiscussionListRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetDiscussionListRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SubscribePluginEventRequest Constructor

ConferenceApiHandlerSubscribePluginEventRequest Constructor

Initializes a new instance of the ConferenceApiHandlerSubscribePluginEventRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


CreateCertificateResponse.PublicCrtData Property

PublicCrtData Property

Syntax
Json
{ Property:PublicCrtData }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetInterpretationLanguages Method

GetInterpretationLanguages Method

Returns interpretation languages to requested clients.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "languages":
    [
        {
            "abbreviation": <string>,
            "index": <int>,
            "label": <string>,
            "languageId": <string>
        }
    ]
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetIndividualVotingResultsRequest Constructor

ConferenceApiHandlerGetIndividualVotingResultsRequest Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerGetIndividualVotingResultsRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.ParticipationInfoList Property

ParticipationInfoList Property

Participation info list placeholder.
Syntax
Json
{ Property:ParticipationInfoList }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


CreateCertificateResponse.Success Property

Success Property

Syntax
Json
{ Property:Success }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnAreaCreated Method

OnAreaCreated Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


AgendaState Enumeration

Defines state of the agenda
Syntax
Json
AgendaState:{
opened
closed}
Members
Member name | Value | Description
opened | 0 | Opened state
closed | 1 | Closed state
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SystemLog.TraceError Method (String)

TraceError Method (String)

 Bosch Logo
Forwards the error event to the trace source.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


PluginHandler.UnSubscribePluginEvents Method

UnSubscribePluginEvents Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceUsers.UpdateUserPermission Method

UpdateUserPermission Method

Add user permissions to the user id
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RegisterEventsRequest Constructor

ConferenceApiHandlerRegisterEventsRequest Constructor

Initializes a new instance of the ConferenceApiHandlerRegisterEventsRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateHasParticipantDatabaseLicense Method

UpdateHasParticipantDatabaseLicense Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModelReader.IsInInterpretationOutputLanguageListOfDesk Method

IsInInterpretationOutputLanguageListOfDesk Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


PluginHandler.PluginEventSubscriptionData Constructor

PluginHandlerPluginEventSubscriptionData Constructor

Initializes a new instance of the PluginHandlerPluginEventSubscriptionData class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.CanEnableSeatIIllumination Property

CanEnableSeatIIllumination Property

Indicates can enable seat illumination
Syntax
Json
{ Property:CanEnableSeatIIllumination }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.SelectFloor Method

SelectFloor Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateSeatsAssignedInfo Method

UpdateSeatsAssignedInfo Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel Methods

The ConferenceModel type exposes the following members.

Methods
 | Name | Description
Protected method | AddCreatedMeeting | Adds created meeting to list of prepared meetings
Protected method | AddCreatedVoting | Adds created voting for list of prepared votings
Protected method | AddPreparedMeetings | Adds prepared meetings
Protected method | AddPreparedVotings | Adds prepared votings for meeting
Private method | ClearLastMinuteFlags |
Protected method | ClearStoredData |
Private method | ContainsInSeatsList | Checks if the seat already exists in the seats list.
Private method | ConvertToAgendaState |
Private method | ConvertToComparisonOperator |
Private method | CreateDiscussionListEntry |
Private method | CreateRequesterDiscussionListEntry |
Protected method | CreateSeatInfoList | Creats the seat info list
Protected method | CreateSeatMicrophoneSensitivityInfoList |
Protected method | DeleteBoothArea |
Protected method | DeletePreparedMeeting | Deletes prepared meeting info.
Protected method | DeletePreparedVoting | Deletes prepared voting
Protected method | DeleteSeatMicrophoneSensitivityInfo |
Protected method | DetermineIndividualVoteCastedResultsVisiblityForExternalSystem |
Protected method | DetermineMajorityResultVisiblityForUser | Determine majority results visibility for user
Protected method | DetermineQuorumResultVisiblity | Determine quorum results visibility for user
Private method | DetermineResultsVisiblityForUser |
Protected method | DetermineTotalVoteCastedResultsVisiblityForExternalSystem |
Protected method | DetermineTotalVoteResultVisiblityForUser | Determine total vote results visibility for user
Protected method | DetermineTotalVotesCastedVisibilityForUser | Determine total votes casted visibility for user
Protected method | DetermineVoteCastedVisiblityForUser | Determine vote casted visibility for user
Private method | DetermineVoteResultsVisiblityForVotingState | Determine voting results visibility based on voting state
Protected method | DetermineVoteResultVisiblityForUser | Determine voting results visibility for user
Public method | Dispose |
Protected method | GetAgendaTopicsList | Get agenda topics for the given meetingId.
Protected method | GetApiState |
Private method | GetDeskType |
Private method | GetDeviceIdsFoundAtSeat |
Private method | GetDeviceInfo |
Private method | GetDevicesAtSeat |
Private method | GetHeadphoneAndMicrophoneSelectionInfo |
Private method | GetInterpreterDeskInfo |
Protected method | GetMeetingInfo | Get meeting information for the given meetingId.
Protected method | GetMeetings | Get Meetings.
Protected method | GetParticipantAccessDeniedReasons |
Protected method | GetParticipationInfoList | Get participants list for the given meetingId.
Private method | GetPreferedDisplayOption | Gets the prefered display voting result option among the passed parameters
Private method | GetSeatInfo |
Private method | GetSeatMicrophoneSensitivity |
Protected method | GetSupportedHeadphones |
Private method | GetVoting | Constructs Voting object from DcnmVotingPreparationInfo
Protected method | GetVotings | Get votings for the given meetingId.
Protected method | Initialize | Initilizes conference updater.
Protected method | IsInDiscussionList |
Private method | IsLicenseAvailable |
Private method | MakeParticipantToSeats |
Private method | MakeSeatInfoListAndNotifyOnChange |
Private method | MakeSeatMicrophoneSensitivityListAndNotifyChange |
Private method | NotifyBoothNotificationsChangedOnClients |
Private method | NotifyDiscussListChangeOnClients |
Private method | NotifyInterpretationLanguagesChangedOnClients |
Private method | NotifyInterpretationMetaRequestChangedOnClients |
Private method | NotifyInterpretationRoutingsChangedOnClients |
Private method | NotifyInterpreterBoothInfoChangedOnClients |
Private method | NotifyInterpreterSeatInfoChangedOnClients |
Private method | NotifyMajorityResultChangedOnClients |
Private method | NotifyParticipantAttendanceSummaryChangedOnClients |
Private method | NotifyParticipantsInfoChangedOnClients | Sends participants info changed notification to connected clients
Private method | NotifySeatInfoChangedOnClients | Seats information change notification to connected clients
Private method | NotifySeatMicrophoneSensitivityChangedOnClients |
Private method | NotifyVotingInfoChangedOnClients |
Private method | NotifyVotingStateChangedOnClients |
Private method | OnRefreshSeatRightsTick | Requests participants list on system power cycle
Private method | OnTimerTick |
Private method | PrepareDiscussList |
Private method | ProcessSpeechTimerInterval |
Protected method | RequestAttendanceInfo |
Protected method | RequestVotingResult |
Protected method | SetWebClientDeviceCapabilities | Sets web client device capabilities
Private method | SetWebClientDeviceCapabilities(Guid) | Sets web client device capabilities to contain power off/on and volume control
Protected method | SetWebClientManageMeetingRights | Set can manage meeting rights to web client.
 | SetWebClientManageMeetingRights(DcnmSeatAssignmentInfo) | Sets web client manage meeting rights
Private method | StartSpeechTimer |
Protected method | TryGetInterpreterBoothFromBoothsList |
Protected method | TryGetInterpreterLanguageFromLanguagesList |
Protected method | TryGetInterpreterSeatFromSeatsList |
Private method | UpdateActiveVotingInfo |
Protected method | UpdateActualSpeaker |
Private method | UpdateActualSpeakerDetails |
Protected method | UpdateActualSpeakerVideo |
Protected method | UpdateAgendaTopicsReceived | Updates the agenda topics received. Important: does not work real-time. Use MeetingListChanged for now.
Private method | UpdateAndNotifyOnDeskInfoChanged |
Private method | UpdateAndNotifyOnSeatInfoChanged |
Protected method | UpdateApiState |
Protected method | UpdateApplicationMode | Updates application state
Protected method | UpdateAssignedParticipantsInfo |
Protected method | UpdateAudioSettings |
Protected method | UpdateAutoRelayForBooth |
Protected method | UpdateBoothAreas |
Protected method | UpdateBoothNotificationsList |
Protected method | UpdateDefaultVotingSettings |
Protected method | UpdateDiscussionOptions |
Protected method | UpdateEmptySeatsCreatedInfo | Updates the created empty seat information
Protected method | UpdateFoundDevicesInSeats | Updates the newly found or lost devices on seat
Protected method | UpdateHasHybridLicense |
Protected method | UpdateHasMeetingPreparationAndManagementLicense |
Protected method | UpdateHasParticipantBasedLicense |
Protected method | UpdateHasParticipantDatabaseLicense |
Protected method | UpdateHasRemoteSubscriptionLicense |
Protected method | UpdateHasVotingPreparationAndManagementLicense |
Protected method | UpdateIlluminatedSeat | Updates illuminated Seat Id
Protected method | UpdateImportantSpeakersList |
Protected method | UpdateIndividualVotingResults | Updates voting results.
Private method | UpdateIndividualVotingResultsOnClients | Sends notification to Updates voting results for client
Protected method | UpdateInterpretationLanguages |
Protected method | UpdateInterpretationMetaRequestStatus |
Protected method | UpdateInterpretationRoutingList |
Protected method | UpdateInterpreterSeatsInfo |
Protected method | UpdateMajorityResult |
Protected method | UpdateMeetingStatusInfo | Updates meeting state.
Protected method | UpdateMicrophoneSensitivityForCreatedSeat |
Protected method | UpdateMicrophoneSensitivityForUpdatedSeat |
Protected method | UpdateNotesListUpdated |
Protected method | UpdateParticipantAccessDeniedInfo |
Protected method | UpdateParticipantPictureUpdatedNumber | Update participant picture number for partcipant
Protected method | UpdateParticipantsForMeeting | Update list of participants for active meeting
Protected method | UpdateParticipantsReceived | Updates the participants received.
Protected method | UpdatePreparedMeeting | Updates prepared meeting info.
Protected method | UpdatePreparedVoting | Updates prepared voting
Protected method | UpdatePresentationState |
Protected method | UpdatePriorityList |
Protected method | UpdateQuorumResult |
Protected method | UpdateRequestsList |
Protected method | UpdateRequestToResponseOptions | Updates request to response options
Protected method | UpdateRequestToSpeakOptions | Updates request to speak options
Protected method | UpdateRespondersList |
Protected method | UpdateResponseRequestList |
Protected method | UpdateRoomContactEmailAndNotify |
Protected method | UpdateRoomNameAndNotify |
Private method | UpdateSeatedParticipantInfoOnSeat |
Private method | UpdateSeatInfo |
Protected method | UpdateSeatMicrophoneSensitivity |
Private method | UpdateSeatRights |
Protected method | UpdateSeatsAssignedInfo |
Protected method | UpdateSeatsConfigurationInfo | Updates the seat configuration information
Protected method | UpdateSeatsDeletedInfo | Updates the deleted seats information
Protected method | UpdateSeatsInfo | Updates the seat configuration information for default meeting.
Protected method | UpdateSeatsUnassigedInfo |
Protected method | UpdateSpeakersList |
Protected method | UpdateSpeakerViewingOptions |
Protected method | UpdateSpeechTimeOptions |
Private method | UpdateSpeechTimerOptions |
Protected method | UpdateSystemPowerMode | Updates system power mode.
Protected method | UpdateVotingResult | Updates the voting result.
Protected method | UpdateVotingScriptForMeetingReceived | Updates the voting script for meeting received.
Protected method | UpdateVotingStatus | Update voting state
Protected method | UpdateWebClientManageRight | Updates manage meeting rights for web client.
Private method | UpdateWebClientRights |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateVotingStatus Method

UpdateVotingStatus Method

Update voting state
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetVotingsResponse Class

ConferenceApiHandlerGetVotingsResponse Class

Represents the voting info response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetVotingsResponse
Syntax
Json
{ JsonClass:GetVotingsResponse		VotingList:<type>,
 }

The ConferenceApiHandlerGetVotingsResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetVotingsResponse | Initializes a new instance of the ConferenceApiHandlerGetVotingsResponse class
Top
Properties
 | Name | Description
Public property | VotingList | List of voting
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AssemblyRedirect.Initialize Method

Initialize Method

Ensure that this class is initialized
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DcnmApi.OnMeetingBoothInfoChanged Method

OnMeetingBoothInfoChanged Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.GetHeadphoneAndMicrophoneSelectionInfo Method

GetHeadphoneAndMicrophoneSelectionInfo Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DcnmApi.UpdatePreparedMeetingsInfo Method

UpdatePreparedMeetingsInfo Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.CancelInterpreterMetaFunctionRequest.SeatId Property

SeatId Property

Syntax
Json
{ Property:SeatId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GrantInterpretationRequest Constructor

ConferenceApiHandlerGrantInterpretationRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGrantInterpretationRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ApiLoginDetails.Schema Property

Schema Property

Syntax
Json
{ Property:Schema }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetParticipantSeatsRequest Constructor

ConferenceApiHandlerGetParticipantSeatsRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetParticipantSeatsRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnRequestToSpeakOptionsChanged Method

OnRequestToSpeakOptionsChanged Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


VotingResult.seatId Property

seatId Property

Seat id
Syntax
Json
{ Property:seatId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetBoothNotifications Method

GetBoothNotifications Method

Returns booth notifications to requested clients.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "notifications":
    [
        {
            "boothId": <string>,
            "notifications": [<string>]
        }
    ]
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


CreateCertificateRequest Properties

The CreateCertificateRequest type exposes the following members.

Properties
 | Name | Description
Public property | DnsNames |
Public property | ForceAddCertificateToStore |
Public property | IPAddresses |
Public property | Purpose |
Public property | RootCertificateName |
Public property | ServerCertificateName |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.IsMeetingActive Property

IsMeetingActive Property

Indicates meeting active state
Syntax
Json
{ Property:IsMeetingActive }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.OnTimerTick Method

OnTimerTick Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetNotesFileListResponse Constructor

ConferenceApiHandlerGetNotesFileListResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetNotesFileListResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.DeactivatePresentationRequest Class

ConferenceApiHandlerDeactivatePresentationRequest Class

Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerDeactivatePresentationRequest
Syntax
Json
{ JsonClass:DeactivatePresentationRequest	 }

The ConferenceApiHandlerDeactivatePresentationRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerDeactivatePresentationRequest | Initializes a new instance of the ConferenceApiHandlerDeactivatePresentationRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpretationSeatMetaRequest Constructor

Initializes a new instance of the InterpretationSeatMetaRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetMaximumMasterVolume Method

GetMaximumMasterVolume Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateIndividualVotingResults Method

UpdateIndividualVotingResults Method

Updates voting results.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DiscussionListEntry Methods

The DiscussionListEntry type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Clone the discussion list entry information
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetIlluminatedSeatResponse Constructor

ConferenceApiHandlerGetIlluminatedSeatResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetIlluminatedSeatResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConnectionTracker Methods

The ConnectionTracker type exposes the following members.

Methods
 | Name | Description
Public method | AddConnection | Adds a conference connection
Protected method | Initialize |
Public method | RegisterEvents | Register events
Public method | RemoveConnection | Removes connection
Public method | ResetEvent | Indicate that the event has been processed and may be sent again
Public method | SendEvent(ConferenceEvent) | Send events to all clients
Public method | SendEvent(Guid, ConferenceEvent) | Send events to all clients where a specific user is logged in
Public method | UnregisterEvents | Unregister events
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetBoothNotificationsResponse Constructor

ConferenceApiHandlerGetBoothNotificationsResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerGetBoothNotificationsResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetParticipantAccessDeniedReasonsResponse Properties

The ConferenceApiHandlerGetParticipantAccessDeniedReasonsResponse type exposes the following members.

Properties
 | Name | Description
Public property | ParticipantAccessDeniedReasonsInfo | Participants Access Denied Reason.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


StatusType Enumeration

This is for holding Majority and Quorum status
Syntax
Json
StatusType:{
True
False
Error}
Members
Member name | Value | Description
True | 0 | It means quorum or majority is reached.
False | 1 | It means quorum or majority is not reached.
Error | 2 | It means some error in formula or in calculation.
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.TryGetInterpreterBoothFromBoothsList Method

TryGetInterpreterBoothFromBoothsList Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UpdateFileRequest Constructor

ConferenceApiHandlerUpdateFileRequest Constructor

Initializes a new instance of the ConferenceApiHandlerUpdateFileRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetMicrophoneSensitivityDescriptionResponse.MicSensitivityDescription Property

MicSensitivityDescription Property

Syntax
Json
{ Property:MicSensitivityDescription }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetInterpretationLanguagesResponse Properties

The ConferenceApiHandlerGetInterpretationLanguagesResponse type exposes the following members.

Properties
 | Name | Description
Public property | Languages | Gets or sets the interpretation languages.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RemoveSeatFromDiscussionListResponse Constructor

ConferenceApiHandlerRemoveSeatFromDiscussionListResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerRemoveSeatFromDiscussionListResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Certificate.GenerateRootCertificateByteArray Method

GenerateRootCertificateByteArray Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetIndividualVotingResultsResponse Constructor

ConferenceApiHandlerGetIndividualVotingResultsResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerGetIndividualVotingResultsResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceUsers.Instance Property

Instance Property

Syntax
Json
{ Property:Instance }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiController.Receive Method

Receive Method

The receive process
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetInterpretationRoutingsResponse.Routings Property

Routings Property

Gets or sets the interpretation routings.
Syntax
Json
{ Property:Routings }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.SetWebClientDeviceCapabilities Method

SetWebClientDeviceCapabilities Method

Sets web client device capabilities
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetInterpretationOutputPresetRequest Class

ConferenceApiHandlerSetInterpretationOutputPresetRequest Class

 Bosch Logo
Represents the set interpretation out preset request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerSetInterpretationOutputPresetRequest
Syntax
Json
{ JsonClass:SetInterpretationOutputPresetRequest		LanguageId:<type>,
    OutputButton:<type>,
    SeatId:<type>,
 }

The ConferenceApiHandlerSetInterpretationOutputPresetRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetInterpretationOutputPresetRequest | Initializes a new instance of the ConferenceApiHandlerSetInterpretationOutputPresetRequest class
Top
Properties
 | Name | Description
Public property | LanguageId |
Public property | OutputButton |
Public property | SeatId |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RegisterEventsResponse Constructor

ConferenceApiHandlerRegisterEventsResponse Constructor

Initializes a new instance of the ConferenceApiHandlerRegisterEventsResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.AcceptVotingRequest Class

ConferenceApiHandlerAcceptVotingRequest Class

Represents the accept voting info request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerAcceptVotingRequest
Syntax
Json
{ JsonClass:AcceptVotingRequest	 }

The ConferenceApiHandlerAcceptVotingRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerAcceptVotingRequest | Initializes a new instance of the ConferenceApiHandlerAcceptVotingRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.Dispose Method

Dispose Method

Cleansup after the object instance.
Syntax
Json
Implements
IDisposableDispose
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


IndividualVotingResult Class

Voting results of perticular participant
Inheritance Hierarchy
SystemObject
SynopticControl.CommonIndividualVotingResult
Syntax
Json
{ JsonClass:IndividualVotingResult		participantId:<type>,
    votingAnswer:<type>,
 }

The IndividualVotingResult type exposes the following members.

Constructors
 | Name | Description
Public method | IndividualVotingResult | Initializes a new instance of the IndividualVotingResult class
Top
Properties
 | Name | Description
Public property | participantId | participant id
Public property | votingAnswer | Voting answer for the participant
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.DeletePreparedVoting Method

DeletePreparedVoting Method

Deletes prepared voting
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


Meeting Methods

The Meeting type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to current object. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Serves as a default hash function. (Overrides ObjectGetHashCode.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LogOnModel.password Property

password Property

Login password
Syntax
Json
{ Property:password }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ParticipantSeats.SeatedSeatId Property

SeatedSeatId Property

Syntax
Json
{ Property:SeatedSeatId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileInfo.title Property

title Property

Title of the file
Syntax
Json
{ Property:title }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnDevicesUnassignedFromSeats Method

OnDevicesUnassignedFromSeats Method

Handles devices that are unassigned from seats.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


CreateFileResponse Properties

The ConferenceApiHandlerCreateFileResponse type exposes the following members.

Properties
 | Name | Description
Public property | FileId |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetIlluminateSeatResponse Class

ConferenceApiHandlerSetIlluminateSeatResponse Class

Represents the set illuminate seat response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerSetIlluminateSeatResponse
Syntax
Json
{ JsonClass:SetIlluminateSeatResponse	 }

The ConferenceApiHandlerSetIlluminateSeatResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetIlluminateSeatResponse | Initializes a new instance of the ConferenceApiHandlerSetIlluminateSeatResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.HoldVoting Method

HoldVoting Method

Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ListFilesResponse Properties

The ConferenceApiHandlerListFilesResponse type exposes the following members.

Properties
 | Name | Description
Public property | FileInfoList | List of file info
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ListFilesRequest.Attributes Property

Attributes Property

Attributes is used to retrieve all files with matching file attributes
Remarks
Attributes indicate what contents of file represent and can contain list of values like 'Bosch.Synoptic.Layout', 'Bosch.Synoptic.Index'
Syntax
Json
{ Property:Attributes }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.UnSubscribePluginEvent Method

UnSubscribePluginEvent Method

Syntax
Json
Request:

Copy
{
    "eventName": <string>,
    "pluginName": <string>
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.DeactivateVoting Method

DeactivateVoting Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConnectionState.uniqueConnectionId Field

uniqueConnectionId Field

Syntax
Json
{ Field:uniqueConnectionId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.RegisterPlugin Method

RegisterPlugin Method

Syntax
Json
Request:

Copy
{
    "pluginCommands":
    [
        {
            "name": <string>
        }
    ],
    "pluginEvents":
    [
        {
            "name": <string>
        }
    ],
    "pluginInterface": <string>,
    "pluginName": <string>
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DeviceType Enumeration

Syntax
Json
DeviceType:{
Unknown
StandardConferenceDevice
InterpretationDevice
OnvifCamera
AudioPoweringSwitch
MeetingApplication
PTZOnvifCamera
VideoSwitch
ExternalVideoSwitch
PresentationDevice
PoweringSwitch
MultimediaDevice
MultimediaDeviceSimulator
VideoStream
OMI
DiscussionDeviceBasic
DiscussionDevice
DiscussionDeviceVoting
DiscussionDeviceLanguageSelection
DiscussionDeviceExtended
SonyCameraDevice
PanasonicCameraDevice
InterpretationDeviceWithVideo
FlushDeviceSelectLanguage
FlushBaseDevice
IntTxoDevice
FlushBaseDeviceV2}
Members
Member name | Value | Description
Unknown | 0 |
StandardConferenceDevice | 1 |
InterpretationDevice | 2 |
OnvifCamera | 3 |
AudioPoweringSwitch | 4 |
MeetingApplication | 5 |
PTZOnvifCamera | 6 |
VideoSwitch | 7 |
ExternalVideoSwitch | 8 |
PresentationDevice | 9 |
PoweringSwitch | 10 |
MultimediaDevice | 11 |
MultimediaDeviceSimulator | 12 |
VideoStream | 13 |
OMI | 14 |
DiscussionDeviceBasic | 15 |
DiscussionDevice | 15 |
DiscussionDeviceVoting | 16 |
DiscussionDeviceLanguageSelection | 17 |
DiscussionDeviceExtended | 18 |
SonyCameraDevice | 19 |
PanasonicCameraDevice | 20 |
InterpretationDeviceWithVideo | 21 |
FlushDeviceSelectLanguage | 22 |
FlushBaseDevice | 23 |
IntTxoDevice | 24 |
FlushBaseDeviceV2 | 25 |
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileLogTraceListener.TraceEvent Method (TraceEventCache, String, TraceEventType, Int32, String)

TraceEvent Method (TraceEventCache, String, TraceEventType, Int32, String)

 Bosch Logo
Writes trace information, a message, and event information to the listener specific output.
Syntax
Json
  Remarks
  Note  Note

            This method is not intended to be called directly by application code but by
            members of the Debug, Trace, and TraceSource
            classes to write trace data to output.

            The default implementation writes the values of the source, eventType and id
            parameters as a header, followed by the message data. The eventCache data is
            written as a footer, the nature of the output data being dependent on the value
            of the TraceOutputOptions property.

  See Also
Reference
TraceListener class
TextWriterTraceListener class
Debug class
Trace class


ConferenceApiHandler.GetInterpreterBoothsResponse Constructor

ConferenceApiHandlerGetInterpreterBoothsResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetInterpreterBoothsResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetApiStateResponse Properties

The ConferenceApiHandlerGetApiStateResponse type exposes the following members.

Properties
 | Name | Description
Public property | Online | Online
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConnectionTracker Constructor

Initializes a new instance of the ConnectionTracker class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetDiscussionOptionsRequest Constructor

ConferenceApiHandlerGetDiscussionOptionsRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetDiscussionOptionsRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GrantInterpretationResponse Constructor

ConferenceApiHandlerGrantInterpretationResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGrantInterpretationResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InputPresetButton Enumeration

Syntax
Json
InputPresetButton:{
InputPresetA
InputPresetB
InputPresetC
InputPresetD
InputPresetE
InputPresetF
InputPresetG}
Members
Member name | Value | Description
InputPresetA | 0 | The preset for input A
InputPresetB | 1 | The preset for input B
InputPresetC | 2 | The preset for input C
InputPresetD | 3 | The preset for input D
InputPresetE | 4 | The preset for input E
InputPresetF | 5 | The preset for input F
InputPresetG | 6 | The preset for input G
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.DeactivatePresentationRequest Constructor

ConferenceApiHandlerDeactivatePresentationRequest Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerDeactivatePresentationRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.DeactivateMicrophoneRequest Constructor

ConferenceApiHandlerDeactivateMicrophoneRequest Constructor

Initializes a new instance of the ConferenceApiHandlerDeactivateMicrophoneRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


IndividualVotingResult.votingAnswer Property

votingAnswer Property

Voting answer for the participant
Syntax
Json
{ Property:votingAnswer }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OpenMeeting Method

OpenMeeting Method

Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceEvent Enumeration

Events that the server can fire to the clients
Syntax
Json
ConferenceEvent:{
ApiStateChanged
PermissionsChanged
SeatsChanged
DiscussionListChanged
DiscussionOptionsChanged
MeetingInfoChanged
IndividualVotingResultsChanged
VotingStateChanged
EnableSeatIlluminationChanged
IlluminatedSeatChanged
SystemPowerModeChanged
AgendaTopicsChanged
ParticipantsChanged
VotingScriptChanged
VotingResultChanged
InterpretationLanguagesChanged
InterpretationRoutingsChanged
InterpreterSeatsChanged
InterpreterBoothsChanged
BoothNotificationsChanged
MasterVolumeChanged
MasterVolumeRangeChanged
PresentationStateChanged
FileChanged
ParticipantSeatsChanged
QuorumResultChanged
MajorityResultChanged
VotingInfoChanged
NotesFileListChanged
InterpretationMetaRequestStatusChanged
RoomNameChanged
RoomContactEmailChanged
PluginsChanged
PluginEventAvailable
PluginCommandAvailable
ParticipantAccessDenied
MeetingListChanged
SeatMicrophoneSensitivityUpdated}
Members
Member name | Value | Description
ApiStateChanged | 0 | Dicentis API state changed
PermissionsChanged | 1 | Permissions changed event
SeatsChanged | 2 | Seats changed event
DiscussionListChanged | 3 | Discussion list changed event
DiscussionOptionsChanged | 4 | Discussion options changed event
MeetingInfoChanged | 5 | Meeting status changed event
IndividualVotingResultsChanged | 6 | Individual voting result changed event
VotingStateChanged | 7 | Voting state changed event
EnableSeatIlluminationChanged | 8 | Enable seat illumination event
IlluminatedSeatChanged | 9 | Illuminated seat changed event
SystemPowerModeChanged | 10 | System power mode changed event
AgendaTopicsChanged | 11 | Topics changed event
ParticipantsChanged | 12 | Participants changed event
VotingScriptChanged | 13 | Voting script changed event
VotingResultChanged | 14 | Voting result changed event
InterpretationLanguagesChanged | 15 | The interpretation languages changed
InterpretationRoutingsChanged | 16 | The interpretation routing list changed
InterpreterSeatsChanged | 17 | The interpreter seats changed
InterpreterBoothsChanged | 18 | The interpreter booths changed
BoothNotificationsChanged | 19 | The notification status of a booth changed
MasterVolumeChanged | 20 | The master volume changed
MasterVolumeRangeChanged | 21 | The master volume range changed
PresentationStateChanged | 22 | The presentation status changed
FileChanged | 23 | Synoptic layouts changed event
ParticipantSeatsChanged | 24 | Participant seats changed event
QuorumResultChanged | 25 | Participant Attendance Summary changed event
MajorityResultChanged | 26 | Voting majority result changed event
VotingInfoChanged | 27 | Voting info changed event
NotesFileListChanged | 28 | Notes location/new file added changed event
InterpretationMetaRequestStatusChanged | 29 | Interpretation meta request status changed event
RoomNameChanged | 30 | Room name changed event
RoomContactEmailChanged | 31 | Room contact email changed event
PluginsChanged | 32 | Plugin added or removed
PluginEventAvailable | 33 | Plugin event available
PluginCommandAvailable | 34 | Plugin command available
ParticipantAccessDenied | 35 | Participant access denied event
MeetingListChanged | 36 | Meeting list changed event
SeatMicrophoneSensitivityUpdated | 37 | Seat microphone sensitivity updated
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi Methods

The DcnmApi type exposes the following members.

Methods
 | Name | Description
Public method | ActivateAdHocVoting |
Public method | ActivateMeeting | Activate meeting request.
Public method | ActivatePresentation | Activate the presentation.
Public method | ActivateVoting |
Public method | CancelImportantSpeaker | Remove important speaker from waiting/speaker list
Protected method | CancelInterpreterMetaFunction |
Public method | CancelRequests |
Public method | CancelResponder | Remove responder from responders list
Public method | CancelResponseRequest | Cancels response request.
Public method | CancelSpeaker | Remove speaker from waiting/speaker list
Protected method | CheckNotesFileTampered |
Public method | CloseAgenda |
Public method | CloseMeeting |
Public method | CloseVoting |
Public method | DeactivateMeeting |
Public method | DeactivatePresentation | Deactivate the presentation.
Public method | DeactivateVoting |
Protected method | DeleteNotesFiles |
Public method | Dispose |
Public method | EnableSeatIllumination | Enable or disable seat illumination
Protected method | GetAgendaTopicsForMeeting |
Protected method | GetDefaultVotingSettings |
Private method | GetLicenseInformation |
Protected method | GetMajorityVariables |
Protected method | GetMaximumMicrophoneSensitivity |
Protected method | GetMeetingDeskConfiguration | Gets the meeting desk configuration.
Protected method | GetMicrophoneSensitivity |
Protected method | GetMicrophoneSensitivityStepSize |
Protected method | GetMinimumMicrophoneSensitivity |
Protected method | GetNotesFileInfos |
Private method | GetParticipantGroupPermissions | Gets participant group permissions
Private method | GetParticipantPermissions | Gets participants permissions.
Protected method | GetParticipantsForMeeting |
Public method | GetPermission | Gets permissions of the user
Public method | GetPlugin |
Public method | GetPlugins |
Private method | GetSeats | Get the seat info list
Protected method | GetVotingsForMeeting |
Protected method | GrantInterpretation | Grants the interpretation.
Public method | GrantRequest |
Public method | GrantResponseRequest |
Public method | GrantSpeech | Add participant to the waiting list
Public method | HoldVoting |
Protected method | Initialize |
Protected method | IssueInterpreterMetaFunction |
Public method | IsValidUserId |
Public method | LogOnDcnmServer | Gets User security claims info for user
Private method | OnActiveMeetingStatusChanged | Called on meeting status changed.
Private method | OnActualSpeakerChanged |
Private method | OnActualSpeakerVideoChanged |
Private method | OnAgendaForMeetingReceived |
Private method | OnApplicationModeStateChanged | Updates application mode
Private method | OnAreaCreated |
Private method | OnAreaDeleted |
Private method | OnAreaUpdated |
Private method | OnAudioSettingsChanged |
Private method | OnBaseCapabilitiesChanged | Handles base capabilities changed
Private method | OnBoothNotificationsChanged |
Private method | OnDevicesAssignedToSeats | Handles devices that are assigned to seats.
Private method | OnDevicesFoundAtSeats | Handles devices that are found at seats.
Private method | OnDevicesLostAtSeats | Handles devices that are lost at seats.
Private method | OnDevicesUnassignedFromSeats | Handles devices that are unassigned from seats.
Private method | OnDiscussionOptionsChanged |
Private method | OnEquipmentPowerStateChanged | Handles system power state changed
Private method | OnImageWebserverInfoChanged |
Private method | OnImportantSpeakersListChanged |
Private method | OnIndividualVotingResultUpdated |
Private method | OnInterpretationLanguagesChanged |
Private method | OnInterpretationMetaRequestStatusChanged |
Private method | OnInterpretationRoutingListChanged |
Private method | OnMajorityResultUpdated |
Private method | OnMeetingBoothInfoChanged |
Private method | OnMeetingCreated |
Private method | OnMeetingDataPathUpdated |
Private method | OnMeetingDeleted |
Private method | OnMeetingDeskInfoChanged |
Private method | OnMeetingListChanged |
Private method | OnMeetingUpdated |
Private method | OnNotesFileListUpdated |
Private method | OnOpenStateChanged | Handles the opened state changed reported by the API.
Private method | OnParticipantAccessDenied |
Private method | OnParticipantAttendanceSummaryChanged |
Private method | OnParticipantsForMeetingReceived |
Private method | OnParticipantsListChanged | Called when participant list is changed
Private method | OnParticipantsUpdated |
Private method | OnPluginsAdded |
Private method | OnPluginsRemoved |
Private method | OnPresentationPuginStateChanged |
Private method | OnPresentationStateChanged |
Private method | OnPriorityListChanged |
Private method | OnRequestsListChanged |
Private method | OnRequestToResponseOptionsChanged |
Private method | OnRequestToSpeakOptionsChanged |
Private method | OnRespondersListChanged |
Private method | OnResponseRequestsListChanged |
Private method | OnRoomContactEmailUpdated |
Private method | OnRoomNameUpdated |
Private method | OnSeatMicrophoneSensitivityUpdated |
Private method | OnSeatsCreated | Handles seats that are created.
Private method | OnSeatsDeleted | Handles seats that are deleted.
Private method | OnSeatSelected | On seat illuminated.
Private method | OnSeatsUpdated | Handles seats that are updated.
Private method | OnSpeakersListChanged | On change of speakerlist
Private method | OnSpeakerViewing_SpeakerViewingOptionsChanged |
Private method | OnSpeechTimerOptionsChanged | Updates speech time options
Private method | OnVotingCreated |
Private method | OnVotingDeleted |
Private method | OnVotingResultUpdated |
Private method | OnVotingScriptChanged |
Private method | OnVotingScriptForMeetingReceived |
Private method | OnVotingStatusChanged |
Private method | OnVotingUpdated |
Public method | OpenAgenda |
Public method | OpenAPI | Opens API for use
Public method | OpenMeeting |
Public method | OpenVoting |
Private method | PluginEventHandler |
Private method | PrepareParticipant2_ScreenLineFormatUpdated | Called on screen format is updated.
Private method | ProcessApiOpenResponse |
Protected method | RaiseBoothNotification |
Private method | ReadDataFromJsonFile |
Private method | ReadSynopticLoginDetail |
Public method | RegisterPlugin |
Public method | RegisterWebApplication | Updates the latest web application info
Public method | RequestAttendanceInfo |
Public method | RequestMicrophoneActive | Request to activate the microphone of the participant with the specified id.
Public method | RequestMicrophoneInactive | Request to deactivate the microphone of the participant with the specified id.
Public method | RequestParticipantsList | Request for participants list
Public method | RequestVotingResult | Request for voting results.
Protected method | ResetMicrophoneSensitivity |
Public method | ResumeVoting |
Protected method | SelectFloor |
Protected method | SelectInputLanguage |
Protected method | SelectRelay |
Public method | SendPluginCommand |
Public method | SendPluginEvent |
Public method | SetIlluminateSeat | Illuminates seat.
Protected method | SetInterpretationOutPreset | Sets the interpretation out preset.
Public method | SetManageMeetingRights | Sets the manage meeting rights
Protected method | SetMasterVolume |
Public method | SetSystemPowerMode | Sets the system power mode to power on
Public method | SetWebClientDeviceCapabilities | Sets the web client device capabilities
Public method | ShiftRequest | Shift the selected request.
Public method | ShiftResponseRequest | Shift the selected response request.
Public method | SubscribePluginEvent |
Protected method | TransformNotesFile |
Private method | UnregisterEvents |
Public method | UnregisterPlugin |
Public method | UnSubscribePluginEvent |
Private method | UpdateBoothInUseInfo |
Private method | UpdateMasterVolumeInformation |
Protected method | UpdateMeetingBoothConfigurations |
Protected method | UpdateMeetingDeskConfigurations |
Protected method | UpdateMicrophoneSensitivity |
Private method | UpdatePowerStateInformation | Updates system power state information
Private method | UpdatePreparedMeetingsInfo |
Private method | UpdateRoomContactEmail |
Private method | UpdateRoomName |
Public method | UpdateSeatsInfo | Updated seats information for default meeting.
Protected method | UpdateVotingsForMeeting |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.DetermineTotalVoteCastedResultsVisiblityForExternalSystem Method

DetermineTotalVoteCastedResultsVisiblityForExternalSystem Method

Bosch Logo
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ActivateAdHocVotingRequest Class

ConferenceApiHandlerActivateAdHocVotingRequest Class

Represents the activate ad-hoc voting info request.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerActivateAdHocVotingRequest
Syntax
Json
{ JsonClass:ActivateAdHocVotingRequest		Description:<type>,
    Number:<type>,
    Subject:<type>,
 }

The ConferenceApiHandlerActivateAdHocVotingRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerActivateAdHocVotingRequest | Initializes a new instance of the ConferenceApiHandlerActivateAdHocVotingRequest class
Top
Properties
 | Name | Description
Public property | Description | Voting description for the ad-hoc voting
Public property | Number | Voting number for the ad-hoc voting
Public property | Subject | Voting subject for the ad-hoc voting
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.MajorityResult Property

MajorityResult Property

Syntax
Json
{ Property:MajorityResult }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetIdsForDiscussionOperations Method

GetIdsForDiscussionOperations Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


FileInfo.Equality Operator

Equality Operator

Function to comapare two file info objects are equal
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


InterpreterDeskInfo.CLanguageList Property

CLanguageList Property

Gets the C language list.
Syntax
Json
{ Property:CLanguageList }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.RemoveSpeech Method

RemoveSpeech Method

Syntax
Json
Request:

Copy
{
    "participantIds": [<string>],
    "seatIds": [<string>]
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.Votings Property

Votings Property

Voting status list placeholder.
Syntax
Json
{ Property:Votings }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ApiClient.AccessRights Property

AccessRights Property

Syntax
Json
{ Property:AccessRights }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


CreateCertificateResponse Constructor

Initializes a new instance of the CreateCertificateResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DiscussionListEntry.ActiveImage Property

ActiveImage Property

Indicates that participant picture is shown of the speaker.
Syntax
Json
{ Property:ActiveImage }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileInfo Structure

This contains the details of the file
Syntax
Json
{ Structure:FileInfo }

The FileInfo type exposes the following members.

Properties
 | Name | Description
Public property | attributes | Attribute indicating file type like synoptic, index etc
Public property | fileId | Id of the file
Public property | payload | Configuration of the file
Public property | title | Title of the file
Top
Methods
 | Name | Description
Public method | Equals(Object) | Override Equals functuion in IEquatable (Overrides ValueTypeEquals(Object).)
Public method | Equals(FileInfo) | Function to comapare file info with other objects
Public method | GetHashCode | Override GetHashCode functuion in IEquatable (Overrides ValueTypeGetHashCode.)
Top
Operators
Name | Description
Equality | Function to comapare two file info objects are equal
Inequality | Function to comapare two file info objects are unequal
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.SeatInfoList Property

SeatInfoList Property

Contains seat information list
Syntax
Json
{ Property:SeatInfoList }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetBoothNotificationsRequest Constructor

ConferenceApiHandlerGetBoothNotificationsRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetBoothNotificationsRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SendPluginCommandInfo Constructor

Initializes a new instance of the SendPluginCommandInfo class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.GetMeetingDeskConfiguration Method

GetMeetingDeskConfiguration Method

Gets the meeting desk configuration.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ApiClient Properties

The ApiClient type exposes the following members.

Properties
 | Name | Description
Public property | AccessRights |
Public property | Password |
Public property | ServerAddress |
Public property | Username |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DiscussionListEntry.Clone Method

Clone Method

Clone the discussion list entry information
Syntax
Json
Implements
ICloneableTClone
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.NotifyParticipantsInfoChangedOnClients Method

NotifyParticipantsInfoChangedOnClients Method

Sends participants info changed notification to connected clients
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.TransformNotesFileRequest.FileName Property

FileName Property

The name of the notes file to XSL transform
Syntax
Json
{ Property:FileName }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetEnableSeatIlluminationRequest Class

ConferenceApiHandlerGetEnableSeatIlluminationRequest Class

Represents the get enable seat illumination request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetEnableSeatIlluminationRequest
Syntax
Json
{ JsonClass:GetEnableSeatIlluminationRequest	 }

The ConferenceApiHandlerGetEnableSeatIlluminationRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetEnableSeatIlluminationRequest | Initializes a new instance of the ConferenceApiHandlerGetEnableSeatIlluminationRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.DeleteFileRequest.FileId Property

FileId Property

File identifier
Syntax
Json
{ Property:FileId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


CreateFileRequest Properties

The ConferenceApiHandlerCreateFileRequest type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Attribute indicating file type and can only have values "synoptic" or "index"
Public property | Payload | The configuration of the layout. The format of the string is defined by the (AngularJs) application. The maximum length of the string is 65KBytes.
Public property | Title | Title of the file
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


MasterVolumeRange.MaximumVolume Property

MaximumVolume Property

Gets or sets the maximum volume.
Syntax
Json
{ Property:MaximumVolume }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SubscribePluginEventRequest Class

ConferenceApiHandlerSubscribePluginEventRequest Class

Request for subscribing to plugin event
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerSubscribePluginEventRequest
Syntax
Json
{ JsonClass:SubscribePluginEventRequest		EventName:<type>,
    PluginName:<type>,
 }

The ConferenceApiHandlerSubscribePluginEventRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSubscribePluginEventRequest | Initializes a new instance of the ConferenceApiHandlerSubscribePluginEventRequest class
Top
Properties
 | Name | Description
Public property | EventName | Event name to subscribe.
Public property | PluginName | Plugin name to subscribe
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SendPluginCommandRequest Properties

The ConferenceApiHandlerSendPluginCommandRequest type exposes the following members.

Properties
 | Name | Description
Public property | Command | The name of the command
Public property | Parameters | Parameters for command.
Public property | PluginName | The name of the Plugin
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.CancelSpeaker Method

CancelSpeaker Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DcnmApi.OnAgendaForMeetingReceived Method

OnAgendaForMeetingReceived Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


Participant.CanPrio Property

CanPrio Property

Indicates whether participant can use priority or not.
Syntax
Json
{ Property:CanPrio }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetCurrentVotingInfo Method

GetCurrentVotingInfo Method

Provides voting state.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DeviceOperationalState Enumeration

Syntax
Json
DeviceOperationalState:{
VersionMismatch
Error
Operational}
Members
Member name | Value | Description
VersionMismatch | -1 |
Error | 0 |
Operational | 1 |
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpretationMetaRequestStatus.GetHashCode Method

GetHashCode Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ResetMicrophoneSensitivityRequest Class

ConferenceApiHandlerResetMicrophoneSensitivityRequest Class

Reset seat microphone sensitivity level to 0.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerResetMicrophoneSensitivityRequest
Syntax
Json
{ JsonClass:ResetMicrophoneSensitivityRequest		SeatIds:<type>,
 }

The ConferenceApiHandlerResetMicrophoneSensitivityRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerResetMicrophoneSensitivityRequest | Initializes a new instance of the ConferenceApiHandlerResetMicrophoneSensitivityRequest class
Top
Properties
 | Name | Description
Public property | SeatIds | List of seat ids to reset sensitivity level to 0. If the list count is 0 then will reset all the seats microphone sensitivity level to 0 in the system.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GrantInterpretationRequest.SeatId Property

SeatId Property

Gets or sets the seat identifier.
Syntax
Json
{ Property:SeatId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SendPluginCommandResponse Constructor

ConferenceApiHandlerSendPluginCommandResponse Constructor

Initializes a new instance of the ConferenceApiHandlerSendPluginCommandResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SystemLog.LogProcess Method

LogProcess Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.InterpreterMetaRequestStatus Property

InterpreterMetaRequestStatus Property

Syntax
Json
{ Property:InterpreterMetaRequestStatus }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetSupportedHeadphonesRequest Class

ConferenceApiHandlerGetSupportedHeadphonesRequest Class

Represents the get supported headphones request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetSupportedHeadphonesRequest
Syntax
Json
{ JsonClass:GetSupportedHeadphonesRequest	 }

The ConferenceApiHandlerGetSupportedHeadphonesRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetSupportedHeadphonesRequest | Initializes a new instance of the ConferenceApiHandlerGetSupportedHeadphonesRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


QuorumResultInfo.Equals Method (QuorumResultInfo)

Equals Method (QuorumResultInfo)

 Bosch Logo
Function to compare QuorumResultInfo with other objects
Syntax
Json
Implements
IEquatableTEquals(T)
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetParticipantIdFromSeatId Method

GetParticipantIdFromSeatId Method

returns participant id from seatid
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


SaveImageResponse Properties

The ConferenceApiHandlerSaveImageResponse type exposes the following members.

Properties
 | Name | Description
Public property | SaveImageUri | The uri of the saved image.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateRespondersList Method

UpdateRespondersList Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetMajorityResult Method

GetMajorityResult Method

Gets the voting majority result
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "majorityResult":
    {
        "comparisonOperator": "greaterThan"|"greaterThanOrEqualTo"|"equals"|"lessThan"|"lessThanOrEqualTo",
        "denominatorValue": <int>,
        "isEnabled": <bool>,
        "numeratorValue": <int>,
        "status": "true"|"false"|"error",
        "thresholdValue": <int>
    }
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SendPluginEventRequest.Parameters Property

Parameters Property

Parameters for command.
Syntax
Json
{ Property:Parameters }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SetMasterVolumeRequest Properties

The ConferenceApiHandlerSetMasterVolumeRequest type exposes the following members.

Properties
 | Name | Description
Public property | Volume | Gets or sets the volume.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetIndividualCastVoteResults Method

GetIndividualCastVoteResults Method

Overload List
 | Name | Description
Public method | GetIndividualCastVoteResults | Get seat individual cast vote results
Private method | GetIndividualCastVoteResults(ReadOnlyCollectionVotingResult) |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetNotesFileListResponse.FileData Property

FileData Property

Holds the list of xml file list entries.
Syntax
Json
{ Property:FileData }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SendPluginCommandRequest Constructor

ConferenceApiHandlerSendPluginCommandRequest Constructor

Initializes a new instance of the ConferenceApiHandlerSendPluginCommandRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ListImagesResponse Class

ConferenceApiHandlerListImagesResponse Class

Represents the list images response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerListImagesResponse
Syntax
Json
{ JsonClass:ListImagesResponse		Images:<type>,
 }

The ConferenceApiHandlerListImagesResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerListImagesResponse | Initializes a new instance of the ConferenceApiHandlerListImagesResponse class
Top
Properties
 | Name | Description
Public property | Images | List of images
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetMicrophoneSensitivityDescriptionResponse Constructor

ConferenceApiHandlerGetMicrophoneSensitivityDescriptionResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerGetMicrophoneSensitivityDescriptionResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetMasterVolumeResponse Properties

The ConferenceApiHandlerGetMasterVolumeResponse type exposes the following members.

Properties
 | Name | Description
Public property | Volume | Gets or sets the volume.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.LoadFileRequest Class

ConferenceApiHandlerLoadFileRequest Class

Represents the open file request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerLoadFileRequest
Syntax
Json
{ JsonClass:LoadFileRequest		FileId:<type>,
 }

The ConferenceApiHandlerLoadFileRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerLoadFileRequest | Initializes a new instance of the ConferenceApiHandlerLoadFileRequest class
Top
Properties
 | Name | Description
Public property | FileId | File identifier. Unique identification of the file
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.DetermineQuorumResultVisiblity Method

DetermineQuorumResultVisiblity Method

Determine quorum results visibility for user
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


Bosch.Operational.AssemblyLoading Namespace

Classes
 | Class | Description
Protected class | AssemblyRedirect | Redirects assembly loads to the installation folder.


FileLogTraceListener Methods

The FileLogTraceListener type exposes the following members.

Methods
 | Name | Description
Public method | Close | When overridden in a derived class, closes the output stream so it no longer receives tracing or debugging output. (Inherited from TraceListener.)
Private method | CreateLogFile | Create a log file
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Private method | DetermineLogFileName | Determine the log file name which depends on the configured Cycle attribute of the FileLogListener
Public method | Dispose | Releases all resources used by the TraceListener. (Inherited from TraceListener.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the TraceListener and optionally releases the managed resources. (Inherited from TraceListener.)
Private method | EnsureWriter | In case no writer is present a new writer will be created. The configured cycle determines if a new log file needs to be created.
Public method | Fail(String) | Emits an error message to the listener you create when you implement the TraceListener class. (Inherited from TraceListener.)
Public method | Fail(String, String) | Emits an error message and a detailed error message to the listener you create when you implement the TraceListener class. (Inherited from TraceListener.)
Public method | Flush | (Overrides TraceListenerFlush.)
 | GetEncodingWithFallback | Provides a failure-handling mechanism, called a fallback, for an input character that cannot be converted to an encoded output byte sequence.
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetSupportedAttributes | Gets the custom attributes supported by the trace listener. (Overrides TraceListenerGetSupportedAttributes.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | IsEnabled | Check fuction for the TraceOutputOptions.
Protected method | MemberwiseClone | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | TraceData(TraceEventCache, String, TraceEventType, Int32, Object) | Writes trace information, a data object and event information to the listener specific output. (Overrides TraceListenerTraceData(TraceEventCache, String, TraceEventType, Int32, Object).)
Public method | TraceData(TraceEventCache, String, TraceEventType, Int32, Object) | Writes trace information, an array of data objects and event information to the listener specific output. (Overrides TraceListenerTraceData(TraceEventCache, String, TraceEventType, Int32, Object).)
Public method | TraceEvent(TraceEventCache, String, TraceEventType, Int32) | Writes trace and event information to the listener specific output. (Inherited from TraceListener.)
Public method | TraceEvent(TraceEventCache, String, TraceEventType, Int32, String) | Writes trace information, a message, and event information to the listener specific output. (Overrides TraceListenerTraceEvent(TraceEventCache, String, TraceEventType, Int32, String).)
Public method | TraceEvent(TraceEventCache, String, TraceEventType, Int32, String, Object) | Writes trace information, a formatted array of objects and event information to the listener specific output. (Overrides TraceListenerTraceEvent(TraceEventCache, String, TraceEventType, Int32, String, Object).)
Public method | TraceTransfer | Writes trace information, a message, a related activity identity and event information to the listener specific output. (Inherited from TraceListener.)
Public method | Write(Object) | Writes the value of the object's ToString method to the listener you create when you implement the TraceListener class. (Inherited from TraceListener.)
Public method | Write(String) | Writes the specified message to the listener you create in the derived class. (Overrides TraceListenerWrite(String).)
Public method | Write(String, String) | Writes a category name and a message to the listener you create when you implement the TraceListener class. (Inherited from TraceListener.)
Public method | Write(Object, String) | Writes a category name and the value of the object's ToString method to the listener you create when you implement the TraceListener class. (Inherited from TraceListener.)
Private method | WriteFooter | Write the footer of the trace message which consists of several configured trace options
Private method | WriteHeader | Write the header of the trace message which consists of several configured trace options and the trace message itself.
Protected method | WriteIndent | Writes the indent to the listener you create when you implement this class, and resets the NeedIndent property to . (Inherited from TraceListener.)
Public method | WriteLine(Object) | Writes the value of the object's ToString method to the listener you create when you implement the TraceListener class, followed by a line terminator. (Inherited from TraceListener.)
Public method | WriteLine(String) | Writes a message to the listener you create in the derived class, followed by a line terminator. (Overrides TraceListenerWriteLine(String).)
Public method | WriteLine(String, String) | Writes a category name and a message to the listener you create when you implement the TraceListener class, followed by a line terminator. (Inherited from TraceListener.)
Public method | WriteLine(Object, String) | Writes a category name and the value of the object's ToString method to the listener you create when you implement the TraceListener class, followed by a line terminator. (Inherited from TraceListener.)
Private method | WriteLineMessage | Writes a message to the listener you create in the derived class, followed by a line terminator.
Private method | WriteMessage | Writes the specified message to the listener you create in the derived class.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetIndividualVotingResultsRequest Class

ConferenceApiHandlerGetIndividualVotingResultsRequest Class

Represents the get individual voting result request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetIndividualVotingResultsRequest
Syntax
Json
{ JsonClass:GetIndividualVotingResultsRequest	 }

The ConferenceApiHandlerGetIndividualVotingResultsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetIndividualVotingResultsRequest | Initializes a new instance of the ConferenceApiHandlerGetIndividualVotingResultsRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


MajorityResultInfo Properties

The MajorityResultInfo type exposes the following members.

Properties
 | Name | Description
Public property | ComparisonOperator | Comparision operator used in majority expression.
Public property | DenominatorValue | Majority denominator value
Public property | IsEnabled | Indicates whether majority is enabled
Public property | NumeratorValue | Majority numerator value
Public property | Status | Majority reached status
Public property | ThresholdValue | Majority threshold value
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetEnableSeatIlluminationResponse Constructor

ConferenceApiHandlerGetEnableSeatIlluminationResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerGetEnableSeatIlluminationResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnParticipantsForMeetingReceived Method

OnParticipantsForMeetingReceived Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetRoomNameRequest Class

ConferenceApiHandlerGetRoomNameRequest Class

Parameters to GetRoomName.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetRoomNameRequest
Syntax
Json
{ JsonClass:GetRoomNameRequest	 }

The ConferenceApiHandlerGetRoomNameRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetRoomNameRequest | Initializes a new instance of the ConferenceApiHandlerGetRoomNameRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.MaximumMasterVolume Property

MaximumMasterVolume Property

Syntax
Json
{ Property:MaximumMasterVolume }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetVotingResultsResponse Properties

The ConferenceApiHandlerGetVotingResultsResponse type exposes the following members.

Properties
 | Name | Description
Public property | VotingResults | List of voting results
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetSeatVotingResultsResponse.VotingResults Property

VotingResults Property

List of voting results
Syntax
Json
{ Property:VotingResults }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateAndNotifyOnSeatInfoChanged Method

UpdateAndNotifyOnSeatInfoChanged Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ResumeVotingRequest Constructor

ConferenceApiHandlerResumeVotingRequest Constructor

Initializes a new instance of the ConferenceApiHandlerResumeVotingRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Voting.Equals Method

Equals Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.AbortVotingRequest Constructor

ConferenceApiHandlerAbortVotingRequest Constructor

Initializes a new instance of the ConferenceApiHandlerAbortVotingRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiController.ErrorResponse Constructor

ConferenceApiControllerErrorResponse Constructor

Initializes a new instance of the ConferenceApiControllerErrorResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetSystemPowerModeRequest Class

ConferenceApiHandlerGetSystemPowerModeRequest Class

Parameters to GetSystemPowerModeRequest
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetSystemPowerModeRequest
Syntax
Json
{ JsonClass:GetSystemPowerModeRequest	 }

The ConferenceApiHandlerGetSystemPowerModeRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetSystemPowerModeRequest | Initializes a new instance of the ConferenceApiHandlerGetSystemPowerModeRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AgendaTopic Methods

The AgendaTopic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.AddSeatToSpeakersRequest Constructor

ConferenceApiHandlerAddSeatToSpeakersRequest Constructor

Initializes a new instance of the ConferenceApiHandlerAddSeatToSpeakersRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.OnRefreshSeatRightsTick Method

OnRefreshSeatRightsTick Method

Requests participants list on system power cycle
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SendPluginEventRequest.Event Property

Event Property

The name of the command.
Syntax
Json
{ Property:Event }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OpenAgenda Method

OpenAgenda Method

Syntax
Json
Request:

Copy
{
    "agendaTopicId": <string>
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.IssueInterpreterMetaFunctionResponse Constructor

ConferenceApiHandlerIssueInterpreterMetaFunctionResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerIssueInterpreterMetaFunctionResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.GetApiState Method

GetApiState Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.DeleteImageResponse Class

ConferenceApiHandlerDeleteImageResponse Class

Represents the delete image response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerDeleteImageResponse
Syntax
Json
{ JsonClass:DeleteImageResponse	 }

The ConferenceApiHandlerDeleteImageResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerDeleteImageResponse | Initializes a new instance of the ConferenceApiHandlerDeleteImageResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SeatInfo.Clone Method

Clone Method

Clone the seat information
Syntax
Json
Implements
ICloneableTClone
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


SynopticControl.Common Namespace

This contains LoginModel , SeatInfo classes info.It also contains SynopticLayoutInfo details as well as permission enumeration details.
Classes
 | Class | Description
Public class | AccessRights |
Public class | AgendaTopic | This contains the details of the agenda
Public class | ApiClient |
Public class | ApiLoginDetails |
Public class | BoothNotificationInfo | Represents booth notification information
Protected class | ConnectionState |
Public class | DeviceInfo | Contains device information
Public class | DiscussionListEntry | Contains various states of discussion list entry
Public class | DocumentVerificationResponse |
Public class | FileInfoDetail | This contains the details of the file
Public class | GuiIdClass |
Public class | Helper |
Public class | IndividualVotingResult | Voting results of perticular participant
Public class | InterpretationLanguage | Represents interpretation language
Public class | InterpretationMetaRequestStatus |
Public class | InterpretationRoutingInfo | Represents interpretation routing information
Public class | InterpretationSeatMetaRequest |
Public class | InterpreterBoothInfo | Contains interpreter booth information
Public class | InterpreterDeskInfo | Contains interpreter desk information.
Public class | LogOnModel | Defines model for login
Public class | MajorityResultInfo | Defines majority result for voting
Public class | MasterVolumeRange | Represents master volume range info
Public class | Meeting | This contains the details of the meeting
Public class | MicrophoneSensitivity |
Public class | MicrophoneSensitivityDescription |
Public class | NotesFileInfo | Class represents xml file data for meeting and voting notes details.
Public class | NotesFileSearchCriteria | Class represents date for selecting note files.
Public class | Participant | This contains the details of the participant
Public class | ParticipantAccessDeniedReasons | Class that contains the participant access denied reasons info
Public class | ParticipantSeats |
Public class | PluginCommandDescription |
Public class | PluginDescription | Describes a plugin
Public class | PluginEventDescription |
Public class | QuorumResultInfo | Defines quorum result for a meeting
Public class | SeatInfo | This contains the details of the seat
Public class | SeatParticipants |
Public class | SupportedHeadphoneTypes |
Public class | Vote | Vote
Public class | VoteMajorityInfo | Holds voting majority information.
Public class | Voting | This contains the details of the Voting
Public class | VotingResult | Voting result type
Structures
 | Structure | Description
Public structure | FileInfo | This contains the details of the file
Interfaces
 | Interface | Description
Public interface | ICloneableT | Cloneable interface for deep copy list
Enumerations
 | Enumeration | Description
Public enumeration | AccessDeniedReason | Represents various access denied reasons
Public enumeration | AgendaState | Defines state of the agenda
Public enumeration | ComparisonOperators |
Public enumeration | ConferenceEvent | Events that the server can fire to the clients
Public enumeration | DeviceOperationalState |
Public enumeration | DeviceType |
Public enumeration | DisplayVotingResultOption | Display voting result option.
Public enumeration | EnumDeskType |
Public enumeration | EquipmentCapabilities |
Public enumeration | IdentificationMethod | Identification method for the meeting
Public enumeration | InputPresetButton |
Public enumeration | InterpretationMetaRequestType |
Public enumeration | InterpretationMicrophoneState |
Public enumeration | InterpretationQualityType | This is for holding the quality type of
Public enumeration | MeetingState | State of the meeting
Public enumeration | MicrophoneState |
Public enumeration | NotesFileType | Notes file type
Public enumeration | OutputPresetButton |
Public enumeration | ParticipantSeatType | Defines seat types
Public enumeration | Permission | Contains user permissions
Public enumeration | PowerMode | The power modes
Public enumeration | SeatStatus | Status of the seats
Public enumeration | SpeakerType |
Public enumeration | SpecialOperationType | Defines the available VIP types within the system.
Public enumeration | StatusType | This is for holding Majority and Quorum status
Public enumeration | VerificationMethod | Verification method for the meeting
Public enumeration | VotingAnswer | Contains voting answer options
Public enumeration | VotingState | Contains voting states.
Public enumeration | VotingTimerType |


ConferenceModel.GetSeatMicrophoneSensitivity Method

GetSeatMicrophoneSensitivity Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ActivateAdHocVotingResponse Class

ConferenceApiHandlerActivateAdHocVotingResponse Class

Represents the activate ad-hoc meeting info response.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerActivateAdHocVotingResponse
Syntax
Json
{ JsonClass:ActivateAdHocVotingResponse	 }

The ConferenceApiHandlerActivateAdHocVotingResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerActivateAdHocVotingResponse | Initializes a new instance of the ConferenceApiHandlerActivateAdHocVotingResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


VotingState Enumeration

Contains voting states.
Syntax
Json
VotingState:{
closed
ready
opened
onHold
done
canceled
accepted
rejected}
Members
Member name | Value | Description
closed | 0 | Indicates that voting is closed.
ready | 1 | Indicates that voting is ready.
opened | 2 | Indicates that voting is opened.
onHold | 3 | Indicates that voting is on hold.
done | 4 | Indicates that voting is completed.
canceled | 5 | Indicates that voting is canceled.
accepted | 6 | Indicates that voting is accepted.
rejected | 7 | Indicates that voting is rejected.
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SendPluginCommandInfo.CorrelationId Property

CorrelationId Property

Syntax
Json
{ Property:CorrelationId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi Class

Provide api functionality for synopitc and acts as wrapper for MainWindowsApi
Inheritance Hierarchy
SystemObject
SynopticControlDcnmApi
Syntax
Json
{ JsonClass:DcnmApi		Instance:<type>,
    SynopticUri:<type>,
 }

The DcnmApi type exposes the following members.

Constructors
 | Name | Description
 | DcnmApi |
Private method | DcnmApi | Initializes a new instance of the DcnmApi class
Top
Properties
 | Name | Description
 | Instance | DcnmApi instance
Public property | SynopticUri | Gets and sets the synoptic uri
Top
Methods
 | Name | Description
Public method | ActivateAdHocVoting |
Public method | ActivateMeeting | Activate meeting request.
Public method | ActivatePresentation | Activate the presentation.
Public method | ActivateVoting |
Public method | CancelImportantSpeaker | Remove important speaker from waiting/speaker list
Protected method | CancelInterpreterMetaFunction |
Public method | CancelRequests |
Public method | CancelResponder | Remove responder from responders list
Public method | CancelResponseRequest | Cancels response request.
Public method | CancelSpeaker | Remove speaker from waiting/speaker list
Protected method | CheckNotesFileTampered |
Public method | CloseAgenda |
Public method | CloseMeeting |
Public method | CloseVoting |
Public method | DeactivateMeeting |
Public method | DeactivatePresentation | Deactivate the presentation.
Public method | DeactivateVoting |
Protected method | DeleteNotesFiles |
Public method | Dispose | Releases all resources used by the DcnmApi
Public method | EnableSeatIllumination | Enable or disable seat illumination
Protected method | GetAgendaTopicsForMeeting |
Protected method | GetDefaultVotingSettings |
Private method | GetLicenseInformation |
Protected method | GetMajorityVariables |
Protected method | GetMaximumMicrophoneSensitivity |
Protected method | GetMeetingDeskConfiguration | Gets the meeting desk configuration.
Protected method | GetMicrophoneSensitivity |
Protected method | GetMicrophoneSensitivityStepSize |
Protected method | GetMinimumMicrophoneSensitivity |
Protected method | GetNotesFileInfos |
Private method | GetParticipantGroupPermissions | Gets participant group permissions
Private method | GetParticipantPermissions | Gets participants permissions.
Protected method | GetParticipantsForMeeting |
Public method | GetPermission | Gets permissions of the user
Public method | GetPlugin |
Public method | GetPlugins |
Private method | GetSeats | Get the seat info list
Protected method | GetVotingsForMeeting |
Protected method | GrantInterpretation | Grants the interpretation.
Public method | GrantRequest |
Public method | GrantResponseRequest |
Public method | GrantSpeech | Add participant to the waiting list
Public method | HoldVoting |
Protected method | Initialize |
Protected method | IssueInterpreterMetaFunction |
Public method | IsValidUserId |
Public method | LogOnDcnmServer | Gets User security claims info for user
Private method | OnActiveMeetingStatusChanged | Called on meeting status changed.
Private method | OnActualSpeakerChanged |
Private method | OnActualSpeakerVideoChanged |
Private method | OnAgendaForMeetingReceived |
Private method | OnApplicationModeStateChanged | Updates application mode
Private method | OnAreaCreated |
Private method | OnAreaDeleted |
Private method | OnAreaUpdated |
Private method | OnAudioSettingsChanged |
Private method | OnBaseCapabilitiesChanged | Handles base capabilities changed
Private method | OnBoothNotificationsChanged |
Private method | OnDevicesAssignedToSeats | Handles devices that are assigned to seats.
Private method | OnDevicesFoundAtSeats | Handles devices that are found at seats.
Private method | OnDevicesLostAtSeats | Handles devices that are lost at seats.
Private method | OnDevicesUnassignedFromSeats | Handles devices that are unassigned from seats.
Private method | OnDiscussionOptionsChanged |
Private method | OnEquipmentPowerStateChanged | Handles system power state changed
Private method | OnImageWebserverInfoChanged |
Private method | OnImportantSpeakersListChanged |
Private method | OnIndividualVotingResultUpdated |
Private method | OnInterpretationLanguagesChanged |
Private method | OnInterpretationMetaRequestStatusChanged |
Private method | OnInterpretationRoutingListChanged |
Private method | OnMajorityResultUpdated |
Private method | OnMeetingBoothInfoChanged |
Private method | OnMeetingCreated |
Private method | OnMeetingDataPathUpdated |
Private method | OnMeetingDeleted |
Private method | OnMeetingDeskInfoChanged |
Private method | OnMeetingListChanged |
Private method | OnMeetingUpdated |
Private method | OnNotesFileListUpdated |
Private method | OnOpenStateChanged | Handles the opened state changed reported by the API.
Private method | OnParticipantAccessDenied |
Private method | OnParticipantAttendanceSummaryChanged |
Private method | OnParticipantsForMeetingReceived |
Private method | OnParticipantsListChanged | Called when participant list is changed
Private method | OnParticipantsUpdated |
Private method | OnPluginsAdded |
Private method | OnPluginsRemoved |
Private method | OnPresentationPuginStateChanged |
Private method | OnPresentationStateChanged |
Private method | OnPriorityListChanged |
Private method | OnRequestsListChanged |
Private method | OnRequestToResponseOptionsChanged |
Private method | OnRequestToSpeakOptionsChanged |
Private method | OnRespondersListChanged |
Private method | OnResponseRequestsListChanged |
Private method | OnRoomContactEmailUpdated |
Private method | OnRoomNameUpdated |
Private method | OnSeatMicrophoneSensitivityUpdated |
Private method | OnSeatsCreated | Handles seats that are created.
Private method | OnSeatsDeleted | Handles seats that are deleted.
Private method | OnSeatSelected | On seat illuminated.
Private method | OnSeatsUpdated | Handles seats that are updated.
Private method | OnSpeakersListChanged | On change of speakerlist
Private method | OnSpeakerViewing_SpeakerViewingOptionsChanged |
Private method | OnSpeechTimerOptionsChanged | Updates speech time options
Private method | OnVotingCreated |
Private method | OnVotingDeleted |
Private method | OnVotingResultUpdated |
Private method | OnVotingScriptChanged |
Private method | OnVotingScriptForMeetingReceived |
Private method | OnVotingStatusChanged |
Private method | OnVotingUpdated |
Public method | OpenAgenda |
Public method | OpenAPI | Opens API for use
Public method | OpenMeeting |
Public method | OpenVoting |
Private method | PluginEventHandler |
Private method | PrepareParticipant2_ScreenLineFormatUpdated | Called on screen format is updated.
Private method | ProcessApiOpenResponse |
Protected method | RaiseBoothNotification |
Private method | ReadDataFromJsonFile |
Private method | ReadSynopticLoginDetail |
Public method | RegisterPlugin |
Public method | RegisterWebApplication | Updates the latest web application info
Public method | RequestAttendanceInfo |
Public method | RequestMicrophoneActive | Request to activate the microphone of the participant with the specified id.
Public method | RequestMicrophoneInactive | Request to deactivate the microphone of the participant with the specified id.
Public method | RequestParticipantsList | Request for participants list
Public method | RequestVotingResult | Request for voting results.
Protected method | ResetMicrophoneSensitivity |
Public method | ResumeVoting |
Protected method | SelectFloor |
Protected method | SelectInputLanguage |
Protected method | SelectRelay |
Public method | SendPluginCommand |
Public method | SendPluginEvent |
Public method | SetIlluminateSeat | Illuminates seat.
Protected method | SetInterpretationOutPreset | Sets the interpretation out preset.
Public method | SetManageMeetingRights | Sets the manage meeting rights
Protected method | SetMasterVolume |
Public method | SetSystemPowerMode | Sets the system power mode to power on
Public method | SetWebClientDeviceCapabilities | Sets the web client device capabilities
Public method | ShiftRequest | Shift the selected request.
Public method | ShiftResponseRequest | Shift the selected response request.
Public method | SubscribePluginEvent |
Protected method | TransformNotesFile |
Private method | UnregisterEvents |
Public method | UnregisterPlugin |
Public method | UnSubscribePluginEvent |
Private method | UpdateBoothInUseInfo |
Private method | UpdateMasterVolumeInformation |
Protected method | UpdateMeetingBoothConfigurations |
Protected method | UpdateMeetingDeskConfigurations |
Protected method | UpdateMicrophoneSensitivity |
Private method | UpdatePowerStateInformation | Updates system power state information
Private method | UpdatePreparedMeetingsInfo |
Private method | UpdateRoomContactEmail |
Private method | UpdateRoomName |
Public method | UpdateSeatsInfo | Updated seats information for default meeting.
Protected method | UpdateVotingsForMeeting |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Voting.MajorityVariables Property

MajorityVariables Property

Gets the voting majority variables list.
Syntax
Json
{ Property:MajorityVariables }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Startup Class

Sets start up configurations.
Inheritance Hierarchy
SystemObject
SynopticControlStartup
Syntax
Json
{ JsonClass:Startup	 }

The Startup type exposes the following members.

Constructors
 | Name | Description
 | Startup |
Public method | Startup | Initializes a new instance of the Startup class
Top
Methods
 | Name | Description
Public method | Configuration | configures Web API. The Startup class is specified as a type parameter in the WebApp.Start method.
Public method | Stop |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpretationMetaRequestStatus Constructor

Initializes a new instance of the InterpretationMetaRequestStatus class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnSpeakerViewing_SpeakerViewingOptionsChanged Method

OnSpeakerViewing_SpeakerViewingOptionsChanged Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


Certificate.GetCertificateStore Method

GetCertificateStore Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DcnmApi.CloseVoting Method

CloseVoting Method

Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Meeting.VerificationMethod Property

VerificationMethod Property

The verification mode for the meeting.
Syntax
Json
{ Property:VerificationMethod }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


CreateCertificateRequest.IPAddresses Property

IPAddresses Property

Syntax
Json
{ Property:IPAddresses }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AuthenticateController.LogOff Method

LogOff Method

UnAuthenticates user
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetMicrophoneSensitivityResponse Constructor

ConferenceApiHandlerGetMicrophoneSensitivityResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerGetMicrophoneSensitivityResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AccessRights.ConfigureSystem Property

ConfigureSystem Property

Syntax
Json
{ Property:ConfigureSystem }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SystemLog.Listeners Property

Listeners Property

Get the collection of trace listeners for the DebugLog
Syntax
Json
{ Property:Listeners }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpretationSeatMetaRequest Properties

The InterpretationSeatMetaRequest type exposes the following members.

Properties
 | Name | Description
Public property | SeatId | Gets or sets the seat identifier.
Public property | SeatMetaRequests | Gets or sets the seat metat data.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ResetMicrophoneSensitivityResponse Constructor

ConferenceApiHandlerResetMicrophoneSensitivityResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerResetMicrophoneSensitivityResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.UnregisterEvents Method

UnregisterEvents Method

Syntax
Json
Request:

Copy
{
    "events":
    [
        "apiStateChanged"|"permissionsChanged"|"seatsChanged"|"discussionListChanged"|"discussionOptionsChanged"|"meetingInfoChanged"|"individualVotingResultsChanged"|
        "votingStateChanged"|"enableSeatIlluminationChanged"|"illuminatedSeatChanged"|"systemPowerModeChanged"|"agendaTopicsChanged"|"participantsChanged"|
        "votingScriptChanged"|"votingResultChanged"|"interpretationLanguagesChanged"|"interpretationRoutingsChanged"|"interpreterSeatsChanged"|
        "interpreterBoothsChanged"|"boothNotificationsChanged"|"masterVolumeChanged"|"masterVolumeRangeChanged"|"presentationStateChanged"|
        "fileChanged"|"participantSeatsChanged"|"quorumResultChanged"|"majorityResultChanged"|"votingInfoChanged"|"notesFileListChanged"|
        "interpretationMetaRequestStatusChanged"|"roomNameChanged"|"roomContactEmailChanged"|"pluginsChanged"|"pluginEventAvailable"|"pluginCommandAvailable"|
    ]
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SendPluginEventResponse Class

ConferenceApiHandlerSendPluginEventResponse Class

Response for send plugin Event .
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerSendPluginEventResponse
Syntax
Json
{ JsonClass:SendPluginEventResponse	 }

The ConferenceApiHandlerSendPluginEventResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSendPluginEventResponse | Initializes a new instance of the ConferenceApiHandlerSendPluginEventResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Certificate.AddCertificateExtensions Method (CertificateRequest, X509Certificate2)

AddCertificateExtensions Method (CertificateRequest, X509Certificate2)

 Bosch Logo
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetQuorumResultResponse Constructor

ConferenceApiHandlerGetQuorumResultResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetQuorumResultResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GuidConverter Methods

The GuidConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvert | (Overrides JsonConverterCanConvert(Type).)
Public method | ReadJson | (Overrides JsonConverterReadJson(JsonReader, Type, Object, JsonSerializer).)
Public method | WriteJson | (Overrides JsonConverterWriteJson(JsonWriter, Object, JsonSerializer).)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ParticipantSeats Constructor

Initializes a new instance of the ParticipantSeats class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.DetermineTotalVoteResultVisibilityForUser Method

DetermineTotalVoteResultVisibilityForUser Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RegisterPluginResponse Class

ConferenceApiHandlerRegisterPluginResponse Class

Represents the register plugin response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerRegisterPluginResponse
Syntax
Json
{ JsonClass:RegisterPluginResponse	 }

The ConferenceApiHandlerRegisterPluginResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerRegisterPluginResponse | Initializes a new instance of the ConferenceApiHandlerRegisterPluginResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileStore Constructor

Initializes a new instance of the FileStore class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Meeting.Equals Method

Equals Method

Determines whether the specified object is equal to current object.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


QuorumResultInfo.Equals Method

Equals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Override Equals function in IEquatable (Overrides ObjectEquals(Object).)
Public method | Equals(QuorumResultInfo) | Function to compare QuorumResultInfo with other objects
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


QuorumResultInfo.GetHashCode Method

GetHashCode Method

Override GetHashCode function in IEquatable
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.GetInterpreterDeskInfo Method

GetInterpreterDeskInfo Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.AddSeatToSpeakersRequest Class

ConferenceApiHandlerAddSeatToSpeakersRequest Class

Represents the speaker request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerAddSeatToSpeakersRequest
Syntax
Json
{ JsonClass:AddSeatToSpeakersRequest		SeatId:<type>,
 }

The ConferenceApiHandlerAddSeatToSpeakersRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerAddSeatToSpeakersRequest | Initializes a new instance of the ConferenceApiHandlerAddSeatToSpeakersRequest class
Top
Properties
 | Name | Description
Public property | SeatId | The seat identifier.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


IndividualVotingResult Properties

The IndividualVotingResult type exposes the following members.

Properties
 | Name | Description
Public property | participantId | participant id
Public property | votingAnswer | Voting answer for the participant
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ResetMicrophoneSensitivityResponse Class

ConferenceApiHandlerResetMicrophoneSensitivityResponse Class

Reset microphone sensitivity response.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerResetMicrophoneSensitivityResponse
Syntax
Json
{ JsonClass:ResetMicrophoneSensitivityResponse		Status:<type>,
 }

The ConferenceApiHandlerResetMicrophoneSensitivityResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerResetMicrophoneSensitivityResponse | Initializes a new instance of the ConferenceApiHandlerResetMicrophoneSensitivityResponse class
Top
Properties
 | Name | Description
Public property | Status | Status after sending request to resetting microphone sensitivity for all seats.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.RoomName Property

RoomName Property

Contains room name information.
Syntax
Json
{ Property:RoomName }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RemoveSpeechResponse Constructor

ConferenceApiHandlerRemoveSpeechResponse Constructor

Initializes a new instance of the ConferenceApiHandlerRemoveSpeechResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


RaiseBoothNotificationRequest Properties

The ConferenceApiHandlerRaiseBoothNotificationRequest type exposes the following members.

Properties
 | Name | Description
Public property | BoothId |
Public property | Notification |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.AbortVotingResponse Constructor

ConferenceApiHandlerAbortVotingResponse Constructor

Initializes a new instance of the ConferenceApiHandlerAbortVotingResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GrantInterpretationRequest.MicrophoneState Property

MicrophoneState Property

Gets or sets the state of the interpretation microphone.
Syntax
Json
{ Property:MicrophoneState }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SystemLog.TraceError Method

TraceError Method

Overload List
Name | Description
TraceError(String) | Forwards the error event to the trace source.
TraceError(String, Object) | Forwards the error event to the trace source.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Certificate.CreateServerCertificatePfxFile Method

CreateServerCertificatePfxFile Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


Certificate.InstallRootCertificateFromCrtFile Method

InstallRootCertificateFromCrtFile Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


EventResponse Properties

The ConferenceApiHandlerEventResponse type exposes the following members.

Properties
 | Name | Description
Public property | Events | List of events
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetPluginResponse Constructor

ConferenceApiHandlerGetPluginResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetPluginResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SendPluginCommandResponse Properties

The ConferenceApiHandlerSendPluginCommandResponse type exposes the following members.

Properties
 | Name | Description
Public property | Response | The response of the command execution
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AgendaTopic.Equals Method

Equals Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetVotings Method

GetVotings Method

Gets the votings.
Syntax
Json
Request:

Copy
{
    "meetingId": <string>
}

Response:

Copy
{
    "votingList":
    [
        {
            "description": <string>,
            "documentationLink": <string>,
            "majorityVariables": [<string>],
            "meetingId": <string>,
            "referenceNumber": <string>,
            "state": "closed"|"ready"|"opened"|"onHold"|"done"|"canceled"|"accepted"|"rejected",
            "subject": <string>,
            "usePresentButton": <bool>,
            "useVoteWeight": <bool>,
            "voteMajorityInfo":
            {
                "isEnabled": <bool>,
                "majorityCondition": "greaterThan"|"greaterThanOrEqualTo"|"equals"|"lessThan"|"lessThanOrEqualTo",
                "majorityDenominatorExpression": <string>,
                "majorityNumeratorExpression": <string>,
                "majorityThresholdExpression": <string>
            },
            "votingAnswers":
            [
                "notVoted"|"yes"|"no"|"abstain"|"dnpv"|"for"|"against"|"present"|"voteCasted"|"A"|"B"|"C"|"D"
            ],
            "votingId": <string>,
            "votingTimeDuration": <int>,
            "votingTimerType": "noVotingTimer"|"keepVotingOpen"|"holdVotingRound"|"closeVotingRound"
        }
    ]
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpretationLanguage.GetHashCode Method

GetHashCode Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetMasterVolumeRangeRequest Class

ConferenceApiHandlerGetMasterVolumeRangeRequest Class

Represents the get master volume range request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetMasterVolumeRangeRequest
Syntax
Json
{ JsonClass:GetMasterVolumeRangeRequest	 }

The ConferenceApiHandlerGetMasterVolumeRangeRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetMasterVolumeRangeRequest | Initializes a new instance of the ConferenceApiHandlerGetMasterVolumeRangeRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


PluginHandler.PluginEventSubscriptionData.ConnectionId Property

ConnectionId Property

Syntax
Json
{ Property:ConnectionId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SubscribePluginEventRequest.PluginName Property

PluginName Property

Plugin name to subscribe
Syntax
Json
{ Property:PluginName }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RemoveResponseRequest Constructor

ConferenceApiHandlerRemoveResponseRequest Constructor

Initializes a new instance of the ConferenceApiHandlerRemoveResponseRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetInterpretationMetaFunctionStatusResponse Class

ConferenceApiHandlerGetInterpretationMetaFunctionStatusResponse Class

 Bosch Logo
Represents get speak slow status response.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetInterpretationMetaFunctionStatusResponse
Syntax
Json
{ JsonClass:GetInterpretationMetaFunctionStatusResponse		RequestStatus:<type>,
 }

The ConferenceApiHandlerGetInterpretationMetaFunctionStatusResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetInterpretationMetaFunctionStatusResponse | Initializes a new instance of the ConferenceApiHandlerGetInterpretationMetaFunctionStatusResponse class
Top
Properties
 | Name | Description
Public property | RequestStatus |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SendPluginCommandInfo.PluginCommand Property

PluginCommand Property

Syntax
Json
{ Property:PluginCommand }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Certificate.CreateECDsaCertificate Method

CreateECDsaCertificate Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModelReader.IsInInterpretationBoothList Method

IsInInterpretationBoothList Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DcnmApi.OnNotesFileListUpdated Method

OnNotesFileListUpdated Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


InterpreterBoothInfo.Equals Method

Equals Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.CloseMeetingResponse Constructor

ConferenceApiHandlerCloseMeetingResponse Constructor

Initializes a new instance of the ConferenceApiHandlerCloseMeetingResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Participant.PictureUpdatedNumber Property

PictureUpdatedNumber Property

PictureUpdatedNumber is used to retrieve latest version of person picture on client side
Syntax
Json
{ Property:PictureUpdatedNumber }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Voting.ReferenceNumber Property

ReferenceNumber Property

Gets the voting reference number.
Syntax
Json
{ Property:ReferenceNumber }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader Class

Create model for conference functions.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceModelReader
Syntax
Json
{ JsonClass:ConferenceModelReader		CanDeactivateMicrophone:<type>,
    Instance:<type>,
 }

The ConferenceModelReader type exposes the following members.

Constructors
 | Name | Description
Private method | ConferenceModelReader | Initializes a new instance of the ConferenceModelReader class
Top
Properties
 | Name | Description
Public property | CanDeactivateMicrophone | Contains can deactivate microphone
 | Instance | Conference model instance
Top
Methods
 | Name | Description
Protected method | ActivateMicrophone |
Protected method | CancelSpeaker |
Protected method | CloseMeeting | Close the active meeting.
Protected method | DeactivateMicrophone |
Protected method | DetermineMajorityResultVisibilityForUser |
Protected method | DetermineQuorumResultVisibility |
Protected method | DetermineTotalResultsHasValidVoteAnswers |
Protected method | DetermineTotalVoteResultVisibilityForUser |
Protected method | DetermineTotalVotesCastedVisibilityForUser |
Protected method | DetermineVoteCastedVisibilityForUser |
Protected method | DetermineVoteResultVisibilityForUser | Determine voting results visibility for user
Public method | Dispose | Cleansup after the object instance.
Protected method | GetApiState |
Protected method | GetBoothNotifications | Returns booth notifications to requested clients.
Public method | GetCurrentVotingInfo | Provides voting state.
Private method | GetDiscussInfoBySeatId | Returns discuss list.
Public method | GetDiscussionList | Returns prepared discussion list to requested clients.
Public method | GetDiscussionMode | Returns current discussion mode to requested clients.
Public method | GetEnableSeatIlluminationState | Gets enable seat illumination state.
Protected method | GetHybridLicenseActiveState |
Private method | GetIdsForDiscussionOperations |
Public method | GetIlluminatedSeatId | Gets Guid of the illuminated seat
Public method | GetImageServerInfo | Gets ImageServerInfo
Public method | GetIndividualCastVoteResults | Get seat individual cast vote results
Private method | GetIndividualCastVoteResults(ReadOnlyCollectionVotingResult) |
Public method | GetIndividualParticipantCastVoteResults | Get participant individual cast vote results
Private method | GetIndividualParticipantCastVoteResults(ReadOnlyCollectionIndividualVotingResult) |
Public method | GetIndividualVotingResults | Get participant voting result
Private method | GetIndividualVotingResults(ReadOnlyCollectionIndividualVotingResult) |
Protected method | GetInterpretationLanguages | Returns interpretation languages to requested clients.
Protected method | GetInterpretationMetaRequestStatus |
Protected method | GetInterpretationRoutings | Returns interpretation routings to requested clients.
Protected method | GetInterpreterBooths | Returns interpreter booths to requested clients.
Protected method | GetInterpreterMetaRequestType |
Protected method | GetInterpreterSeats | Returns interpreter seats to requested clients.
Public method | GetMajorityResult | Gets the voting majority result
Protected method | GetMasterVolume |
Protected method | GetMaximumMasterVolume |
Public method | GetMaxRequests | Returns max requests for current discussion.
Public method | GetMaxResponses | Returns max responses for current discussion.
Public method | GetMeetingInfo | Gets the meeting information.
Public method | GetMeetings | Gets the meetings information.
Public method | GetMicrophoneSensitivity |
Protected method | GetMinimumMasterVolume |
Protected method | GetParticipantAccessDeniedReasons |
Private method | GetParticipantIdFromSeatId | returns participant id from seatid
Public method | GetParticipants | Gets the participants.
Public method | GetParticipantSeats |
Public method | GetPresentationState | Gets the state of the presentation.
Public method | GetQuorumResult | Gets the meeting quorum result
Public method | GetRoomContactEmail | Gets room contact email
Public method | GetRoomName | Gets room name
Public method | GetSeatInfoList | Get seat list
Public method | GetSeatVotingResults | Get seat voting results
Private method | GetSeatVotingResults(ReadOnlyCollectionVotingResult) |
Protected method | GetSupportedHeadphones |
Public method | GetSystemPowerMode | Gets the power mode information of the system
Public method | GetTopics | Gets the topics.
Public method | GetTotalCastVoteResult |
Private method | GetTotalCastVoteResult(ReadOnlyCollectionVote) |
Private method | GetTotalVoteResult |
Public method | GetVotingResult | Gets the voting result.
Public method | GetVotings | Gets the votings.
Public method | GetVotingState | Provides voting state.
Protected method | GrantResponse |
Protected method | GrantSpeech(ListGuid) |
Protected method | GrantSpeech(Guid) |
Protected method | Initialize |
Public method | IsInInterpretationBoothList |
Public method | IsInInterpretationLanguageList |
Public method | IsInInterpretationOutputLanguageListOfDesk |
Public method | IsInInterpretationSeatList |
Public method | IsInRespondersList |
Public method | IsInSpeakerList |
Protected method | IsValidInterpreterMetaRequest |
Protected method | RemoveResponse |
Protected method | RemoveSpeech |
Protected method | RequestResponse |
Protected method | RequestSpeech |
Public method | SetImageServerInfo | Set the Imageserver info
Protected method | TryGetInterpreterSeatFromSeatsList |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AuthenticateController Methods

The AuthenticateController type exposes the following members.

Methods
 | Name | Description
Public method | GetApiState | Gets Api connection state
Public method | LogOff | UnAuthenticates user
Public method | LogOn | Authenticates user
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateIndividualVotingResultsOnClients Method

UpdateIndividualVotingResultsOnClients Method

Sends notification to Updates voting results for client
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateWebClientRights Method

UpdateWebClientRights Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetInterpretationMetaFunctionStatusRequest Constructor

ConferenceApiHandlerGetInterpretationMetaFunctionStatusRequest Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerGetInterpretationMetaFunctionStatusRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileInfo.Equals Method

Equals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Override Equals functuion in IEquatable (Overrides ValueTypeEquals(Object).)
Public method | Equals(FileInfo) | Function to comapare file info with other objects
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Certificate.GetServerCertificateRequest Method

GetServerCertificateRequest Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateAgendaTopicsReceived Method

UpdateAgendaTopicsReceived Method

Updates the agenda topics received. Important: does not work real-time. Use MeetingListChanged for now.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


InterpreterBoothInfo Methods

The InterpreterBoothInfo type exposes the following members.

Methods
 | Name | Description
Public method | Clone | handles clone
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UnRegisterPluginRequest.PluginName Property

PluginName Property

The Plugin name to unregister
Syntax
Json
{ Property:PluginName }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GrantSpeechRequest.SeatIds Property

SeatIds Property

List of seat identifiers.
Syntax
Json
{ Property:SeatIds }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.VotingStatusInfo Property

VotingStatusInfo Property

Indicates voting status info
Syntax
Json
{ Property:VotingStatusInfo }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.CanDeactivateMicrophone Property

CanDeactivateMicrophone Property

Contains can deactivate microphone
Syntax
Json
{ Property:CanDeactivateMicrophone }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetInterpretationOutputPresetRequest.LanguageId Property

LanguageId Property

Syntax
Json
{ Property:LanguageId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ResetMicrophoneSensitivityRequest Properties

The ConferenceApiHandlerResetMicrophoneSensitivityRequest type exposes the following members.

Properties
 | Name | Description
Public property | SeatIds | List of seat ids to reset sensitivity level to 0. If the list count is 0 then will reset all the seats microphone sensitivity level to 0 in the system.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpretationRoutingInfo Methods

The InterpretationRoutingInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.CheckNotesFileTampered Method

CheckNotesFileTampered Method

Syntax
Json
Request:

Copy
{
    "fileName": <string>
}

Response:

Copy
{
    "fileVerificationResponse":
    {
        "hasHashTag": <bool>,
        "isAuthenticatedUsingCertificate": <bool>,
        "isDocumentSigned": <bool>,
        "isTampered": <bool>
    }
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Certificate.GetRootCertificateRequest Method

GetRootCertificateRequest Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetImageServerInfoResponse Constructor

ConferenceApiHandlerGetImageServerInfoResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetImageServerInfoResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.GetVotings Method

GetVotings Method

Get votings for the given meetingId.
Syntax
Json
Request:

Copy
{
    "meetingId": <string>
}

Response:

Copy
{
    "votingList":
    [
        {
            "description": <string>,
            "documentationLink": <string>,
            "majorityVariables": [<string>],
            "meetingId": <string>,
            "referenceNumber": <string>,
            "state": "closed"|"ready"|"opened"|"onHold"|"done"|"canceled"|"accepted"|"rejected",
            "subject": <string>,
            "usePresentButton": <bool>,
            "useVoteWeight": <bool>,
            "voteMajorityInfo":
            {
                "isEnabled": <bool>,
                "majorityCondition": "greaterThan"|"greaterThanOrEqualTo"|"equals"|"lessThan"|"lessThanOrEqualTo",
                "majorityDenominatorExpression": <string>,
                "majorityNumeratorExpression": <string>,
                "majorityThresholdExpression": <string>
            },
            "votingAnswers":
            [
                "notVoted"|"yes"|"no"|"abstain"|"dnpv"|"for"|"against"|"present"|"voteCasted"|"A"|"B"|"C"|"D"
            ],
            "votingId": <string>,
            "votingTimeDuration": <int>,
            "votingTimerType": "noVotingTimer"|"keepVotingOpen"|"holdVotingRound"|"closeVotingRound"
        }
    ]
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SystemLog.SOURCE_CATEGORY Field

SOURCE_CATEGORY Field

The source name of this category
Syntax
Json
{ Field:SOURCE_CATEGORY }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AgendaTopic.GetHashCode Method

GetHashCode Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConnectionTracker Properties

The ConnectionTracker type exposes the following members.

Properties
Name | Description
Instance | Connection tracker instance
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileLogTraceListener.WriteHeader Method

WriteHeader Method

Write the header of the trace message which consists of several configured trace options and the trace message itself.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GrantInterpretationResponse Class

ConferenceApiHandlerGrantInterpretationResponse Class

Represents the grant interpretation response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGrantInterpretationResponse
Syntax
Json
{ JsonClass:GrantInterpretationResponse	 }

The ConferenceApiHandlerGrantInterpretationResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGrantInterpretationResponse | Initializes a new instance of the ConferenceApiHandlerGrantInterpretationResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConnectionTracker.Instance Property

Instance Property

Connection tracker instance
Syntax
Json
{ Property:Instance }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.PrepareParticipant2_ScreenLineFormatUpdated Method

PrepareParticipant2_ScreenLineFormatUpdated Method

Called on screen format is updated.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


SeatStatus Enumeration

Status of the seats
Syntax
Json
SeatStatus:{
disconnected
connected
selected}
Members
Member name | Value | Description
disconnected | 0 | Disconnected state
connected | 1 | Connected state
selected | 2 | Selected state
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ActivateAdHocVotingRequest Constructor

ConferenceApiHandlerActivateAdHocVotingRequest Constructor

Initializes a new instance of the ConferenceApiHandlerActivateAdHocVotingRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateApplicationMode Method

UpdateApplicationMode Method

Updates application state
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


PluginHandler Class

Inheritance Hierarchy
SystemObject
SynopticControl.ServerPluginHandler
Syntax
Json
{ JsonClass:PluginHandler		Instance:<type>,
 }

The PluginHandler type exposes the following members.

Constructors
 | Name | Description
 | PluginHandler |
Private method | PluginHandler | Initializes a new instance of the PluginHandler class
Top
Properties
Name | Description
Instance |
Top
Methods
 | Name | Description
Private method | CachePluginEvents |
Private method | CancelWaitingCommands |
Protected method | CommandHandler |
Protected method | GetPlugin |
Protected method | GetPluginCommands |
Protected method | GetPluginEventData |
Protected method | GetPlugins |
Protected method | HandleApiConnectionStateChanged |
Protected method | HandleRemoveConnection |
Protected method | Initialize |
Protected method | NotifyPluginEvent |
Protected method | NotifyPluginsChanged |
Protected method | RegisterPlugin |
Protected method | SendPluginCommand |
Protected method | SendPluginEvent |
Protected method | SetPluginCommandResult |
Protected method | SubscribePluginEvents |
Protected method | UnRegisterPlugin |
Protected method | UnSubscribePluginEvents |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.ContainsInSeatsList Method

ContainsInSeatsList Method

Checks if the seat already exists in the seats list.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiMethodCaller(Response, Request).LoginRequired Property

LoginRequired Property

Syntax
Json
{ Property:LoginRequired }

Implements

IConferenceApiMethodCallerLoginRequired
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnVotingScriptChanged Method

OnVotingScriptChanged Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


SetPluginCommandResultRequest Properties

The ConferenceApiHandlerSetPluginCommandResultRequest type exposes the following members.

Properties
 | Name | Description
Public property | CorrelationId | The correlation id
Public property | Result | The result of the command execution
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


VoteMajorityInfo Methods

The VoteMajorityInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Function to compare one VoteMajorityInfo object with other
Public method | GetHashCode | Override GetHashCode function in IEquatable (Overrides ObjectGetHashCode.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetQuorumResultResponse.QuorumResult Property

QuorumResult Property

Quorum Result.
Syntax
Json
{ Property:QuorumResult }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.ActivatePresentation Method

ActivatePresentation Method

Activate the presentation.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiController.ProcessWebsocketSession Method

ProcessWebsocketSession Method

Wrapper needed by AcceptWebSocketRequest
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


QuorumResultInfo Constructor

Initializes instance of class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

SynopticControl.CommonQuorumResultInfo


ConferenceApiHandler.GetSeatVotingResultsRequest Constructor

ConferenceApiHandlerGetSeatVotingResultsRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetSeatVotingResultsRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GuiIdClass Constructor

Overload List
 | Name | Description
Protected method | GuiIdClass | Initializes a new instance of the GuiIdClass class
Protected method | GuiIdClass(Guid) | Initializes a new instance of the GuiIdClass class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Meeting.IdentificationMethod Property

IdentificationMethod Property

The identification mode for the meeting.
Syntax
Json
{ Property:IdentificationMethod }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.CancelRequests Method

CancelRequests Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ServerCertificateData.RootCertificateFriendlyName Property

RootCertificateFriendlyName Property

Syntax
Json
{ Property:RootCertificateFriendlyName }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


UnRegisterPluginRequest Properties

The ConferenceApiHandlerUnRegisterPluginRequest type exposes the following members.

Properties
 | Name | Description
Public property | PluginName | The Plugin name to unregister
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConnectionTracker.RemoveConnection Method

RemoveConnection Method

Removes connection
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RemoveSeatFromDiscussionListRequest Constructor

ConferenceApiHandlerRemoveSeatFromDiscussionListRequest Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerRemoveSeatFromDiscussionListRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetIlluminatedSeatResponse Class

ConferenceApiHandlerGetIlluminatedSeatResponse Class

Represents the GetIlluminatedSeat response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetIlluminatedSeatResponse
Syntax
Json
{ JsonClass:GetIlluminatedSeatResponse		SeatId:<type>,
 }

The ConferenceApiHandlerGetIlluminatedSeatResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetIlluminatedSeatResponse | Initializes a new instance of the ConferenceApiHandlerGetIlluminatedSeatResponse class
Top
Properties
 | Name | Description
Public property | SeatId | The seat identifier
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


PluginHandler.HandleApiConnectionStateChanged Method

HandleApiConnectionStateChanged Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


SystemLog.TraceVerbose Method

TraceVerbose Method

Overload List
Name | Description
TraceVerbose(String) | Forwards the informational event to the trace source.
TraceVerbose(String, Object) | Forwards the informational event to the trace source.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiMethodCaller(Response, Request) Methods

ConferenceApiMethodCallerResponse, Request Methods

The ConferenceApiMethodCallerResponse, Request generic type exposes the following members.

Methods
 | Name | Description
Public method | Call |
Public method | Initialize |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler Methods

Methods
 | Name | Description
Private method | AbortVoting | Abort the open voting
Private method | AcceptVoting | Accept the closed voting
Private method | ActivateAdHocVoting | Activate an ad-hoc voting
Private method | ActivateMeeting | To activate a meeting.
Private method | ActivateMicrophone | Un-mutes the microphone for the specified seat.
Private method | ActivatePresentation | Activate the presentation screen of the device.
Private method | ActivateVoting | Activate a voting
Private method | AddSeatToSpeakers | Adds the seat to active speakers list.
Private method | CancelInterpreterMetaFunction | Cancel interpreter meta request from a seat.
Private method | CanExecutePresentationPlugin |
Private method | CheckforLicense |
Private method | CheckIfNoNullOrEmptyGuids |
Private method | CheckNotesFileTampered | Check whether the notes file is tampered with and its certifcate is valid
Private method | CloseAgenda | Close Agenda for current meeting.
Private method | CloseMeeting | To close active meeting.
Private method | CloseVoting | Close the open voting
Private method | ConvertStringsToGuids |
Private method | CreateFile | Creates the specified file.
Private method | CreatePluginDescription |
Private method | DeactivateMeeting | To deactivate active meeting.
Private method | DeactivateMicrophone | Mutes the microphone for the specified seat.
Private method | DeactivatePresentation | De-Activate the presentation screen of the device.
Private method | DeleteFile | Deletes saved files.
Private method | DeleteImage | Deletes the specified image.
Private method | DeleteNotesFiles | Deletes the notes files.
Private method | EnableSeatIllumination | Enables or disables seat illumination mode.
Private method | ExecutePluginCommand |
Private method | GenerateJwtToken |
Private method | GetAgendaTopics | Gets the list of agenda topics information for the active meeting.
Private method | GetBoothNotifications | Gets the booth notifications from the system.
Private method | GetDiscussionList | Gets the list of speakers, requests, request responders, important and priority speakers of the active discussion.
Private method | GetDiscussionOptions | Gets the discussion options of the active discussion.
Private method | GetEnableSeatIllumination | Gets state whether system is in installation mode or not.
Private method | GetIlluminatedSeat | Gets identifier of the illuminated seat.
Private method | GetImageServerInfo | Gets the Uri of the image server.
Private method | GetIndividualVotingResults | Gets individual voting results.
Private method | GetInterpretationLanguages | Gets the interpretation languages of the active meeting.
Private method | GetInterpretationMetaFunctionStatus | Gets interpretation meta requests status from system.
Private method | GetInterpretationRoutings | Get list of all the active translation.
Private method | GetInterpreterBooths | Gets list of interpreter booths configured for active meeting.
Private method | GetInterpreterSeats | Gets list of interpreter seats configured for active meeting.
Private method | GetMajorityResult | Gets the majority result of the active voting.
Private method | GetMasterVolume | Gets the master volume of the DICENTIS System.
Private method | GetMasterVolumeRange | Gets the master volume range (minimum and maximum) of the DICENTIS System
Private method | GetMeetingInfo | Gets the information related to the active meeting.
Private method | GetMeetings | Gets the list of meeting's.
Private method | GetMicrophoneSensitivity | Gets microphone sensitivity for seat ids.
Private method | GetMicrophoneSensitivityDescription | Gets microphone sensitivity description from system.
Private method | GetNotesFileList | Get list of meeting and voting notes xml file details.
Private method | GetParticipantAccessDeniedReasons | Gets the participant access denied reasons
Private method | GetParticipants | Gets the list of participants assigned to the active meeting.
Private method | GetParticipantSeats | Gets the list of participant identifier along with assigned seat and seated seat identifier of the active meeting. A participant can be assigned to a seat during the meeting preparation. The participant becomes a seated participant when he logs in (identify and if configured verify) at a seat. When there is no identification method configured, then the assigned participant, immediately becomes a seated participant upon activating the meeting.
Private method | GetPermissions | Gets the permissions of the logged-in user
Private method | GetPlugin | Retrieve details of a specific plugin
Private method | GetPluginCommands | Gets the list of plugin commands
Private method | GetPluginEventData | Gets the plugin event data
Private method | GetPlugins | Retrieves all the plugins. Use GetPluginAsync to retrieve details of a specific plugin
Private method | GetPresentationState | Gets the current presentation state whether the presentation is enabled / disabled.
Private method | GetQuorumResult | Gets the quorum result of the active meeting.
Private method | GetRoomContactEmail | Gets room contact email.
Private method | GetRoomName | Gets room name.
Private method | GetSeats | Gets list of participant seats.
Private method | GetSeatVotingResults | Gets seat voting results.
Private method | GetSupportedHeadphones | Gets the collection of supported headphones for interpretation
Private method | GetSystemPowerMode | Gets the power state of the system.
Private method | GetVotingInfo | Gets the active voting.
Private method | GetVotingResults | Gets the voting results of the active voting.
Private method | GetVotings | Gets the list of prepared voting's of the active meeting.
Private method | GetVotingState | Gets the state of active voting.
Private method | GrantInterpretation | Grant the interpretation to the specified interpretation seat.
Private method | GrantResponse | Shifts the given seat(s) participant(s) to the responders list, and removes the oldest speaker in the responders list.
Private method | GrantSpeech | Adds the seat or participant to active speakers list.
Private method | HoldVoting | Hold the open voting
Private method | IssueInterpreterMetaFunction | Issues interpreter meta request from a seat.
Private method | ListFiles | Lists the files.
Private method | ListImages | Lists the images.
Private method | LoadFile | Opens the saved file.
Private method | Login | Logs in the user
Private method | Logout | Logs off the user
Private method | OpenAgenda | Open Agenda for current meeting.
Private method | OpenMeeting | To open active meeting.
Private method | OpenVoting | Open the active voting
Private method | RaiseBoothNotification | Raises a notification on a booth.
Private method | RegisterEvents | This functions allows to register for the events (ex: Voting state changed, Permission changed) whose callbacks needs to be received, whenever the event is triggered
Private method | RegisterPlugin | Register a plugin
Private method | RejectVoting | Reject the closed voting
Private method | RemoveResponse | Cancels a request to respond of a participant or seat.
Private method | RemoveSeatFromDiscussionList | Removes the seat from active speakers list.
Private method | RemoveSpeech | Removes the seat or participant from active speakers list.
Private method | RequestResponse | Adds the seat or participant to response request waiting list.
Private method | RequestSpeech | Adds the seat or participant to waiting list.
Private method | ResetMicrophoneSensitivity | Resets microphone sensitivity for all seats.
Private method | ResumeVoting | Resume the on hold voting
Private method | SaveImage | Saves the specified image.
Private method | SelectInterpretationFloor | Selects the floor language for interpretation seat.
Private method | SelectInterpretationInputLanguage | Sets and selects the input language on the preset for interpretation seat.
Private method | SelectRelayInterpretation | Selects the relay language for interpretation seat.
Private method | SendPluginCommand | Send a command to a plugin
Private method | SendPluginEvent | Send a plugin event
Private method | SetIlluminateSeat | Illuminates specified seat.
Private method | SetInterpretationOutputPreset | Updates output preset for interpretation seat.
Private method | SetMasterVolume | Sets the master volume of the system with the specified value(dB)
Private method | SetPluginCommandResult | Sets the result of the command execution
Private method | SetSystemPowerMode | Sets the power mode of the system.
Private method | SubscribePluginEvent | Subscribe to an event coming from a plugin
Private method | TransformNotesFile | XSL transform the notes file.
Private method | UnregisterEvents | This functions allows to un register for the registered events
Private method | UnRegisterPlugin | Unregister a plugin
Private method | UnSubscribePluginEvent | Unsubscribe from an event coming from a plugin
Private method | UpdateFile | Updates the specified file.
Private method | UpdateMicrophoneSensitivity | Update microphone sensitivity for seat ids.
Private method | ValidateJwtToken |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetMicrophoneSensitivityRequest.SeatIds Property

SeatIds Property

List of seat ids to get sensitivity. It the list count is 0 then will retrieve all the seat microphone sensitivity in the system.
Syntax
Json
{ Property:SeatIds }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.GetDevicesAtSeat Method

GetDevicesAtSeat Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


FileInfo Properties

The FileInfo type exposes the following members.

Properties
 | Name | Description
Public property | attributes | Attribute indicating file type like synoptic, index etc
Public property | fileId | Id of the file
Public property | payload | Configuration of the file
Public property | title | Title of the file
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Certificate.GenerateECDsaCertificatePfxByteArray Method

GenerateECDsaCertificatePfxByteArray Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DeviceInfo.IsFoundAtSeat Property

IsFoundAtSeat Property

Syntax
Json
{ Property:IsFoundAtSeat }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SaveImageResponse Constructor

ConferenceApiHandlerSaveImageResponse Constructor

Initializes a new instance of the ConferenceApiHandlerSaveImageResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.TransformNotesFileRequest Constructor

ConferenceApiHandlerTransformNotesFileRequest Constructor

Initializes a new instance of the ConferenceApiHandlerTransformNotesFileRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


MicrophoneSensitivityDescription Properties

The MicrophoneSensitivityDescription type exposes the following members.

Properties
 | Name | Description
Public property | MaximumMicrophoneSensitivity | Maximum microphone sensitivity.
Public property | MicrophoneSensitivityStepSize | Microphone sensitivity step size.
Public property | MinimumMicrophoneSensitivity | Minimum microphone sensitivity.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.IssueInterpreterMetaFunction Method

IssueInterpreterMetaFunction Method

Syntax
Json
Request:

Copy
{
    "request": <string>,
    "seatId": <string>
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetMeetingInfoRequest Properties

The ConferenceApiHandlerGetMeetingInfoRequest type exposes the following members.

Properties
 | Name | Description
Public property | MeetingId | The meeting identifier.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetBoothNotificationsResponse Properties

The ConferenceApiHandlerGetBoothNotificationsResponse type exposes the following members.

Properties
 | Name | Description
Public property | Notifications | Gets or sets the booth notifications.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Voting Properties

The Voting type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the description.
Public property | DocumentationLink | Gets the documentation URL.
Public property | MajorityVariables | Gets the voting majority variables list.
Public property | MeetingId | Gets the meeting identifier.
Public property | ReferenceNumber | Gets the voting reference number.
Public property | State | Gets the state.
Public property | Subject | Gets the subject.
Public property | UsePresentButton | If this flag is true then present button will be enabled for voting round.
Public property | UseVoteWeight | Flag to set whether participant vote weight considered or not
Public property | VoteMajorityInfo | Gets the voting majority info.
Public property | VotingAnswers | Gets the voting answers.
Public property | VotingId | Gets the voting identifier.
Public property | VotingTimeDuration | Gets the duration of the voting time.
Public property | VotingTimerType | Gets the voting timer type info.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SystemLog Constructor

Initializes the static fields of the SystemLog class
Syntax
Json
{ Constructor:.cctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetPluginCommandResultRequest Constructor

ConferenceApiHandlerSetPluginCommandResultRequest Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerSetPluginCommandResultRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetMajorityResultRequest Constructor

ConferenceApiHandlerGetMajorityResultRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetMajorityResultRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConnectionTracker.RegisterEvents Method

RegisterEvents Method

Register events
Syntax
Json
Request:

Copy
{
    "events":
    [
        "apiStateChanged"|"permissionsChanged"|"seatsChanged"|"discussionListChanged"|"discussionOptionsChanged"|"meetingInfoChanged"|"individualVotingResultsChanged"|
        "votingStateChanged"|"enableSeatIlluminationChanged"|"illuminatedSeatChanged"|"systemPowerModeChanged"|"agendaTopicsChanged"|"participantsChanged"|
        "votingScriptChanged"|"votingResultChanged"|"interpretationLanguagesChanged"|"interpretationRoutingsChanged"|"interpreterSeatsChanged"|
        "interpreterBoothsChanged"|"boothNotificationsChanged"|"masterVolumeChanged"|"masterVolumeRangeChanged"|"presentationStateChanged"|
        "fileChanged"|"participantSeatsChanged"|"quorumResultChanged"|"majorityResultChanged"|"votingInfoChanged"|"notesFileListChanged"|
        "interpretationMetaRequestStatusChanged"|"roomNameChanged"|"roomContactEmailChanged"|"pluginsChanged"|"pluginEventAvailable"|"pluginCommandAvailable"|
    ]
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.CreateFileRequest Constructor

ConferenceApiHandlerCreateFileRequest Constructor

Initializes a new instance of the ConferenceApiHandlerCreateFileRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetVotingInfoResponse.VotingInfo Property

VotingInfo Property

Voting info
Syntax
Json
{ Property:VotingInfo }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetEnableSeatIlluminationState Method

GetEnableSeatIlluminationState Method

Gets enable seat illumination state.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


Certificate.AddUsersReadPermissionsForCertificate Method

AddUsersReadPermissionsForCertificate Method

Overload List
Name | Description
AddUsersReadPermissionsForCertificate(String) |
AddUsersReadPermissionsForCertificate(String, String, Boolean) |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UpdateFileRequest.Attributes Property

Attributes Property

Attributes indicate what contents of file represent and can contain list of values like 'Bosch.Synoptic.Layout', 'Bosch.Synoptic.Index'
Syntax
Json
{ Property:Attributes }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceUsers Properties

The ConferenceUsers type exposes the following members.

Properties
Name | Description
Instance |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


QuorumResultInfo.ComparisonOperator Property

ComparisonOperator Property

Comparision operator used in quorum expression.
Syntax
Json
{ Property:ComparisonOperator }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpretationMicrophoneState Enumeration

Syntax
Json
InterpretationMicrophoneState:{
Off
ActiveOnOutputA
ActiveOnOutputB
ActiveOnOutputC}
Members
Member name | Value | Description
Off | 0 | Microphone is off.
ActiveOnOutputA | 1 | The active on output a
ActiveOnOutputB | 2 | The active on output b
ActiveOnOutputC | 3 | The active on output c
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConnectionState Constructor

Initializes a new instance of the ConnectionState class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SendPluginCommandResponse Class

ConferenceApiHandlerSendPluginCommandResponse Class

Response for send plugin command .
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerSendPluginCommandResponse
Syntax
Json
{ JsonClass:SendPluginCommandResponse		Response:<type>,
 }

The ConferenceApiHandlerSendPluginCommandResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSendPluginCommandResponse | Initializes a new instance of the ConferenceApiHandlerSendPluginCommandResponse class
Top
Properties
 | Name | Description
Public property | Response | The response of the command execution
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


NotesFileSearchCriteria Properties

The NotesFileSearchCriteria type exposes the following members.

Properties
 | Name | Description
Public property | EndDate | End date for the file search in the string format of 'yyyy-MM-dd'
Public property | StartDate | Start date for the file search in the string format of 'yyyy-MM-dd'
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Startup Constructor

Initializes a new instance of the Startup class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetMasterVolumeRequest.Volume Property

Volume Property

Gets or sets the volume.
Syntax
Json
{ Property:Volume }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateSpeakersList Method

UpdateSpeakersList Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ApiLoginDetails Class

Inheritance Hierarchy
SystemObject
SynopticControl.CommonApiLoginDetails
Syntax
Json
{ JsonClass:ApiLoginDetails		Api:<type>,
    Schema:<type>,
 }

The ApiLoginDetails type exposes the following members.

Constructors
 | Name | Description
Public method | ApiLoginDetails | Initializes a new instance of the ApiLoginDetails class
Top
Properties
 | Name | Description
Public property | Api |
Public property | Schema |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetApiStateResponse.Online Property

Online Property

Online
Syntax
Json
{ Property:Online }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Meeting.State Property

State Property

Gets the state.
Syntax
Json
{ Property:State }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetQuorumResultResponse Class

ConferenceApiHandlerGetQuorumResultResponse Class

Represents the get quorum result response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetQuorumResultResponse
Syntax
Json
{ JsonClass:GetQuorumResultResponse		QuorumResult:<type>,
 }

The ConferenceApiHandlerGetQuorumResultResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetQuorumResultResponse | Initializes a new instance of the ConferenceApiHandlerGetQuorumResultResponse class
Top
Properties
 | Name | Description
Public property | QuorumResult | Quorum Result.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpreterBoothInfo Constructor (Guid, Int32, Boolean)

Initializes a new instance of the InterpreterBoothInfo class.
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetPermissionsResponse Properties

The ConferenceApiHandlerGetPermissionsResponse type exposes the following members.

Properties
 | Name | Description
Public property | Permissions | Permissions list
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel Constructor

Initializes a new instance of the ConferenceModel class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnPresentationPuginStateChanged Method

OnPresentationPuginStateChanged Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


PluginHandler.Initialize Method

Initialize Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


PluginHandler Methods

The PluginHandler type exposes the following members.

Methods
 | Name | Description
Private method | CachePluginEvents |
Private method | CancelWaitingCommands |
Protected method | CommandHandler |
Protected method | GetPlugin |
Protected method | GetPluginCommands |
Protected method | GetPluginEventData |
Protected method | GetPlugins |
Protected method | HandleApiConnectionStateChanged |
Protected method | HandleRemoveConnection |
Protected method | Initialize |
Protected method | NotifyPluginEvent |
Protected method | NotifyPluginsChanged |
Protected method | RegisterPlugin |
Protected method | SendPluginCommand |
Protected method | SendPluginEvent |
Protected method | SetPluginCommandResult |
Protected method | SubscribePluginEvents |
Protected method | UnRegisterPlugin |
Protected method | UnSubscribePluginEvents |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DocumentVerificationResponse Constructor

Initializes a new instance of the DocumentVerificationResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiAttribute Constructor

Initializes a new instance of the ConferenceApiAttribute class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ListImagesResponse Properties

The ConferenceApiHandlerListImagesResponse type exposes the following members.

Properties
 | Name | Description
Public property | Images | List of images
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.IssueInterpreterMetaFunctionResponse Class

ConferenceApiHandlerIssueInterpreterMetaFunctionResponse Class

 Bosch Logo
Represents issue interpreter meta function response.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerIssueInterpreterMetaFunctionResponse
Syntax
Json
{ JsonClass:IssueInterpreterMetaFunctionResponse	 }

The ConferenceApiHandlerIssueInterpreterMetaFunctionResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerIssueInterpreterMetaFunctionResponse | Initializes a new instance of the ConferenceApiHandlerIssueInterpreterMetaFunctionResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SeatParticipants.SeatedParticipantId Property

SeatedParticipantId Property

Syntax
Json
{ Property:SeatedParticipantId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UnregisterEventsRequest Class

ConferenceApiHandlerUnregisterEventsRequest Class

Parameters to UnRegisterEvents
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerUnregisterEventsRequest
Syntax
Json
{ JsonClass:UnregisterEventsRequest		Events:<type>,
 }

The ConferenceApiHandlerUnregisterEventsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerUnregisterEventsRequest | Initializes a new instance of the ConferenceApiHandlerUnregisterEventsRequest class
Top
Properties
 | Name | Description
Public property | Events | List of unregistered events
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnResponseRequestsListChanged Method

OnResponseRequestsListChanged Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


GetEnableSeatIlluminationResponse Properties

The ConferenceApiHandlerGetEnableSeatIlluminationResponse type exposes the following members.

Properties
 | Name | Description
Public property | Enable | Enable
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RemoveResponseRequest Class

ConferenceApiHandlerRemoveResponseRequest Class

Represents the removal of requested responder request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerRemoveResponseRequest
Syntax
Json
{ JsonClass:RemoveResponseRequest		ParticipantIds:<type>,
    SeatIds:<type>,
 }

The ConferenceApiHandlerRemoveResponseRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerRemoveResponseRequest | Initializes a new instance of the ConferenceApiHandlerRemoveResponseRequest class
Top
Properties
 | Name | Description
Public property | ParticipantIds | List of particpant identifiers.
Public property | SeatIds | List of seat identifiers.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


CreateCertificateRequest.ServerCertificateName Property

ServerCertificateName Property

Syntax
Json
{ Property:ServerCertificateName }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SubscribePluginEventResponse Constructor

ConferenceApiHandlerSubscribePluginEventResponse Constructor

Initializes a new instance of the ConferenceApiHandlerSubscribePluginEventResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetInterpreterSeatsRequest Class

ConferenceApiHandlerGetInterpreterSeatsRequest Class

Represents the request to get interpreter seats
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetInterpreterSeatsRequest
Syntax
Json
{ JsonClass:GetInterpreterSeatsRequest	 }

The ConferenceApiHandlerGetInterpreterSeatsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetInterpreterSeatsRequest | Initializes a new instance of the ConferenceApiHandlerGetInterpreterSeatsRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.GrantSpeech Method

GrantSpeech Method

Add participant to the waiting list
Syntax
Json
Request:

Copy
{
    "participantIds": [<string>],
    "seatIds": [<string>]
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


RemoveResponseRequest Properties

The ConferenceApiHandlerRemoveResponseRequest type exposes the following members.

Properties
 | Name | Description
Public property | ParticipantIds | List of particpant identifiers.
Public property | SeatIds | List of seat identifiers.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DocumentVerificationResponse Class

Inheritance Hierarchy
SystemObject
SynopticControl.CommonDocumentVerificationResponse
Syntax
Json
{ JsonClass:DocumentVerificationResponse		HasHashTag:<type>,
    IsAuthenticatedUsingCertificate:<type>,
    IsDocumentSigned:<type>,
    IsTampered:<type>,
 }

The DocumentVerificationResponse type exposes the following members.

Constructors
 | Name | Description
Public method | DocumentVerificationResponse | Initializes a new instance of the DocumentVerificationResponse class
Top
Properties
 | Name | Description
Public property | HasHashTag | True if the file has hash tag in file (version before 3.6 files has hash tag).
Public property | IsAuthenticatedUsingCertificate | True if the signature failed to authenticate with root certificate on the system.
Public property | IsDocumentSigned | Indicates if file contains digital signature.
Public property | IsTampered | True if the hash or signature check fails.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetVotingResultsResponse Class

ConferenceApiHandlerGetVotingResultsResponse Class

Represents the get voting results response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetVotingResultsResponse
Syntax
Json
{ JsonClass:GetVotingResultsResponse		VotingResults:<type>,
 }

The ConferenceApiHandlerGetVotingResultsResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetVotingResultsResponse | Initializes a new instance of the ConferenceApiHandlerGetVotingResultsResponse class
Top
Properties
 | Name | Description
Public property | VotingResults | List of voting results
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Certificate.InstallServerCertificateFromPfxFile Method

InstallServerCertificateFromPfxFile Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceUsers.AddUser Method

AddUser Method

Add a user to the administration
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.DeleteFileResponse Constructor

ConferenceApiHandlerDeleteFileResponse Constructor

Initializes a new instance of the ConferenceApiHandlerDeleteFileResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


MajorityResultInfo.Equals Method

Equals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Override Equals function in IEquatable (Overrides ObjectEquals(Object).)
Public method | Equals(MajorityResultInfo) | Function to compare MajorityResultInfo with other objects
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.MinimumMasterVolume Property

MinimumMasterVolume Property

Syntax
Json
{ Property:MinimumMasterVolume }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UpdateMicrophoneSensitivityRequest.SeatMicrophoneSensitivity Property

SeatMicrophoneSensitivity Property

List of seat ids with sensitivity value SeatMicrophoneSensitivity.
Syntax
Json
{ Property:SeatMicrophoneSensitivity }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetVotingResultsRequest Class

ConferenceApiHandlerGetVotingResultsRequest Class

Represents the get voting results request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetVotingResultsRequest
Syntax
Json
{ JsonClass:GetVotingResultsRequest	 }

The ConferenceApiHandlerGetVotingResultsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetVotingResultsRequest | Initializes a new instance of the ConferenceApiHandlerGetVotingResultsRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


MicrophoneSensitivity Class

Inheritance Hierarchy
SystemObject
SynopticControl.CommonMicrophoneSensitivity
Syntax
Json
{ JsonClass:MicrophoneSensitivity		SeatId:<type>,
    SeatName:<type>,
    SensitivityValue:<type>,
 }

The MicrophoneSensitivity type exposes the following members.

Constructors
 | Name | Description
Public method | MicrophoneSensitivity | Initializes a new instance of the MicrophoneSensitivity class
Top
Properties
 | Name | Description
Public property | SeatId | seat id.
Public property | SeatName | seat name.
Public property | SensitivityValue | Sensitivity value.
Top
Methods
 | Name | Description
Public method | Clone | Clone the seat microphone sensitivity information
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.VotingState Property

VotingState Property

Contains voting state
Syntax
Json
{ Property:VotingState }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiController.ProcessRequest Method

ProcessRequest Method

Given a JSON message, interpret it, call a handler method and generate the JSON response
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


AccessRights Constructor

Initializes a new instance of the AccessRights class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.GrantResponseRequest Method

GrantResponseRequest Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


MajorityResultInfo.DenominatorValue Property

DenominatorValue Property

Majority denominator value
Syntax
Json
{ Property:DenominatorValue }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.NotifyVotingInfoChangedOnClients Method

NotifyVotingInfoChangedOnClients Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ImageManagement.ListImages Method

ListImages Method

Gets a list of all the images uploaded to the server
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "images": [<string>]
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.DetermineResultsVisiblityForUser Method

DetermineResultsVisiblityForUser Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


SystemLog.AddTraceListener Method

AddTraceListener Method

Adds the given trace listener to the list of listeners to this trace source.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


InterpreterDeskInfo Properties

The InterpreterDeskInfo type exposes the following members.

Properties
 | Name | Description
Public property | ALanguageId | Gets or sets the A language identifier.
Public property | AutomaticMicrophoneSelection |
Public property | BLanguageId | Gets or sets the B language identifier.
Public property | BLanguageList | Gets the B language list.
Public property | BoothId | Gets or sets the booth identifier.
Public property | CLanguageId | Gets or sets the C language identifier.
Public property | CLanguageList | Gets the C language list.
Public property | DeskNumber | Gets or sets the desk number.
Public property | DeskType | Gets the type of desk.
Public property | Headphone |
Public property | SeatId | Gets or sets the seat identifier.
Public property | Status | Gets or sets the status.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SeatInfo.SeatName Property

SeatName Property

Seat name
Syntax
Json
{ Property:SeatName }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetPluginRequest.PluginName Property

PluginName Property

The name of plugin.
Syntax
Json
{ Property:PluginName }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RequestResponseRequest Class

ConferenceApiHandlerRequestResponseRequest Class

Represents the reponse to the speaker by seats and participants request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerRequestResponseRequest
Syntax
Json
{ JsonClass:RequestResponseRequest		ParticipantIds:<type>,
    SeatIds:<type>,
 }

The ConferenceApiHandlerRequestResponseRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerRequestResponseRequest | Initializes a new instance of the ConferenceApiHandlerRequestResponseRequest class
Top
Properties
 | Name | Description
Public property | ParticipantIds | List of particpant identifiers.
Public property | SeatIds | List of seat identifiers.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnSeatsUpdated Method

OnSeatsUpdated Method

Handles seats that are updated.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


FileInfo.Equals Method (FileInfo)

Equals Method (FileInfo)

 Bosch Logo
Function to comapare file info with other objects
Syntax
Json
Implements
IEquatableTEquals(T)
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.OpenVotingRequest Class

ConferenceApiHandlerOpenVotingRequest Class

Represents the open voting info request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerOpenVotingRequest
Syntax
Json
{ JsonClass:OpenVotingRequest	 }

The ConferenceApiHandlerOpenVotingRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerOpenVotingRequest | Initializes a new instance of the ConferenceApiHandlerOpenVotingRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SeatInfo.CanVote Property

CanVote Property

Indicates seat canvote capability
Syntax
Json
{ Property:CanVote }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RejectVotingRequest Class

ConferenceApiHandlerRejectVotingRequest Class

Represents the reject voting info request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerRejectVotingRequest
Syntax
Json
{ JsonClass:RejectVotingRequest	 }

The ConferenceApiHandlerRejectVotingRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerRejectVotingRequest | Initializes a new instance of the ConferenceApiHandlerRejectVotingRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetMasterVolumeRequest Class

ConferenceApiHandlerGetMasterVolumeRequest Class

Represents the get master volume request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetMasterVolumeRequest
Syntax
Json
{ JsonClass:GetMasterVolumeRequest	 }

The ConferenceApiHandlerGetMasterVolumeRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetMasterVolumeRequest | Initializes a new instance of the ConferenceApiHandlerGetMasterVolumeRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ResumeVotingResponse Class

ConferenceApiHandlerResumeVotingResponse Class

Represents the resume voting info response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerResumeVotingResponse
Syntax
Json
{ JsonClass:ResumeVotingResponse	 }

The ConferenceApiHandlerResumeVotingResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerResumeVotingResponse | Initializes a new instance of the ConferenceApiHandlerResumeVotingResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InterpretationMetaRequestStatus Class

Inheritance Hierarchy
SystemObject
SynopticControl.CommonInterpretationMetaRequestStatus
Syntax
Json
{ JsonClass:InterpretationMetaRequestStatus		ActiveInterpretationMetaRequests:<type>,
    SeatMetaData:<type>,
 }

The InterpretationMetaRequestStatus type exposes the following members.

Constructors
 | Name | Description
Public method | InterpretationMetaRequestStatus | Initializes a new instance of the InterpretationMetaRequestStatus class
Top
Properties
 | Name | Description
Public property | ActiveInterpretationMetaRequests | Active interpretation meta request type.
Public property | SeatMetaData | Contains list of seat ids with active meta requests.
Top
Methods
 | Name | Description
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Participant Methods

The Participant type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


NotesFileInfo.IsTampered Property

IsTampered Property

Syntax
Json
{ Property:IsTampered }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


PluginHandler.AwaiterInfo Class

PluginHandlerAwaiterInfo Class

Inheritance Hierarchy
SystemObject
SynopticControl.ServerPluginHandlerAwaiterInfo
Syntax
Json
{ JsonClass:AwaiterInfo		Awaiter:<type>,
    PluginName:<type>,
 }

The PluginHandlerAwaiterInfo type exposes the following members.

Constructors
 | Name | Description
Public method | PluginHandlerAwaiterInfo | Initializes a new instance of the PluginHandlerAwaiterInfo class
Top
Properties
 | Name | Description
Public property | Awaiter |
Public property | PluginName |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


PluginHandler.AwaiterInfo Constructor

PluginHandlerAwaiterInfo Constructor

Initializes a new instance of the PluginHandlerAwaiterInfo class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Certificate.GetCertificateCollection2 Method

GetCertificateCollection2 Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


SeatInfo.SeatId Property

SeatId Property

Unique identifier for seat
Syntax
Json
{ Property:SeatId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DiscussionListEntry.ParticipantId Property

ParticipantId Property

Id of the partcipant
Syntax
Json
{ Property:ParticipantId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetPluginEventDataResponse Class

ConferenceApiHandlerGetPluginEventDataResponse Class

Represents the GetPluginEventDataResponse
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetPluginEventDataResponse
Syntax
Json
{ JsonClass:GetPluginEventDataResponse		PluginEventsData:<type>,
 }

The ConferenceApiHandlerGetPluginEventDataResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetPluginEventDataResponse | Initializes a new instance of the ConferenceApiHandlerGetPluginEventDataResponse class
Top
Properties
 | Name | Description
Public property | PluginEventsData | Collections of plugin events
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GrantResponseResponse Class

ConferenceApiHandlerGrantResponseResponse Class

Represents the requested responder to respond response.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGrantResponseResponse
Syntax
Json
{ JsonClass:GrantResponseResponse	 }

The ConferenceApiHandlerGrantResponseResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGrantResponseResponse | Initializes a new instance of the ConferenceApiHandlerGrantResponseResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UpdateFileRequest.Title Property

Title Property

Title of the file
Syntax
Json
{ Property:Title }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


PluginCommandDescription Properties

The PluginCommandDescription type exposes the following members.

Properties
 | Name | Description
Public property | Name | Name of the command
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DiscussionListEntry Constructor (Guid, Guid, Guid, String, MicrophoneState, SpeakerType, Int32, Int32, Boolean, Boolean, Boolean)

Initializes a new instance of the DiscussionListEntry class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetNotesFileListRequest Properties

The ConferenceApiHandlerGetNotesFileListRequest type exposes the following members.

Properties
 | Name | Description
Public property | SearchDateRange | The file search criteria of type NotesFileSearchCriteria
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetInterpretationOutputPresetResponse Class

ConferenceApiHandlerSetInterpretationOutputPresetResponse Class

 Bosch Logo
Represents the set interpretation out preset response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerSetInterpretationOutputPresetResponse
Syntax
Json
{ JsonClass:SetInterpretationOutputPresetResponse	 }

The ConferenceApiHandlerSetInterpretationOutputPresetResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetInterpretationOutputPresetResponse | Initializes a new instance of the ConferenceApiHandlerSetInterpretationOutputPresetResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ParticipantSeats.ParticipantId Property

ParticipantId Property

Syntax
Json
{ Property:ParticipantId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


NotesFileInfo Class

Class represents xml file data for meeting and voting notes details.
Inheritance Hierarchy
SystemObject
SynopticControl.CommonNotesFileInfo
Syntax
Json
{ JsonClass:NotesFileInfo		CreationDateTime:<type>,
    FileName:<type>,
    FileType:<type>,
    IsTampered:<type>,
 }

The NotesFileInfo type exposes the following members.

Constructors
 | Name | Description
Public method | NotesFileInfo | Initializes a new instance of the NotesFileInfo class
Top
Properties
 | Name | Description
Public property | CreationDateTime | File creation date time.
Public property | FileName | Name of the xml file.
Public property | FileType | Indicates whether its a meeting or voting xml.
Public property | IsTampered |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Certificate.RemoveCertificate Method

RemoveCertificate Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetHybridLicenseActiveState Method

GetHybridLicenseActiveState Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConnectionState.eventSent Field

eventSent Field

Syntax
Json
{ Field:eventSent }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SelectInterpretationFloorRequest Properties

The ConferenceApiHandlerSelectInterpretationFloorRequest type exposes the following members.

Properties
 | Name | Description
Public property | SeatId |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RegisterPluginRequest.PluginInterface Property

PluginInterface Property

Identifies the interface exposed by the plugin
Syntax
Json
{ Property:PluginInterface }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetVotingInfoResponse Class

ConferenceApiHandlerGetVotingInfoResponse Class

Represents the get voting info response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetVotingInfoResponse
Syntax
Json
{ JsonClass:GetVotingInfoResponse		VotingInfo:<type>,
 }

The ConferenceApiHandlerGetVotingInfoResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetVotingInfoResponse | Initializes a new instance of the ConferenceApiHandlerGetVotingInfoResponse class
Top
Properties
 | Name | Description
Public property | VotingInfo | Voting info
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceUsers Methods

The ConferenceUsers type exposes the following members.

Methods
 | Name | Description
Protected method | AddUser | Add a user to the administration
Public method | Dispose |
Protected method | GetUserPermission |
Protected method | Initialize |
Protected method | RemoveUser |
Protected method | UpdateUserPermission | Add user permissions to the user id
Protected method | UpdateUsersPermissions |
Protected method | UserHasPermission | Checks given user permissions
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetMeetings Method

GetMeetings Method

Gets the meetings information.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "meetings":
    [
        {
            "agendaList":
            [
                {
                    "agendaTopicId": <string>,
                    "description": <string>,
                    "discussionId": <string>,
                    "meetingId": <string>,
                    "state": "opened"|"closed",
                    "subject": <string>
                }
            ],
            "autoOpenOnActivate": <bool>,
            "autoStartAgendaOnOpen": <bool>,
            "defaultDiscussionId": <string>,
            "description": <string>,
            "documentationRef": <string>,
            "identificationMethod": "fixed"|"userName"|"selectFromList"|"qRCode"|"externalSystem"|"nFC"|"nFCKeptAtDevice",
            "isDefault": <bool>,
            "meetingEndDate": <dateTime>,
            "meetingId": <string>,
            "meetingStartDate": <dateTime>,
            "state": "activated"|"deactivated"|"opened"|"closed",
            "title": <string>,
            "verificationMethod": "none"|"confirmation"|"password"|"pINCode"|"externalSystem"
        }
    ]
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RaiseBoothNotificationRequest Constructor

ConferenceApiHandlerRaiseBoothNotificationRequest Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerRaiseBoothNotificationRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SaveImageRequest Class

ConferenceApiHandlerSaveImageRequest Class

Represents the save image request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerSaveImageRequest
Syntax
Json
{ JsonClass:SaveImageRequest		ImageData:<type>,
    Name:<type>,
 }

The ConferenceApiHandlerSaveImageRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSaveImageRequest | Initializes a new instance of the ConferenceApiHandlerSaveImageRequest class
Top
Properties
 | Name | Description
Public property | ImageData | The image data
Public property | Name | The name of the image
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AccessRights.AssignAccessRights Property

AssignAccessRights Property

Syntax
Json
{ Property:AssignAccessRights }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileLogTraceListener Constructor

Initializes a new instance of the FileLogTraceListener class.
Overload List
 | Name | Description
Public method | FileLogTraceListener | Flush the write stream
Public method | FileLogTraceListener(TextWriter) | Initializes a new instance of the FileLogTraceListener class, using the stream as the recipient of the debugging and tracing output.
Public method | FileLogTraceListener(String) | Initializes a new instance of the TextWriterTraceListener class, using the file as the recipient of the debugging and tracing output.
Public method | FileLogTraceListener(TextWriter, String) | Initializes a new instance of the FileLogTraceListener class with the specified name, using the stream as the recipient of the debugging and tracing output.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.NotifySeatMicrophoneSensitivityChangedOnClients Method

NotifySeatMicrophoneSensitivityChangedOnClients Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DcnmApi.GetNotesFileInfos Method

GetNotesFileInfos Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


DcnmApi.UpdateMasterVolumeInformation Method

UpdateMasterVolumeInformation Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetDiscussionListResponse Class

ConferenceApiHandlerGetDiscussionListResponse Class

Represents the get discussion list response.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetDiscussionListResponse
Syntax
Json
{ JsonClass:GetDiscussionListResponse		DiscussionList:<type>,
    ReferenceTime:<type>,
 }

The ConferenceApiHandlerGetDiscussionListResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetDiscussionListResponse | Initializes a new instance of the ConferenceApiHandlerGetDiscussionListResponse class
Top
Properties
 | Name | Description
Public property | DiscussionList | Holds the list of discussion list entries.
Public property | ReferenceTime | Holds the value of Environment.TickCount
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SeatInfo.SetFoundDevices Method

SetFoundDevices Method

Sets the found devices
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


UpdateFileRequest Properties

The ConferenceApiHandlerUpdateFileRequest type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Attributes indicate what contents of file represent and can contain list of values like 'Bosch.Synoptic.Layout', 'Bosch.Synoptic.Index'
Public property | FileId | File identifier. Unique identification of the file
Public property | Payload | The configuration of the layout. The format of the string is defined by the (AngularJs) application. The maximum length of the string is 65KBytes.
Public property | Title | Title of the file
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


PluginHandler.CommandHandler Method

CommandHandler Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetQuorumResultRequest Constructor

ConferenceApiHandlerGetQuorumResultRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetQuorumResultRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetApiState Method

GetApiState Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ActivateAdHocVotingRequest.Description Property

Description Property

Voting description for the ad-hoc voting
Syntax
Json
{ Property:Description }
Remarks
The maximum characters supported is 255.
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.GetDiscussInfoBySeatId Method

GetDiscussInfoBySeatId Method

Returns discuss list.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetIlluminateSeatResponse Constructor

ConferenceApiHandlerSetIlluminateSeatResponse Constructor

Initializes a new instance of the ConferenceApiHandlerSetIlluminateSeatResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetSeatVotingResultsRequest Class

ConferenceApiHandlerGetSeatVotingResultsRequest Class

Represents the get seat voting result request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetSeatVotingResultsRequest
Syntax
Json
{ JsonClass:GetSeatVotingResultsRequest	 }

The ConferenceApiHandlerGetSeatVotingResultsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetSeatVotingResultsRequest | Initializes a new instance of the ConferenceApiHandlerGetSeatVotingResultsRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.UnregisterPlugin Method

UnregisterPlugin Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


MajorityResultInfo.NumeratorValue Property

NumeratorValue Property

Majority numerator value
Syntax
Json
{ Property:NumeratorValue }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.HoldVotingRequest Constructor

ConferenceApiHandlerHoldVotingRequest Constructor

Initializes a new instance of the ConferenceApiHandlerHoldVotingRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetMeetingInfoRequest Class

ConferenceApiHandlerGetMeetingInfoRequest Class

Represents the meeting info request
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetMeetingInfoRequest
Syntax
Json
{ JsonClass:GetMeetingInfoRequest		MeetingId:<type>,
 }

The ConferenceApiHandlerGetMeetingInfoRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetMeetingInfoRequest | Initializes a new instance of the ConferenceApiHandlerGetMeetingInfoRequest class
Top
Properties
 | Name | Description
Public property | MeetingId | The meeting identifier.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


PluginHandler.SendPluginCommand Method

SendPluginCommand Method

Syntax
Json
Request:

Copy
{
    "command": <string>,
    "parameters": <string>,
    "pluginName": <string>
}

Response:

Copy
{
    "response": <string>
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.AcceptVotingResponse Class

ConferenceApiHandlerAcceptVotingResponse Class

Represents the accept voting info response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerAcceptVotingResponse
Syntax
Json
{ JsonClass:AcceptVotingResponse	 }

The ConferenceApiHandlerAcceptVotingResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerAcceptVotingResponse | Initializes a new instance of the ConferenceApiHandlerAcceptVotingResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UnSubscribePluginEventRequest Constructor

ConferenceApiHandlerUnSubscribePluginEventRequest Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerUnSubscribePluginEventRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.UpdateMajorityResult Method

UpdateMajorityResult Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetPluginsResponse Constructor

ConferenceApiHandlerGetPluginsResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetPluginsResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Meeting.AutoStartAgendaOnOpen Property

AutoStartAgendaOnOpen Property

Syntax
Json
{ Property:AutoStartAgendaOnOpen }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetSystemPowerModeRequest Constructor

ConferenceApiHandlerSetSystemPowerModeRequest Constructor

Initializes a new instance of the ConferenceApiHandlerSetSystemPowerModeRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetSystemPowerModeResponse Class

ConferenceApiHandlerSetSystemPowerModeResponse Class

Response from SetSystemPowerModeResponse
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerSetSystemPowerModeResponse
Syntax
Json
{ JsonClass:SetSystemPowerModeResponse	 }

The ConferenceApiHandlerSetSystemPowerModeResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetSystemPowerModeResponse | Initializes a new instance of the ConferenceApiHandlerSetSystemPowerModeResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetDiscussionOptionsResponse Class

ConferenceApiHandlerGetDiscussionOptionsResponse Class

Represents the get discussion options response.
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerGetDiscussionOptionsResponse
Syntax
Json
{ JsonClass:GetDiscussionOptionsResponse		DiscussionMode:<type>,
    MaxRequests:<type>,
    MaxResponses:<type>,
 }

The ConferenceApiHandlerGetDiscussionOptionsResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetDiscussionOptionsResponse | Initializes a new instance of the ConferenceApiHandlerGetDiscussionOptionsResponse class
Top
Properties
 | Name | Description
Public property | DiscussionMode | Holds the current discussion mode.
Public property | MaxRequests | Holds max requests for current discussion.
Public property | MaxResponses | Holds max responses for current discussion.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Meeting.IsDefault Property

IsDefault Property

Gets a value indicating whether this instance is default.
Syntax
Json
{ Property:IsDefault }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SeatParticipants.AssignedParticipantId Property

AssignedParticipantId Property

Syntax
Json
{ Property:AssignedParticipantId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


NotesFileInfo.FileType Property

FileType Property

Indicates whether its a meeting or voting xml.
Syntax
Json
{ Property:FileType }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileLogTraceListener Constructor

Flush the write stream
Initializes a new instance of the FileLogTraceListener class with TextWriter as the output recipient.
Syntax
Json
{ Constructor:.ctor }
Remarks
This constructor uses the TextWriter stream as the recipient of the tracing or debugging output. Its Name is initialized to "TextWriter".
See Also

Reference

TraceListener class
TextWriterTraceListener class
Debug class
Trace class


DeviceInfo.DeviceState Property

DeviceState Property

Syntax
Json
{ Property:DeviceState }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


IdentificationMethod Enumeration

Identification method for the meeting
Syntax
Json
IdentificationMethod:{
Fixed
UserName
SelectFromList
QRCode
ExternalSystem
NFC
NFCKeptAtDevice}
Members
Member name | Value | Description
Fixed | 0 | Participant is fixed on the seat; pre-set identification.
UserName | 1 | Identification by username.
SelectFromList | 2 | Identification by selecting from a list.
QRCode | 3 | Identification by QR-code.
ExternalSystem | 4 | Identification by external system.
NFC | 5 | Identification by swiping NFC at device
NFCKeptAtDevice | 6 | Identification by keeping NFC at device, participant logs off if NFC is removed from the device
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnParticipantAccessDenied Method

OnParticipantAccessDenied Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ServerCertificateData.PrivatePfx Property

PrivatePfx Property

Syntax
Json
{ Property:PrivatePfx }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


MicrophoneState Enumeration

Syntax
Json
MicrophoneState:{
off
on
mute}
Members
Member name | Value | Description
off | 0 | Microphone is off.
on | 1 | Microphone is on.
mute | 2 | Microphone is muted.
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.CheckNotesFileTamperedResponse Class

ConferenceApiHandlerCheckNotesFileTamperedResponse Class

Defines CheckNotesFileTampered response
Inheritance Hierarchy
SystemObject
SynopticControl.ServerConferenceApiHandlerCheckNotesFileTamperedResponse
Syntax
Json
{ JsonClass:CheckNotesFileTamperedResponse		FileVerificationResponse:<type>,
 }

The ConferenceApiHandlerCheckNotesFileTamperedResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerCheckNotesFileTamperedResponse | Initializes a new instance of the ConferenceApiHandlerCheckNotesFileTamperedResponse class
Top
Properties
 | Name | Description
Public property | FileVerificationResponse | Result of document verification response.DocumentVerificationResponse
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModelReader.SetImageServerInfo Method

SetImageServerInfo Method

Set the Imageserver info
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ListImagesRequest Constructor

ConferenceApiHandlerListImagesRequest Constructor

Initializes a new instance of the ConferenceApiHandlerListImagesRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileLogTraceListener.WriteLineMessage Method

WriteLineMessage Method

Writes a message to the listener you create in the derived class, followed by a line terminator.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.SetWebClientDeviceCapabilities Method

SetWebClientDeviceCapabilities Method

Overload List
 | Name | Description
Protected method | SetWebClientDeviceCapabilities | Sets web client device capabilities
Private method | SetWebClientDeviceCapabilities(Guid) | Sets web client device capabilities to contain power off/on and volume control
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.GetDefaultVotingSettings Method

GetDefaultVotingSettings Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RemoveSpeechRequest.ParticipantIds Property

ParticipantIds Property

List of particpant identifiers.
Syntax
Json
{ Property:ParticipantIds }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


PluginHandler.RegisterPlugin Method

RegisterPlugin Method

Syntax
Json
Request:

Copy
{
    "pluginCommands":
    [
        {
            "name": <string>
        }
    ],
    "pluginEvents":
    [
        {
            "name": <string>
        }
    ],
    "pluginInterface": <string>,
    "pluginName": <string>
}

Response:

Copy
{
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceModel.SetWebClientDeviceCapabilities Method (Guid)

SetWebClientDeviceCapabilities Method (Guid)

 Bosch Logo
Sets web client device capabilities to contain power off/on and volume control
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


Certificate.GetRootCertificateFromLocalMachine Method

GetRootCertificateFromLocalMachine Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.AddSeatToSpeakersRequest.SeatId Property

SeatId Property

The seat identifier.
Syntax
Json
{ Property:SeatId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetPermissionsResponse Constructor

ConferenceApiHandlerGetPermissionsResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetPermissionsResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiController.CreateCallableMethodsTable Method

CreateCallableMethodsTable Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceModel.NotifyParticipantAttendanceSummaryChangedOnClients Method

NotifyParticipantAttendanceSummaryChangedOnClients Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


FileLogTraceListener Constructor (String)

Initializes a new instance of the TextWriterTraceListener class, using the file as the recipient of the debugging and tracing output.
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

TraceListener class
TextWriterTraceListener class
Debug class
Trace class


Voting.VoteMajorityInfo Property

VoteMajorityInfo Property

Gets the voting majority info.
Syntax
Json
{ Property:VoteMajorityInfo }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetMasterVolumeRangeResponse.Range Property

Range Property

Gets or sets the master volume range.
Syntax
Json
{ Property:Range }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetVotingInfoResponse Constructor

ConferenceApiHandlerGetVotingInfoResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetVotingInfoResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileLogTraceListener.GetSupportedAttributes Method

GetSupportedAttributes Method

Gets the custom attributes supported by the trace listener.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


IConferenceConnection Interface

Interface to send conference events
Syntax
Json
{ Interface:IConferenceConnection }

The IConferenceConnection type exposes the following members.

Methods
 | Name | Description
Public method | SendEvent | Send an event to a client
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


FileLogTraceListener.IsEnabled Method

IsEnabled Method

Check fuction for the TraceOutputOptions.
Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetParticipantSeatsResponse.ParticipantSeats Property

ParticipantSeats Property

Participant Seats List.
Syntax
Json
{ Property:ParticipantSeats }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DcnmApi.OnVotingResultUpdated Method

OnVotingResultUpdated Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


FileStore Methods

The FileStore type exposes the following members.

Methods
 | Name | Description
Public method | CreateFile |
Public method | DeleteFile | Deteles the configuration of a file from the server.
Private method | GetFile | Gets file info
 | GetFileInfo |
Private method | GetXmlDataFiles | Gets all stored xml files from data folder
Public method | ListFiles | Get the description of all the stored files
Public method | LoadFile | Get the detailed information for a specific file layout
Public method | UpdateFile | Saves the configuration of file.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024